Re: [PATCH V4] cpuidle/powernv: Read target_residency value of idle states from DT if available

2015-02-17 Thread Preeti U Murthy
Hi Rafael, Can you please pull this patch ? Another patch based on top of this is waiting to be pulled: [PATCH] driver/cpuidle-powernv: Avoid endianness conversions while parsing DT Regards Preeti U Murthy On 02/03/2015 11:50 AM, Preeti U Murthy wrote: > The device tree now exposes the residency

[PATCH 1/3] powerpc/powernv: Move OPAL API definitions to opal-api.h

2015-02-17 Thread Michael Ellerman
We'd like to get to the stage where the OPAL API is defined in a header that is identical between Linux and Skiboot. As step one, split the bits that actually define the API into opal-api.h. The Linux specific parts stay in opal.h. Signed-off-by: Michael Ellerman --- arch/powerpc/include/asm/op

[PATCH 2/3] powerpc/powernv: Move opal-api.h closer to the Skiboot version

2015-02-17 Thread Michael Ellerman
This commit gets opal-api.h to mostly match the version in Skiboot as of commit ea7d806ab0ba. The exceptions are things which are not (currently) used in Linux. Most of this is just whitespace and a few things moving around. I think the diff is readable. Also OpalMessageType became opal_msg_type

[RFC PATCH 3/3] powerpc/powernv: Remove unused definitions in opal-api.h

2015-02-17 Thread Michael Ellerman
This removes definitions in opal-api.h that are completely unused in Linux. For each of these I see three possibilities, 1) we *should* be using them in Linux and patches will arrive to do that, 2) they are not used but should stay in the header to document the API for some important reason, 3) th

Re: [PATCH V4] cpuidle/powernv: Read target_residency value of idle states from DT if available

2015-02-17 Thread Rafael J. Wysocki
On Tuesday, February 17, 2015 01:29:10 PM Preeti U Murthy wrote: > Hi Rafael, Hi, > Can you please pull this patch ? Sorry, I wasn't sure whether or not the patch was for me to take and then I've been traveling lately. Applied now. > Another patch based on top of this is waiting to be pulled:

Re: [PATCH 1/3] powerpc/powernv: Move OPAL API definitions to opal-api.h

2015-02-17 Thread Stewart Smith
Michael Ellerman writes: > We'd like to get to the stage where the OPAL API is defined in a header > that is identical between Linux and Skiboot. > > As step one, split the bits that actually define the API into > opal-api.h. The Linux specific parts stay in opal.h. > > Signed-off-by: Michael Ell

Re: [RFC PATCH 3/3] powerpc/powernv: Remove unused definitions in opal-api.h

2015-02-17 Thread Stewart Smith
Michael Ellerman writes: > This removes definitions in opal-api.h that are completely unused in > Linux. > > For each of these I see three possibilities, 1) we *should* be using > them in Linux and patches will arrive to do that, 2) they are not used > but should stay in the header to document the

Re: [PATCH 2/3] powerpc/powernv: Move opal-api.h closer to the Skiboot version

2015-02-17 Thread Stewart Smith
Michael Ellerman writes: > This commit gets opal-api.h to mostly match the version in Skiboot as of > commit ea7d806ab0ba. > > The exceptions are things which are not (currently) used in Linux. > > Most of this is just whitespace and a few things moving around. I think > the diff is readable. > >

Re: [PATCH RESEND v2 0/7] powerpc/powernv: Unified PCI slot reset and hotplug

2015-02-17 Thread Stewart Smith
Gavin Shan writes: > The patchset was built based on patchset "powerpc/powernv: Simplify EEH > implementation", which can be found from: > > https://patchwork.ozlabs.org/patch/439956/ > > The patchset corresponds to skiboot changes, which manages PCI slots > in a unified way: OPAL APIs used to do

[PATCH 0/9] powerpc/hv-24x7: Reorganize single_24x7_request()

2015-02-17 Thread Sukadev Bhattiprolu
We currently issue a new hcall for to retrieve the value of each 24x7 counter that we want to read. However, the H_GET_24x7_DATA hcall can retrieve several counters in a single call, which would be useful in getting a more consistent snapshot of the system. Reorganize the code that prepares a 24x

[PATCH 1/9] powerpc/hv-24x7: Modify definition of request and result buffers

2015-02-17 Thread Sukadev Bhattiprolu
The parameters to the 24x7 HCALL have variable number of elements in them. Set the minimum number of such elements to 1 rather than 0 and eliminate the temporary structures. This would enable us to submit multiple counter requests and process multiple results from a single HCALL (in a follow on pa

[PATCH 2/9] powerpc/hv24x7: Remove unnecessary parameter

2015-02-17 Thread Sukadev Bhattiprolu
Use pr_notice_ratelimited() to log error messages and remove the 'success_expected' parameter. Signed-off-by: Sukadev Bhattiprolu --- arch/powerpc/perf/hv-24x7.c | 16 ++-- 1 file changed, 6 insertions(+), 10 deletions(-) diff --git a/arch/powerpc/perf/hv-24x7.c b/arch/powerpc/perf/

[PATCH 3/9] powerpc/hv-24x7: Drop event_24x7_request()

2015-02-17 Thread Sukadev Bhattiprolu
The function event_24x7_request() is essentially a wrapper to the function single_24x7_request() and can be dropped to simplify code. Signed-off-by: Sukadev Bhattiprolu --- arch/powerpc/perf/hv-24x7.c | 41 - 1 file changed, 16 insertions(+), 25 deletions(

[PATCH 4/9] powerpc/hv24x7: Move debug prints to separate function

2015-02-17 Thread Sukadev Bhattiprolu
To simplify/cleanup code, move the rather long printk() to a separate function. Signed-off-by: Sukadev Bhattiprolu --- arch/powerpc/perf/hv-24x7.c | 23 --- 1 file changed, 16 insertions(+), 7 deletions(-) diff --git a/arch/powerpc/perf/hv-24x7.c b/arch/powerpc/perf/hv-24x7.

[PATCH 6/9] powerpc/hv-24x7: Define add_event_to_24x7_request()

2015-02-17 Thread Sukadev Bhattiprolu
Move code that maps a perf_event to a 24x7 request buffer into a separate function, add_event_to_24x7_request(). Signed-off-by: Sukadev Bhattiprolu --- arch/powerpc/perf/hv-24x7.c | 61 - 1 file changed, 43 insertions(+), 18 deletions(-) diff --git a/

[PATCH 5/9] powerpc/hv-24x7: Rename hv_24x7_event_update

2015-02-17 Thread Sukadev Bhattiprolu
For consistency with the pmu operation ->read() and with other pmus, rename hv_24x7_event_update() to hv_24x7_event_read(). Signed-off-by: Sukadev Bhattiprolu --- arch/powerpc/perf/hv-24x7.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/arch/powerpc/perf/hv-24x7.c b/a

[PATCH 8/9] powerpc/hv-24x7: Break up single_24x7_request

2015-02-17 Thread Sukadev Bhattiprolu
Break up the function single_24x7_request() into smaller functions. This would later enable us to "prepare" a multi-event request buffer and then submit a single hcall for several events. Signed-off-by: Sukadev Bhattiprolu --- arch/powerpc/perf/hv-24x7.c | 56 +---

[PATCH 7/9] powerpc/hv-24x7: Define update_event_count()

2015-02-17 Thread Sukadev Bhattiprolu
Move the code to update an event count into a new function, update_event_count(). Signed-off-by: Sukadev Bhattiprolu --- arch/powerpc/perf/hv-24x7.c | 12 +--- 1 file changed, 9 insertions(+), 3 deletions(-) diff --git a/arch/powerpc/perf/hv-24x7.c b/arch/powerpc/perf/hv-24x7.c index 76

[PATCH 9/9] powerpc/hv-24x7: Add missing put_cpu_var()

2015-02-17 Thread Sukadev Bhattiprolu
Add missing put_cpu_var() for 24x7 requests. Signed-off-by: Sukadev Bhattiprolu --- arch/powerpc/perf/hv-24x7.c | 4 +++- 1 file changed, 3 insertions(+), 1 deletion(-) diff --git a/arch/powerpc/perf/hv-24x7.c b/arch/powerpc/perf/hv-24x7.c index fde6211..7d578d6 100644 --- a/arch/powerpc/perf/h

Re: [PATCH RESEND v2 7/7] PCI/hotplug: PowerPC PowerNV PCI hotplug driver

2015-02-17 Thread Bjorn Helgaas
On Tue, Feb 17, 2015 at 06:13:23PM +1100, Gavin Shan wrote: > The patch intends to add standalone driver to support PCI hotplug > for PowerPC PowerNV platform, which runs on top of skiboot firmware. > The firmware identified hotpluggable slots and marked their device > tree node with proper "ibm,sl

Re: [PATCH RESEND v2 0/7] powerpc/powernv: Unified PCI slot reset and hotplug

2015-02-17 Thread Gavin Shan
On Wed, Feb 18, 2015 at 08:44:19AM +1100, Stewart Smith wrote: >Gavin Shan writes: > >> The patchset was built based on patchset "powerpc/powernv: Simplify EEH >> implementation", which can be found from: >> >> https://patchwork.ozlabs.org/patch/439956/ >> >> The patchset corresponds to skiboot ch

[PATCH 0/3] powerpc/powernv: Correctly detect optional OPAL calls

2015-02-17 Thread Stewart Smith
This series fixes three possible warnings that OPAL firmware would emit when booting on hardware/simulator that didn't support certain functionality. The correct thing for Linux to do is to detect firmware capability by using the OPAL_CHECK_TOKEN call or examining device tree. In the case of these

[PATCH 2/3] powerpc/powernv: only call OPAL_ELOG_RESEND if firmware supports it

2015-02-17 Thread Stewart Smith
Otherwise firmware complains: "OPAL: Called with bad token 74 !" as not all OPAL systems have the ability to resend error logs. Signed-off-by: Stewart Smith --- arch/powerpc/platforms/powernv/opal-elog.c |3 ++- 1 file changed, 2 insertions(+), 1 deletion(-) diff --git a/arch/powerpc/platfo

[PATCH 3/3] powerpc/powernv: only call OPAL_RESEND_DUMP if firmware supports it

2015-02-17 Thread Stewart Smith
Not all OPAL platforms support resending system dumps, so check that current firmware supports it first. Otherwise we get firmware complaining: "OPAL: Called with bad token 91 !" Signed-off-by: Stewart Smith --- arch/powerpc/platforms/powernv/opal-dump.c |3 ++- 1 file changed, 2 insertions(

[PATCH 1/3] powerpc/powernv: only register log if OPAL supports doing so

2015-02-17 Thread Stewart Smith
Correct use of REGISTER/UNREGISTER is to check if the token exists before calling. If we don't we get a "OPAL: Called with bad token 101 !" error, which is harmless but may be alarming to some. Signed-off-by: Stewart Smith --- arch/powerpc/platforms/powernv/opal.c |6 +- 1 file changed,

Re: [PATCH RESEND v2 7/7] PCI/hotplug: PowerPC PowerNV PCI hotplug driver

2015-02-17 Thread Gavin Shan
On Tue, Feb 17, 2015 at 04:09:16PM -0600, Bjorn Helgaas wrote: >On Tue, Feb 17, 2015 at 06:13:23PM +1100, Gavin Shan wrote: >> The patch intends to add standalone driver to support PCI hotplug >> for PowerPC PowerNV platform, which runs on top of skiboot firmware. >> The firmware identified hotplug

Re: [PATCH RESEND v2 7/7] PCI/hotplug: PowerPC PowerNV PCI hotplug driver

2015-02-17 Thread Benjamin Herrenschmidt
On Wed, 2015-02-18 at 11:16 +1100, Gavin Shan wrote: > >What is vm_unmap_aliases() for? I see this is probably copied from > >rpaphp_core.c, where it was added by b4a26be9f6f8 ("powerpc/pseries: > Flush > >lazy kernel mappings after unplug operations"). > > > >But I don't know whether: > > > > -

Re: [PATCH v3 1/3] powerpc: Don't force ENOSYS as error on syscall fail

2015-02-17 Thread Mike Strosaker
This patch failed to build using pseries_le_defconfig. With the change noted below in entry_64.S, the build succeeded and seccomp mode 2 worked correctly. Best, Mike Strosaker On 02/13/2015 02:22 AM, Bogdan Purcareata wrote: In certain scenarios - e.g. seccomp filtering with ERRNO as default

Re: [PATCH V4] cpuidle/powernv: Read target_residency value of idle states from DT if available

2015-02-17 Thread Preeti U Murthy
On 02/17/2015 11:23 PM, Rafael J. Wysocki wrote: > On Tuesday, February 17, 2015 01:29:10 PM Preeti U Murthy wrote: >> Hi Rafael, > > Hi, > >> Can you please pull this patch ? > > Sorry, I wasn't sure whether or not the patch was for me to take and then > I've been traveling lately. Applied n

Re: [PATCH V4] cpuidle/powernv: Read target_residency value of idle states from DT if available

2015-02-17 Thread Rafael J. Wysocki
On Wednesday, February 18, 2015 10:13:23 AM Preeti U Murthy wrote: > > On 02/17/2015 11:23 PM, Rafael J. Wysocki wrote: > > On Tuesday, February 17, 2015 01:29:10 PM Preeti U Murthy wrote: > >> Hi Rafael, > > > > Hi, > > > >> Can you please pull this patch ? > > > > Sorry, I wasn't sure whether

Re: [PATCH V4] cpuidle/powernv: Read target_residency value of idle states from DT if available

2015-02-17 Thread Preeti U Murthy
On 02/18/2015 11:21 AM, Rafael J. Wysocki wrote: > On Wednesday, February 18, 2015 10:13:23 AM Preeti U Murthy wrote: >> >> On 02/17/2015 11:23 PM, Rafael J. Wysocki wrote: >>> On Tuesday, February 17, 2015 01:29:10 PM Preeti U Murthy wrote: Hi Rafael, >>> >>> Hi, >>> Can you please pul

Re: [PATCH v3 1/3] powerpc: Don't force ENOSYS as error on syscall fail

2015-02-17 Thread Purcareata Bogdan
On 18.02.2015 05:01, Mike Strosaker wrote: This patch failed to build using pseries_le_defconfig. With the change noted below in entry_64.S, the build succeeded and seccomp mode 2 worked correctly. Best, Mike Strosaker On 02/13/2015 02:22 AM, Bogdan Purcareata wrote: In certain scenarios - e.

Re: [PATCH 0/3] powerpc/powernv: Correctly detect optional OPAL calls

2015-02-17 Thread Vasant Hegde
On 02/18/2015 05:33 AM, Stewart Smith wrote: > This series fixes three possible warnings that OPAL firmware would emit > when booting on hardware/simulator that didn't support certain functionality. > > The correct thing for Linux to do is to detect firmware capability > by using the OPAL_CHECK_TO