From: Jiajun Wu
Date: Wed, 8 Jun 2011 15:46:51 +0800
> Each eTSEC device should own localized filer table.
>
> Signed-off-by: Jiajun Wu
Applied, thanks.
___
Linuxppc-dev mailing list
Linuxppc-dev@lists.ozlabs.org
https://lists.ozlabs.org/listinfo/lin
On Thursday 09 June 2011 00:45:54 Timur Tabi wrote:
> +struct fsl_hv_ioctl_memcpy {
> + __u32 ret;
> + __u32 source;
> + __u32 target;
> + __u64 local_vaddr;
> + __u64 remote_paddr;
> + __u64 count;
> +};
> +struct fsl_hv_ioctl_prop {
> + __u32 ret;
> +
On Thursday 09 June 2011 01:10:09 Randy Dunlap wrote:
> On Wed, 8 Jun 2011 17:45:54 -0500 Timur Tabi wrote:
>
> > Add the drivers/virt directory, which houses drivers that support
> > virtualization environments, and add the Freescale hypervisor management
> > driver.
>
> It can't go in linux/vir
On 05/31/2011 02:19 PM, Meador Inge wrote:
> This patch set defines a binding for FSL MPIC message registers and implements
> an API for accessing those message registers. Testing was done on a MPC8572DS
> in an Linux-Linux AMP setup using OpenMCAPI (www.openmcapi.org) to communicate
> between OS
On Tue, Jun 7, 2011 at 7:47 PM, Benjamin Herrenschmidt
wrote:
> On Tue, 2011-06-07 at 16:36 -0500, Eric Van Hensbergen wrote:
>
>> open to alternatives. jimix also suggested changing NEED_L1_WRITETHROUGH
>> to DCBZ_BROKEN, which I'm open to if you think appropriate, or maybe
>> DCBZ_BROKEN_DAMNIT
Sorry, if I'm being too noisy, what about this patch?
On 6/1/11, Dmitry Eremin-Solenikov wrote:
> fsl-lbc driver requires an interrupt to bind to localbus device.
> Populate 85xx boards' dts trees with lbc interrupt info.
>
> Signed-off-by: Dmitry Eremin-Solenikov
> ---
> arch/powerpc/boot/dts/
On 06/09/11 00:38, Arnd Bergmann wrote:
> On Thursday 09 June 2011 01:10:09 Randy Dunlap wrote:
>> On Wed, 8 Jun 2011 17:45:54 -0500 Timur Tabi wrote:
>>
>>> Add the drivers/virt directory, which houses drivers that support
>>> virtualization environments, and add the Freescale hypervisor managemen
Randy Dunlap wrote:
> But it sounds like virt/ needs virt/host/ and virt/guest/ to me.
I'm okay with that idea, except there's a consensus that drivers should be in
drivers/.
--
Timur Tabi
Linux kernel developer at Freescale
___
Linuxppc-dev mailing l
On 06/09/11 09:36, Timur Tabi wrote:
> Randy Dunlap wrote:
>> But it sounds like virt/ needs virt/host/ and virt/guest/ to me.
>
> I'm okay with that idea, except there's a consensus that drivers should be in
> drivers/.
>
Like sound/ ?
but what makes it a "driver"?
--
~Randy
*** Remember to
Randy Dunlap wrote:
>> > I'm okay with that idea, except there's a consensus that drivers should be
>> > in
>> > drivers/.
>> >
> Like sound/ ?
My understanding is that this is something that's considered broken and should
be fixed, but I don't know what the holdup is.
> but what makes it a "dr
Arnd Bergmann wrote:
> Then get rid of all the code that takes apart the ioctl command numbers
> again and just do a switch/case based on the command.
I still need to keep that code to maintain binary compatibility with existing
applications that pass the union as a parameter.
I'll fix that after
Add the drivers/virt directory, which houses drivers that support
virtualization environments, and add the Freescale hypervisor management
driver.
The Freescale hypervisor management driver provides several services to
drivers and applications related to the Freescale hypervisor:
1. An ioctl inte
On Thu, 9 Jun 2011 14:13:14 -0500 Timur Tabi wrote:
> Add the drivers/virt directory, which houses drivers that support
> virtualization environments, and add the Freescale hypervisor management
> driver.
>
> The Freescale hypervisor management driver provides several services to
> drivers and ap
Randy Dunlap wrote:
>> > +enum fsl_hv_ioctl_cmd {
>> > + FSL_HV_IOCTL_PARTITION_RESTART = _IOWR(0, 1, struct
>> > fsl_hv_ioctl_restart),
>> > + FSL_HV_IOCTL_PARTITION_GET_STATUS = _IOWR(0, 2, struct
>> > fsl_hv_ioctl_status),
>> > + FSL_HV_IOCTL_PARTITION_START = _IOWR(0, 3, struct fsl_hv_ioct
On 06/09/11 12:47, Timur Tabi wrote:
> Randy Dunlap wrote:
+enum fsl_hv_ioctl_cmd {
+ FSL_HV_IOCTL_PARTITION_RESTART = _IOWR(0, 1, struct
fsl_hv_ioctl_restart),
+ FSL_HV_IOCTL_PARTITION_GET_STATUS = _IOWR(0, 2, struct
fsl_hv_ioctl_status),
+ FSL_HV_IOCTL_PARTITION
Hi Timur, thanks for addressing the issues I pointed out. Unfortunately, I
have found a few more now:
On Thursday 09 June 2011 21:13:14 Timur Tabi wrote:
> + /* Make sure the application is called the right driver. */
> + if (_IOC_TYPE(cmd) != 0) {
> + pr_debug("fsl-hv: i
Arnd Bergmann wrote:
> As mentioned, it would be easier and more readable to just do
>
> switch(cmd) {
> case FSL_HV_IOCTL_PARTITION_RESTART:
> ...
>
> case FSL_HV_IOCTL_PARTITION_GET_STATUS;
> ...
>
> There is no need to check the bits individually
On Thursday 09 June 2011 20:55:17 Timur Tabi wrote:
> Arnd Bergmann wrote:
> > Then get rid of all the code that takes apart the ioctl command numbers
> > again and just do a switch/case based on the command.
>
> I still need to keep that code to maintain binary compatibility with existing
> appli
Arnd Bergmann wrote:
> The lesson to learn here is obviously not to ship binaries of applications
> to customers before the driver has been merged in a mainline kernel.
Believe me, I know this, but unfortunately I have no control over every aspect
of our development cycle.
> The best way out that
On Thursday 09 June 2011 21:48:58 Randy Dunlap wrote:
> > So is it okay to stick with 0, or do I need to pick a new number?
>
> I wasn't suggesting that you change the 0, just note that it has conflicts,
> like other ioctls do.
We normally don't try to maintain binary compatibility with out of tr
On Thu, Jun 09, 2011 at 03:18:28PM -0500, Timur Tabi wrote:
> > More importantly, the code you have chose (0) conflicts with existing
> > drivers
> > (frame buffer, scsi and wavefront among others). Please chose a free one and
> > add it to Documentation/ioctl/ioctl-number.txt in the same patch.
>
On Thursday 09 June 2011 22:18:28 Timur Tabi wrote:
> > More importantly, the code you have chose (0) conflicts with existing
> > drivers
> > (frame buffer, scsi and wavefront among others). Please chose a free one and
> > add it to Documentation/ioctl/ioctl-number.txt in the same patch.
>
> Ok,
Greg KH wrote:
> Why is binary compatibility important? Isn't this a brand new driver
> for a brand new system? What userspace tools are out there in the wild
> for such a thing?
This driver (and the hypervisor it talks to, plus the apps, etc) has been in
internal development for three years. T
Hi Linus !
Here are a small batch of fixes for powerpc.
Just one note: I just noticed a mistake while fixing a bug in "powerpc:
Force page alignment for initrd reserved memory". Bloody "citool"
changed the authorchip to me. The real author is Dave Carroll
. (it's a nasty mis-feature of ci-tool th
On Thu, 2011-06-09 at 19:01 +0400, Dmitry Eremin-Solenikov wrote:
> Sorry, if I'm being too noisy, what about this patch?
Just wait til somebody has a chance to pick it up. I have been too busy
lately and it looks like others as well. It shouldn't get lost, it's
tracked on patchwork.
Cheers,
Ben.
Add the drivers/virt directory, which houses drivers that support
virtualization environments, and add the Freescale hypervisor management
driver.
The Freescale hypervisor management driver provides several services to
drivers and applications related to the Freescale hypervisor:
1. An ioctl inte
On Thursday 09 June 2011 22:52:06 Timur Tabi wrote:
> Add the drivers/virt directory, which houses drivers that support
> virtualization environments, and add the Freescale hypervisor management
> driver.
>
> The Freescale hypervisor management driver provides several services to
> drivers and app
On Thu, 2011-06-09 at 09:58 -0500, Eric Van Hensbergen wrote:
> On Tue, Jun 7, 2011 at 7:47 PM, Benjamin Herrenschmidt
> wrote:
> > On Tue, 2011-06-07 at 16:36 -0500, Eric Van Hensbergen wrote:
> >
> >> open to alternatives. jimix also suggested changing NEED_L1_WRITETHROUGH
> >> to DCBZ_BROKEN,
On Thu, Jun 9, 2011 at 6:42 PM, Benjamin Herrenschmidt
wrote:
> On Thu, 2011-06-09 at 09:58 -0500, Eric Van Hensbergen wrote:
>> On Tue, Jun 7, 2011 at 7:47 PM, Benjamin Herrenschmidt
>> wrote:
>> > BTW. Care to explain to me why you have U2 -both- in the arguments to
>> > tlbwe and in MMUCR ? Th
29 matches
Mail list logo