Re: [Uclinux-dist-devel] [PATCH 1/2] mtd: m25p80: Reworkprobing/JEDEC code

2010-06-21 Thread Anton Vorontsov
On Mon, Jun 21, 2010 at 11:27:31AM +0800, Barry Song wrote: [...] > > How about we add a non_jedec flag in platform_data, if the flag is 1, we > > let the detection pass even though the ID is 0? Otherwise, we need a > > valid ID? > Here i mean: This will break at least OF-enabled platforms (e.g. P

Re: [Uclinux-dist-devel] [PATCH 1/2] mtd: m25p80: Reworkprobing/JEDEC code

2010-06-21 Thread Barry Song
On Mon, Jun 21, 2010 at 3:15 PM, Anton Vorontsov wrote: > On Mon, Jun 21, 2010 at 11:27:31AM +0800, Barry Song wrote: > [...] >> > How about we add a non_jedec flag in platform_data, if the flag is 1, we >> > let the detection pass even though the ID is 0? Otherwise, we need a >> > valid ID? >> He

Re: [Uclinux-dist-devel] [PATCH 1/2] mtd: m25p80: Reworkprobing/JEDEC code

2010-06-21 Thread Anton Vorontsov
On Mon, Jun 21, 2010 at 03:22:48PM +0800, Barry Song wrote: > On Mon, Jun 21, 2010 at 3:15 PM, Anton Vorontsov > wrote: > > On Mon, Jun 21, 2010 at 11:27:31AM +0800, Barry Song wrote: > > [...] > >> > How about we add a non_jedec flag in platform_data, if the flag is 1, we > >> > let the detectio

Re: [Uclinux-dist-devel] [PATCH 1/2] mtd: m25p80: Reworkprobing/JEDEC code

2010-06-21 Thread Barry Song
On Mon, Jun 21, 2010 at 3:39 PM, Anton Vorontsov wrote: > On Mon, Jun 21, 2010 at 03:22:48PM +0800, Barry Song wrote: >> On Mon, Jun 21, 2010 at 3:15 PM, Anton Vorontsov >> wrote: >> > On Mon, Jun 21, 2010 at 11:27:31AM +0800, Barry Song wrote: >> > [...] >> >> > How about we add a non_jedec fla

Re: [Uclinux-dist-devel] [PATCH 1/2] mtd: m25p80: Reworkprobing/JEDEC code

2010-06-21 Thread Anton Vorontsov
On Mon, Jun 21, 2010 at 06:31:44PM +0800, Barry Song wrote: > On Mon, Jun 21, 2010 at 3:39 PM, Anton Vorontsov > wrote: > > On Mon, Jun 21, 2010 at 03:22:48PM +0800, Barry Song wrote: > >> On Mon, Jun 21, 2010 at 3:15 PM, Anton Vorontsov > >> wrote: > >> > On Mon, Jun 21, 2010 at 11:27:31AM +08

[PATCH] KVM: PPC: Make BAT only guest segments work

2010-06-21 Thread Alexander Graf
When a guest sets its SR entry to invalid, we may still find a corresponding entry in a BAT. So we need to make sure we're not faulting on invalid SR entries, but instead just claim them to be BAT resolved. This resolves breakage experienced when using libogc based guests. Signed-off-by: Alexande

[PATCH] KVM: PPC: Use kernel hash function

2010-06-21 Thread Alexander Graf
The linux kernel already provides a hash function. Let's reuse that instead of reinventing the wheel! Signed-off-by: Alexander Graf --- arch/powerpc/kvm/book3s_32_mmu_host.c | 10 ++ arch/powerpc/kvm/book3s_64_mmu_host.c | 11 ++- 2 files changed, 4 insertions(+), 17 deletion

[PATCH] KVM: PPC: Remove obsolete kvmppc_mmu_find_pte

2010-06-21 Thread Alexander Graf
Initially we had to search for pte entries to invalidate them. Since the logic has improved since then, we can just get rid of the search function. Signed-off-by: Alexander Graf --- arch/powerpc/include/asm/kvm_book3s.h |1 - arch/powerpc/kvm/book3s_32_mmu_host.c | 20

[PATCH 1/2] KVM: PPC: Add generic hpte management functions

2010-06-21 Thread Alexander Graf
Currently the shadow paging code keeps an array of entries it knows about. Whenever the guest invalidates an entry, we loop through that entry, trying to invalidate matching parts. While this is a really simple implementation, it is probably the most ineffective one possible. So instead, let's kee

[PATCH 2/2] KVM: PPC: Make use of hash based Shadow MMU

2010-06-21 Thread Alexander Graf
We just introduced generic functions to handle shadow pages on PPC. This patch makes the respective backends make use of them, getting rid of a lot of duplicate code along the way. Signed-off-by: Alexander Graf --- arch/powerpc/include/asm/kvm_book3s.h |7 ++ arch/powerpc/include/asm/kvm_hos

Re: [Uclinux-dist-devel] [PATCH 1/2] mtd: m25p80: Reworkprobing/JEDEC code

2010-06-21 Thread Mike Frysinger
On Mon, Jun 21, 2010 at 07:20, Anton Vorontsov wrote: > You can't easily change OF. It's like "let's change ACPI tables > or BIOS in these PCs". Doable, but involves things like reflashing. > And we usually have to support old BIOSes as well. > > OTOH, I see (git grep m25p arch/powerpc/boot/dts/) t

Re: [Uclinux-dist-devel] [PATCH 1/2] mtd: m25p80: Reworkprobing/JEDEC code

2010-06-21 Thread Anton Vorontsov
On Mon, Jun 21, 2010 at 12:34:05PM -0400, Mike Frysinger wrote: > On Mon, Jun 21, 2010 at 07:20, Anton Vorontsov wrote: > > You can't easily change OF. It's like "let's change ACPI tables > > or BIOS in these PCs". Doable, but involves things like reflashing. > > And we usually have to support old

Re: [Uclinux-dist-devel] [PATCH 1/2] mtd: m25p80: Reworkprobing/JEDEC code

2010-06-21 Thread Mike Frysinger
On Mon, Jun 21, 2010 at 12:47, Anton Vorontsov wrote: > On Mon, Jun 21, 2010 at 12:34:05PM -0400, Mike Frysinger wrote: >> On Mon, Jun 21, 2010 at 07:20, Anton Vorontsov wrote: >> > You can't easily change OF. It's like "let's change ACPI tables >> > or BIOS in these PCs". Doable, but involves thin

Re: [PATCH] serial: Add missing call to init UCC UART port timeout

2010-06-21 Thread Timur Tabi
On Fri, Jun 18, 2010 at 8:22 AM, Chuck Meade wrote: > From: Chuck Meade > > The UCC UART driver is missing a call to uart_update_timeout(). > Without this call, attempting to close the port after outputting large > amounts of data (i.e. using tty and uart buffering) results in long > timeouts bef

UCC interactions

2010-06-21 Thread Gary Thomas
I'm running 2.6.33.3 on MPC8358. I have UCC1+UCC2 working fine for ethernet, but when I add UCC3 as a UART, the network devices quit working. Here are my device tree entries: /* ETH0 (UCC1, MDIO 0x02, RMII) */ enet_eth0: ether...@2000 { device_type = "network";

RE: UCC interactions

2010-06-21 Thread Steven Blakeslee
I believe the offset for UCC3 is wrong. The usermanual says UCC3's registers are at 0x2200-0x23FF. 0x4000 is SDMA. Hope that helps. > -Original Message- > From: linuxppc-dev-bounces+blakeslees=embeddedplanet@lists.ozlabs.org > [mailto:linuxppc-dev- > bounces+blakeslees=embeddedplane

Re: UCC interactions

2010-06-21 Thread Gary Thomas
On 06/21/2010 01:19 PM, Steven Blakeslee wrote: I believe the offset for UCC3 is wrong. The usermanual says UCC3's registers are at 0x2200-0x23FF. 0x4000 is SDMA. Hope that helps. Looks like that was it (not sure where I got that value from!) Thanks -Original Message- From: linux

Re: [PATCH 3/5] of/address: Merge all of the bus translation code

2010-06-21 Thread Grant Likely
On Thu, Jun 10, 2010 at 8:26 AM, Grant Likely wrote: > On Thu, Jun 10, 2010 at 12:43 AM, Benjamin Herrenschmidt > wrote: >> On Tue, 2010-06-08 at 08:10 -0600, Grant Likely wrote: >>> Microblaze and PowerPC share a large chunk of code for translating >>> OF device tree data into usable addresses.

Re: [PATCH 3/5] of/irq: merge of_irq_find_parent()

2010-06-21 Thread Grant Likely
On Thu, Jun 10, 2010 at 12:38 AM, Benjamin Herrenschmidt wrote: > On Fri, 2010-06-04 at 15:21 -0600, Grant Likely wrote: >> Merge common code between PowerPC and Microblaze.  Also create a new >> arch hook, of_irq_find_parent_by_phandle() to handle arch-specific >> quirks. > > First, you changeset

[PATCH v2 0/5] Consolidate OF IRQ handling code

2010-06-21 Thread Grant Likely
This series merges the common IRQ handling code between Microblaze and Powerpc Changes in v2: - The 3 patches to merge of_irq_find_parent(), of_irq_map_raw() and of_irq_map_one() have been merged into a single patch. - Patch added to move powermac quirk handing into arch/powerpc/platforms/powe

[PATCH v2 1/5] of/irq: Move irq_of_parse_and_map() to common code

2010-06-21 Thread Grant Likely
Merge common code between PowerPC and Microblaze. SPARC implements irq_of_parse_and_map(), but the implementation is different, so it does not use this code. Signed-off-by: Grant Likely Acked-by: Benjamin Herrenschmidt Cc: Michal Simek Cc: "David S. Miller" Cc: Stephen Rothwell Cc: Jeremy Ke

[PATCH v2 2/5] of/microblaze: strip out of_irq_workarounds code

2010-06-21 Thread Grant Likely
Microblaze doesn't have any legacy workaround in the device tree irq mapping data. All of the of_irq_workarounds stuff can be dropped Signed-off-by: Grant Likely Cc: Michal Simek Cc: Stephen Rothwell --- arch/microblaze/include/asm/prom.h | 10 - arch/microblaze/kernel/prom_parse.c

[PATCH v2 4/5] of/irq: merge irq mapping code

2010-06-21 Thread Grant Likely
Merge common irq mapping code between PowerPC and Microblaze. This patch merges of_irq_find_parent(), of_irq_map_raw() and of_irq_map_one(). The functions are dependent on one another, so all three are merged in a single patch. Other than cosmetic difference (ie. DBG() vs. pr_debug()), the imple

[PATCH v2 5/5] of/irq: little endian fixes

2010-06-21 Thread Grant Likely
From: Rob Herring Fix some endian issues in the irq mapping OF code. Signed-off-by: Rob Herring Signed-off-by: Grant Likely CC: Michal Simek CC: Wolfram Sang CC: Stephen Rothwell CC: Benjamin Herrenschmidt --- drivers/of/irq.c | 17 + 1 files changed, 9 insertions(+), 8

[PATCH v2 3/5] of/powerpc: Move Powermac irq quirk code into powermac pic driver code

2010-06-21 Thread Grant Likely
The code that figures out what is wrong with the powermac irq device tree data belongs with the rest of the powermac irq code. This patch moves it out of prom_parse.c and into powermac/pic.c so that it is only compiled in when actually needed. The quirk flags are also conditionally compiled out t

Re: [PATCH 3/5] of/address: Merge all of the bus translation code

2010-06-21 Thread Benjamin Herrenschmidt
On Mon, 2010-06-21 at 15:06 -0600, Grant Likely wrote: > On Thu, Jun 10, 2010 at 8:26 AM, Grant Likely > wrote: > > On Thu, Jun 10, 2010 at 12:43 AM, Benjamin Herrenschmidt > > wrote: > >> On Tue, 2010-06-08 at 08:10 -0600, Grant Likely wrote: > >>> Microblaze and PowerPC share a large chunk of