Re: [PATCH 2/5] perf: Hoist perf_instruction_pointer() and perf_misc_flags()

2024-09-11 Thread Colton Lewis
Ingo Molnar writes: * Colton Lewis wrote: --- a/kernel/events/core.c +++ b/kernel/events/core.c @@ -6915,6 +6915,16 @@ void perf_unregister_guest_info_callbacks(struct perf_guest_info_callbacks *cbs) EXPORT_SYMBOL_GPL(perf_unregister_guest_info_callbacks); #endif +unsigned long pe

Re: [PATCH 2/5] perf: Hoist perf_instruction_pointer() and perf_misc_flags()

2024-09-05 Thread Ingo Molnar
* Colton Lewis wrote: > --- a/kernel/events/core.c > +++ b/kernel/events/core.c > @@ -6915,6 +6915,16 @@ void perf_unregister_guest_info_callbacks(struct > perf_guest_info_callbacks *cbs) > EXPORT_SYMBOL_GPL(perf_unregister_guest_info_callbacks); > #endif > > +unsigned long perf_misc_flags

[PATCH 2/5] perf: Hoist perf_instruction_pointer() and perf_misc_flags()

2024-09-04 Thread Colton Lewis
For clarity, rename the arch-specific definitions of these functions to perf_arch_* to denote they are arch-specifc. Define the generic-named functions in one place where they can call the arch-specific ones as needed. Signed-off-by: Colton Lewis --- arch/arm64/include/asm/perf_event.h