Re: [PATCH 1/3] [WATCHDOG] mpc83xx_wdt: add support for MPC86xx CPUs

2008-05-12 Thread Kumar Gala
On May 12, 2008, at 5:12 PM, Anton Vorontsov wrote: On Mon, May 12, 2008 at 04:55:16PM -0500, Timur Tabi wrote: Anton Vorontsov wrote: I don't know the IP block name... what is it for the 83xx/86xx watchdogs? My point was that we developers should just pick a name and run with it. That'

Re: [PATCH 1/3] [WATCHDOG] mpc83xx_wdt: add support for MPC86xx CPUs

2008-05-12 Thread Anton Vorontsov
On Mon, May 12, 2008 at 04:55:16PM -0500, Timur Tabi wrote: > Anton Vorontsov wrote: > >> I don't know the IP block name... what is it for the 83xx/86xx >> watchdogs? > > My point was that we developers should just pick a name and run with it. > That's where the name "Elo" came from. None of of

Re: [PATCH 1/3] [WATCHDOG] mpc83xx_wdt: add support for MPC86xx CPUs

2008-05-12 Thread Timur Tabi
Anton Vorontsov wrote: I don't know the IP block name... what is it for the 83xx/86xx watchdogs? My point was that we developers should just pick a name and run with it. That's where the name "Elo" came from. None of official Freescale documentation calls the DMA controller on 85xx parts "

Re: [PATCH 1/3] [WATCHDOG] mpc83xx_wdt: add support for MPC86xx CPUs

2008-05-12 Thread Anton Vorontsov
On Mon, May 12, 2008 at 04:42:41PM -0500, Timur Tabi wrote: > Anton Vorontsov wrote: > >> They're completely different watchdogs... > > But the drivers both generally do the same thing, just with different > timers? All the watchdogs do the same thing, generally... > I think the best option is

Re: [PATCH 1/3] [WATCHDOG] mpc83xx_wdt: add support for MPC86xx CPUs

2008-05-12 Thread Timur Tabi
Anton Vorontsov wrote: They're completely different watchdogs... But the drivers both generally do the same thing, just with different timers? I think the best option is to just pick a name for the IP block that mpc83xx_wdt.c supports and use that name for the driver as well. __

Re: [PATCH 1/3] [WATCHDOG] mpc83xx_wdt: add support for MPC86xx CPUs

2008-05-12 Thread Anton Vorontsov
On Mon, May 12, 2008 at 04:20:59PM -0500, Timur Tabi wrote: > Anton Vorontsov wrote: >> On Mon, May 12, 2008 at 04:01:06PM -0500, Timur Tabi wrote: >>> Scott Wood wrote: >>> It avoids confusion. I vote for renaming. >>> Me too. How about fsl_wdt.c? >> >> fsl_wdt sounds too generic, I think i

Re: [PATCH 1/3] [WATCHDOG] mpc83xx_wdt: add support for MPC86xx CPUs

2008-05-12 Thread Timur Tabi
Anton Vorontsov wrote: On Mon, May 12, 2008 at 04:01:06PM -0500, Timur Tabi wrote: Scott Wood wrote: It avoids confusion. I vote for renaming. Me too. How about fsl_wdt.c? fsl_wdt sounds too generic, I think it would conflict with at least booke_wdt.c.. no? Yeah, that makes sense. What

Re: [PATCH 1/3] [WATCHDOG] mpc83xx_wdt: add support for MPC86xx CPUs

2008-05-12 Thread Anton Vorontsov
On Mon, May 12, 2008 at 04:01:06PM -0500, Timur Tabi wrote: > Scott Wood wrote: > >> It avoids confusion. I vote for renaming. > > Me too. How about fsl_wdt.c? fsl_wdt sounds too generic, I think it would conflict with at least booke_wdt.c.. no? -- Anton Vorontsov email: [EMAIL PROTECTED] irc:

Re: [PATCH 1/3] [WATCHDOG] mpc83xx_wdt: add support for MPC86xx CPUs

2008-05-12 Thread Timur Tabi
Scott Wood wrote: It avoids confusion. I vote for renaming. Me too. How about fsl_wdt.c? Or we could come up with a name for that particular WDT device, like we did with the 85xx DMA controller. ___ Linuxppc-dev mailing list Linuxppc-dev@ozlabs

Re: [PATCH 1/3] [WATCHDOG] mpc83xx_wdt: add support for MPC86xx CPUs

2008-05-12 Thread Scott Wood
Anton Vorontsov wrote: On Mon, May 12, 2008 at 02:24:20PM -0500, Kumar Gala wrote: we should rename it to mpc8xxx_wdt.c I don't see much sense in renaming the files just because the driver now supports another line of processors... Do you really want the rename? Please repeat if so. It avoi

Re: [PATCH 1/3] [WATCHDOG] mpc83xx_wdt: add support for MPC86xx CPUs

2008-05-12 Thread Anton Vorontsov
On Mon, May 12, 2008 at 02:24:20PM -0500, Kumar Gala wrote: > > On May 12, 2008, at 1:52 PM, Anton Vorontsov wrote: > >> On MPC86xx the watchdog could be enabled only at power-on-reset, and >> could not be disabled afterwards. We must ping the watchdog from the >> kernel until the userspace handles

Re: [PATCH 1/3] [WATCHDOG] mpc83xx_wdt: add support for MPC86xx CPUs

2008-05-12 Thread Jochen Friedrich
Hi Kumar, >> Also move the probe code into subsys_initcall, because we want start >> pinging the watchdog ASAP, and misc devices are available in >> subsys_initcall. >> >> Signed-off-by: Anton Vorontsov <[EMAIL PROTECTED]> >> --- >> drivers/watchdog/Kconfig |4 +- >> drivers/watchdog/mpc8

Re: [PATCH 1/3] [WATCHDOG] mpc83xx_wdt: add support for MPC86xx CPUs

2008-05-12 Thread Kumar Gala
On May 12, 2008, at 1:52 PM, Anton Vorontsov wrote: On MPC86xx the watchdog could be enabled only at power-on-reset, and could not be disabled afterwards. We must ping the watchdog from the kernel until the userspace handles it. MPC83xx CPUs are only differ in a way that watchdog could be disa

Re: [PATCH 1/3] [WATCHDOG] mpc83xx_wdt: add support for MPC86xx CPUs

2008-05-12 Thread Scott Wood
Anton Vorontsov wrote: + enabled = in_be32(&wd_base->swcrr) & SWCRR_SWEN; +#ifdef CONFIG_PPC_86xx + if (!enabled) { + dev_info(&dev->dev, "could not be enabled by software\n"); + ret = -ENOSYS; + goto err_unmap; + } +#endif What happen

[PATCH 1/3] [WATCHDOG] mpc83xx_wdt: add support for MPC86xx CPUs

2008-05-12 Thread Anton Vorontsov
On MPC86xx the watchdog could be enabled only at power-on-reset, and could not be disabled afterwards. We must ping the watchdog from the kernel until the userspace handles it. MPC83xx CPUs are only differ in a way that watchdog could be disabled once, but after it was enabled via software it beco