Hi David,
I suppose you are looking for more details than those found in the
current patch-0 (http://lkml.org/lkml/2010/5/1/140).
We omitted them for brevity sake; here is a link to patch-0 of a
previous post of the patchset: http://lkml.org/lkml/2009/9/23/423
Thanks,
Oren.
David Howells wr
From: Nathan Lynch
Changelog [v21]:
- Fix build break with CONFIG_CHECKPOINT=n
Changelog [v19]:
- Checkpoint/powerpc: fix up checkpoint syscall, tidy restart
Cc: linuxppc-...@ozlabs.org
Signed-off-by: Nathan Lynch
Acked-by: Serge E. Hallyn
---
arch/powerpc/include/asm/systbl.h |2 ++
ar
From: Nathan Lynch
Cc: linuxppc-...@ozlabs.org
Signed-off-by: Nathan Lynch
Acked-by: Serge E. Hallyn
---
arch/powerpc/Kconfig |3 +++
1 files changed, 3 insertions(+), 0 deletions(-)
diff --git a/arch/powerpc/Kconfig b/arch/powerpc/Kconfig
index 2e19500..16416b0 100644
--- a/arch/powerpc/
From: Nathan Lynch
A checkpointed task image may specify a value for the DABR (Data
Access Breakpoint Register). The restart code needs to validate this
value before making any changes to the current task.
ptrace_set_debugreg encapsulates the bounds checking and platform
dependencies of program
d:
* ppc32 (but it builds)
Changelog[v21]:
- Do not include checkpoint_hdr.h explicitly
Changelog[v19]:
- [Serge Hallyn] Add hook task_has_saved_sigmask()
Changelog[v19-rc3]:
- [Oren Laadan] Move checkpoint.c from arch/powerpc/{mm->kernel}
- [Nathan Lynch] Warn if full register sta
From: Nathan Lynch
Changelog [v19-rc1]:
- [Matt Helsley] Add cpp definitions for enums
Cc: linuxppc-...@ozlabs.org
Signed-off-by: Nathan Lynch
Acked-by: Serge E. Hallyn
Tested-by: Serge E. Hallyn
---
include/linux/checkpoint_hdr.h |4
1 files changed, 4 insertions(+), 0 deletions(
el.org
Cc: x...@kernel.org
Cc: linux-s...@vger.kernel.org
Cc: linuxppc-...@ozlabs.org
Signed-off-by: Oren Laadan
Signed-off-by: Dave Hansen
Acked-by: Serge E. Hallyn
Tested-by: Serge E. Hallyn
---
Makefile |2 +-
arch/x86/Kconfig |4 +++
arch/x86/
From: Sukadev Bhattiprolu
To simplify alloc_pidmap(), move code to allocate a pid map page to a
separate function.
Changelog[v4]:
- [Oren Laadan] Adapt to kernel 2.6.33-rc5
Changelog[v3]:
- Earlier version of patchset called alloc_pidmap_page() from two
places. But now
linux-s...@vger.kernel.org
Cc: linuxppc-...@ozlabs.org
Signed-off-by: Sukadev Bhattiprolu
Signed-off-by: Serge E. Hallyn
Reviewed-by: Oren Laadan
---
kernel/pid.c | 41 +
1 files changed, 33 insertions(+), 8 deletions(-)
diff --git a/kernel/pid.c b/ker
#x27; (next patch moves the arch-independent
code to kernel/fork.c)
Cc: linux-...@vger.kernel.org
Cc: x...@kernel.org
Cc: linux-s...@vger.kernel.org
Cc: linuxppc-...@ozlabs.org
Cc: Oleg Nesterov
Signed-off-by: Sukadev Bhattiprolu
Acked-by: Serge E. Hallyn
Tested-by: Serge E. Hallyn
Reviewed-
From: Sukadev Bhattiprolu
As pointed out by Oren Laadan, we want to ensure that unused bits in the
clone-flags remain unused and available for future. To ensure this, define
a mask of clone-flags and check the flags in the clone() system calls.
Changelog[v9]:
- Include the unused clone
ov
Signed-off-by: Sukadev Bhattiprolu
Acked-by: Serge E. Hallyn
Tested-by: Serge E. Hallyn
Reviewed-by: Oren Laadan
---
kernel/fork.c |7 ---
1 files changed, 4 insertions(+), 3 deletions(-)
diff --git a/kernel/fork.c b/kernel/fork.c
index 62018c8..9d2b57e 100644
--- a/kernel/fork.c
++
es.
Changelog[v12]:
- [Serge Hallyn] Fix/simplify stack-setup in the example code
- [Serge Hallyn, Oren Laadan] Rename syscall to eclone()
Changelog[v11]:
- [Dave Hansen] Move clone_args validation checks to arch-indpendent
code.
- [Oren Laadan] Make args_si
angelog[v2]:
- [ntl] powerpc: vdso build fix (ckpt-v17)
Cc: x...@kernel.org
Cc: linux-s...@vger.kernel.org
Cc: linuxppc-...@ozlabs.org
Signed-off-by: Alexey Dobriyan
Signed-off-by: Oren Laadan
---
arch/powerpc/include/asm/elf.h |1 +
arch/powerpc/kernel/vdso.c | 13 -
. Hallyn
Reviewed-by: Oren Laadan
---
include/linux/pid.h |2 +-
kernel/fork.c |3 ++-
kernel/pid.c|9 +++--
3 files changed, 10 insertions(+), 4 deletions(-)
diff --git a/include/linux/pid.h b/include/linux/pid.h
index 49f1c2f..914185d 100644
--- a/include/linux/pid.h
From: Nathan Lynch
Wired up for both ppc32 and ppc64, but tested only with the latter.
Changelog:
- Jan 20: (ntl) fix 32-bit build
- Nov 17: (serge) remove redundant flags_high check, and
don't fold it into flags.
Cc: linux-...@vger.kernel.org
Cc: x...@kernel.org
Cc: linux-s...@
From: Serge E. Hallyn
Implement the s390 hook for sys_eclone().
Changelog:
Nov 24: Removed user-space code from commit log. See user-cr git tree.
Nov 17: remove redundant flags_high check
Nov 13: As suggested by Heiko, convert eclone to take its
parameters
l functions and that patchset seems independent of this
new system call.
Changelog[v14]:
- [Oren Laadan] Rebase to kernel 2.6.33
* introduce PTREGSCALL4 for sys_eclone
* consolidate syscall definitions for 32/64 bit
- [Oren Laadan] Merge
-ENOMEM, have alloc_pidmap() return
the actual error.
Changelog[v1]:
- [Oren Laadan] Rebase to kernel 2.6.33
Cc: linux-...@vger.kernel.org
Cc: x...@kernel.org
Cc: linux-s...@vger.kernel.org
Cc: linuxppc-...@ozlabs.org
Signed-off-by: Sukadev Bhattiprolu
Acked-by: Serge E. Hallyn
Tested-by
An alternative: the task that created the container namely, is the parent
(outside the container) of the container init(1). In turn, init(1) creates
a special 'monitor' thread that monitors the restart, and the outside task
reaps the exit status of that thread (and only that thread).
[Hmmm... thi
Nathan Lynch wrote:
> Nathan Lynch wrote:
>> Oren Laadan wrote:
>>> Nathan Lynch wrote:
>>>> What doesn't work:
>>>> * restarting a 32-bit task from a 64-bit task and vice versa
>>> Is there a test to bail if we attempt to checkpoint such
Nathan Lynch wrote:
> On Tue, 24 Feb 2009 13:58:26 -0600
> "Serge E. Hallyn" wrote:
>
>> Quoting Nathan Lynch (n...@pobox.com):
>>> Nathan Lynch wrote:
>>>> Oren Laadan wrote:
>>>>> Nathan Lynch wrote:
>>>>>> W
Benjamin Herrenschmidt wrote:
> On Wed, 2009-02-04 at 18:44 -0500, Oren Laadan wrote:
>> * Anything that is decided at compiled time should probably go to the arch-
>> dependent header.
>>
>> * Anything that can change at boot time (e.g., for x86 that would include
>
Benjamin Herrenschmidt wrote:
> On Wed, 2009-02-04 at 09:54 -0600, Serge E. Hallyn wrote:
>> Quoting Benjamin Herrenschmidt (b...@kernel.crashing.org):
+struct cr_hdr_cpu {
+ struct pt_regs pt_regs;
+ /* relevant fields from thread_struct */
+ double fpr[32][TS_FPRWIDTH];
>
Nathan Lynch wrote:
> Hey Oren, thanks for taking a look.
>
> Oren Laadan wrote:
>> Nathan Lynch wrote:
>>> What doesn't work:
>>> * restarting a 32-bit task from a 64-bit task and vice versa
>> Is there a test to bail if we attempt to checkpoint
h
> @@ -0,0 +1,40 @@
> +#ifndef __ASM_PPC_CKPT_HDR_H
> +#define __ASM_PPC_CKPT_HDR_H
> +/*
> + * Checkpoint/restart - architecture specific headers ppc
> + *
> + * Copyright (C) 2008 Oren Laadan
> + *
> + * This file is subject to the terms and conditions of
26 matches
Mail list logo