[PATCH v3] of: remove internal arguments from of_property_for_each_u32()

2024-07-24 Thread Luca Ceresoli
/soc/codecs/arizona.c Acked-by: Michael Ellerman # arch/powerpc/sysdev/xive/spapr.c Acked-by: Stephen Boyd # clk Signed-off-by: Luca Ceresoli --- [Note: to reduce the noise I have trimmed the get_maintainers list manually. Should you want to be removed, or someone else added, to future version

Re: [PATCH v2] of: remove internal arguments from of_property_for_each_u32()

2024-07-18 Thread Luca Ceresoli
operty is OK */ > > + if (sz < 0) > > + return dev_err_probe(&client->dev, sz, "invalid > > pll-source"); > > Needs a newline on the printk message. Ouch! Fix queued for v3. Thanks, Luca -- Luca Ceresoli, Bootlin Embedded Linux and Kernel engineering https://bootlin.com

[PATCH v2] of: remove internal arguments from of_property_for_each_u32()

2024-07-17 Thread Luca Ceresoli
ave been build tested. The few for which I have the hardware have been runtime-tested too. Signed-off-by: Luca Ceresoli Reviewed-by: Andre Przywara # drivers/clk/sunxi/clk-simple-gates.c, drivers/clk/sunxi/clk-sun8i-bus-gates.c Acked-by: Bartosz Golaszewski # drivers/gpio/gpio-brcmstb.c Acked

Re: [PATCH 20/20] of: deprecate and rename of_property_for_each_u32()

2024-07-04 Thread Luca Ceresoli
Hello Rob, On Wed, 3 Jul 2024 12:01:11 -0600 Rob Herring wrote: > On Wed, Jul 03, 2024 at 12:37:04PM +0200, Luca Ceresoli wrote: > > of_property_for_each_u32() is meant to disappear. All the call sites not > > using the 3rd and 4th arguments have already b

Re: [PATCH 00/20] Simplify of_property_for_each_u32()

2024-07-04 Thread Luca Ceresoli
Hello Rob, On Wed, 3 Jul 2024 12:07:42 -0600 Rob Herring wrote: > On Wed, Jul 03, 2024 at 12:36:44PM +0200, Luca Ceresoli wrote: > > [Note: to reduce the noise I have trimmed the get_maintainers list > > manually. Should you want to be removed, or someone else added, to futu

[PATCH 15/20] usb: usb251xb: convert to of_property_for_each_u32_new()

2024-07-03 Thread Luca Ceresoli
Simplify code using of_property_for_each_u32_new() as the two additional parameters in of_property_for_each_u32() are not used here. Signed-off-by: Luca Ceresoli --- drivers/usb/misc/usb251xb.c | 4 +--- 1 file changed, 1 insertion(+), 3 deletions(-) diff --git a/drivers/usb/misc/usb251xb.c b

[PATCH 13/20] pwm: samsung: convert to of_property_for_each_u32_new()

2024-07-03 Thread Luca Ceresoli
Simplify code using of_property_for_each_u32_new() as the two additional parameters in of_property_for_each_u32() are not used here. Signed-off-by: Luca Ceresoli --- drivers/pwm/pwm-samsung.c | 4 +--- 1 file changed, 1 insertion(+), 3 deletions(-) diff --git a/drivers/pwm/pwm-samsung.c b

[PATCH 14/20] tty: sysrq: convert to of_property_for_each_u32_new()

2024-07-03 Thread Luca Ceresoli
Simplify code using of_property_for_each_u32_new() as the two additional parameters in of_property_for_each_u32() are not used here. Signed-off-by: Luca Ceresoli --- drivers/tty/sysrq.c | 4 +--- 1 file changed, 1 insertion(+), 3 deletions(-) diff --git a/drivers/tty/sysrq.c b/drivers/tty

[PATCH 12/20] iio: adc: ti_am335x_adc: convert to of_property_for_each_u32_new()

2024-07-03 Thread Luca Ceresoli
Simplify code using of_property_for_each_u32_new() as the two additional parameters in of_property_for_each_u32() are not used here. Signed-off-by: Luca Ceresoli --- drivers/iio/adc/ti_am335x_adc.c | 4 +--- 1 file changed, 1 insertion(+), 3 deletions(-) diff --git a/drivers/iio/adc

[PATCH 11/20] irqchip/atmel-aic: convert to of_property_for_each_u32_new()

2024-07-03 Thread Luca Ceresoli
Simplify code using of_property_for_each_u32_new() as the two additional parameters in of_property_for_each_u32() are not used here. Signed-off-by: Luca Ceresoli --- drivers/irqchip/irq-atmel-aic-common.c | 4 +--- 1 file changed, 1 insertion(+), 3 deletions(-) diff --git a/drivers/irqchip/irq

[PATCH 10/20] pinctrl: s32cc: convert to of_property_for_each_u32_new()

2024-07-03 Thread Luca Ceresoli
Simplify code using of_property_for_each_u32_new() as the two additional parameters in of_property_for_each_u32() are not used here. Signed-off-by: Luca Ceresoli --- drivers/pinctrl/nxp/pinctrl-s32cc.c | 4 +--- 1 file changed, 1 insertion(+), 3 deletions(-) diff --git a/drivers/pinctrl/nxp

[PATCH 09/20] gpio: brcmstb: convert to of_property_for_each_u32_new()

2024-07-03 Thread Luca Ceresoli
Simplify code using of_property_for_each_u32_new() as the two additional parameters in of_property_for_each_u32() are not used here. Signed-off-by: Luca Ceresoli --- drivers/gpio/gpio-brcmstb.c | 5 + 1 file changed, 1 insertion(+), 4 deletions(-) diff --git a/drivers/gpio/gpio-brcmstb.c b

[PATCH 08/20] lk: clk-conf: convert to of_property_for_each_u32_new()

2024-07-03 Thread Luca Ceresoli
Simplify code using of_property_for_each_u32_new() as the two additional parameters in of_property_for_each_u32() are not used here. Signed-off-by: Luca Ceresoli --- drivers/clk/clk-conf.c | 4 +--- 1 file changed, 1 insertion(+), 3 deletions(-) diff --git a/drivers/clk/clk-conf.c b/drivers

[PATCH 07/20] bus: ti-sysc: convert to of_property_for_each_u32_new()

2024-07-03 Thread Luca Ceresoli
Simplify code using of_property_for_each_u32_new() as the two additional parameters in of_property_for_each_u32() are not used here. Signed-off-by: Luca Ceresoli --- drivers/bus/ti-sysc.c | 4 +--- 1 file changed, 1 insertion(+), 3 deletions(-) diff --git a/drivers/bus/ti-sysc.c b/drivers/bus

[PATCH 06/20] clocksource/drivers/samsung_pwm: convert to of_property_for_each_u32_new()

2024-07-03 Thread Luca Ceresoli
Simplify code using of_property_for_each_u32_new() as the two additional parameters in of_property_for_each_u32() are not used here. Signed-off-by: Luca Ceresoli --- drivers/clocksource/samsung_pwm_timer.c | 4 +--- 1 file changed, 1 insertion(+), 3 deletions(-) diff --git a/drivers

[PATCH 05/20] clk: sunxi: clk-sun8i-bus-gates: convert to of_property_for_each_u32_new()

2024-07-03 Thread Luca Ceresoli
Simplify code using of_property_for_each_u32_new() as the two additional parameters in of_property_for_each_u32() are not used here. Signed-off-by: Luca Ceresoli --- drivers/clk/sunxi/clk-sun8i-bus-gates.c | 4 +--- 1 file changed, 1 insertion(+), 3 deletions(-) diff --git a/drivers/clk/sunxi

[PATCH 04/20] clk: sunxi: clk-simple-gates: convert to of_property_for_each_u32_new()

2024-07-03 Thread Luca Ceresoli
Simplify code using of_property_for_each_u32_new() as the two additional parameters in of_property_for_each_u32() are not used here. Signed-off-by: Luca Ceresoli --- drivers/clk/sunxi/clk-simple-gates.c | 4 +--- 1 file changed, 1 insertion(+), 3 deletions(-) diff --git a/drivers/clk/sunxi/clk

[PATCH 00/20] Simplify of_property_for_each_u32()

2024-07-03 Thread Luca Ceresoli
_u32_new() * Remove of_property_for_each_u32_old() * Rename of_property_for_each_u32_new() to of_property_for_each_u32() Signed-off-by: Luca Ceresoli --- Luca Ceresoli (20): of: add of_property_for_each_u32_new() clk: convert to of_property_for_each_u32_new() clk: qcom: convert to of_prope

[PATCH 03/20] clk: qcom: convert to of_property_for_each_u32_new()

2024-07-03 Thread Luca Ceresoli
Simplify code using of_property_for_each_u32_new() as the two additional parameters in of_property_for_each_u32() are not used here. Signed-off-by: Luca Ceresoli --- drivers/clk/qcom/common.c | 4 +--- 1 file changed, 1 insertion(+), 3 deletions(-) diff --git a/drivers/clk/qcom/common.c b

[PATCH 02/20] clk: convert to of_property_for_each_u32_new()

2024-07-03 Thread Luca Ceresoli
Simplify code using of_property_for_each_u32_new() as the two additional parameters in of_property_for_each_u32() are not used here. Signed-off-by: Luca Ceresoli --- drivers/clk/clk.c | 4 +--- 1 file changed, 1 insertion(+), 3 deletions(-) diff --git a/drivers/clk/clk.c b/drivers/clk/clk.c

[PATCH 01/20] of: add of_property_for_each_u32_new()

2024-07-03 Thread Luca Ceresoli
t;_it" so it is visible during code reviews, helping to avoid new code to use it directly. Signed-off-by: Luca Ceresoli --- .clang-format | 1 + include/linux/of.h | 11 --- 2 files changed, 9 insertions(+), 3 deletions(-) diff --git a/.clang-format b/.clang-format index cc

[PATCH 20/20] of: deprecate and rename of_property_for_each_u32()

2024-07-03 Thread Luca Ceresoli
of_property_for_each_u32_new() macro in not(-yet)-upstream code. Signed-off-by: Luca Ceresoli --- Notes: * The following files have not been build-tested simply because I haven't managed to have a config that enables them so far: drivers/irqchip/irq-pic32-evic.c drivers/pinctrl/pinctrl-k

[PATCH 19/20] powerpc/xive: convert to of_property_for_each_u32_new()

2024-07-03 Thread Luca Ceresoli
here is no side effect because the of_property_for_each_u32() macro being removed would anyway write 'reg' bwfore reading its value, and 'reg' is not used in _following_ lines. Signed-off-by: Luca Ceresoli --- arch/powerpc/sysdev/xive/spapr.c | 3 +-- 1 file changed, 1 inser

[PATCH 18/20] powerpc/xive: convert to of_property_for_each_u32_new()

2024-07-03 Thread Luca Ceresoli
Simplify code using of_property_for_each_u32_new() as the two additional parameters in of_property_for_each_u32() are not used here. Signed-off-by: Luca Ceresoli --- arch/powerpc/sysdev/xive/native.c | 4 +--- 1 file changed, 1 insertion(+), 3 deletions(-) diff --git a/arch/powerpc/sysdev/xive

[PATCH 16/20] mfd: ti_am335x_tscadc: convert to of_property_for_each_u32_new()

2024-07-03 Thread Luca Ceresoli
Simplify code using of_property_for_each_u32_new() as the two additional parameters in of_property_for_each_u32() are not used here. Signed-off-by: Luca Ceresoli --- drivers/mfd/ti_am335x_tscadc.c | 4 +--- 1 file changed, 1 insertion(+), 3 deletions(-) diff --git a/drivers/mfd

[PATCH 17/20] ASoC: arizona: convert to of_property_for_each_u32_new()

2024-07-03 Thread Luca Ceresoli
Simplify code using of_property_for_each_u32_new() as the two additional parameters in of_property_for_each_u32() are not used here. Signed-off-by: Luca Ceresoli --- sound/soc/codecs/arizona.c | 12 +--- 1 file changed, 5 insertions(+), 7 deletions(-) diff --git a/sound/soc/codecs

Re: [PATCH] sound: Switch i2c drivers back to use .probe()

2023-05-25 Thread Luca Ceresoli
eter") convert > back to (the new) .probe() to be able to eventually drop .probe_new() from > struct i2c_driver. > > Signed-off-by: Uwe Kleine-König Reviewed-by: Luca Ceresoli -- Luca Ceresoli, Bootlin Embedded Linux and Kernel engineering https://bootlin.com

Re: [PATCH] scripts/spelling.txt: add "exsits" pattern and fix typo instances

2023-01-27 Thread Luca Ceresoli
Hello Jakub, thanks for our review. On Thu, 26 Jan 2023 15:55:26 -0800 Jakub Kicinski wrote: > On Thu, 26 Jan 2023 16:22:05 +0100 Luca Ceresoli wrote: > > Fix typos and add the following to the scripts/spelling.txt: > > > > exsits||exists > > > > Signed-

[PATCH] scripts/spelling.txt: add "exsits" pattern and fix typo instances

2023-01-26 Thread Luca Ceresoli
Fix typos and add the following to the scripts/spelling.txt: exsits||exists Signed-off-by: Luca Ceresoli --- drivers/infiniband/ulp/iser/iscsi_iser.c | 2 +- net/openvswitch/flow_table.c | 2 +- scripts/spelling.txt | 1 + sound/soc/fsl/fsl-asoc-card.c

[PATCH] ASoC: fsl-asoc-card: constify fsl_asoc_card_dai

2023-01-26 Thread Luca Ceresoli
This is never modified and can be made const. Signed-off-by: Luca Ceresoli --- sound/soc/fsl/fsl-asoc-card.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/sound/soc/fsl/fsl-asoc-card.c b/sound/soc/fsl/fsl-asoc-card.c index 2f25358196ee..00118a75d126 100644 --- a/sound/soc

Re: [PATCH 6/6] i2c: Make remove callback return void

2022-06-29 Thread Luca Ceresoli
= i2c_get_clientdata(client); > > @@ -1146,8 +1146,6 @@ static int vc5_remove(struct i2c_client *client) > > if (vc5->chip_info->flags & VC5_HAS_INTERNAL_XTAL) > clk_unregister_fixed_rate(vc5->pin_xin); > - > - return 0; > } >

Re: [PATCH] arch/powerpc: use simple i2c probe function

2020-08-13 Thread Luca Ceresoli
les during probes. > > Signed-off-by: Stephen Kitt Reviewed-by: Luca Ceresoli -- Luca