evice_configure = pata_macio_device_configure,
.sdev_groups= ata_common_sdev_groups,
.can_queue = ATA_DEF_QUEUE,
Feel free to add:
Reviewed-by: John Garry
On 30/01/2023 22:54, Ian Rogers wrote:
This is almost identical to generated perf_pmu__find_events_table(),
except we return a pmu_metrics_table * (instead of a pmu_events_table *)
and also return the metric table member (instead of event table). But
the definitions are:
/* Struct used to make t
On 31/01/2023 00:39, Ian Rogers wrote:
Thanks John, will fix. Is there anything else?
Do you think that pmu-events/__pycache__/metric.cpython-36.pyc should be
deleted with a make clean? I would expect stuff like this to be deleted
(with a clean), but I am not sure if we have a policy on this (py
On 26/01/2023 23:36, Ian Rogers wrote:
@@ -660,7 +763,29 @@ const struct pmu_events_table
*perf_pmu__find_events_table(struct perf_pmu *pmu)
const struct pmu_metrics_table *perf_pmu__find_metrics_table(struct perf_pmu *pmu)
{
-return (struct pmu_metrics_table *)perf_pmu__find_eve
On 27/01/2023 13:48, Ian Rogers wrote:
On Fri, Jan 27, 2023, 5:20 AM John Garry <mailto:john.g.ga...@oracle.com>> wrote:
On 26/01/2023 23:36, Ian Rogers wrote:
Hi Ian,
At a glance, none of this series has your Signed-off-by tag..
Thanks,
John
Thanks John, wil
On 27/01/2023 13:48, Ian Rogers wrote:
On Fri, Jan 27, 2023, 5:20 AM John Garry <mailto:john.g.ga...@oracle.com>> wrote:
On 26/01/2023 23:36, Ian Rogers wrote:
Hi Ian,
At a glance, none of this series has your Signed-off-by tag..
Thanks,
John
Thanks John, wil
On 26/01/2023 23:36, Ian Rogers wrote:
Hi Ian,
At a glance, none of this series has your Signed-off-by tag..
Thanks,
John
Add an optimization to jevents using the metric code, rewrite metrics
in terms of each other in order to minimize size and improve
readability. For example, on Power8
othe
failure can be avoided when running
as a test.
Fixes: acef233b7ca7 ("perf pmu: Add #slots literal support for arm64")
---
Again, no SoB here.
For me, though:
Reviewed-by: John Garry
On 26/01/2023 23:36, Ian Rogers wrote:
This allows the set of generated jevents events and metrics be limited
to a subset of the model names. Appropriate if trying to minimize the
binary size where only a set of models are possible.
No SoB or RB tags at all.
Thanks,
John
---
tools/perf/pmu
On 26/01/2023 01:18, Ian Rogers wrote:
Add RewriteMetricsInTermsOfOthers that iterates over pairs of names
and expressions trying to replace an expression, within the current
expression, with its name.
Signed-off-by: Ian Rogers
hmmm ... did you test this for many python versions?
Maybe this
On 26/01/2023 14:20, Arnaldo Carvalho de Melo wrote:
Em Thu, Jan 26, 2023 at 01:44:39PM +, John Garry escreveu:
On 26/01/2023 01:18, Ian Rogers wrote:
This allows the set of generated jevents events and metrics be limited
to a subset of the model names. Appropriate if trying to minimize
: John Garry
---
tools/perf/pmu-events/Build | 3 ++-
tools/perf/pmu-events/jevents.py | 14 ++
2 files changed, 16 insertions(+), 1 deletion(-)
diff --git a/tools/perf/pmu-events/Build b/tools/perf/pmu-events/Build
index 15b9e8fdbffa..a14de24ecb69 100644
--- a/tools/perf/pmu
On 24/01/2023 06:33, Ian Rogers wrote:
This allows the set of generated jevents events and metrics be limited
to a subset of the model names. Appropriate if trying to minimize the
binary size where only a set of models are possible. On ARM64 the
--model selects the implementor rather than model.
ty is questionable. Also the
MetricNames look broken (contain spaces) in some cases and when trying
to use the functionality with '-e' the metrics fail but regular
metrics with '-M' work. For example, on SkylakeX '-M' works:
Reviewed-by: John Garry
: Ian Rogers
Reviewed-by: John Garry
events,
and the metric iterator skip event only events.
Signed-off-by: Ian Rogers
Reviewed-by: John Garry
On 21/12/2022 22:34, Ian Rogers wrote:
Previously both events and metrics were encoded in struct
pmu_event. Create a new pmu_metric that has the metric related
variables and remove these from pmu_event. Add iterators for
pmu_metric and use in places that metrics are desired rather than
events.
N
On 21/12/2022 22:34, Ian Rogers wrote:
Add a metrics table that is just a cast from pmu_events_table. This
changes the APIs so that event and metric usage of the underlying
table is different. Later changes will separate the tables.
This introduction fixes a NO_JEVENTS=1 regression on:
68: Par
On 21/12/2022 22:34, Ian Rogers wrote:
Turn a perf json event into an event, metric or both. This reduces the
number of events needed to scan to find an event or metric. As events
no longer need the relatively seldom used metric fields, 4 bytes is
saved per event. This reduces the big C string's
On 21/12/2022 22:34, Ian Rogers wrote:
Add an optimization to jevents using the metric code, rewrite metrics
in terms of each other in order to minimize size and improve
readability. For example, on Power8
other_stall_cpi is rewritten from:
"PM_CMPLU_STALL / PM_RUN_INST_CMPL - PM_CMPLU_STALL_BRU_
On 21/12/2022 22:34, Ian Rogers wrote:
Metrics are their own unit and these variables held broken metrics
previously and now just hold the value NULL. Remove code that used
these variables.
Signed-off-by: Ian Rogers
Reviewed-by: John Garry
Hi Martin,
Use scsi_cmd_to_rq(scsi_cmnd)->tag in preference to scsi_cmnd.tag.
Applied to 5.15/scsi-staging and rebased for bisectability.
Thanks, and sorry for the hassle. But I would still like the maintainers
to have a look, as I was curious about current usage of scsi_cmnd.tag in
tha
Use scsi_cmd_to_rq(scsi_cmnd)->tag in preference to scsi_cmnd.tag.
Signed-off-by: John Garry
---
This patch was missed in a series to remove scsi_cmnd.tag, which caused
a build error on Martin's SCSI staging tree:
https://lore.kernel.org/linux-scsi/yq14kbppa42@ca-mkp.ca.orac
On 11/01/2021 23:12, Tyrel Datwyler wrote:
Introduce several new vhost fields for managing MQ state of the adapter
as well as initial defaults for MQ enablement.
Signed-off-by: Tyrel Datwyler
---
drivers/scsi/ibmvscsi/ibmvfc.c | 8
drivers/scsi/ibmvscsi/ibmvfc.h | 9 +
2 fi
On 08/12/2020 22:37, Tyrel Datwyler wrote:
On 12/7/20 3:56 AM, Hannes Reinecke wrote:
On 12/4/20 3:26 PM, Brian King wrote:
On 12/2/20 11:27 AM, Tyrel Datwyler wrote:
On 12/2/20 7:14 AM, Brian King wrote:
On 12/1/20 6:53 PM, Tyrel Datwyler wrote:
Introduce several new vhost fields for managi
-config IOMMU_DEFAULT_PASSTHROUGH
-bool "IOMMU passthrough by default"
+choice
+prompt "IOMMU default DMA mode"
depends on IOMMU_API
-help
- Enable passthrough by default, removing the need to pass in
- iommu.passthrough=on or iommu=pt through command line. If thi
not picked up, but modulo (somtimes same) comments below:
Reviewed-by: John Garry
Signed-off-by: Zhen Lei
---
drivers/iommu/Kconfig | 42 +++---
drivers/iommu/iommu.c | 3 ++-
2 files changed, 37 insertions(+), 8 deletions(-)
diff --git a/drivers/iommu
dma modes on each ARCHs have no change.
Signed-off-by: Zhen Lei
Apart from more minor comments, FWIW:
Reviewed-by: John Garry
---
arch/ia64/kernel/pci-dma.c| 2 +-
arch/powerpc/platforms/powernv/pci-ioda.c | 3 ++-
arch/s390/pci/pci_dma.c | 2 +-
arch
On 18/04/2019 14:57, Zhen Lei wrote:
First, add build option IOMMU_DEFAULT_{LAZY|STRICT}, so that we have the
opportunity to set {lazy|strict} mode as default at build time. Then put
the three config options in an choice, make people can only choose one of
the three at a time.
The default IOMMU
On 09/04/2019 13:53, Zhen Lei wrote:
Currently the IOMMU dma contains 3 modes: passthrough, lazy, strict. The
passthrough mode bypass the IOMMU, the lazy mode defer the invalidation
of hardware TLBs, and the strict mode invalidate IOMMU hardware TLBs
synchronously. The three modes are mutually ex
30 matches
Mail list logo