oticed. Preemptively fix backtrace() for all
> architectures.
>
> Fixes: 52266791750d ("lib: backtrace printing")
> Signed-off-by: Andrew Jones
Acked-by: Claudio Imbrenda
> ---
> lib/arm/stack.c | 13 +
> lib/arm64/stack.c | 12 +---
> lib
On Fri, 22 Dec 2023 23:50:40 +1000
Nicholas Piggin wrote:
> Signed-off-by: Nicholas Piggin
> ---
> s390x/Makefile | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/s390x/Makefile b/s390x/Makefile
> index f79fd009..95ef9533 100644
> --- a/s390x/Makefile
> +++ b/s390x/Make
gration code already.
>
> Signed-off-by: Nicholas Piggin
for s390x:
Acked-by: Claudio Imbrenda
[...]
t; index 02217fb4ae10..f17249ab2a72 100644
> --- a/arch/s390/kvm/Makefile
> +++ b/arch/s390/kvm/Makefile
> @@ -5,7 +5,7 @@
>
> include $(srctree)/virt/kvm/Makefile.kvm
>
> -ccflags-y := -Ivirt/kvm -Iarch/s390/kvm
> +ccflags-y := -Iarch/s390/kvm
>
> kvm-y +
hine (KVM) support"
> - depends on HAVE_KVM
> select PREEMPT_NOTIFIERS
> select HAVE_KVM_CPU_RELAX_INTERCEPT
> select HAVE_KVM_VCPU_ASYNC_IOCTL
it looks like we don't use HAVE_KVM on s390x
Reviewed-by: Claudio Imbrenda
On Tue, 11 Jul 2023 21:38:35 -0700 (PDT)
Hugh Dickins wrote:
[...]
> +#ifdef CONFIG_TRANSPARENT_HUGEPAGE
> +void pte_free_defer(struct mm_struct *mm, pgtable_t pgtable)
> +{
> + struct page *page;
> +
> + page = virt_to_page(pgtable);
> + SetPageActive(page);
> + page_table_free(
On Fri, 30 Jun 2023 12:22:43 -0700 (PDT)
Hugh Dickins wrote:
[...]
> That's something I would have expected to be handled already via
> mmu_notifiers, rather than buried inside the page table freeing.
>
> If s390 is the only architecture to go that way, and could instead do
> it via mmu_notifie
On Fri, 30 Jun 2023 08:28:54 -0700 (PDT)
Hugh Dickins wrote:
> On Fri, 30 Jun 2023, Claudio Imbrenda wrote:
> > On Tue, 20 Jun 2023 00:51:19 -0700 (PDT)
> > Hugh Dickins wrote:
> >
> > [...]
> >
> > > +void pte_free_defer(struct mm_struct *mm, pg
On Tue, 20 Jun 2023 00:51:19 -0700 (PDT)
Hugh Dickins wrote:
[...]
> @@ -407,6 +429,77 @@ void __tlb_remove_table(void *_table)
> __free_page(page);
> }
>
> +#ifdef CONFIG_TRANSPARENT_HUGEPAGE
> +static void pte_free_now0(struct rcu_head *head);
> +static void pte_free_now1(struct rcu_h
and fix old comment there: must be called after THP was disabled.
>
> Signed-off-by: Hugh Dickins
Acked-by: Claudio Imbrenda
> ---
> arch/s390/kernel/uv.c | 2 ++
> arch/s390/mm/gmap.c| 9 -
> arch/s390/mm/pgtable.c | 12 +---
> 3 files changed, 1
On Tue, 23 May 2023 18:49:14 -0700 (PDT)
Hugh Dickins wrote:
> On Tue, 23 May 2023, Claudio Imbrenda wrote:
> >
> > so if I understand the above correctly, pte_offset_map_lock will only
> > fail if the whole page table has disappeared, and in that case, it will
> &g
On Wed, 17 May 2023 14:50:28 -0700 (PDT)
Hugh Dickins wrote:
> On Wed, 17 May 2023, Claudio Imbrenda wrote:
> > On Tue, 9 May 2023 22:01:16 -0700 (PDT)
> > Hugh Dickins wrote:
> >
> > > In rare transient cases, not yet made possible, pte_offset_map() and
>
On Tue, 9 May 2023 22:01:16 -0700 (PDT)
Hugh Dickins wrote:
> In rare transient cases, not yet made possible, pte_offset_map() and
> pte_offset_map_lock() may not find a page table: handle appropriately.
>
> Signed-off-by: Hugh Dickins
> ---
> arch/s390/kernel/uv.c | 2 ++
> arch/s390/mm/gma
On Fri, 3 Feb 2023 10:42:30 +0100
Thomas Huth wrote:
> All kvm_arch_vm_ioctl() implementations now only deal with "int"
> types as return values, so we can change the return type of these
> functions to use "int" instead of "long".
>
> Signed-off
On Fri, 3 Feb 2023 10:42:28 +0100
Thomas Huth wrote:
> These two functions only return normal integers, so it does not
> make sense to declare the return type as "long" here.
>
> Signed-off-by: Thomas Huth
Reviewed-by: Claudio Imbrenda
> ---
> arch/s390/kvm/k
On Thu, 3 Nov 2022 13:44:15 +0100
Claudio Imbrenda wrote:
> On Wed, 2 Nov 2022 23:18:52 +
> Sean Christopherson wrote:
>
> > Move the guts of kvm_arch_init() into a new helper, __kvm_s390_init(),
> > and invoke the new helper directly from kvm_s390_init() instead of
On Wed, 2 Nov 2022 23:18:52 +
Sean Christopherson wrote:
> Move the guts of kvm_arch_init() into a new helper, __kvm_s390_init(),
> and invoke the new helper directly from kvm_s390_init() instead of
> bouncing through kvm_init(). Invoking kvm_arch_init() is the very
> first action performed
flicts for ARM (due to file movement) and manually handle RISC-V
> which comes after the commit.
>
> And changes about kvm_arch_hardware_setup() in original commit are still
> needed so they are not reverted.
>
> Signed-off-by: Chao Gao
> Reviewed-by: Sean Christophe
On Fri, 5 Nov 2021 19:20:59 +
Marc Zyngier wrote:
> As we are about to change the way vcpus are allocated, mandate
> the use of kvm_get_vcpu() instead of open-coding the access.
>
> Signed-off-by: Marc Zyngier
makes sense
Reviewed-by: Claudio Imbrenda
> ---
> arch/s
the references from the array.
>
> Make this code common, which will simplify further changes.
>
> Signed-off-by: Marc Zyngier
no objections
Reviewed-by: Claudio Imbrenda
> ---
> arch/arm64/kvm/arm.c | 10 +-
> arch/mips/kvm/mips.c | 21 +--
20 matches
Mail list logo