[PATCH v6 7/7] powerpc/pseries: Add a char driver for physical-attestation RTAS

2025-02-14 Thread Haren Myneni
The RTAS call ibm,physical-attestation is used to retrieve information about the trusted boot state of the firmware and hypervisor on the system, and also Trusted Platform Modules (TPM) data if the system is TCG 2.0 compliant. This RTAS interface expects the caller to define different command stru

[PATCH v6 6/7] powerpc/pseries: Add papr-platform-dump character driver for dump retrieval

2025-02-14 Thread Haren Myneni
ibm,platform-dump RTAS call in combination with writable mapping /dev/mem is issued to collect platform dump from the hypervisor and may need multiple calls to get the complete dump. The current implementation uses rtas_platform_dump() API provided by librtas library to issue these RTAS calls. But

[PATCH v6 4/7] powerpc/pseries: Add ibm,set-dynamic-indicator RTAS call support

2025-02-14 Thread Haren Myneni
The RTAS call ibm,set-dynamic-indicator is used to set the new indicator state identified by a location code. The current implementation uses rtas_set_dynamic_indicator() API provided by librtas library which allocates RMO buffer and issue this RTAS call in the user space. But /dev/mem access by th

[PATCH v6 5/7] powerpc/pseries: Add ibm,get-dynamic-sensor-state RTAS call support

2025-02-14 Thread Haren Myneni
The RTAS call ibm,get-dynamic-sensor-state is used to get the sensor state identified by the location code and the sensor token. The librtas library provides an API rtas_get_dynamic_sensor() which uses /dev/mem access for work area allocation but is restricted under system lockdown. This patch pro

[PATCH v6 3/7] powerpc/pseries: Add papr-indices char driver for ibm,get-indices

2025-02-14 Thread Haren Myneni
The RTAS call ibm,get-indices is used to obtain indices and location codes for a specified indicator or sensor token. The current implementation uses rtas_get_indices() API provided by librtas library which allocates RMO buffer and issue this RTAS call in the user space. But writable mapping /dev/m

[PATCH v6 2/7] powerpc/pseries: Define papr_indices_io_block for papr-indices ioctls

2025-02-14 Thread Haren Myneni
To issue ibm,get-indices, ibm,set-dynamic-indicator and ibm,get-dynamic-sensor-state in the user space, the RMO buffer is allocated for the work area which is restricted under system lockdown. So instead of user space execution, the kernel will provide /dev/papr-indices interface to execute these R

[PATCH v6 1/7] powerpc/pseries: Define common functions for RTAS sequence calls

2025-02-14 Thread Haren Myneni
The RTAS call can be normal where retrieves the data form the hypervisor once or sequence based RTAS call which has to issue multiple times until the complete data is obtained. For some of these sequence RTAS calls, the OS should not interleave calls with different input until the sequence is compl

[PATCH v6 0/7] Add character devices for indices, platform-dump

2025-02-14 Thread Haren Myneni
Several APIs such as rtas_get_indices(), rtas_get_dynamic_sensor(), rtas_set_dynamic_indicator(), rtas_platform_dump() and rtas_physical_attestation() provided by librtas library are implemented in user space using rtas syscall in combination with writable mappings of /dev/mem. But this implementa

[PATCH v4 3/3] printf: implicate test line in failure messages

2025-02-14 Thread Tamir Duberstein
This improves the failure output by pointing to the failing line at the top level of the test, e.g.: # test_number: EXPECTATION FAILED at lib/printf_kunit.c:103 lib/printf_kunit.c:167: vsnprintf(buf, 256, "%#-12x", ...) wrote '0x1234abcd ', expected '0x1234abce ' # test_number: EXP

[PATCH v4 2/3] printf: break kunit into test cases

2025-02-14 Thread Tamir Duberstein
Move all tests into `printf_test_cases`. This gives us nicer output in the event of a failure. Combine `plain_format` and `plain_hash` into `hash_pointer` since they're testing the same scenario. Signed-off-by: Tamir Duberstein --- lib/tests/printf_kunit.c | 331 +---

[PATCH v4 0/3] printf: convert self-test to KUnit

2025-02-14 Thread Tamir Duberstein
This is one of just 3 remaining "Test Module" kselftests (the others being bitmap and scanf), the rest having been converted to KUnit. I tested this using: $ tools/testing/kunit/kunit.py run --arch arm64 --make_options LLVM=1 printf I have also sent out a series converting scanf[0]. Link: http

[PATCH v4 1/3] printf: convert self-test to KUnit

2025-02-14 Thread Tamir Duberstein
Convert the printf() self-test to a KUnit test. In the interest of keeping the patch reasonably-sized this doesn't refactor the tests into proper parameterized tests - it's all one big test case. Signed-off-by: Tamir Duberstein --- Documentation/core-api/printk-formats.rst | 4 +- MAINTAINE

Re: [PATCH v3 0/2] printf: convert self-test to KUnit

2025-02-14 Thread Tamir Duberstein
On Fri, Feb 14, 2025 at 4:47 PM Rasmus Villemoes wrote: > > On Fri, 14 Feb 2025 at 17:53, Tamir Duberstein wrote: > > > > On Fri, Feb 14, 2025 at 11:02 AM Andy Shevchenko > > wrote: > > > > > > On Fri, Feb 14, 2025 at 04:35:12PM +0100, Petr Mladek wrote: > > > > > I have just quickly tested this

Re: [PATCH v3 0/2] printf: convert self-test to KUnit

2025-02-14 Thread Rasmus Villemoes
On Fri, 14 Feb 2025 at 17:53, Tamir Duberstein wrote: > > On Fri, Feb 14, 2025 at 11:02 AM Andy Shevchenko > wrote: > > > > On Fri, Feb 14, 2025 at 04:35:12PM +0100, Petr Mladek wrote: > > > I have just quickly tested this before leaving for a week. > > > And I am fine with the result. > > Than

Re: [PATCH 4/4] PCI: Descope pci_printk() to aer_printk()

2025-02-14 Thread Bjorn Helgaas
On Fri, Feb 14, 2025 at 01:56:47PM +0200, Ilpo Järvinen wrote: > On Thu, 13 Feb 2025, Bjorn Helgaas wrote: > > On Mon, Dec 16, 2024 at 06:10:12PM +0200, Ilpo Järvinen wrote: > > > include/linux/pci.h provides low-level pci_printk() interface that is > > > only used by AER because it needs to print

Re: [PATCH v13 4/5] arm64: support copy_mc_[user]_highpage()

2025-02-14 Thread Catalin Marinas
On Fri, Feb 14, 2025 at 10:49:01AM +0800, Tong Tiangen wrote: > 在 2025/2/13 1:11, Catalin Marinas 写道: > > On Mon, Dec 09, 2024 at 10:42:56AM +0800, Tong Tiangen wrote: > > > Currently, many scenarios that can tolerate memory errors when copying > > > page > > > have been supported in the kernel[1~

Re: [PATCH v3 0/2] printf: convert self-test to KUnit

2025-02-14 Thread Tamir Duberstein
On Fri, Feb 14, 2025 at 11:02 AM Andy Shevchenko wrote: > > On Fri, Feb 14, 2025 at 04:35:12PM +0100, Petr Mladek wrote: > > On Mon 2025-02-10 13:23:21, Tamir Duberstein wrote: > > > This is one of just 3 remaining "Test Module" kselftests (the others > > > being bitmap and scanf), the rest having

Re: [PATCH v3 0/2] printf: convert self-test to KUnit

2025-02-14 Thread Andy Shevchenko
On Fri, Feb 14, 2025 at 04:35:12PM +0100, Petr Mladek wrote: > On Mon 2025-02-10 13:23:21, Tamir Duberstein wrote: > > This is one of just 3 remaining "Test Module" kselftests (the others > > being bitmap and scanf), the rest having been converted to KUnit. > > > > I tested this using: > > > > $

Re: [PATCH v3 0/2] printf: convert self-test to KUnit

2025-02-14 Thread Petr Mladek
On Mon 2025-02-10 13:23:21, Tamir Duberstein wrote: > This is one of just 3 remaining "Test Module" kselftests (the others > being bitmap and scanf), the rest having been converted to KUnit. > > I tested this using: > > $ tools/testing/kunit/kunit.py run --arch arm64 --make_options LLVM=1 printf

Re: [linux-next-20250212] syscall kexec_file_load not available

2025-02-14 Thread Sourabh Jain
Hello, On 14/02/25 12:15, Sourabh Jain wrote: Hello Hari, On 14/02/25 12:02, Hari Bathini wrote: On 13/02/25 8:34 pm, Venkat Rao Bagalkote wrote: Greetings!!!  From kernel next-20250210, I am observing syscall kexec_file_load not available, there by kdump service is failing to start.

Re: [PATCH 3/4] PCI: shpchp: Cleanup logging and debug wrappers

2025-02-14 Thread Ilpo Järvinen
On Thu, 13 Feb 2025, Bjorn Helgaas wrote: > On Mon, Dec 16, 2024 at 06:10:11PM +0200, Ilpo Järvinen wrote: > > The shpchp hotplug driver defines logging wrappers ctrl_*() and another > > set of wrappers with generic names which are just duplicates of > > existing generic printk() wrappers. Only th

Re: [PATCH] net: freescale: ucc_geth: make ugeth_mac_ops be static

2025-02-14 Thread Andrew Lunn
On Fri, Feb 14, 2025 at 02:11:07PM +0800, xiaopei...@foxmail.com wrote: > From: Pei Xiao > > sparse warning: > sparse: symbol 'ugeth_mac_ops' was not declared. Should it be > static. > > Add static to fix sparse warnings. While you are touching it, can it also be made const? struct phylink

Re: [PATCH v2] powerpc/code-patching: Fix KASAN hit by not flagging text patching area as VM_ALLOC

2025-02-14 Thread Madhavan Srinivasan
On Wed, 12 Feb 2025 07:46:28 +0100, Christophe Leroy wrote: > Erhard reported the following KASAN hit while booting his PowerMac G4 > with a KASAN-enabled kernel 6.13-rc6: > > BUG: KASAN: vmalloc-out-of-bounds in copy_to_kernel_nofault+0xd8/0x1c8 > Write of size 8 at addr f100 by task chro

Re: [PATCH v2] powerpc/64s: Rewrite __real_pte() and __rpte_to_hidx() as static inline

2025-02-14 Thread Madhavan Srinivasan
On Sun, 12 Jan 2025 19:24:46 +0100, Christophe Leroy wrote: > Rewrite __real_pte() and __rpte_to_hidx() as static inline in order to > avoid following warnings/errors when building with 4k page size: > > CC arch/powerpc/mm/book3s64/hash_tlb.o > arch/powerpc/mm/book3s64/hash_tlb.

Re: [PATCH] powerpc/code-patching: Disable KASAN report during patching via temporary mm

2025-02-14 Thread Madhavan Srinivasan
On Mon, 03 Feb 2025 11:14:57 +0100, Christophe Leroy wrote: > Erhard reports the following KASAN hit on Talos II (power9) with kernel 6.13: > > [ 12.028126] > == > [ 12.028198] BUG: KASAN: user-memory-access in > copy_to_kernel_

Re: [PATCH v2 0/2] ASoC: imx-card: support playback or capture only

2025-02-14 Thread Iuliana Prodan
On 2/14/2025 9:05 AM, Shengjiu Wang wrote: Be similar to audio graph card, support playback or capture only for imx-audio-card. imx-card can't directly refer to audio-graph-port.yaml, because it is not based on 'ports'. Add playback-only and capture-only property directly changes in v2: - wrap

Re: [PATCH] tools/perf: Add check to tool pmu tests to ensure if the event is valid

2025-02-14 Thread Thomas Richter
On 2/12/25 19:54, Athira Rajeev wrote: > "Tool PMU" tests fails on powerpc as below: > >12.1: Parsing without PMU name: >--- start --- >test child forked, pid 48492 >Using CPUID 0x00800200 >Attempt to add: tool/duration_time/ >..after resolving event: tool/config=0x1/ >

Re: [PATCH v2 05/12] dt-bindings: dma: Convert fsl,elo*-dma to YAML

2025-02-14 Thread J . Neuschäfer
On Mon, Feb 10, 2025 at 02:39:13PM -0500, Frank Li wrote: > On Fri, Feb 07, 2025 at 10:30:22PM +0100, J. Neuschäfer via B4 Relay wrote: > > From: "J. Neuschäfer" > > > > The devicetree bindings for Freescale DMA engines have so far existed as > > a text file. This patch converts them to YAML, and

Re: [PATCH v3 00/18] vDSO: Introduce generic data storage

2025-02-14 Thread David Woodhouse
On Fri, 2025-02-14 at 12:34 +0100, Thomas Gleixner wrote: > >  2. In kernel, asking KVM to populate the vmclock structure much like > >     it does other pvclocks shared with the guest. KVM/x86 already uses > >     pvclock_gtod_register_notifier() to hook changes; should we expand > >     on that?

Re: [PATCH v2 2/2] ASoC: imx-audmix: Update correct dai names

2025-02-14 Thread Daniel Baluta
Hi Chancel, This change should be squashed together with patch 1/2 otherwise you break bisectability On Fri, Feb 14, 2025 at 10:15 AM Chancel Liu wrote: > > Update correct dai names which are changed in CPU dai. > > Signed-off-by: Chancel Liu > --- > sound/soc/fsl/imx-audmix.c | 4 ++-- > 1 f

Re: [PATCH 4/4] PCI: Descope pci_printk() to aer_printk()

2025-02-14 Thread Ilpo Järvinen
On Thu, 13 Feb 2025, Bjorn Helgaas wrote: > On Mon, Dec 16, 2024 at 06:10:12PM +0200, Ilpo Järvinen wrote: > > include/linux/pci.h provides low-level pci_printk() interface that is > > only used by AER because it needs to print the same message with > > different levels depending on the error seve

Re: [PATCH v3 00/18] vDSO: Introduce generic data storage

2025-02-14 Thread Thomas Gleixner
David! On Thu, Feb 06 2025 at 09:31, David Woodhouse wrote: > Thanks for working on this. Is there a plan to expose the time data > directly to userspace in a form which is usable *other* than by > function calls which get the value of the clock at a given moment? > > For populating the vmclock de

[PATCH] net: freescale: ucc_geth: make ugeth_mac_ops be static

2025-02-14 Thread xiaopeitux
From: Pei Xiao sparse warning: sparse: symbol 'ugeth_mac_ops' was not declared. Should it be static. Add static to fix sparse warnings. Reported-by: kernel test robot Closes: https://lore.kernel.org/oe-kbuild-all/202502141128.9hfxcdie-...@intel.com/ Fixes: 53036aa8d031 ("net: freescale: u

Re: [PATCH] net: freescale: ucc_geth: make ugeth_mac_ops be static

2025-02-14 Thread Maxime Chevallier
Hi, On Fri, 14 Feb 2025 14:11:07 +0800 xiaopei...@foxmail.com wrote: > From: Pei Xiao > > sparse warning: > sparse: symbol 'ugeth_mac_ops' was not declared. Should it be > static. > > Add static to fix sparse warnings. > > Reported-by: kernel test robot > Closes: > https://lore.kernel.o

Re: [PATCH v2 1/2] ASoC: dt-bindings: imx-card: Add playback-only and capture-only property

2025-02-14 Thread Krzysztof Kozlowski
On Fri, Feb 14, 2025 at 03:05:32PM +0800, Shengjiu Wang wrote: > diff --git a/Documentation/devicetree/bindings/sound/imx-audio-card.yaml > b/Documentation/devicetree/bindings/sound/imx-audio-card.yaml > index f7ad5ea2491e..86571fa930f6 100644 > --- a/Documentation/devicetree/bindings/sound/imx-au

[PATCH v2 2/2] ASoC: imx-audmix: Update correct dai names

2025-02-14 Thread Chancel Liu
Update correct dai names which are changed in CPU dai. Signed-off-by: Chancel Liu --- sound/soc/fsl/imx-audmix.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/sound/soc/fsl/imx-audmix.c b/sound/soc/fsl/imx-audmix.c index 50ecc5f51100..dac5d4ddacd6 100644 --- a/sound/soc

[PATCH v2 1/2] ASoC: fsl_sai: Rename stream name of dai driver

2025-02-14 Thread Chancel Liu
If stream names of dai driver are duplicated there'll be warnings when machine driver tries to add widgets on a route: [8.831335] fsl-asoc-card sound-wm8960: ASoC: sink widget CPU-Playback overwritten [8.839917] fsl-asoc-card sound-wm8960: ASoC: source widget CPU-Capture overwritten Use