Re: [PATCH] powerpc/pseries: Add papr-platform-dump character driver for dump retrieval

2024-12-02 Thread Haren Myneni
On Wed, 2024-11-27 at 10:11 +0100, Michal Suchánek wrote: > On Tue, Nov 26, 2024 at 12:40:20PM -0800, Haren Myneni wrote: > > On Wed, 2024-11-27 at 00:42 +0530, Mahesh J Salgaonkar wrote: > > > On 2024-11-23 21:20:39 Sat, Haren Myneni wrote: > > > [...] > > > > +static ssize_t papr_platform_dump_ha

[PATCH 06/11] tools headers: Sync *xattrat syscall changes with the kernel sources

2024-12-02 Thread Namhyung Kim
To pick up the changes in this cset: 6140be90ec70c39f ("fs/xattr: add *at family syscalls") This addresses these perf build warnings: Warning: Kernel ABI header differences: diff -u tools/include/uapi/asm-generic/unistd.h include/uapi/asm-generic/unistd.h diff -u tools/perf/arch/x86

Re: [PATCH v2] of: WARN on deprecated #address-cells/#size-cells handling

2024-12-02 Thread Rob Herring
On Mon, Dec 2, 2024 at 4:09 PM Segher Boessenkool wrote: > > On Mon, Dec 02, 2024 at 08:18:22AM -0600, Rob Herring wrote: > > On Wed, Nov 27, 2024 at 3:47 PM Segher Boessenkool > > wrote: > > > On Tue, Nov 26, 2024 at 02:36:32PM +1100, Michael Ellerman wrote: > > > > Michael Ellerman writes: > >

Re: [PATCH v2] of: WARN on deprecated #address-cells/#size-cells handling

2024-12-02 Thread Segher Boessenkool
On Mon, Dec 02, 2024 at 08:18:22AM -0600, Rob Herring wrote: > On Wed, Nov 27, 2024 at 3:47 PM Segher Boessenkool > wrote: > > On Tue, Nov 26, 2024 at 02:36:32PM +1100, Michael Ellerman wrote: > > > Michael Ellerman writes: > > > > "Rob Herring (Arm)" writes: > > > >> While OpenFirmware original

Re: [PATCH v1 0/6] mm/page_alloc: gfp flags cleanups for alloc_contig_*()

2024-12-02 Thread Zi Yan
On 2 Dec 2024, at 7:58, David Hildenbrand wrote: > Let's clean up the gfp flags handling, and support __GFP_ZERO, such that we > can finally remove the TODO in memtrace code. > > I did some alloc_contig_*() testing with virtio-mem and hugetlb; I did not > test powernv/memtrace -- I cross-compiled

Re: [PATCH v1 3/6] mm/page_alloc: make __alloc_contig_migrate_range() static

2024-12-02 Thread Zi Yan
On 2 Dec 2024, at 7:58, David Hildenbrand wrote: > The single user is in page_alloc.c. > > Signed-off-by: David Hildenbrand > --- > mm/internal.h | 4 > mm/page_alloc.c | 5 ++--- > 2 files changed, 2 insertions(+), 7 deletions(-) > Reviewed-by: Zi Yan Best Regards, Yan, Zi

Re: [PATCH v2 09/21] drm/etnaviv: Convert timeouts to secs_to_jiffies()

2024-12-02 Thread Christian Gmeiner
> > Changes made with the following Coccinelle rules: > > @@ constant C; @@ > > - msecs_to_jiffies(C * 1000) > + secs_to_jiffies(C) > > @@ constant C; @@ > > - msecs_to_jiffies(C * MSEC_PER_SEC) > + secs_to_jiffies(C) > > Signed-off-by: Easwar Hariharan Reviewed-by: Christian Gmeiner > --- > d

Re: [PATCH v1 4/6] mm/page_alloc: sort out the alloc_contig_range() gfp flags mess

2024-12-02 Thread Zi Yan
On 2 Dec 2024, at 7:58, David Hildenbrand wrote: > It's all a bit complicated for alloc_contig_range(). For example, we don't > support many flags, so let's start bailing out on unsupported > ones -- ignoring the placement hints, as we are already given the range > to allocate. > > While we curren

Re: [PATCH 1/3] powerpc: copy preempt.h into arch/include/asm

2024-12-02 Thread Shrikanth Hegde
On 11/27/24 12:07, Christophe Leroy wrote: Le 25/11/2024 à 05:22, Shrikanth Hegde a écrit : PowerPC uses asm-generic preempt definitions as of now. Copy that into arch/asm so that arch specific changes can be done. This would help the next patch for enabling dynamic preemption. The reas

Re: [PATCH v2] of: WARN on deprecated #address-cells/#size-cells handling

2024-12-02 Thread Rob Herring
On Wed, Nov 27, 2024 at 3:47 PM Segher Boessenkool wrote: > > On Tue, Nov 26, 2024 at 02:36:32PM +1100, Michael Ellerman wrote: > > Michael Ellerman writes: > > > "Rob Herring (Arm)" writes: > > >> While OpenFirmware originally allowed walking parent nodes and default > > >> root values for #add

Re: [PATCH v2] selftests/ftrace: adjust offset for kprobe syntax error test

2024-12-02 Thread Steven Rostedt
On Sat, 30 Nov 2024 01:56:21 +0530 Hari Bathini wrote: > In 'NOFENTRY_ARGS' test case for syntax check, any offset X of > `vfs_read+X` except function entry offset (0) fits the criterion, > even if that offset is not at instruction boundary, as the parser > comes before probing. But with "ENDBR64

[PATCH 4/5] firmware: google: gsmi: Use BIN_ATTR_ADMIN_WO() for bin_attribute definition

2024-12-02 Thread Thomas Weißschuh
Using the macro saves some lines of code and prepares the attribute for the general constifications of struct bin_attributes. While at it also constify the callback parameter. Signed-off-by: Thomas Weißschuh --- drivers/firmware/google/gsmi.c | 17 +++-- 1 file changed, 7 insertions

[PATCH 5/5] scsi: arcmsr: Use BIN_ATTR_ADMIN_WO() for bin_attribute definitions

2024-12-02 Thread Thomas Weißschuh
Using the macro saves some lines of code and prepares the attributes for the general constifications of struct bin_attributes. While at it also constify the callback parameters. Signed-off-by: Thomas Weißschuh --- drivers/scsi/arcmsr/arcmsr_attr.c | 73 ++- 1

[PATCH 3/5] powerpc/powernv/flash: Use BIN_ATTR_ADMIN_WO() for bin_attribute definition

2024-12-02 Thread Thomas Weißschuh
Using the macro saves some lines of code and prepares the attribute for the general constifications of struct bin_attributes. While at it also constify the callback parameter. Signed-off-by: Thomas Weißschuh --- arch/powerpc/platforms/powernv/opal-flash.c | 14 +- 1 file changed, 5

[PATCH 1/5] sysfs: add macro BIN_ATTR_ADMIN_WO()

2024-12-02 Thread Thomas Weißschuh
The macros BIN_ATTR_RO/BIN_ATTR_WO/BIN_ATTR_WR and BIN_ATTR_ADMIN_RO/BIN_ATTR_ADMIN_RW already exist. To complete the collection also add BIN_ATTR_ADMIN_WO. Signed-off-by: Thomas Weißschuh --- include/linux/sysfs.h | 6 ++ 1 file changed, 6 insertions(+) diff --git a/include/linux/sysfs.h b

[PATCH 0/5] sysfs: introduce and use macro BIN_ATTR_ADMIN_WO()

2024-12-02 Thread Thomas Weißschuh
For the bin_attribute constification effort it is useful to have BIN_ATTR_ADMIN_WO() macro. Introduce it and switch over all places in the tree which can make use of it. While at it also constify the bin_attribute callback parameters. This series is meant to be applied through the driver core tre

[PATCH 2/5] s390/sclp_config: use BIN_ATTR_ADMIN_WO() for bin_attribute definition

2024-12-02 Thread Thomas Weißschuh
Using the macro saves some lines of code and prepares the attribute for the general constifications of struct bin_attributes. While at it also constify the callback parameter. Signed-off-by: Thomas Weißschuh --- drivers/s390/char/sclp_config.c | 16 +--- 1 file changed, 5 insertions

Re: [PATCH 1/3] powerpc: copy preempt.h into arch/include/asm

2024-12-02 Thread Christophe Leroy
Le 02/12/2024 à 15:05, Shrikanth Hegde a écrit : On 11/27/24 12:07, Christophe Leroy wrote: Le 25/11/2024 à 05:22, Shrikanth Hegde a écrit : PowerPC uses asm-generic preempt definitions as of now. Copy that into arch/asm so that arch specific changes can be done. This would help the next

Re: [PATCH v1 5/6] mm/page_alloc: forward the gfp flags from alloc_contig_range() to post_alloc_hook()

2024-12-02 Thread Zi Yan
On 2 Dec 2024, at 7:58, David Hildenbrand wrote: > In the __GFP_CONT case, we already pass the gfp_flags to s/__GFP_CONT/__GFP_COMP/ > prep_new_page()->post_alloc_hook(). However, in the !__GFP_CONT case, we Ditto > essentially pass only hardcoded __GFP_MOVABLE to post_alloc_hook(), > preventi

Re: [PATCH v1 2/6] mm/page_isolation: don't pass gfp flags to start_isolate_page_range()

2024-12-02 Thread Zi Yan
On 2 Dec 2024, at 7:58, David Hildenbrand wrote: > The parameter is unused, so let's stop passing it. > > Signed-off-by: David Hildenbrand > --- > include/linux/page-isolation.h | 2 +- > mm/memory_hotplug.c| 3 +-- > mm/page_alloc.c| 2 +- > mm/page_isolation.c

Re: [PATCH v1 1/6] mm/page_isolation: don't pass gfp flags to isolate_single_pageblock()

2024-12-02 Thread Zi Yan
On 2 Dec 2024, at 7:58, David Hildenbrand wrote: > The flags are no longer used, we can stop passing them to > isolate_single_pageblock(). > > Signed-off-by: David Hildenbrand > --- > mm/page_isolation.c | 8 +++- > 1 file changed, 3 insertions(+), 5 deletions(-) > Reviewed-by: Zi Yan Best

[PATCH v1 6/6] powernv/memtrace: use __GFP_ZERO with alloc_contig_pages()

2024-12-02 Thread David Hildenbrand
alloc_contig_pages()->alloc_contig_range() now supports __GFP_ZERO, so let's use that instead to resolve our TODO. Signed-off-by: David Hildenbrand --- arch/powerpc/platforms/powernv/memtrace.c | 31 +-- 1 file changed, 6 insertions(+), 25 deletions(-) diff --git a/arch/powe

[PATCH v1 5/6] mm/page_alloc: forward the gfp flags from alloc_contig_range() to post_alloc_hook()

2024-12-02 Thread David Hildenbrand
In the __GFP_CONT case, we already pass the gfp_flags to prep_new_page()->post_alloc_hook(). However, in the !__GFP_CONT case, we essentially pass only hardcoded __GFP_MOVABLE to post_alloc_hook(), preventing some action modifiers from being effective.. Let's pass our now properly adjusted gfp fla

[PATCH v1 4/6] mm/page_alloc: sort out the alloc_contig_range() gfp flags mess

2024-12-02 Thread David Hildenbrand
It's all a bit complicated for alloc_contig_range(). For example, we don't support many flags, so let's start bailing out on unsupported ones -- ignoring the placement hints, as we are already given the range to allocate. While we currently set cc.gfp_mask, in __alloc_contig_migrate_range() we sim

[PATCH v1 3/6] mm/page_alloc: make __alloc_contig_migrate_range() static

2024-12-02 Thread David Hildenbrand
The single user is in page_alloc.c. Signed-off-by: David Hildenbrand --- mm/internal.h | 4 mm/page_alloc.c | 5 ++--- 2 files changed, 2 insertions(+), 7 deletions(-) diff --git a/mm/internal.h b/mm/internal.h index 0d17095c2dee..5656089eea7c 100644 --- a/mm/internal.h +++ b/mm/internal

[PATCH v1 1/6] mm/page_isolation: don't pass gfp flags to isolate_single_pageblock()

2024-12-02 Thread David Hildenbrand
The flags are no longer used, we can stop passing them to isolate_single_pageblock(). Signed-off-by: David Hildenbrand --- mm/page_isolation.c | 8 +++- 1 file changed, 3 insertions(+), 5 deletions(-) diff --git a/mm/page_isolation.c b/mm/page_isolation.c index 7e04047977cf..e680d40d96de 10

[PATCH v1 2/6] mm/page_isolation: don't pass gfp flags to start_isolate_page_range()

2024-12-02 Thread David Hildenbrand
The parameter is unused, so let's stop passing it. Signed-off-by: David Hildenbrand --- include/linux/page-isolation.h | 2 +- mm/memory_hotplug.c| 3 +-- mm/page_alloc.c| 2 +- mm/page_isolation.c| 4 +--- 4 files changed, 4 insertions(+), 7 deletions(-)

[PATCH v1 0/6] mm/page_alloc: gfp flags cleanups for alloc_contig_*()

2024-12-02 Thread David Hildenbrand
Let's clean up the gfp flags handling, and support __GFP_ZERO, such that we can finally remove the TODO in memtrace code. I did some alloc_contig_*() testing with virtio-mem and hugetlb; I did not test powernv/memtrace -- I cross-compiled it, though. Cc: Andrew Morton Cc: Oscar Salvador Cc: Zi

Re: [PATCH v2 10/12] lib/crc32test: delete obsolete crc32test.c

2024-12-02 Thread Geert Uytterhoeven
On Mon, Dec 2, 2024 at 2:24 AM Eric Biggers wrote: > From: Eric Biggers > > Delete crc32test.c, since it has been superseded by crc_kunit.c. > > Reviewed-by: Ard Biesheuvel > Reviewed-by: Martin K. Petersen > Cc: Vinicius Peixoto > Signed-off-by: Eric Biggers > --- > arch/m68k/configs/amiga_