Hi,
Le 04/09/2024 à 04:26, Hongbo Li a écrit :
Replace kthread_create/kthread_bind/wake_up_process() with
kthread_run_on_cpu() to simplify the code.
Signed-off-by: Hongbo Li
A similar change is proposed as part of a larger series, see patch 7 in
that series
https://lore.kernel.org/lkml/202
Hi,
Le 06/11/2024 à 08:11, Zhang Zekun a écrit :
of_find_compatible_node() will increase the refcount of the device_node.
Decrease the refcount once finish using it.
Fixes: e95f287deed2 ("soc: fsl: handle RCPM errata A-008646 on SoC LS1021A")
Signed-off-by: Zhang Zekun
Your patch is redundan
Hi Javier,
On Wed, 02 Oct 2024 22:21:51 +0200
Javier Carrasco wrote:
> The non-scoped variant of this macro turns error-prone as soon as error
> paths are included, because explicit calls to of_node_put() are required
> to avoid leaking memory.
>
> Using its scoped counterpart simplifies the co
https://bugzilla.kernel.org/show_bug.cgi?id=214913
Michael Ellerman (mich...@ellerman.id.au) changed:
What|Removed |Added
Status|NEEDINFO|CLOSED
Geert Uytterhoeven writes:
> On Thu, Nov 7, 2024 at 12:37 PM Michael Ellerman wrote:
>> "Rob Herring (Arm)" writes:
>> > While OpenFirmware originally allowed walking parent nodes and default
>> > root values for #address-cells and #size-cells, FDT has long required
>> > explicit values. It's be
Shrikanth Hegde writes:
> Thank you Sebastian for taking a look and rwb tag.
>
>> On 2024-11-08 15:48:53 [+0530], Shrikanth Hegde wrote:
>>> Define preempt lazy bit for Powerpc. Use bit 9 which is free and within
>>> 16 bit range of NEED_RESCHED, so compiler can issue single andi.
>>>
>>> Since Po
Stephen Rothwell writes:
> Hi all,
>
> Today's linux-next merge of the powerpc tree got a conflict in:
>
> arch/powerpc/Makefile
>
> between commit:
>
> de51342c5157 ("kbuild: add $(objtree)/ prefix to some in-kernel build
> artifacts")
>
> from the kbuild tree and commit:
>
> bee08a9e6ab0
The type definition of "fsl,liodn" is defined as uint32 in
crypto/fsl,sec-v4.0.yaml and uint32-array in soc/fsl/fsl,bman.yaml,
soc/fsl/fsl,qman-portal.yaml, and soc/fsl/fsl,qman.yaml. Unify the type to
be uint32-array and constraint the single entry cases.
Signed-off-by: Rob Herring (Arm)
---
..
Previously any PMU overflow interrupt that fired while a VCPU was
loaded was recorded as a guest event whether it truly was or not. This
resulted in nonsense perf recordings that did not honor
perf_event_attr.exclude_guest and recorded guest IPs where it should
have recorded host IPs.
Rework the s
Break the assignment logic for misc flags into their own respective
functions to reduce the complexity of the nested logic.
Signed-off-by: Colton Lewis
Acked-by: Kan Liang
Reviewed-by: Oliver Upton
---
arch/x86/events/core.c| 59 ++-
arch/x86/include/asm
Make sure powerpc uses the arch-specific function now that those have
been reorganized.
Signed-off-by: Colton Lewis
Acked-by: Madhavan Srinivasan
Reviewed-by: Oliver Upton
---
arch/powerpc/perf/callchain.c| 2 +-
arch/powerpc/perf/callchain_32.c | 2 +-
arch/powerpc/perf/callchain_64.c | 2
For clarity, rename the arch-specific definitions of these functions
to perf_arch_* to denote they are arch-specifc. Define the
generic-named functions in one place where they can call the
arch-specific ones as needed.
Signed-off-by: Colton Lewis
Acked-by: Thomas Richter
Acked-by: Mark Rutland
For arm's implementation, perf_instruction_pointer() and
perf_misc_flags() are equivalent to the generic versions in
include/linux/perf_event.h so arch/arm doesn't need to provide its
own versions. Drop them here.
Signed-off-by: Colton Lewis
Acked-by: Will Deacon
Reviewed-by: Oliver Upton
---
v8:
* Improve patch 4 perf flags refactor
* Rebase to v6.12-rc7
v7:
https://lore.kernel.org/all/20241107190336.2963882-1-coltonle...@google.com/
v6:
https://lore.kernel.org/all/20241105195603.2317483-1-coltonle...@google.com/
v5:
https://lore.kernel.org/all/20240920174740.781614-1-coltonle...@go
Colton Lewis writes:
Peter Zijlstra writes:
On Fri, Nov 08, 2024 at 08:20:44PM +0100, Peter Zijlstra wrote:
Isn't the below more or less what you want?
static unsigned long misc_flags(struct pt_regs *regs)
{
unsigned long flags = 0;
if (regs->flags & PERF_EFLAGS_EXA
On 13.11.24 18:56, Peter Xu wrote:
On Wed, Nov 13, 2024 at 05:42:15PM +0100, David Hildenbrand wrote:
On 13.11.24 17:39, Peter Xu wrote:
On Mon, Nov 11, 2024 at 10:20:59PM +0100, Jann Horn wrote:
On Mon, Aug 12, 2024 at 8:12 PM Peter Xu wrote:
Dax supports pud pages for a while, but mprotect
Peter Zijlstra writes:
On Fri, Nov 08, 2024 at 08:20:44PM +0100, Peter Zijlstra wrote:
Isn't the below more or less what you want?
static unsigned long misc_flags(struct pt_regs *regs)
{
unsigned long flags = 0;
if (regs->flags & PERF_EFLAGS_EXACT)
flags
On Wed, Nov 13, 2024 at 05:42:15PM +0100, David Hildenbrand wrote:
> On 13.11.24 17:39, Peter Xu wrote:
> > On Mon, Nov 11, 2024 at 10:20:59PM +0100, Jann Horn wrote:
> > > On Mon, Aug 12, 2024 at 8:12 PM Peter Xu wrote:
> > > > Dax supports pud pages for a while, but mprotect on puds was missing
On 13.11.24 17:39, Peter Xu wrote:
On Mon, Nov 11, 2024 at 10:20:59PM +0100, Jann Horn wrote:
On Mon, Aug 12, 2024 at 8:12 PM Peter Xu wrote:
Dax supports pud pages for a while, but mprotect on puds was missing since
the start. This series tries to fix that by providing pud handling in
mprote
On Mon, Nov 11, 2024 at 10:20:59PM +0100, Jann Horn wrote:
> On Mon, Aug 12, 2024 at 8:12 PM Peter Xu wrote:
> > Dax supports pud pages for a while, but mprotect on puds was missing since
> > the start. This series tries to fix that by providing pud handling in
> > mprotect(). The goal is to add
cma_init_reserved_mem() checks base and size alignment with
CMA_MIN_ALIGNMENT_BYTES. However, some users might call this during
early boot when pageblock_order is 0. That means if base and size does
not have pageblock_order alignment, it can cause functional failures
during cma activate area.
So l
DEFINE(VDSO_CLOCKMODE_TIMENS, VDSO_CLOCKMODE_TIMENS);
#ifdef CONFIG_BUG
DEFINE(BUG_ENTRY_SIZE, sizeof(struct bug_entry));
---
base-commit: 0161bd38c24312853ed5ae9a425a1c41c4ac674a
change-id: 20241113-vdso-powerpc-asm-offsets-056016f80174
Best regards,
Hi Rosen,
On Wed, Nov 13, 2024 at 8:14 AM Rosen Penev wrote:
>
> In probe, np == pdev->dev.of_node. It's easier to pass pdev directly.
>
> Replace irq_of_parse_and_map() by platform_get_irq() to do so. Requires
> removing the error message as well as fixing the return type.
>
> Replace of_address
On Wed, Nov 13, 2024 at 08:06:04AM +0100, Thomas Gleixner wrote:
> On Mon, Nov 11 2024 at 11:19, Luming Yu wrote:
> > Due to the common layer and internal calls details are hidden from
> > the top level at the call side in ppc arch code, there are some
> > difficulties in preserving
> > all semanti
ZE, sizeof(struct bug_entry));
---
base-commit: 0161bd38c24312853ed5ae9a425a1c41c4ac674a
change-id: 20241113-vdso-powerpc-asm-offsets-056016f80174
Best regards,
--
Thomas Weißschuh
25 matches
Mail list logo