Re: [PATCH v3] crypto: Removing CRYPTO_AES_GCM_P10.

2024-09-20 Thread Stephen Rothwell
Hi Kamlesh, On Fri, 20 Sep 2024 15:07:19 +0530 Kamlesh Gurudasani wrote: > > Danny Tsen writes: > > > Data mismatch found when testing ipsec tunnel with AES/GCM crypto. > > Disabling CRYPTO_AES_GCM_P10 in Kconfig for this feature. > > > > Fixes: fd0e9b3e2ee6 ("crypto: p10-aes-gcm - An accelerat

Re: [PATCH] ALSA: Drop explicit initialization of struct i2c_device_id::driver_data to 0

2024-09-20 Thread Takashi Iwai
On Fri, 20 Sep 2024 17:10:08 +0200, Uwe Kleine-König wrote: > > These drivers don't use the driver_data member of struct i2c_device_id, > so don't explicitly initialize this member. > > This prepares putting driver_data in an anonymous union which requires > either no initialization or named desi

[powerpc:fixes-test] BUILD SUCCESS 3af2e2f68cc6baf0a11f662d30b0bf981f77bfea

2024-09-20 Thread kernel test robot
tree/branch: https://git.kernel.org/pub/scm/linux/kernel/git/powerpc/linux.git fixes-test branch HEAD: 3af2e2f68cc6baf0a11f662d30b0bf981f77bfea powerpc/pseries/eeh: move pseries_eeh_err_inject() outside CONFIG_DEBUG_FS block elapsed time: 725m configs tested: 92 configs skipped: 119 The follo

Re: [PATCH] powerpc/kvm: Fix typo in the kvm functions

2024-09-20 Thread Amit Machhiwal
On 2024/09/20 05:08 PM, Kajol Jain wrote: > Fix typo in the following kvm function names from: > > kmvhv_counters_tracepoint_regfunc -> kvmhv_counters_tracepoint_regfunc > kmvhv_counters_tracepoint_unregfunc -> kvmhv_counters_tracepoint_unregfunc > Nice catch! Reviewed-by: Amit Machhiwal > Fi

[PATCH v5 5/5] perf: Correct perf sampling with guest VMs

2024-09-20 Thread Colton Lewis
Previously any PMU overflow interrupt that fired while a VCPU was loaded was recorded as a guest event whether it truly was or not. This resulted in nonsense perf recordings that did not honor perf_event_attr.exclude_guest and recorded guest IPs where it should have recorded host IPs. Rework the s

[PATCH v5 4/5] x86: perf: Refactor misc flag assignments

2024-09-20 Thread Colton Lewis
Break the assignment logic for misc flags into their own respective functions to reduce the complexity of the nested logic. Signed-off-by: Colton Lewis --- arch/x86/events/core.c| 31 +++ arch/x86/include/asm/perf_event.h | 2 ++ 2 files changed, 25 inser

[PATCH v5 0/5] Correct perf sampling with Guest VMs

2024-09-20 Thread Colton Lewis
v5: * Correct the same compilation failure on s390 This time I made sure to download all the cross-toolchains of all architectures touched and compiled once for each arch. v4: https://lore.kernel.org/kvm/20240919190750.4163977-1-coltonle...@google.com/ v3: https://lore.kernel.org/kvm/20240912

[PATCH v5 3/5] powerpc: perf: Use perf_arch_instruction_pointer()

2024-09-20 Thread Colton Lewis
Make sure powerpc uses the arch-specific function now that those have been reorganized. Signed-off-by: Colton Lewis --- arch/powerpc/perf/callchain.c| 2 +- arch/powerpc/perf/callchain_32.c | 2 +- arch/powerpc/perf/callchain_64.c | 2 +- 3 files changed, 3 insertions(+), 3 deletions(-) dif

[PATCH v5 2/5] perf: Hoist perf_instruction_pointer() and perf_misc_flags()

2024-09-20 Thread Colton Lewis
For clarity, rename the arch-specific definitions of these functions to perf_arch_* to denote they are arch-specifc. Define the generic-named functions in one place where they can call the arch-specific ones as needed. Signed-off-by: Colton Lewis --- arch/arm64/include/asm/perf_event.h

[PATCH v5 1/5] arm: perf: Drop unused functions

2024-09-20 Thread Colton Lewis
For arm's implementation, perf_instruction_pointer() and perf_misc_flags() are equivalent to the generic versions in include/linux/perf_event.h so arch/arm doesn't need to provide its own versions. Drop them here. Signed-off-by: Colton Lewis --- arch/arm/include/asm/perf_event.h | 7 --- ar

Re: [PATCH v3 2/3] powerpc/pseries: Export hardware trace macro dump via debugfs

2024-09-20 Thread IBM
Madhavan Srinivasan writes: > This patch adds debugfs interface to export Hardware Trace Macro (HTM) > function data in a LPAR. New hypervisor call "H_HTM" has been > defined to setup, configure, control and dump the HTM data. > This patch supports only dumping of HTM data in a LPAR. > New debugf

[PATCH] ALSA: Drop explicit initialization of struct i2c_device_id::driver_data to 0

2024-09-20 Thread Uwe Kleine-König
These drivers don't use the driver_data member of struct i2c_device_id, so don't explicitly initialize this member. This prepares putting driver_data in an anonymous union which requires either no initialization or named designators. But it's also a nice cleanup on its own. Signed-off-by: Uwe Kle

Re: [PATCH] powerpc/kvm: Fix typo in the kvm functions

2024-09-20 Thread IBM
Kajol Jain writes: > Fix typo in the following kvm function names from: > > kmvhv_counters_tracepoint_regfunc -> kvmhv_counters_tracepoint_regfunc > kmvhv_counters_tracepoint_unregfunc -> kvmhv_counters_tracepoint_unregfunc Gr8 spotting! It took sometime to realize k[mv] and k[vm] is the change

[PATCH v1] usb: gadget: udc: fix typo in the comment

2024-09-20 Thread Yan Zhen
Correctly spelled comments make it easier for the reader to understand the code. Fix typos: 'trasmit' -> 'transmit', 'structres' -> 'structures', 'divisble' -> 'divisible', 'trainsmited' -> 'transmitted', 'packect's' -> 'packet's', 'timmer' -> 'timer', 'devcice' -> 'device', 'delelate' -> 'delegat

[PATCH] powerpc/kvm: Fix typo in the kvm functions

2024-09-20 Thread Kajol Jain
Fix typo in the following kvm function names from: kmvhv_counters_tracepoint_regfunc -> kvmhv_counters_tracepoint_regfunc kmvhv_counters_tracepoint_unregfunc -> kvmhv_counters_tracepoint_unregfunc Fixes: e1f288d2f9c6 ("KVM: PPC: Book3S HV nestedv2: Add support for reading VPA counters for pserie

Re: [PATCH v3] crypto: Removing CRYPTO_AES_GCM_P10.

2024-09-20 Thread Kamlesh Gurudasani
Danny Tsen writes: > Data mismatch found when testing ipsec tunnel with AES/GCM crypto. > Disabling CRYPTO_AES_GCM_P10 in Kconfig for this feature. > > Fixes: fd0e9b3e2ee6 ("crypto: p10-aes-gcm - An accelerated AES/GCM stitched > implementation") > Fixes: cdcecfd9991f ("crypto: p10-aes-gcm - Glu

[PATCH] powerpc/powernv: Free name on error in opal_event_init()

2024-09-20 Thread Michael Ellerman
In opal_event_init() if request_irq() fails name is not freed, leading to a memory leak. The code only runs at boot time, there's no way for a user to trigger it, so there's no security impact. Fix the leak by freeing name in the error path. Reported-by: 2639161967 <2639161...@qq.com> Closes: htt

Re: [PATCH] powerpc/vdso32: Fix use of crtsavres for PPC64

2024-09-20 Thread Michael Ellerman
On Thu, 19 Sep 2024 20:55:57 +0200, Christophe Leroy wrote: > crtsavres.S content is encloded by a #ifndef CONFIG_PPC64 > > To be used on VDSO32 on PPC64 it's content must available on PPC64 as > well. > > Replace #ifndef CONFIG_PPC64 by #ifndef __powerpc64__ as __powerpc64__ > is not set when bu

Re: [PATCH] powerpc/pseries/eeh: move pseries_eeh_err_inject() outside CONFIG_DEBUG_FS block

2024-09-20 Thread Michael Ellerman
On Tue, 17 Sep 2024 09:24:45 -0400, Narayana Murty N wrote: > Makes pseries_eeh_err_inject() available even when debugfs > is disabled (CONFIG_DEBUG_FS=n). It moves eeh_debugfs_break_device() > and eeh_pe_inject_mmio_error() out of the CONFIG_DEBUG_FS block > and renames it as eeh_break_device(). >

Re: [PATCH] powerpc/perf: Use guard(irqsave)() in eight functions

2024-09-20 Thread Markus Elfring
>> Scope-based resource management became supported for some >> programming interfaces by contributions of Peter Zijlstra on 2023-05-26. >> See also the commit 54da6a0924311c7cf5015533991e44fb8eb12773 ("locking: >> Introduce __cleanup() based infrastructure"). >> >> * Thus replace local_irq_save()