> On 3. Mar 2022, at 05:58, David Laight wrote:
>
> From: Xiaomeng Tong
>> Sent: 03 March 2022 02:27
>>
>> On Wed, 2 Mar 2022 14:04:06 +, David Laight
>> wrote:
>>> I think that it would be better to make any alternate loop macro
>>> just set the variable to NULL on the loop exit.
>>> Th
On Thu, 3 Mar 2022 04:58:23 +, David Laight wrote:
> on 3 Mar 2022 10:27:29 +0800, Xiaomeng Tong wrote:
> > The problem is the mis-use of iterator outside the loop on exit, and
> > the iterator will be the HEAD's container_of pointer which pointers
> > to a type-confused struct. Sidenote: The *
Move the cede abort logic out of xive escalation rearming and into
the caller to prepare for handling a similar case with nested guest
entry.
Signed-off-by: Nicholas Piggin
---
arch/powerpc/include/asm/kvm_ppc.h | 4 ++--
arch/powerpc/kvm/book3s_hv.c | 10 --
arch/powerpc/kvm/book
The L1 should not be able to adjust LPES mode for the L2. Setting LPES
if the L0 needs it clear would cause external interrupts to be sent to
L2 and missed by the L0.
Clearing LPES when it may be set, as typically happens with XIVE enabled
could cause a performance issue despite having no native X
The PowerNV L0 currently pushes the OS xive context when running a vCPU,
regardless of whether it is running a nested guest. The problem is that
xive OS ring interrupts will be delivered while the L2 is running.
At the moment, by default, the L2 guest runs with LPCR[LPES]=0, which
actually makes e
The differences between nested and !nested will become larger in
later changes so split them out for readability.
Signed-off-by: Nicholas Piggin
---
arch/powerpc/kvm/book3s_hv.c | 17 +
1 file changed, 13 insertions(+), 4 deletions(-)
diff --git a/arch/powerpc/kvm/book3s_hv.c b/
If there is a pending xive interrupt, inject it at guest entry (if
MSR[EE] is enabled) rather than take another interrupt when the guest
is entered. If xive is enabled then LPCR[LPES] is set so this behaviour
should be expected.
Signed-off-by: Nicholas Piggin
---
arch/powerpc/kvm/book3s_hv.c | 9
This series fixes up a bunch of little interrupt issues which were found
by inspection haven't seem to have caused big problems but possibly
could or could cause the occasional latency spike from a temporarily lost
interrupt.
The big thing is the xive context change. Currently we run an L2 with
it
When new work is created that requires attention from the hypervisor
(e.g., to inject an interrupt into the guest), fast_vcpu_kick is used to
pull the target vcpu out of the guest if it may have been running.
Therefore the work creation side looks like this:
vcpu->arch.doorbell_request = 1;
k
From: Xiaomeng Tong
> Sent: 03 March 2022 02:27
>
> On Wed, 2 Mar 2022 14:04:06 +, David Laight
> wrote:
> > I think that it would be better to make any alternate loop macro
> > just set the variable to NULL on the loop exit.
> > That is easier to code for and the compiler might be persuaded
Hi Rob,
Thanks for the review.
On 3/3/22 00:36, Rob Herring wrote:
On Tue, Mar 1, 2022 at 10:44 PM Ash Logan wrote:
Add a device tree source file for the Nintendo Wii U video game console.
Test this with 'make W=1 dtbs_checks'.
Does make W=1 ARCH=powerpc wiiu_defconfig dtbs_check seem rea
https://bugzilla.kernel.org/show_bug.cgi?id=215652
Alex Deucher (alexdeuc...@gmail.com) changed:
What|Removed |Added
CC||alexdeuc...@gmail.c
On Wed, 2 Mar 2022 14:04:06 +, David Laight
wrote:
> I think that it would be better to make any alternate loop macro
> just set the variable to NULL on the loop exit.
> That is easier to code for and the compiler might be persuaded to
> not redo the test.
No, that would lead to a NULL derefe
On Wed, 2 Mar 2022, Christoph Hellwig wrote:
> On Tue, Mar 01, 2022 at 06:55:47PM -0800, Stefano Stabellini wrote:
> > Unrelated to this specific patch series: now that I think about it, if
> > io_tlb_default_mem.nslabs is already allocated by the time xen_mm_init
> > is called, wouldn't we potenti
https://bugzilla.kernel.org/show_bug.cgi?id=215652
--- Comment #2 from Erhard F. (erhar...@mailbox.org) ---
Created attachment 300522
--> https://bugzilla.kernel.org/attachment.cgi?id=300522&action=edit
kernel .config (kernel 5.17-rc5, CONFIG_DRM_RADEON=m, Talos II)
--
You may reply to this em
https://bugzilla.kernel.org/show_bug.cgi?id=215652
--- Comment #1 from Erhard F. (erhar...@mailbox.org) ---
Created attachment 300521
--> https://bugzilla.kernel.org/attachment.cgi?id=300521&action=edit
kernel dmesg (kernel 5.17-rc5, CONFIG_DRM_RADEON=y, Talos II)
--
You may reply to this emai
https://bugzilla.kernel.org/show_bug.cgi?id=215652
Bug ID: 215652
Summary: kernel 5.17-rc fail to load radeon DRM "modprobe:
ERROR: could not insert 'radeon': Unknown symbol in
module, or unknown parameter (see dmesg)"
Produ
On Wed, Feb 23, 2022 at 04:11:15PM +0100, Petr Vorel wrote:
> vmx-crypto module depends on CRYPTO_AES, CRYPTO_CBC, CRYPTO_CTR or
> CRYPTO_XTS, thus add them.
>
> These dependencies are likely to be enabled, but if
> CRYPTO_DEV_VMX=y && !CRYPTO_MANAGER_DISABLE_TESTS
> and either of CRYPTO_AES, CRYP
On 28/02/2022 11:08, Jakob Koschel wrote:
When list_for_each_entry() completes the iteration over the whole list
without breaking the loop, the iterator value will be a bogus pointer
computed based on the head element.
While it is safe to use the pointer to determine if it was computed
based o
On Wed, Mar 02, 2022 at 12:18:45PM -0800, Linus Torvalds wrote:
> On Wed, Mar 2, 2022 at 12:07 PM Kees Cook wrote:
> >
> > I've long wanted to change kfree() to explicitly set pointers to NULL on
> > free. https://github.com/KSPP/linux/issues/87
>
> We've had this discussion with the gcc people i
On Wed, Mar 2, 2022 at 12:07 PM Kees Cook wrote:
>
> I've long wanted to change kfree() to explicitly set pointers to NULL on
> free. https://github.com/KSPP/linux/issues/87
We've had this discussion with the gcc people in the past, and gcc
actually has some support for it, but it's sadly tied to
On Wed, Mar 02, 2022 at 10:29:31AM +0100, Rasmus Villemoes wrote:
> This won't help the current issue (because it doesn't exist and might
> never), but just in case some compiler people are listening, I'd like to
> have some sort of way to tell the compiler "treat this variable as
> uninitialized f
Christophe Leroy wrote:
Le 10/01/2022 à 11:07, Naveen N. Rao a écrit :
kernel test robot reported the below build error with a randconfig:
powerpc64-linux-ld: arch/powerpc/net/bpf_jit_comp64.o:(.toc+0x0):
undefined reference to `powerpc_security_features'
This can happen if CONFIG_PPC_B
Christophe Leroy wrote:
Le 27/06/2019 à 13:23, Naveen N. Rao a écrit :
Since ftrace_replace_code() is a __weak function and can be overridden,
we need to expose the flags that can be set. So, move the flags enum to
the header file.
Reviewed-by: Steven Rostedt (VMware)
Signed-off-by: Naveen N
Le 02/09/2020 à 00:25, Nick Desaulniers a écrit :
Rather than invoke the compiler as the driver, use the linker. That way
we can check --orphan-handling=warn support correctly, as cc-ldoption
was removed in
commit 055efab3120b ("kbuild: drop support for cc-ldoption").
Painstakingly compared t
Christophe Leroy wrote:
Le 27/07/2021 à 08:55, Jordan Niethe a écrit :
Implement commit 40272035e1d0 ("powerpc/bpf: Reallocate BPF registers to
volatile registers when possible on PPC32") for PPC64.
When the BPF routine doesn't call any function, the non volatile
registers can be reallocated
Le 01/03/2021 à 03:16, chenjun (AM) a écrit :
Hi
After run the following commands
make distclean
make allmodconfig ARCH=powerpc CROSS_COMPILE=powerpc64-linux-gnu-
make oldconfig ARCH=powerpc CROSS_COMPILE=powerpc64-linux-gnu-
make -j64 ARCH=powerpc CROSS_COMPILE=powerpc64-linux-gnu-
I get so
Le 28/04/2021 à 01:45, Randy Dunlap a écrit :
On 4/21/21 12:15 AM, Michael Ellerman wrote:
Randy Dunlap writes:
Reviewed-by: Randy Dunlap
Tested-by: Randy Dunlap
Please merge this. :)
Merged as f259fb893c69 ("powerpc/Makefile: Add ppc32/ppc64_randconfig
targets")
Le 09/05/2021 à 14:00, Nour-eddine Taleb a écrit :
remove unnecessary castings, from "void *" to "struct kvmppc_xics *"
Signed-off-by: Nour-eddine Taleb <1337.nouredd...@gmail.com>
This patch doesn't apply. Tabs are broken, they've been replaced by 4
space chars.
---
arch/powerpc/kvm/
Le 19/07/2021 à 21:52, Anson Jacob a écrit :
This is an attempt to have generic FPU enable/disable
calls similar to x86.
So that we can simplify gpu/drm/amd/display/dc/os_types.h
Seems like gpu/drm/amd/display/dc/os_types.h has been simplified through
another way via commit 96ee63730fa3 ("d
Le 17/02/2022 à 08:04, Joel Stanley a écrit :
> x86 added a control for turning SMT on and off in commit 05736e4ac13c
> ("cpu/hotplug: Provide knobs to control SMT").
>
> Implement this for powerpc as an alternative to the currently method of
> iterating through /sys/devices/system/cpu/cpuN/onli
Le 24/05/2021 à 14:08, Liu Shixin a écrit :
The simple_strtol() function is deprecated in some situation since
it does not check for the range overflow. Use kstrtoint() instead.
Signed-off-by: Liu Shixin
---
drivers/macintosh/therm_adt746x.c | 6 --
1 file changed, 4 insertions(+), 2
On 3/1/22 9:55 PM, Stefano Stabellini wrote:
On Tue, 1 Mar 2022, Christoph Hellwig wrote:
Allow to pass a remap argument to the swiotlb initialization functions
to handle the Xen/x86 remap case. ARM/ARM64 never did any remapping
from xen_swiotlb_fixup, so we don't even need that quirk.
A
From: Xiaomeng Tong
> Sent: 02 March 2022 09:31
>
> On Mon, 28 Feb 2022 16:41:04 -0800, Linus Torvalds
> wrote:
> >
> > But basically to _me_, the important part is that the end result is
> > maintainable longer-term.
>
> I couldn't agree more. And because of that, I stick with the following
> a
On Tue, Mar 1, 2022 at 10:44 PM Ash Logan wrote:
>
> Add a device tree source file for the Nintendo Wii U video game console.
Test this with 'make W=1 dtbs_checks'.
>
> Signed-off-by: Ash Logan
> Co-developed-by: Roberto Van Eeden
> Signed-off-by: Roberto Van Eeden
> Co-developed-by: Emmanuel
On Tue, Mar 1, 2022 at 10:44 PM Ash Logan wrote:
>
> Adds schema for the various Wii U devicetree nodes used.
Please resend to the DT list if you want this reviewed and so that checks run.
>
> Signed-off-by: Ash Logan
> ---
> .../bindings/powerpc/nintendo/wiiu.yaml | 28 +++
> ..
Le 09/04/2021 à 11:35, Zucheng Zheng a écrit :
sccdbg symbol is not used, so remove it
You could mention that it hasn't been used since commit 51d3082fe6e5
("[PATCH] powerpc: Unify udbg (#2)")
Reported-by: Hulk Robot
Signed-off-by: Zucheng Zheng
---
arch/powerpc/platforms/powermac/
Le 09/04/2021 à 11:38, Zucheng Zheng a écrit :
> ppc_override_l2cr/ppc_override_l2cr_value/has_l2cache symbol is not used
> outside of setup.c, so commit marks it static.
>
> Reported-by: Hulk Robot
> Signed-off-by: Zucheng Zheng
> ---
> arch/powerpc/platforms/powermac/setup.c | 6 +++---
>
On 3/2/22 8:15 AM, Boris Ostrovsky wrote:
On 3/1/22 9:55 PM, Stefano Stabellini wrote:
On Tue, 1 Mar 2022, Christoph Hellwig wrote:
Allow to pass a remap argument to the swiotlb initialization functions
to handle the Xen/x86 remap case. ARM/ARM64 never did any remapping
from xen_swiotlb_fi
On Tue, 25 Jan 2022 01:52:04 +0530, Vaibhav Jain wrote:
> Presently PAPR doesn't support injecting smart errors on an
> NVDIMM. This makes testing the NVDIMM health reporting functionality
> difficult as simulating NVDIMM health related events need a hacked up
> qemu version.
>
> To solve this pro
On Mon, 14 Feb 2022 07:55:43 +0100, Paul Menzel wrote:
> Currently, `git status` lists the file as untracked by git, so tell git
> to ignore it.
>
>
Applied to powerpc/next.
[1/1] powerpc/boot: Add `otheros-too-big.bld` to .gitignore
https://git.kernel.org/powerpc/c/cb7356986db020c96f3753
On Fri, 4 Feb 2022 13:53:48 +1000, Nicholas Piggin wrote:
> Hash faults are not resoved in NMI context, instead causing the access
> to fail. This is done because perf interrupts can get backtraces
> including walking the user stack, and taking a hash fault on those could
> deadlock on the HPTE loc
On Tue, 15 Feb 2022 22:28:58 +1100, Michael Ellerman wrote:
> When CONFIG_GENERIC_CPU=y (true for all our defconfigs) we pass
> -mcpu=powerpc64 to the compiler, even when we're building a 32-bit
> kernel.
>
> This happens because we have an ifdef CONFIG_PPC_BOOK3S_64/else block in
> the Makefile t
On Thu, 27 Jan 2022 12:49:52 +0530, Kajol Jain wrote:
> Patch series adds support for perf sampling tests that
> enables capturing sampling data in perf mmap buffer and
> further support for reading and processing the samples.
> It also addds basic utility functions to process the
> mmap buffer ino
On Tue, 1 Feb 2022 16:23:05 +0530, Hari Bathini wrote:
> Crash recovery (fadump) is setup in the userspace by some service.
> This service rebuilds initrd with dump capture capability, if it is
> not already dump capture capable before proceeding to register for
> firmware assisted dump (echo 1 > /
On Wed, 23 Feb 2022 15:54:23 +0800, Guo Zhengkui wrote:
> Fix following coccicheck warning:
> ./arch/powerpc/kernel/module_64.c:432:40-41: WARNING: Use ARRAY_SIZE.
>
> ARRAY_SIZE(arr) is a macro provided by the kernel. It makes sure that arr
> is an array, so it's safer than sizeof(arr) / sizeof(a
On Thu, 24 Feb 2022 17:22:13 +0100, Anders Roxell wrote:
> Looks like there been a copy paste mistake when added the instruction
> 'stbcx' twice and one was probably meant to be 'sthcx'.
> Changing to 'sthcx' from 'stbcx'.
>
>
Applied to powerpc/next.
[1/3] powerpc: lib: sstep: fix 'sthcx' inst
On Sun, 13 Feb 2022 10:02:41 +0100, Christophe Leroy wrote:
> Warnings in assembly must use EMIT_WARN_ENTRY in order to generate
> the necessary entry in exception table.
>
> Check in EMIT_BUG_ENTRY that flags don't include BUGFLAG_WARNING.
>
> This change avoids problems like the one fixed by
>
On Fri, 25 Feb 2022 17:36:22 +0100, Christophe Leroy wrote:
> Since commit ceff77efa4f8 ("powerpc/64e/interrupt: Use new interrupt
> context tracking scheme") struct interrupt_state has been empty and
> unused.
>
> Remove it.
>
>
> [...]
Applied to powerpc/next.
[1/1] powerpc/interrupt: Remove
On Tue, 22 Feb 2022 15:05:30 +0100, Christophe Leroy wrote:
> Following commit 12318163737c ("powerpc/32: Remove remaining .stabs
> annotations"), stabs code are not used anymore.
>
> Remove them.
>
>
Applied to powerpc/next.
[1/1] powerpc: Remove remaining stab codes
https://git.kernel.
On Thu, 24 Feb 2022 15:23:12 -0300, Daniel Henrique Barboza wrote:
> Executing node_set_online() when nid = NUMA_NO_NODE results in an
> undefined behavior. node_set_online() will call node_set_state(), into
> __node_set(), into set_bit(), and since NUMA_NO_NODE is -1 we'll end up
> doing a negativ
On Tue, 15 Feb 2022 19:31:22 +0100, Christophe Leroy wrote:
> Also save r1 in ftrace_caller()
>
> r1 is needed during unwinding when the function_graph tracer
> is active.
>
>
Applied to powerpc/next.
[1/4] powerpc/ftrace: Also save r1 in ftrace_caller()
https://git.kernel.org/powerpc/c/
On Wed, Mar 02, 2022 at 04:36:52PM +0530, Anshuman Khandual wrote:
> On 3/2/22 3:35 PM, Geert Uytterhoeven wrote:
> > I doubt the switch() variant would give better code on any platform.
> >
> > What about using tables everywhere, using designated initializers
> > to improve readability?
>
> Desi
Hi Anshuman,
On Wed, Mar 2, 2022 at 12:07 PM Anshuman Khandual
wrote:
> On 3/2/22 3:35 PM, Geert Uytterhoeven wrote:
> > On Wed, Mar 2, 2022 at 10:51 AM Anshuman Khandual
> > wrote:
> >> On 3/2/22 12:35 PM, Christophe Leroy wrote:
> >>> Le 02/03/2022 à 04:22, Anshuman Khandual a écrit :
> O
On 3/2/22 3:35 PM, Geert Uytterhoeven wrote:
> Hi Anshuman,
>
> On Wed, Mar 2, 2022 at 10:51 AM Anshuman Khandual
> wrote:
>> On 3/2/22 12:35 PM, Christophe Leroy wrote:
>>> Le 02/03/2022 à 04:22, Anshuman Khandual a écrit :
On 3/1/22 1:46 PM, Christophe Leroy wrote:
> Le 01/03/2022 à
Hi Anshuman,
On Wed, Mar 2, 2022 at 10:51 AM Anshuman Khandual
wrote:
> On 3/2/22 12:35 PM, Christophe Leroy wrote:
> > Le 02/03/2022 à 04:22, Anshuman Khandual a écrit :
> >> On 3/1/22 1:46 PM, Christophe Leroy wrote:
> >>> Le 01/03/2022 à 01:31, Russell King (Oracle) a écrit :
> On Tue, Ma
This patch adds generic support for serial multipoint
addressing. Two new ioctls are added. TIOCSADDR is used to
indicate the destination/receive address. TIOCGADDR returns
the current address in use. The driver should implement
set_addr and get_addr to support addressing mode.
Adjust ADDRB cleari
Add ADDRB to termbits to indicate 9th bit addressing mode.
This change is necessary for supporting devices with RS485
multipoint addressing [*]. A later patch in the patch series
adds support for Synopsys Designware UART capable for 9th bit
addressing mode. In this mode, 9th bit is used to indicate
On Mon, 28 Feb 2022 16:41:04 -0800, Linus Torvalds
wrote:
>
> But basically to _me_, the important part is that the end result is
> maintainable longer-term.
I couldn't agree more. And because of that, I stick with the following
approach because it's maintainable longer-term than "type(pos) pos"
On 3/2/22 12:35 PM, Christophe Leroy wrote:
>
>
> Le 02/03/2022 à 04:22, Anshuman Khandual a écrit :
>>
>>
>> On 3/1/22 1:46 PM, Christophe Leroy wrote:
>>>
>>>
>>> Le 01/03/2022 à 01:31, Russell King (Oracle) a écrit :
On Tue, Mar 01, 2022 at 05:30:41AM +0530, Anshuman Khandual wrote:
>>
On 02/03/2022 00.55, Linus Torvalds wrote:
> On Tue, Mar 1, 2022 at 3:19 PM David Laight wrote:
>>
> With the "don't use iterator outside the loop" approach, the exact
> same code works in both the old world order and the new world order,
> and you don't have the semantic confusion. And *if* you
On Wed, Mar 02, 2022 at 12:18:26PM +0300, Anatoly Pugachev wrote:
> Is it possible to keep documentation comments in source files? Or are
> they completely irrelevant now?
That ones you quoted are very much irrelevant now. And the behaviour
of the swiotlb disabling will have to change (this patch
On Sun, Feb 27, 2022 at 7:31 PM Christoph Hellwig wrote:
>
> The IOMMU table tries to separate the different IOMMUs into different
> backends, but actually requires various cross calls.
>
> Rewrite the code to do the generic swiotlb/swiotlb-xen setup directly
> in pci-dma.c and then just call into
[Update: Included the build fix reported by kernel test robot ]
Since the VAS windows belong to the VAS hardware resource, the
hypervisor expects the partition to close them on source partition
and reopen them after the partition migrated on the destination
machine.
This handler is called before
On Wed, Mar 02, 2022 at 01:31:39PM +0530, Abdul Haleem wrote:
> Greeting's
>
> Linux next kernel 5.17.0-rc5-next-20220225 crashed on my power 10 LPAR when
> merge lvm snapshot on nvme disk
Please try next-20220301, in which the "bad" patch of 'block: cancel all
throttled bios in del_gendisk()' is
On Tue, Mar 01, 2022 at 06:55:47PM -0800, Stefano Stabellini wrote:
> Unrelated to this specific patch series: now that I think about it, if
> io_tlb_default_mem.nslabs is already allocated by the time xen_mm_init
> is called, wouldn't we potentially have an issue with the GFP flags used
> for the
On Tue, Mar 01, 2022 at 01:20:22PM -0500, Konrad Rzeszutek Wilk wrote:
> I think you also need to check for IBM Calgary?
The IBM Calgary IOMMU support is long gone.
Greeting's
Linux next kernel 5.17.0-rc5-next-20220225 crashed on my power 10 LPAR
when merge lvm snapshot on nvme disk
console logs
fdisk -l /dev/nvme1n1
Disk /dev/nvme1n1: 372.6 GiB, 400088457216 bytes, 97677846 sectors
Units: sectors of 1 * 4096 = 4096 bytes
Sector size (logic
68 matches
Mail list logo