Re: [PATCH v2 27/45] mfd: ntxec: Use devm_register_power_handler()

2021-11-06 Thread Jonathan Neuschäfer
Hi, On Thu, Oct 28, 2021 at 12:16:57AM +0300, Dmitry Osipenko wrote: > Use devm_register_power_handler() that replaces global pm_power_off > variable and allows to register multiple power-off handlers. It also > provides restart-handler support, i.e. all in one API. > > Signed-off-by: Dmitry Osip

Re: [PATCH 2/5] KVM: mips: Use kvm_get_vcpu() instead of open-coded access

2021-11-06 Thread Philippe Mathieu-Daudé
On Fri, Nov 5, 2021 at 9:14 PM Marc Zyngier wrote: > > As we are about to change the way vcpus are allocated, mandate > the use of kvm_get_vcpu() instead of open-coding the access. > > Signed-off-by: Marc Zyngier > --- > arch/mips/kvm/loongson_ipi.c | 4 ++-- > arch/mips/kvm/mips.c | 2 +

Re: [PATCH 5/5] KVM: Convert the kvm->vcpus array to a xarray

2021-11-06 Thread Marc Zyngier
On Fri, 05 Nov 2021 20:21:36 +, Sean Christopherson wrote: > > On Fri, Nov 05, 2021, Marc Zyngier wrote: > > At least on arm64 and x86, the vcpus array is pretty huge (512 entries), > > and is mostly empty in most cases (running 512 vcpu VMs is not that > > common). This mean that we end-up w

Re: [PATCH 1/5] KVM: Move wiping of the kvm->vcpus array to common code

2021-11-06 Thread Marc Zyngier
On Fri, 05 Nov 2021 20:12:12 +, Sean Christopherson wrote: > > On Fri, Nov 05, 2021, Marc Zyngier wrote: > > All architectures have similar loops iterating over the vcpus, > > freeing one vcpu at a time, and eventually wiping the reference > > off the vcpus array. They are also inconsistently