[PATCH] crypto: af_alg - Fix regression on empty requests

2020-06-25 Thread Herbert Xu
On Tue, Jun 23, 2020 at 10:02:17AM -0700, Eric Biggers wrote: > > The source code for the two failing AF_ALG tests is here: > > https://github.com/linux-test-project/ltp/blob/master/testcases/kernel/crypto/af_alg02.c > https://github.com/linux-test-project/ltp/blob/master/testcases/kernel/crypto/a

Re: [PATCH RFC 1/1] powerpc/eeh: Provide a unique ID for each EEH recovery

2020-06-25 Thread Oliver O'Halloran
On Wed, Jun 24, 2020 at 3:20 PM Sam Bobroff wrote: > > Give a unique ID to each recovery event, to ease log parsing and > prepare for parallel recovery. > > Also add some new messages with a very simple format that may be > useful to log-parsers. > > Signed-off-by: Sam Bobroff > --- > This patch

[powerpc:next] BUILD SUCCESS 105fb38124a490f38e9c1e23bb4c4a0b6ba12fdb

2020-06-25 Thread kernel test robot
tree/branch: https://git.kernel.org/pub/scm/linux/kernel/git/powerpc/linux.git next branch HEAD: 105fb38124a490f38e9c1e23bb4c4a0b6ba12fdb powerpc/8xx: Modify ptep_get() elapsed time: 942m configs tested: 120 configs skipped: 5 The following configs have been built successfully. More configs

[powerpc:fixes-test] BUILD SUCCESS c1ed1754f271f6b7acb1bfdc8cfb62220fbed423

2020-06-25 Thread kernel test robot
tree/branch: https://git.kernel.org/pub/scm/linux/kernel/git/powerpc/linux.git fixes-test branch HEAD: c1ed1754f271f6b7acb1bfdc8cfb62220fbed423 powerpc/kvm/book3s64: Fix kernel crash with nested kvm & DEBUG_VIRTUAL elapsed time: 945m configs tested: 114 configs skipped: 108 The following con

[powerpc:merge] BUILD SUCCESS 90a3c369b73246c37616c947e83b9939e41974c8

2020-06-25 Thread kernel test robot
tree/branch: https://git.kernel.org/pub/scm/linux/kernel/git/powerpc/linux.git merge branch HEAD: 90a3c369b73246c37616c947e83b9939e41974c8 Automatic merge of 'master', 'next' and 'fixes' (2020-06-25 23:12) elapsed time: 908m configs tested: 124 configs skipped: 5 The following configs have b

Re: [PATCH] powerpc/64: indirect function call use bctrl rather than blrl in ret_from_kernel_thread

2020-06-25 Thread Michael Ellerman
On Thu, 11 Jun 2020 22:11:19 +1000, Nicholas Piggin wrote: > blrl is not recommended to use as an indirect function call, as it may > corrupt the link stack predictor. > > This is not a performance critical path but this should be fixed for > consistency. Applied to powerpc/next. [1/1] powerpc/6

Re: [PATCH] powerpc/mm: Fix typo in IS_ENABLED()

2020-06-25 Thread Michael Ellerman
On Fri, 5 Jun 2020 07:18:06 -0700, Kees Cook wrote: > IS_ENABLED() matches names exactly, so the missing "CONFIG_" prefix > means this code would never be built. > > Also fixes a missing newline in pr_warn(). Applied to powerpc/next. [1/1] powerpc/mm: Fix typo in IS_ENABLED() https://git.k

Re: [PATCH V2] powerpc/pseries/svm: Drop unused align argument in alloc_shared_lppaca() function

2020-06-25 Thread Michael Ellerman
On Fri, 12 Jun 2020 19:59:53 +0530, Satheesh Rajendran wrote: > Argument "align" in alloc_shared_lppaca() was unused inside the > function. Let's drop it and update code comment for page alignment. Applied to powerpc/next. [1/1] powerpc/pseries/svm: Drop unused align argument in alloc_shared_lppa

Re: [PATCH 0/3] powerpc/dt_cpu_ftrs: Make use of ISA_V3_* macros

2020-06-25 Thread Michael Ellerman
On Wed, 10 Jun 2020 18:51:11 -0300, Murilo Opsfelder Araujo wrote: > The first patch removes unused macro ISA_V2_07B. The second and third > patches make use of macros ISA_V3_0B and ISA_V3_1, respectively, > instead their corresponding literals. > > Murilo Opsfelder Araujo (3): > powerpc/dt_cpu

Re: [PATCH] arch: powerpc: ppc4xx compile flag optimizations

2020-06-25 Thread Michael Ellerman
On Thu, 22 Dec 2016 09:06:08 +0100, John Crispin wrote: > This patch splits up the compile flags between ppc40x and ppc44x. Applied to powerpc/next. [1/1] powerpc/4xx: ppc4xx compile flag optimizations https://git.kernel.org/powerpc/c/548ad77d10f7ad6e5f84a0026978da2ed1df0dae cheers

Re: [PATCH] powerpc/ptdump: Fix build failure in hashpagetable.c

2020-06-25 Thread Michael Ellerman
On Mon, 15 Jun 2020 13:18:39 + (UTC), Christophe Leroy wrote: > H_SUCCESS is only defined when CONFIG_PPC_PSERIES is defined. > > != H_SUCCESS means != 0. Modify the test accordingly. Applied to powerpc/next. [1/1] powerpc/ptdump: Fix build failure in hashpagetable.c https://git.kernel

Re: [PATCH 1/2] selftests/powerpc: Allow choice of CI memory location in alignment_handler test

2020-06-25 Thread Michael Ellerman
On Wed, 20 May 2020 12:11:02 +1000, Jordan Niethe wrote: > The alignment handler selftest needs cache-inhibited memory and > currently /dev/fb0 is relied on to provided this. This prevents running > the test on systems without /dev/fb0 (e.g., mambo). Read the commandline > arguments for an optional

Re: [PATCH] powerpc/fixmap: Fix FIX_EARLY_DEBUG_BASE when page size is 256k

2020-06-25 Thread Michael Ellerman
On Mon, 15 Jun 2020 07:48:25 + (UTC), Christophe Leroy wrote: > FIX_EARLY_DEBUG_BASE reserves a 128k area for debuging. > > When page size is 256k, the calculation results in a 0 number of > pages, leading to the following failure: > > CC arch/powerpc/kernel/asm-offsets.s > In file inc

Re: [PATCH] powerpc/8xx: Modify ptep_get()

2020-06-25 Thread Michael Ellerman
On Thu, 18 Jun 2020 12:07:46 + (UTC), Christophe Leroy wrote: > Move ptep_get() close to pte_update(), in an ifdef section already > dedicated to powerpc 8xx. This section contains explanation about > the layout of page table entries. > > Also modify it to return 4 times the pte value instead

Re: [PATCH v3 0/2] powerpc: CMDLINE config cleanup

2020-06-25 Thread Michael Ellerman
On Fri, 12 Jun 2020 10:42:18 +1200, Chris Packham wrote: > This series cleans up the config options related to the boot command line. > > Chris Packham (2): > powerpc: Remove inaccessible CMDLINE default > powerpc: configs: remove CMDLINE_BOOL > > arch/powerpc/Kconfig

Re: [PATCH] powerpc/mm/book3s64: Skip 16G page reservation with radix

2020-06-25 Thread Michael Ellerman
On Mon, 22 Jun 2020 12:10:19 +0530, Aneesh Kumar K.V wrote: > With hash translation, the hypervisor can hint the LPAR about 16GB contiguous > range > via ibm,expected#pages. The kernel marks the range specified in the device > tree > as reserved. Avoid doing this when using radix translation. Rad

Re: [PATCH kernel v2] powerpc/powernv/ioda: Return correct error if TCE level allocation failed

2020-06-25 Thread Michael Ellerman
On Wed, 17 Jun 2020 10:38:35 +1000, Alexey Kardashevskiy wrote: > The iommu_table_ops::xchg_no_kill() callback updates TCE. It is quite > possible that not entire table is allocated if it is huge and multilevel > so xchg may also allocate subtables. If failed, it returns H_HARDWARE > for failed all

Re: [PATCH kernel] powerpc/xive: Ignore kmemleak false positives

2020-06-25 Thread Michael Ellerman
On Fri, 12 Jun 2020 14:33:03 +1000, Alexey Kardashevskiy wrote: > xive_native_provision_pages() allocates memory and passes the pointer to > OPAL so kmemleak cannot find the pointer usage in the kernel memory and > produces a false positive report (below) (even if the kernel did scan > OPAL memory,

Re: [PATCH] powerpc/fsl_booke/32: fix build with CONFIG_RANDOMIZE_BASE

2020-06-25 Thread Michael Ellerman
On Sat, 13 Jun 2020 23:28:01 +0700, Arseny Solokha wrote: > Building the current 5.8 kernel for a e500 machine with > CONFIG_RANDOMIZE_BASE set yields the following failure: > > arch/powerpc/mm/nohash/kaslr_booke.c: In function 'kaslr_early_init': > arch/powerpc/mm/nohash/kaslr_booke.c:387:2:

Re: [PATCH] powerpc/kvm/book3s64/nested: Fix kernel crash with nested kvm

2020-06-25 Thread Michael Ellerman
On Thu, 11 Jun 2020 17:31:59 +0530, Aneesh Kumar K.V wrote: > __pa() do check for addr value passed and if < PAGE_OFFSET > results in BUG. > > #define __pa(x) > \ > ({

[PATCH V3 2/3] cpufreq: Register governors at core_initcall

2020-06-25 Thread Viresh Kumar
From: Quentin Perret Currently, most CPUFreq governors are registered at core_initcall time when used as default, and module_init otherwise. In preparation for letting users specify the default governor on the kernel command line, change all of them to use core_initcall unconditionally, as is alr

[PATCH v3 0/3] cpufreq: Allow default governor on cmdline and fix locking issues

2020-06-25 Thread Viresh Kumar
Hi, I have picked Quentin's series over my patch, modified both and tested. V2->V3: - default_governor is a string now and we don't set it on governor registration or unregistration anymore. - Fixed locking issues in cpufreq_init_policy(). -- Viresh Original cover letter fro Quentin: This se

Re: [PATCH] selftests/powerpc: Fix build issue with output directory

2020-06-25 Thread Michael Ellerman
Harish writes: > We use OUTPUT directory as TMPOUT for checking no-pie option. When > building powerpc/ from selftests directory, the OUTPUT directory > eventually points to powerpc/pmu/ebb/ and gets removed when > checking for -no-pie option in try-run routine, subsequently build > fails with the

Re: [PATCH v2 2/2] cpufreq: Specify default governor on command line

2020-06-25 Thread Viresh Kumar
On 23-06-20, 15:21, Quentin Perret wrote: > @@ -2789,7 +2796,13 @@ static int __init cpufreq_core_init(void) > cpufreq_global_kobject = kobject_create_and_add("cpufreq", > &cpu_subsys.dev_root->kobj); > BUG_ON(!cpufreq_global_kobject); > > + mutex_lock(&cpufreq_governor_mutex); >

Re: [PATCH 00/13] iommu: Remove usage of dev->archdata.iommu

2020-06-25 Thread Jerry Snitselaar
On Thu Jun 25 20, Joerg Roedel wrote: From: Joerg Roedel Hi, here is a patch-set to remove the usage of dev->archdata.iommu from the IOMMU code in the kernel and replace its uses by the iommu per-device private data field. The changes also remove the field entirely from the architectures which

Re: [PATCH v2] SUNRPC: Add missing definition of ARCH_IMPLEMENTS_FLUSH_DCACHE_PAGE

2020-06-25 Thread Bruce Fields
On Mon, Jun 15, 2020 at 08:33:40AM -0400, Chuck Lever wrote: > > > > On Jun 15, 2020, at 2:25 AM, Christophe Leroy > > wrote: > > > > Even if that's only a warning, not including asm/cacheflush.h > > leads to svc_flush_bvec() being empty allthough powerpc defines > > ARCH_IMPLEMENTS_FLUSH_DCAC

Re: [PATCH] powerpc: Warn about use of smt_snooze_delay

2020-06-25 Thread Tyrel Datwyler
On 6/25/20 3:29 AM, Christophe Leroy wrote: > > > Le 25/06/2020 à 12:03, Joel Stanley a écrit : >> It's not done anything for a long time. Save the percpu variable, and >> emit a warning to remind users to not expect it to do anything. > > Why not just drop the file entirely  if it is useless ?

Re: [PATCH v2 2/2] cpufreq: Specify default governor on command line

2020-06-25 Thread Rafael J. Wysocki
On Thu, Jun 25, 2020 at 3:50 PM Quentin Perret wrote: > > On Thursday 25 Jun 2020 at 15:28:43 (+0200), Rafael J. Wysocki wrote: > > On Thu, Jun 25, 2020 at 1:53 PM Quentin Perret wrote: > > > > > > On Thursday 25 Jun 2020 at 13:44:34 (+0200), Rafael J. Wysocki wrote: > > > > On Thu, Jun 25, 2020

Re: [PATCH] hvc: unify console setup naming

2020-06-25 Thread Petr Mladek
On Sat 2020-06-20 02:22:40, Sergey Senozhatsky wrote: > Use the 'common' foo_console_setup() naming scheme. There are 71 > foo_console_setup() callbacks and only one foo_setup_console(). > > Signed-off-by: Sergey Senozhatsky This patch is commited in printk/linux.git, branch for-5.9-console-retu

Re: [PATCH v2 2/2] cpufreq: Specify default governor on command line

2020-06-25 Thread Rafael J. Wysocki
On Thu, Jun 25, 2020 at 1:53 PM Quentin Perret wrote: > > On Thursday 25 Jun 2020 at 13:44:34 (+0200), Rafael J. Wysocki wrote: > > On Thu, Jun 25, 2020 at 1:36 PM Viresh Kumar > > wrote: > > > This change is not right IMO. This part handles the set-policy case, > > > where there are no governor

Re: [PATCH 02/13] iommu/vt-d: Use dev_iommu_priv_get/set()

2020-06-25 Thread Lu Baolu
Hi Joerg, On 2020/6/25 21:08, Joerg Roedel wrote: From: Joerg Roedel Remove the use of dev->archdata.iommu and use the private per-device pointer provided by IOMMU core code instead. Signed-off-by: Joerg Roedel --- .../gpu/drm/i915/selftests/mock_gem_device.c | 10 -- drivers/io

[PATCH 10/13] ia64: Remove dev->archdata.iommu pointer

2020-06-25 Thread Joerg Roedel
From: Joerg Roedel There are no users left, all drivers have been converted to use the per-device private pointer offered by IOMMU core. Signed-off-by: Joerg Roedel --- arch/ia64/include/asm/device.h | 3 --- 1 file changed, 3 deletions(-) diff --git a/arch/ia64/include/asm/device.h b/arch/ia

[PATCH 08/13] iommu/mediatek: Do no use dev->archdata.iommu

2020-06-25 Thread Joerg Roedel
From: Joerg Roedel The iommu private pointer is already used in the Mediatek IOMMU v1 driver, so move the dma_iommu_mapping pointer into 'struct mtk_iommu_data' and do not use dev->archdata.iommu anymore. Signed-off-by: Joerg Roedel --- drivers/iommu/mtk_iommu.h| 2 ++ drivers/iommu/mtk_i

[PATCH 06/13] iommu/tegra: Use dev_iommu_priv_get/set()

2020-06-25 Thread Joerg Roedel
From: Joerg Roedel Remove the use of dev->archdata.iommu and use the private per-device pointer provided by IOMMU core code instead. Signed-off-by: Joerg Roedel --- drivers/iommu/tegra-gart.c | 8 drivers/iommu/tegra-smmu.c | 8 2 files changed, 8 insertions(+), 8 deletions(-

[PATCH 05/13] iommu/rockchip: Use dev_iommu_priv_get/set()

2020-06-25 Thread Joerg Roedel
From: Joerg Roedel Remove the use of dev->archdata.iommu and use the private per-device pointer provided by IOMMU core code instead. Signed-off-by: Joerg Roedel --- drivers/iommu/rockchip-iommu.c | 8 1 file changed, 4 insertions(+), 4 deletions(-) diff --git a/drivers/iommu/rockchip

[PATCH 04/13] iommu/omap: Use dev_iommu_priv_get/set()

2020-06-25 Thread Joerg Roedel
From: Joerg Roedel Remove the use of dev->archdata.iommu and use the private per-device pointer provided by IOMMU core code instead. Signed-off-by: Joerg Roedel --- drivers/iommu/omap-iommu.c | 20 ++-- 1 file changed, 10 insertions(+), 10 deletions(-) diff --git a/drivers/iom

[PATCH 01/13] iommu/exynos: Use dev_iommu_priv_get/set()

2020-06-25 Thread Joerg Roedel
From: Joerg Roedel Remove the use of dev->archdata.iommu and use the private per-device pointer provided by IOMMU core code instead. Signed-off-by: Joerg Roedel --- drivers/iommu/exynos-iommu.c | 20 +-- .../media/platform/s5p-mfc/s5p_mfc_iommu.h| 4 +++-

[PATCH 02/13] iommu/vt-d: Use dev_iommu_priv_get/set()

2020-06-25 Thread Joerg Roedel
From: Joerg Roedel Remove the use of dev->archdata.iommu and use the private per-device pointer provided by IOMMU core code instead. Signed-off-by: Joerg Roedel --- .../gpu/drm/i915/selftests/mock_gem_device.c | 10 -- drivers/iommu/intel/iommu.c| 18 +

[PATCH 00/13] iommu: Remove usage of dev->archdata.iommu

2020-06-25 Thread Joerg Roedel
From: Joerg Roedel Hi, here is a patch-set to remove the usage of dev->archdata.iommu from the IOMMU code in the kernel and replace its uses by the iommu per-device private data field. The changes also remove the field entirely from the architectures which no longer need it. On PowerPC the fiel

Re: [PATCH v2 2/2] cpufreq: Specify default governor on command line

2020-06-25 Thread Rafael J. Wysocki
On Thu, Jun 25, 2020 at 1:36 PM Viresh Kumar wrote: > > After your last email (reply to my patch), I noticed a change which > isn't required. :) > > On 23-06-20, 15:21, Quentin Perret wrote: > > diff --git a/drivers/cpufreq/cpufreq.c b/drivers/cpufreq/cpufreq.c > > index 0128de3603df..4b1a5c0173cf

Re: [PATCH v2 1/4] powerpc/mm/radix: Fix PTE/PMD fragment count for early page table mappings

2020-06-25 Thread Aneesh Kumar K.V
"Aneesh Kumar K.V" writes: > Fixing this includes 3 parts: > > - Re-walk the init_mm page tables from mem_init() and initialize > the PMD and PTE fragment count to 1. > - When freeing PUD, PMD and PTE page table pages, check explicitly > if they come from memblock and if so free then appropr

Re: [PATCH v2 2/2] cpufreq: Specify default governor on command line

2020-06-25 Thread Rafael J. Wysocki
On Thu, Jun 25, 2020 at 10:50 AM Viresh Kumar wrote: > > On 24-06-20, 16:32, Quentin Perret wrote: > > Right, but I must admit that, looking at this more, I'm getting a bit > > confused with the overall locking for governors :/ > > > > When in cpufreq_init_policy() we find a governor using > > fin

Re: [PATCH] powerpc: Warn about use of smt_snooze_delay

2020-06-25 Thread Christophe Leroy
Le 25/06/2020 à 12:03, Joel Stanley a écrit : It's not done anything for a long time. Save the percpu variable, and emit a warning to remind users to not expect it to do anything. Why not just drop the file entirely if it is useless ? Christophe Signed-off-by: Joel Stanley --- arch/p

Re: FSL P5020/P5040: DPAA Ethernet issue with the latest Git kernel

2020-06-25 Thread Alexander Gordeev
On Thu, Jun 25, 2020 at 01:01:52AM +0200, Christian Zigotzky wrote: [...] > I compiled a test kernel with the option "CONFIG_TEST_BITMAP=y" > yesterday. After that Skateman and I booted it and looked for the > bitmap tests with "dmesg | grep -i bitmap". > > Results: > > FSL P5020: > > [    0.297

[PATCH] powerpc: Warn about use of smt_snooze_delay

2020-06-25 Thread Joel Stanley
It's not done anything for a long time. Save the percpu variable, and emit a warning to remind users to not expect it to do anything. Signed-off-by: Joel Stanley --- arch/powerpc/kernel/sysfs.c | 41 + 1 file changed, 14 insertions(+), 27 deletions(-) diff --

Re: PowerPC KVM-PR issue

2020-06-25 Thread Christian Zigotzky
On 15 June 2020 at 01:39 pm, Christian Zigotzky wrote: On 14 June 2020 at 04:52 pm, Christian Zigotzky wrote: On 14 June 2020 at 02:53 pm, Nicholas Piggin wrote: Excerpts from Christian Zigotzky's message of June 12, 2020 11:01 pm: On 11 June 2020 at 04:47 pm, Christian Zigotzky wrote: On 10

Re: [PATCH 16/17] arch: remove HAVE_COPY_THREAD_TLS

2020-06-25 Thread Thomas Bogendoerfer
On Tue, Jun 23, 2020 at 01:43:25AM +0200, Christian Brauner wrote: > All architectures support copy_thread_tls() now, so remove the legacy > copy_thread() function and the HAVE_COPY_THREAD_TLS config option. Everyone > uses the same process creation calling convention based on > copy_thread_tls() a

Re: [PATCH 17/17] arch: rename copy_thread_tls() back to copy_thread()

2020-06-25 Thread Thomas Bogendoerfer
On Tue, Jun 23, 2020 at 01:43:26AM +0200, Christian Brauner wrote: > Now that HAVE_COPY_THREAD_TLS has been removed, rename copy_thread_tls() > back simply copy_thread(). It's a simpler name, and doesn't imply that only > tls is copied here. This finishes an outstanding chunk of internal process >

Re: [PATCH v5 01/13] powerpc: Remove Xilinx PPC405/PPC440 support

2020-06-25 Thread Joel Stanley
On Fri, 19 Jun 2020 at 11:02, Michael Ellerman wrote: > > Nathan Chancellor writes: > >> It's kind of nuts that the zImage points to some arbitrary image > >> depending on what's configured and the order of things in the Makefile. > >> But I'm not sure how we make it less nuts without risking bre

Re: [PATCH v4 6/8] arm: Break cyclic percpu include

2020-06-25 Thread Will Deacon
On Wed, Jun 24, 2020 at 07:53:20PM +0200, Peter Zijlstra wrote: > On Tue, Jun 23, 2020 at 10:02:57AM +0100, Will Deacon wrote: > > On Tue, Jun 23, 2020 at 10:36:51AM +0200, Peter Zijlstra wrote: > > > In order to use in irqflags.h, we need to make sure > > > asm/percpu.h does not itself depend on