On Fri, Sep 07, 2018 at 08:43:59PM +0200, Luc Van Oostenryck wrote:
> On Fri, Sep 07, 2018 at 04:15:33PM +0200, Christophe LEROY wrote:
> > Le 07/09/2018 à 15:58, Peter Zijlstra a écrit :
> > > On Fri, Sep 07, 2018 at 01:50:18PM +, Christophe Leroy wrote:
> > > >
> > > >
> > > > On 09/07/2018
If you are going to do this, please add for_each_set_bit64() and similar.
For example, see:
https://marc.info/?l=linux-netdev&m=153633391214025&w=2
On Fri, 2018-08-31 at 11:52 +0800, Ran Wang wrote:
> This driver is to provide a independent framework for PM service
> provider and consumer to configure system level wake up feature. For
> example, RCPM driver could register a callback function on this
> platform first, and Flex timer driver who
On Fri, 2018-08-31 at 11:52 +0800, Ran Wang wrote:
> The NXP's QorIQ Processors based on ARM Core have RCPM module (Run
> Control and Power Management), which performs all device-level
> tasks associated with power management such as wakeup source control.
>
> This driver depends on FSL platform P
On Fri, 2018-08-31 at 11:52 +0800, Ran Wang wrote:
> +Optional properties:
> + - big-endian : Indicate RCPM registers is big-endian. A RCPM node
> + that doesn't have this property will be regarded as little-endian.
You've just broken all the existing powerpc device trees that are big-endian
and
On Fri, 2018-09-07 at 19:41 +, Corentin Labbe wrote:
> This patch adds setbits32/clrbits32/clrsetbits32 and
> setbits64/clrbits64/clrsetbits64 in linux/setbits.h header.
>
> Signed-off-by: Corentin Labbe
> ---
> include/linux/setbits.h | 55
> +
Since setbits32/clrbits32 work on be32, it's better to remove ambiguity on
the used data type.
Signed-off-by: Corentin Labbe
---
arch/powerpc/include/asm/fsl_lbc.h | 2 +-
arch/powerpc/include/asm/io.h| 5 +-
arch/powerpc/platforms/44x/canyonlands.c |
This patch convert stmmac driver to use all xxxsetbits32 functions.
Signed-off-by: Corentin Labbe
---
.../net/ethernet/stmicro/stmmac/dwmac-meson8b.c| 54 +++--
drivers/net/ethernet/stmicro/stmmac/dwmac-sun8i.c | 55 -
.../net/ethernet/stmicro/stmmac/dwmac1000_co
This patch converts ahci_sunxi to use xxxsetbits32 functions
Signed-off-by: Corentin Labbe
---
drivers/ata/ahci_sunxi.c | 51
1 file changed, 12 insertions(+), 39 deletions(-)
diff --git a/drivers/ata/ahci_sunxi.c b/drivers/ata/ahci_sunxi.c
index
This patch adds setbits32/clrbits32/clrsetbits32 and
setbits64/clrbits64/clrsetbits64 in linux/setbits.h header.
Signed-off-by: Corentin Labbe
---
include/linux/setbits.h | 55 +
1 file changed, 55 insertions(+)
create mode 100644 include/linux/se
Hello
This patchset adds a new set of functions which are open-coded in lot of
place.
Basicly the pattern is always the same, "read, modify a bit, write"
some driver already have thoses pattern them as functions. (like ahci_sunxi.c
or dwmac-meson8b)
The first patch rename some powerpc funtions w
This patch add a spatch which convert all open coded of
setbits32/clrbits32/clrsetbits32
and their 64 bits counterparts.
Signed-off-by: Corentin Labbe
---
scripts/coccinelle/misc/setbits.cocci | 423 ++
1 file changed, 423 insertions(+)
create mode 100644 script
On Fri, Sep 7, 2018 at 4:51 AM Ran Wang wrote:
>
> Hi Leo,
>
> On September 05, 2018 at 11:22 Yang Li wrote:
> > -Original Message-
> > From: Li Yang
> > Sent: Wednesday, September 05, 2018 11:22
> > To: dongsheng.w...@hxt-semitech.com
> > Cc: Ran Wang ; Rob Herring ;
> > Mark Rutland ; o
On Fri, Sep 07, 2018 at 04:15:33PM +0200, Christophe LEROY wrote:
> Le 07/09/2018 à 15:58, Peter Zijlstra a écrit :
> > On Fri, Sep 07, 2018 at 01:50:18PM +, Christophe Leroy wrote:
> > >
> > >
> > > On 09/07/2018 01:42 PM, Peter Zijlstra wrote:
> > > > On Fri, Sep 07, 2018 at 01:27:19PM +000
2018-08-27 8:56 GMT+09:00 Rob Herring :
> On Sat, Aug 25, 2018 at 9:06 PM Masahiro Yamada
> wrote:
>>
>> Hi Rob,
>>
>>
>> 2018-08-22 6:55 GMT+09:00 Rob Herring :
>> > There is nothing arch specific about building dtb files other than their
>> > location under /arch/*/boot/dts/. Keeping each arch a
Hi Rob,
2018-09-07 21:17 GMT+09:00 Rob Herring :
> On Fri, Sep 7, 2018 at 5:33 AM Masahiro Yamada
> wrote:
>>
>> 2018-09-06 8:53 GMT+09:00 Rob Herring :
>> > There is nothing arch specific about building dtb files other than their
>> > location under /arch/*/boot/dts/. Keeping each arch aligned i
WARN_ON() already contains an unlikely(), so it's not necessary to
wrap it into another.
Signed-off-by: Igor Stoppa
Cc: Arseny Solokha
Cc: Benjamin Herrenschmidt
Cc: Paul Mackerras
Cc: Michael Ellerman
Cc: linuxppc-dev@lists.ozlabs.org
Cc: linux-ker...@vger.kernel.org
---
arch/powerpc/mm/tlb
On Fri, Sep 07, 2018 at 04:15:33PM +0200, Christophe LEROY wrote:
> Ah yes, it seems that GCC is happy. So sparse should be fixed instead ?
Ideally, yes.
> Anyway, is it really correct to put this constant inside that enum, after
> PERF_SAMPLE_MAX ?
It is a bit of a hack, agreed. What we do is
Le 07/09/2018 à 15:58, Peter Zijlstra a écrit :
On Fri, Sep 07, 2018 at 01:50:18PM +, Christophe Leroy wrote:
On 09/07/2018 01:42 PM, Peter Zijlstra wrote:
On Fri, Sep 07, 2018 at 01:27:19PM +, Christophe Leroy wrote:
On PPC32, enums are 32 bits, so __PERF_SAMPLE_CALLCHAIN_EARLY i
On Fri, Sep 07, 2018 at 03:58:17PM +0200, Peter Zijlstra wrote:
> On Fri, Sep 07, 2018 at 01:50:18PM +, Christophe Leroy wrote:
> >
> >
> > On 09/07/2018 01:42 PM, Peter Zijlstra wrote:
> > > On Fri, Sep 07, 2018 at 01:27:19PM +, Christophe Leroy wrote:
> > > > On PPC32, enums are 32 bits
On Fri, Sep 7, 2018 at 7:54 AM Michal Simek wrote:
>
> Hi Rob,
>
> 2018-09-05 21:37 GMT+02:00 Rob Herring :
>>
>> This series adds an iterator for cpu nodes and converts users over to use
>> it or of_get_cpu_node in some cases. This allows us to remove the
>> dependency on device_type property for
On Fri, Sep 07, 2018 at 01:50:18PM +, Christophe Leroy wrote:
>
>
> On 09/07/2018 01:42 PM, Peter Zijlstra wrote:
> > On Fri, Sep 07, 2018 at 01:27:19PM +, Christophe Leroy wrote:
> > > On PPC32, enums are 32 bits, so __PERF_SAMPLE_CALLCHAIN_EARLY is
> > > out of scope. The following spar
On 09/07/2018 01:42 PM, Peter Zijlstra wrote:
On Fri, Sep 07, 2018 at 01:27:19PM +, Christophe Leroy wrote:
On PPC32, enums are 32 bits, so __PERF_SAMPLE_CALLCHAIN_EARLY is
out of scope. The following sparse warning is encountered:
CHECK arch/powerpc/kernel/process.c
./include/uapi/
instructions_to_print var is assigned value 16 and there is no
way to change it.
This patch replaces it by a constant.
Signed-off-by: Christophe Leroy
---
v3: no change
v2: no change
arch/powerpc/kernel/process.c | 11 +--
1 file changed, 5 insertions(+), 6 deletions(-)
diff --git a
When two processes crash at the same time, we sometimes encounter
interleaving in the middle of a line:
[4.365317] init[1]: segfault (11) at 0 nip 0 lr 0 code 1
[4.370452] init[1]: code:
[4.372042] init[74]: segfault (11) at 10a74 nip 1000c198 lr 100
This patch fixes the following warnings. The first ones are leftovers
from when __get_user() was replaced by probe_kernel_address().
The last one is from when show_user_instructions() was added.
arch/powerpc/kernel/process.c:1287:22: warning: incorrect type in argument 2
(different address space
On Fri, Sep 07, 2018 at 01:27:19PM +, Christophe Leroy wrote:
> On PPC32, enums are 32 bits, so __PERF_SAMPLE_CALLCHAIN_EARLY is
> out of scope. The following sparse warning is encountered:
>
> CHECK arch/powerpc/kernel/process.c
> ./include/uapi/linux/perf_event.h:147:56: warning: cast tr
On PPC32, enums are 32 bits, so __PERF_SAMPLE_CALLCHAIN_EARLY is
out of scope. The following sparse warning is encountered:
CHECK arch/powerpc/kernel/process.c
./include/uapi/linux/perf_event.h:147:56: warning: cast truncates bits from
constant value (8000 becomes 0)
This patch c
On Fri, Sep 7, 2018 at 5:33 AM Masahiro Yamada
wrote:
>
> 2018-09-06 8:53 GMT+09:00 Rob Herring :
> > There is nothing arch specific about building dtb files other than their
> > location under /arch/*/boot/dts/. Keeping each arch aligned is a pain.
> > The dependencies and supported targets are a
On Fri 07-09-18 16:45:09, Aneesh Kumar K.V wrote:
> On 09/07/2018 02:33 PM, Michal Hocko wrote:
> > On Thu 06-09-18 19:00:43, Aneesh Kumar K.V wrote:
> > > On 09/06/2018 06:23 PM, Michal Hocko wrote:
> > > > On Thu 06-09-18 11:13:42, Aneesh Kumar K.V wrote:
> > > > > Current code doesn't do page mi
On 09/07/2018 02:33 PM, Michal Hocko wrote:
On Thu 06-09-18 19:00:43, Aneesh Kumar K.V wrote:
On 09/06/2018 06:23 PM, Michal Hocko wrote:
On Thu 06-09-18 11:13:42, Aneesh Kumar K.V wrote:
Current code doesn't do page migration if the page allocated is a compound page.
With HugeTLB migration su
2018-09-06 8:53 GMT+09:00 Rob Herring :
> There is nothing arch specific about building dtb files other than their
> location under /arch/*/boot/dts/. Keeping each arch aligned is a pain.
> The dependencies and supported targets are all slightly different.
> Also, a cross-compiler for each arch is
On 2018/9/7 16:49, Ran Wang wrote:
> Hi Dongsheng
>
>> On 2018/9/5 11:05, Dongsheng Wang wrote:
>>
>> Please change your comments style.
>>
>> On 2018/8/31 11:57, Ran Wang wrote:
>>> This driver is to provide a independent framework for PM service
>>> provider and consumer to configure system level
Hi Leo,
On September 05, 2018 at 11:22 Yang Li wrote:
> -Original Message-
> From: Li Yang
> Sent: Wednesday, September 05, 2018 11:22
> To: dongsheng.w...@hxt-semitech.com
> Cc: Ran Wang ; Rob Herring ;
> Mark Rutland ; open list:OPEN FIRMWARE AND
> FLATTENED DEVICE TREE BINDINGS ; linux
On 09/06/2018 09:58 AM, Aneesh Kumar K.V wrote:
Christophe Leroy writes:
Today flags like for instance _PAGE_RW or _PAGE_USER are used through
common parts of code.
Using those directly in common parts of code have proven to lead to
mistakes or misbehaviour, because their use is not always
Hi Dongsheng,
On 2018/9/5 10:58, Dongsheng Wang wrote:
>
> Please change your comments style.
>
> On 2018/8/31 11:56, Ran Wang wrote:
> > The NXP's QorIQ Processors based on ARM Core have RCPM module (Run
> > Control and Power Management), which performs all device-level tasks
> > associated wit
On Fri, Sep 07, 2018 at 10:47:56AM +0200, Michal Hocko wrote:
> On Fri 07-09-18 11:42:12, Mike Rapoport wrote:
> > On Thu, Sep 06, 2018 at 03:46:27PM +0200, Michal Hocko wrote:
> > > On Thu 06-09-18 16:39:58, Mike Rapoport wrote:
> > > > On Thu, Sep 06, 2018 at 03:01:02PM +0200, Michal Hocko wrote:
On Thu 06-09-18 19:00:43, Aneesh Kumar K.V wrote:
> On 09/06/2018 06:23 PM, Michal Hocko wrote:
> > On Thu 06-09-18 11:13:42, Aneesh Kumar K.V wrote:
> > > Current code doesn't do page migration if the page allocated is a
> > > compound page.
> > > With HugeTLB migration support, we can end up all
On Fri 07-09-18 11:42:12, Mike Rapoport wrote:
> On Thu, Sep 06, 2018 at 03:46:27PM +0200, Michal Hocko wrote:
> > On Thu 06-09-18 16:39:58, Mike Rapoport wrote:
> > > On Thu, Sep 06, 2018 at 03:01:02PM +0200, Michal Hocko wrote:
> > > > On Thu 06-09-18 15:43:21, Mike Rapoport wrote:
> > > > > On T
On Thu, Sep 06, 2018 at 03:46:27PM +0200, Michal Hocko wrote:
> On Thu 06-09-18 16:39:58, Mike Rapoport wrote:
> > On Thu, Sep 06, 2018 at 03:01:02PM +0200, Michal Hocko wrote:
> > > On Thu 06-09-18 15:43:21, Mike Rapoport wrote:
> > > > On Thu, Sep 06, 2018 at 09:28:00AM +0200, Michal Hocko wrote:
Hi Dongsheng
> On 2018/9/5 11:05, Dongsheng Wang wrote:
>
> Please change your comments style.
>
> On 2018/8/31 11:57, Ran Wang wrote:
> > This driver is to provide a independent framework for PM service
> > provider and consumer to configure system level wake up feature. For
> > example, RCPM d
On 09/06/2018 09:58 AM, Aneesh Kumar K.V wrote:
Christophe Leroy writes:
Today flags like for instance _PAGE_RW or _PAGE_USER are used through
common parts of code.
Using those directly in common parts of code have proven to lead to
mistakes or misbehaviour, because their use is not always
On 07/09/18 17:34, Vaibhav Jain wrote:
Ever since fast reboot is enabled by default in opal,
opal_cec_reboot() will use fast-reset instead of full IPL to perform
system reboot. This leaves the user with no direct way to force a full
IPL reboot except changing an nvram setting that persistently di
On Thu, Sep 06, 2018 at 11:39:42PM +0200, Daniel Vetter wrote:
> On Thu, Sep 6, 2018 at 6:01 PM, Steven Rostedt wrote:
> > On Thu, 6 Sep 2018 09:58:04 -0600
> > Jonathan Corbet wrote:
> >
> >> Thanks,
> >>
> >> jon (who is increasingly inclined to apply this patch)
> >
> > As Colin Kaepernick no
Ever since fast reboot is enabled by default in opal,
opal_cec_reboot() will use fast-reset instead of full IPL to perform
system reboot. This leaves the user with no direct way to force a full
IPL reboot except changing an nvram setting that persistently disables
fast-reset for all subsequent rebo
45 matches
Mail list logo