Le 12/05/2017 à 02:47, Nicholas Piggin a écrit :
On Thu, 11 May 2017 20:52:56 +0200
christophe leroy wrote:
Le 11/05/2017 à 19:14, christophe leroy a écrit :
Le 11/05/2017 à 17:15, Nicholas Piggin a écrit :
Cc: Scott Wood
Cc: Christophe Leroy
Signed-off-by: Nicholas Piggin
---
arch/p
On powernv/pseries and ppc64 defconfigs
Most distros will want it on by default and I've missed
turning it on during developer testing. Having it on ensures
we are testing our patches with the config enabled.
Signed-off-by: Balbir Singh
---
arch/powerpc/configs/powernv_defconfig | 1 +
arch/pow
On Thursday 11 May 2017 01:19 PM, Stewart Smith wrote:
Anju T Sudhakar writes:
This patch does three things :
- Enables "opal.c" to create a platform device for the IMC interface
according to the appropriate compatibility string.
- Find the reserved-memory region details from the syst
Experiments with the netperf benchmark indicated that the size selecting
VMX-based copies in __copy_tofrom_user_power7() was suboptimal on POWER8.
Measurements showed that parity was in the neighbourhood of 3328 bytes,
rather than greater than 4096. The change gives a 1.5-2.0% improvement in
perfor
On Friday 12 May 2017 09:03 AM, Michael Ellerman wrote:
Stewart Smith writes:
Madhavan Srinivasan writes:
* in patch 9 should opal_imc_counters_init return something other
than OPAL_SUCCESS in the case on invalid arguments? Maybe
OPAL_PARAMETER? (I think you fix this
Paul Clarke writes:
> On 05/11/2017 06:24 AM, Nicholas Piggin wrote:
>> Provide a dt_cpu_ftrs= cmdline option to disable the dt_cpu_ftrs CPU
>> feature discovery, and fall back to the "cputable" based version.
>
> This boat has already sailed, I think, but "ftrs"?
What you think vowels grow on t
On Friday 12 May 2017 07:48 AM, Stewart Smith wrote:
Madhavan Srinivasan writes:
* in patch 9 should opal_imc_counters_init return something other
than OPAL_SUCCESS in the case on invalid arguments? Maybe
OPAL_PARAMETER? (I think you fix this in a later patch anyway?)
S
Nicholas Piggin writes:
> The single-operand form of tlbie used to be accepted as the second
> operand (L) being implicitly 0. Newer binutils reject this.
>
> Change remaining single-op tlbie instructions to have explicit 0
> second argument.
Do old(er) binutils accept the two operand version?
Stewart Smith writes:
> Madhavan Srinivasan writes:
>>> * in patch 9 should opal_imc_counters_init return something other
>>>than OPAL_SUCCESS in the case on invalid arguments? Maybe
>>>OPAL_PARAMETER? (I think you fix this in a later patch anyway?)
>>
>> So, init call will
Madhavan Srinivasan writes:
>> * in patch 9 should opal_imc_counters_init return something other
>>than OPAL_SUCCESS in the case on invalid arguments? Maybe
>>OPAL_PARAMETER? (I think you fix this in a later patch anyway?)
>
> So, init call will return OPAL_PARAMETER for the u
On Thu, 11 May 2017 20:52:56 +0200
christophe leroy wrote:
> Le 11/05/2017 à 19:14, christophe leroy a écrit :
> >
> >
> > Le 11/05/2017 à 17:15, Nicholas Piggin a écrit :
> >> Cc: Scott Wood
> >> Cc: Christophe Leroy
> >> Signed-off-by: Nicholas Piggin
> >> ---
> >> arch/powerpc/xmon/xmon.
We should either keep memset() only for deferred struct pages as what I
have in my patches.
Another option is to add a new function struct_page_clear() which would
default to memset() and to something else on platforms that decide to
optimize it.
On SPARC it would call STBIs, and we would do
Have you measured that? I do not think it would be super hard to
measure. I would be quite surprised if this added much if anything at
all as the whole struct page should be in the cache line already. We do
set reference count and other struct members. Almost nobody should be
looking at our page
On Thu, 11 May 2017 20:52:56 +0200
christophe leroy wrote:
> Le 11/05/2017 à 19:14, christophe leroy a écrit :
> >
> >
> > Le 11/05/2017 à 17:15, Nicholas Piggin a écrit :
> >> Cc: Scott Wood
> >> Cc: Christophe Leroy
> >> Signed-off-by: Nicholas Piggin
> >> ---
> >> arch/powerpc/xmon/xmon.
On Thu, 11 May 2017 11:47:47 -0700
Linus Torvalds wrote:
> On Thu, May 11, 2017 at 9:57 AM, Nicholas Piggin wrote:
> >
> > If you find this acceptable, I'd like to start wiring in the powerpc
> > and adding the annotations to some important core spin loops (there's
> > not too many really). I'm
fadump fails to register when there are holes in boot memory area.
Provide a helpful error message to the user in such case.
Signed-off-by: Hari Bathini
---
Changes since v1:
* Introducing this patch to provide better error message on failure.
arch/powerpc/kernel/fadump.c | 36 +
To register fadump, boot memory area - the size of low memory chunk that
is required for a kernel to boot successfully when booted with restricted
memory, is assumed to have no holes. But this memory area is currently
not protected from hot-remove operations. So, fadump could fail to
re-register af
fadump sets up crash memory ranges to be used for creating PT_LOAD
program headers in elfcore header. Memory chunk RMA_START through
boot memory area size is added as the first memory range because
firmware, at the time of crash, moves this memory chunk to different
location specified during fadump
Le 11/05/2017 à 19:14, christophe leroy a écrit :
Le 11/05/2017 à 17:15, Nicholas Piggin a écrit :
Cc: Scott Wood
Cc: Christophe Leroy
Signed-off-by: Nicholas Piggin
---
arch/powerpc/xmon/xmon.c | 5 -
1 file changed, 4 insertions(+), 1 deletion(-)
diff --git a/arch/powerpc/xmon/xmo
On Thu, May 11, 2017 at 9:57 AM, Nicholas Piggin wrote:
>
> If you find this acceptable, I'd like to start wiring in the powerpc
> and adding the annotations to some important core spin loops (there's
> not too many really). I'm hoping if you take this patch during this
> merge window, I'll be abl
Add --orphan-handling=warn to final link flags. This ensures we can
handle all sections explicitly. This would have caught subtle breakage
such as 7de3b27bac47da9de08409df1d69664acbb72197 at build-time.
Also bring existing orphan sections into the fold:
- .text.hot and .text.unlikely are compiler
Use a tool to check the location of "fixed sections" is where we
expected them, which catches cases the linker script can't (stubs
being added to start of .text section), and which ends up being
neater.
Sample output:
ERROR: start_text address is c0008100, should be c0008000
E
Direct banches from code below __end_interrupts to code above
__end_interrupts when built with CONFIG_RELOCATABLE are disallowed
because they will break when the kernel is not located at 0.
Sample output:
WARNING: Unrelocated relative branches
c118 bl-> 0xc0038fb8
Nicholas Piggin (3):
powerpc/64s: tool to flag direct branches from unrelocated interrupt
vectors
powerpc/64: tool to check head sections location sanity
powerpc: link warning for orphan sections
arch/powerpc/Makefile| 1 +
arch/powerpc/Makefile.postlink
Le 11/05/2017 à 17:15, Nicholas Piggin a écrit :
Cc: Scott Wood
Cc: Christophe Leroy
Signed-off-by: Nicholas Piggin
---
arch/powerpc/xmon/xmon.c | 5 -
1 file changed, 4 insertions(+), 1 deletion(-)
diff --git a/arch/powerpc/xmon/xmon.c b/arch/powerpc/xmon/xmon.c
index f11f65634aab..ec
Current busy-wait loops are implemented by repeatedly calling cpu_relax()
to give an arch option for a low-latency option to improve power and/or
SMT resource contention.
This poses some difficulties for powerpc, which has SMT priority setting
instructions (priorities determine how ifetch cycles a
For final link, the powerpc64 linker generates fpr save/restore
functions on-demand, placing them in the .sfpr section. Starting with
binutils 2.25, these can be provided for non-final links with
--save-restore-funcs. Use that where possible for module links.
This saves about 200 bytes per module
There is no need to create a new section for these. Consolidate with
32-bit and just use .text.
Signed-off-by: Nicholas Piggin
---
arch/powerpc/lib/crtsavres.S | 6 ++
1 file changed, 2 insertions(+), 4 deletions(-)
diff --git a/arch/powerpc/lib/crtsavres.S b/arch/powerpc/lib/crtsavres.S
in
crtsaveres.S is empty with 64-bit builds already, so just don't
build and link it to match the vmlinux build.
Signed-off-by: Nicholas Piggin
---
arch/powerpc/boot/Makefile| 3 ++-
arch/powerpc/boot/crtsavres.S | 8
2 files changed, 6 insertions(+), 5 deletions(-)
diff --git a/arch/
The 64-bit linker creates save/restore functions on demand with final
links, so vmlinux does not require crtsavres.o.
Make crtsavres.o extra-y on 64-bit (it is still required by modules).
Signed-off-by: Nicholas Piggin
---
arch/powerpc/lib/Makefile | 8 ++--
1 file changed, 6 insertions(+),
Signed-off-by: Nicholas Piggin
---
arch/powerpc/kernel/vmlinux.lds.S | 8
1 file changed, 8 insertions(+)
diff --git a/arch/powerpc/kernel/vmlinux.lds.S
b/arch/powerpc/kernel/vmlinux.lds.S
index 2f793be3d2b1..bcfda21c3179 100644
--- a/arch/powerpc/kernel/vmlinux.lds.S
+++ b/arch/powerp
These are some minor improvements I came up when investigating
"orphan" sections (.sfpr currently is). For 4.13.
Nicholas Piggin (5):
powerpc/64: place sfpr section explicitly with the linker script
powerpc/64: do not link crtsavres.o in vmlinux
powerpc/64: do not link crtsaveres.o in boot
Cc: Scott Wood
Cc: Christophe Leroy
Signed-off-by: Nicholas Piggin
---
arch/powerpc/xmon/xmon.c | 5 -
1 file changed, 4 insertions(+), 1 deletion(-)
diff --git a/arch/powerpc/xmon/xmon.c b/arch/powerpc/xmon/xmon.c
index f11f65634aab..ec420b0e6e88 100644
--- a/arch/powerpc/xmon/xmon.c
+++
The single-operand form of tlbie used to be accepted as the second
operand (L) being implicitly 0. Newer binutils reject this.
Change remaining single-op tlbie instructions to have explicit 0
second argument.
Cc: Scott Wood
Cc: Christophe Leroy
Signed-off-by: Nicholas Piggin
---
arch/powerpc/
Fixes: a7cd88da97 ("powerpc/powernv: Move CPU-Offline idle state invocation
from smp.c to idle.c")
Cc: Gautham R. Shenoy
Signed-off-by: Nicholas Piggin
---
arch/powerpc/platforms/powernv/idle.c | 2 ++
1 file changed, 2 insertions(+)
diff --git a/arch/powerpc/platforms/powernv/idle.c
b/arch/p
On Thu, 11 May 2017 02:00:11 +0530
Hari Bathini wrote:
> Hello Michal,
>
> On Wednesday 10 May 2017 09:31 PM, Michal Suchánek wrote:
> > Hello,
> >
> > On Wed, 03 May 2017 23:52:52 +0530
> > Hari Bathini wrote:
> >
> >> With the introduction of 'fadump_append=' parameter to pass
> >> addition
From: Michal Hocko
Date: Thu, 11 May 2017 10:05:38 +0200
> Anyway, do you agree that doing the struct page initialization along
> with other writes to it shouldn't add a measurable overhead comparing
> to pre-zeroing of larger block of struct pages? We already have an
> exclusive cache line and
On Thu, May 11, 2017 at 10:34 PM, Juergen Schindele wrote:
> Next try to submit two patches for Freescale mpc8315.
>
> first one
> ---
> powerpc/ipic: Configure "EDGE" capabilities for IRQ0 too (like IRQ1-7)
> Signed-o
On 05/11/2017 06:24 AM, Nicholas Piggin wrote:
> Provide a dt_cpu_ftrs= cmdline option to disable the dt_cpu_ftrs CPU
> feature discovery, and fall back to the "cputable" based version.
This boat has already sailed, I think, but "ftrs"? Was it too difficult to
type "features"? This seems like s
On Thu, 11 May 2017 02:00:11 +0530
Hari Bathini wrote:
> Hello Michal,
>
> On Wednesday 10 May 2017 09:31 PM, Michal Suchánek wrote:
> > Hello,
> >
> > On Wed, 03 May 2017 23:52:52 +0530
> > Hari Bathini wrote:
> >
> >> With the introduction of 'fadump_append=' parameter to pass
> >> addition
Next try to submit two patches for Freescale mpc8315.
first one
---
powerpc/ipic: Configure "EDGE" capabilities for IRQ0 too (like IRQ1-7)
Signed-off-by: Jurgen Schindele
The external IRQ0 has the same capabilities a
Provide a dt_cpu_ftrs= cmdline option to disable the dt_cpu_ftrs CPU
feature discovery, and fall back to the "cputable" based version.
Also allow control of advertising unknown features to userspace and
with this parameter, and remove the clunky CONFIG option.
Signed-off-by: Nicholas Piggin
---
On Wed, 2017-05-04 at 08:32:38 UTC, Balbir Singh wrote:
> Most distros will want it on by default and I've missed
> turning it on during developer testing. Having it on ensures
> we are testing our patches with the config enabled.
I agree, but I think we should do it in the defconfigs instead.
ch
From: Aravinda Prasad
Enhance KVM to cause a guest exit with KVM_EXIT_NMI
exit reason upon a machine check exception (MCE) in
the guest address space if the KVM_CAP_PPC_FWNMI
capability is enabled (instead of delivering a 0x200
interrupt to guest). This enables QEMU to build error
log and deliver
From: Mahesh Salgaonkar
It will be used in arch/powerpc/kvm/book3s_hv.c KVM module.
Signed-off-by: Mahesh Salgaonkar
Acked-by: Michael Ellerman
---
arch/powerpc/kernel/mce.c |1 +
1 file changed, 1 insertion(+)
diff --git a/arch/powerpc/kernel/mce.c b/arch/powerpc/kernel/mce.c
index 5f9e
From: Aravinda Prasad
This patch introduces a new KVM capability to control
how KVM behaves on machine check exception (MCE).
Without this capability, KVM redirects machine check
exceptions to guest's 0x200 vector, if the address in
error belongs to the guest. With this capability KVM
causes a gu
From: Aravinda Prasad
This series of patches add FWNMI support for KVM guests
on POWER.
Memory errors such as bit flips that cannot be corrected
by hardware is passed on to the kernel for handling
by raising machine check exception (an NMI). Upon such
machine check exceptions, if the address in
On Wed, 2017-05-10 at 19:55 +0200, Christoph Hellwig wrote:
> Hi Abdul,
>
> can you test the patch below? I'll try to create a way to inject
> short WRITE SAME commands using qemu next, but I thought I'd give
> you a chance to try it as well.
No warnings with the patch. Thanks for all your suppo
Remove the open-coding of radix set sizes for loops. Populate the
cputable with the correct values for old firmware, but dt_cpu_ftrs
will use a property under its mmu feature nodes.
Not-yet-Signed-off-by: Nicholas Piggin
---
Hi,
This is a proposal for a different approach here, by using specifi
On Thu, 11 May 2017, Stephen Rothwell wrote:
> Hi,
>
> On Wed, 10 May 2017 14:09:53 +0200 (CEST) Thomas Gleixner
> wrote:
> >
> > > +static void nest_change_cpu_context(int old_cpu, int new_cpu)
> > > +{
> > > + int i;
> > > +
> > > + for (i = 0;
> > > + (per_nest_pmu_arr[i] != NULL) && (i
On Wed 10-05-17 11:19:43, David S. Miller wrote:
> From: Michal Hocko
> Date: Wed, 10 May 2017 16:57:26 +0200
>
> > Have you measured that? I do not think it would be super hard to
> > measure. I would be quite surprised if this added much if anything at
> > all as the whole struct page should be
Anju T Sudhakar writes:
> This patch does three things :
> - Enables "opal.c" to create a platform device for the IMC interface
>according to the appropriate compatibility string.
> - Find the reserved-memory region details from the system device tree
>and get the base address of HOMER (
EXPORT_SYMBOL_GPL for random non-coherent exports for single users,
please.
53 matches
Mail list logo