On Mon, May 09, 2016 at 10:59:32PM +0300, Andy Shevchenko wrote:
> On Mon, May 9, 2016 at 10:05 PM, Tejun Heo wrote:
> > On Mon, May 09, 2016 at 10:13:59AM +0100, Måns Rullgård wrote:
> >> Andy Shevchenko writes:
> >>
> >> > On Mon, May 9, 2016 at 4:09 AM, Tejun Heo wrote:
> >> >> On Sun, May 08
Power ISAv3 extends the width of the decrementer register from 32 bits.
The enlarged register width is implementation dependent, but reads from
these registers are automatically sign extended to produce a 64 bit
output when operating in large mode. The HDEC always operates in large
mode while the D
POWER ISA v3 adds large decrementer (LD) mode of operation which increases
the size of the decrementer register from 32 bits to an implementation
defined with of up to 64 bits.
This patch adds support for the LD on processors with the CPU_FTR_ARCH_300
cpu feature flag set. For CPUs with this featu
test-hexdump.c doesn't work on BE because the test data is in LE format.
So add in data for BE.
Signed-off-by: Rashmica Gupta
---
V2: Checking __BYTE_ORDER__.
lib/test_hexdump.c | 35 +++
1 file changed, 27 insertions(+), 8 deletions(-)
diff --git a/lib/test_h
On Mon, May 09, 2016 at 08:03:50PM +1000, Michael Ellerman wrote:
>On Fri, 2016-26-02 at 00:26:25 UTC, Gavin Shan wrote:
>> When the page fault happened in user space, we need check it's
>> caused by stack frame pointer update instruction and update
>> local variable @flag with FAULT_FLAG_USER. Cur
On Thu, 2016-05-05 at 07:54:09 UTC, Oliver O'Halloran wrote:
> The mm zone mechanism was traditionally used by arch specific code to
> partition memory into allocation zones. However there are several zones
> that are managed by the mm subsystem rather than the architecture. Most
> architectures se
On Mon, 2016-05-09 at 21:06 +0200, Christian Lamparter via Linuxppc-dev wrote:
>
> I ran into the following issues:
> - gadget.c uses ioread32_rep [0] & iowrite32_rep [1].
> This is interesting because both of these functions actually use
> the __raw_io* on powerpc. Thi
On Mon, 2016-05-09 at 17:08 +0200, Arnd Bergmann wrote:
>
> Unfortunately, I don't see any way this could be done in MIPS specific
> code: There is typically a byteswap between the internal bus and the PCI
> bus on big-endian MIPS systems, so the PCI MMIO ends up being little-endian,
Ugh ... not
On Mon, 2016-05-09 at 13:39 +0300, Felipe Balbi wrote:
> and patch all drivers similarly? Shouldn't arch/mips itself deal with
> it and hide it from drivers ?
Not sure what you mean, but we never had "endian neutral" accessors. It
would be a bit of an endeavour and we already have so many accessor
On Monday 09 May 2016 14:11:23 John Youn wrote:
> On 5/9/2016 1:39 PM, Arnd Bergmann wrote:
>
> > The systems are not a particular endianess, only the current state
> > of the CPU is, and that may change independent of the way the
> > hardware block got synthesized. We don't support swapping endian
On 5/9/2016 1:39 PM, Arnd Bergmann wrote:
> On Monday 09 May 2016 13:22:48 John Youn wrote:
>> On 5/9/2016 3:36 AM, Arnd Bergmann wrote:
>>> On Monday 09 May 2016 10:23:22 Benjamin Herrenschmidt wrote:
On Sun, 2016-05-08 at 13:44 +0200, Christian Lamparter wrote:
> On Sunday, May 08, 2016
On Monday 09 May 2016 13:22:48 John Youn wrote:
> On 5/9/2016 3:36 AM, Arnd Bergmann wrote:
> > On Monday 09 May 2016 10:23:22 Benjamin Herrenschmidt wrote:
> >> On Sun, 2016-05-08 at 13:44 +0200, Christian Lamparter wrote:
> >>> On Sunday, May 08, 2016 08:40:55 PM Benjamin Herrenschmidt wrote:
> >
On 5/9/2016 3:36 AM, Arnd Bergmann wrote:
> On Monday 09 May 2016 10:23:22 Benjamin Herrenschmidt wrote:
>> On Sun, 2016-05-08 at 13:44 +0200, Christian Lamparter wrote:
>>> On Sunday, May 08, 2016 08:40:55 PM Benjamin Herrenschmidt wrote:
On Sun, 2016-05-08 at 00:54 +0200, Christian Lamp
Em Sat, May 07, 2016 at 02:15:36PM +1000, Michael Ellerman escreveu:
> On Thu, 2016-05-05 at 15:23:19 UTC, "Naveen N. Rao" wrote:
> > Generalize existing macros to serve the purpose.
> >
> > Cc: Wang Nan
> > Cc: Arnaldo Carvalho de Melo
> > Cc: Masami Hiramatsu
> > Cc: Ian Munsie
> > Cc: Micha
On Monday 09 May 2016 21:06:07 Christian Lamparter wrote:
> Uh, Thanks for the participation!
>
> On Monday, May 09, 2016 05:08:48 PM Arnd Bergmann wrote:
> > On Monday 09 May 2016 13:39:50 Felipe Balbi wrote:
> > > Arnd Bergmann writes:
> > > > On Monday 09 May 2016 10:23:22 Benjamin Herrenschmi
On Mon, May 9, 2016 at 10:05 PM, Tejun Heo wrote:
> On Mon, May 09, 2016 at 10:13:59AM +0100, Måns Rullgård wrote:
>> Andy Shevchenko writes:
>>
>> > On Mon, May 9, 2016 at 4:09 AM, Tejun Heo wrote:
>> >> On Sun, May 08, 2016 at 04:00:08PM -0400, Tejun Heo wrote:
>> >>> Hello, Andy.
>> >>>
>> >>
On Mon, May 09, 2016 at 10:13:59AM +0100, Måns Rullgård wrote:
> Andy Shevchenko writes:
>
> > On Mon, May 9, 2016 at 4:09 AM, Tejun Heo wrote:
> >> On Sun, May 08, 2016 at 04:00:08PM -0400, Tejun Heo wrote:
> >>> Hello, Andy.
> >>>
> >>> On Wed, May 04, 2016 at 03:22:51PM +0300, Andy Shevchenko
On Wed, 4 May 2016, Josh Poimboeuf wrote:
> On Wed, May 04, 2016 at 04:12:05PM +0200, Petr Mladek wrote:
> > On Wed 2016-05-04 14:39:40, Petr Mladek wrote:
> > >*
> > >* Note that the task must never be migrated to the target
> > >* state when being inside this
On 03-05-16, 20:49, Akshay Adiga wrote:
> Fixes are based on patch https://patchwork.ozlabs.org/patch/612058/ which
> is in Rafael's linux-next.
>
> - Patch [1] fixes WARN_ON in powernv_target_index()
> - Patch [2] Deleting any pending timer to saves an unnecessary irq call
> in powernv_target_in
On Monday 09 May 2016 13:39:50 Felipe Balbi wrote:
> Arnd Bergmann writes:
> > On Monday 09 May 2016 10:23:22 Benjamin Herrenschmidt wrote:
> >> On Sun, 2016-05-08 at 13:44 +0200, Christian Lamparter wrote:
> >
> > The patch that caused the problem had multiple issues:
> >
> > - it broke big-endia
On Mon, 2016-05-09 at 12:36 +0200, Arnd Bergmann wrote:
>
> I think we can simply make this set of accessors architecture-
> dependent
> (MIPS vs. the rest of the world) to revert ARM and PowerPC back to
> the working version.
Or use writel_be which mips seems to support...
Really, make it a BE
On 05/06/2016 05:19 PM, Michael Ellerman wrote:
> On Tue, 2016-02-16 at 14:29 +0530, Anshuman Khandual wrote:
>
>> >This patch series adds twelve new ELF core note sections which can
>> > be used with existing ptrace request PTRACE_GETREGSET-SETREGSET for
>> > accessing
>> > various transacti
On 05/03/2016 08:49 PM, Akshay Adiga wrote:
Fixes are based on patch https://patchwork.ozlabs.org/patch/612058/ which
is in Rafael's linux-next.
- Patch [1] fixes WARN_ON in powernv_target_index()
- Patch [2] Deleting any pending timer to saves an unnecessary irq call
in powernv_target_index(
On Fri 2016-05-06 07:38:55, Josh Poimboeuf wrote:
> On Thu, May 05, 2016 at 01:57:01PM +0200, Petr Mladek wrote:
> > I have missed that the two commands are called with preemption
> > disabled. So, I had the following crazy scenario in mind:
> >
> >
> > CPU0CPU1
>
> > > +static inline bool large_dec_supp(void)
> > > +{
> > > + return cpu_has_feature(CPU_FTR_ARCH_300);
> > > +}
> > > +
> > Can we rename this to is_large_dec()?
> Honestly, I don't like either. How about have_large_dec() ?
How about cpu_has_large_dec() like the underlying call?
Mikey
___
Hi,
Arnd Bergmann writes:
> On Monday 09 May 2016 10:23:22 Benjamin Herrenschmidt wrote:
>> On Sun, 2016-05-08 at 13:44 +0200, Christian Lamparter wrote:
>> > On Sunday, May 08, 2016 08:40:55 PM Benjamin Herrenschmidt wrote:
>> > >
>> > > On Sun, 2016-05-08 at 00:54 +0200, Christian Lamparter v
On 5/5/2016 6:37 PM, Horia Geantă wrote:
> This will allow device drivers to consistently use io{read,write}XX
> also for 64-bit accesses.
>
> Signed-off-by: Horia Geantă
It would be great if PPC maintainers could Ack this patch.
As stated in the cover letter: https://lkml.org/lkml/2016/5/5/340
On Monday 09 May 2016 10:23:22 Benjamin Herrenschmidt wrote:
> On Sun, 2016-05-08 at 13:44 +0200, Christian Lamparter wrote:
> > On Sunday, May 08, 2016 08:40:55 PM Benjamin Herrenschmidt wrote:
> > >
> > > On Sun, 2016-05-08 at 00:54 +0200, Christian Lamparter via Linuxppc-dev
> > > wrote:
> > >
On Fri, 2016-26-02 at 00:26:25 UTC, Gavin Shan wrote:
> When the page fault happened in user space, we need check it's
> caused by stack frame pointer update instruction and update
> local variable @flag with FAULT_FLAG_USER. Currently, the code
> has two separate check for the same condition. That
On Fri, 2016-05-06 at 13:00 +1000, Suraj Jitindar Singh wrote:
> On 05/05/16 16:50, Michael Ellerman wrote:
> > On Tue, 2016-05-03 at 15:32 -0700, Tyrel Datwyler wrote:
> > > On 04/27/2016 10:34 PM, Suraj Jitindar Singh wrote:
> > > > diff --git a/arch/powerpc/platforms/pseries/mobility.c
> > > >
[...]
> +static int klp_target_state;
[...]
> +void klp_init_transition(struct klp_patch *patch, int state)
> +{
> + struct task_struct *g, *task;
> + unsigned int cpu;
> + struct klp_object *obj;
> + struct klp_func *func;
> + int initial_state = !state;
> +
> + klp_tra
On 05/07/2016 09:41 AM, Michael Ellerman wrote:
On Fri, 2016-06-05 at 11:50:37 UTC, Hari Bathini wrote:
Currently, memory for fadump can be specified with fadump_reserve_mem=size,
where only a fixed size can be specified. This patch tries to extend this
syntax to support conditional reservatio
On 05/07/2016 09:42 AM, Michael Ellerman wrote:
On Fri, 2016-06-05 at 11:51:08 UTC, Hari Bathini wrote:
Kernel parameter 'nr_cpus' can be used to limit the maximum number
of processors that an SMP kernel could support. This patch extends
this to fadump by introducing 'fadump_nr_cpus' parameter
Andy Shevchenko writes:
> On Mon, May 9, 2016 at 4:09 AM, Tejun Heo wrote:
>> On Sun, May 08, 2016 at 04:00:08PM -0400, Tejun Heo wrote:
>>> Hello, Andy.
>>>
>>> On Wed, May 04, 2016 at 03:22:51PM +0300, Andy Shevchenko wrote:
>>> > Tejun, since Vinod applied all necessary patches into his tree,
On Mon, May 9, 2016 at 4:09 AM, Tejun Heo wrote:
> On Sun, May 08, 2016 at 04:00:08PM -0400, Tejun Heo wrote:
>> Hello, Andy.
>>
>> On Wed, May 04, 2016 at 03:22:51PM +0300, Andy Shevchenko wrote:
>> > Tejun, since Vinod applied all necessary patches into his tree, the
>> > series now has just a d
On Mon, May 9, 2016 at 4:28 PM, Balbir Singh wrote:
>
>
> On 04/05/16 17:37, Oliver O'Halloran wrote:
>> POWER ISA v3 adds large decrementer (LD) mode of operation which increases
>> the size of the decrementer register from 32 bits to an implementation
>> defined with of up to 64 bits.
>>
>> This
Hello,
the "fman" Ethernet driver was integrated in mainline Linux Dezember
2015 ("drivers/net/ethernet/freescale/fman"). It seems that the other
parts, e.g. BMan, QMan ("drivers/soc/fsl/qbman") and basic DPAA Ethernet
support ("drivers/net/ethernet/freescale/dpaa") are still missing. Are
the
On Mon, May 9, 2016 at 10:24 AM, Geert Uytterhoeven
wrote:
> JFYI, when comparing v4.6-rc7[1] to v4.6-rc6[3], the summaries are:
> - build errors: +188/-7
For a quiet -rc7, the results are devastating:
+ /home/kisskb/slave/src/arch/sh/kernel/setup.c: error: implicit
declaration of function '
On 21.04.2016 11:25, Thomas Huth wrote:
> On 15.03.2016 21:18, Laurent Vivier wrote:
>> While writing some instruction tests for kvm-unit-tests for powerpc,
>> I've found that illegal instructions are not managed correctly with kvm-pr,
>> while it is fine with kvm-hv.
>>
>> When an illegal instruct
On Sat, 2016-05-07 at 16:43 +0530, Naveen N. Rao wrote:
> On 2016/05/07 02:15PM, Michael Ellerman wrote:
> > On Thu, 2016-05-05 at 15:23:19 UTC, "Naveen N. Rao" wrote:
> > > Generalize existing macros to serve the purpose.
> > >
> > > Cc: Wang Nan
> > > Cc: Arnaldo Carvalho de Melo
> > > Cc: Mas
platform_get_irq can fail, so we should handle negative value when
returned.
[v2]
platform_get_irq can actually return zero on some platforms. So do not
remove checks for irq == 0 there.
Signed-off-by: Jiri Slaby
Cc: Russell King
Cc: "Uwe Kleine-König"
Cc: Russell King
Cc: Benjamin Herrensch
41 matches
Mail list logo