It is always a headache dealing with different defconfigs
though they only differ in a few places. Hence we are proposing a new
way of writing the defconfig:
1. Define a basic defconfig say mpc85xx_basic_defconfig
2. Spin off as much features as possible from the current mpc85xx_defconfig
a
At Fri, 12 Jun 2015 12:01:42 +0200,
Quentin Lambert wrote:
>
>
>
> On 12/06/2015 11:59, Andreas Schwab wrote:
> > Quentin Lambert writes:
> >
> >> The dev_attrs field of struct bus_type is going away, sue dev_groups
> >> instead.
> > s/sue/use/
> I meant use do you need to fix something else o
On 06/13/2015 01:06 AM, Nishanth Aravamudan wrote:
On 12.06.2015 [16:47:03 +1000], Gavin Shan wrote:
On Fri, Jun 12, 2015 at 04:19:17PM +1000, Alexey Kardashevskiy wrote:
The existing code puts all devices from a root PE to the same IOMMU group.
However it is a possible situation when subordina
On 12.06.2015 [16:47:03 +1000], Gavin Shan wrote:
> On Fri, Jun 12, 2015 at 04:19:17PM +1000, Alexey Kardashevskiy wrote:
> >The existing code puts all devices from a root PE to the same IOMMU group.
> >However it is a possible situation when subordinate buses belong to
> >separate PEs, in this cas
On Fri, 12 Jun 2015, Baolin Wang wrote:
Sigh. Again threading of the series failed. Some patches are, the
whole series is not. Can you please get your tools straight?
You neither managed to cc me on the security patch.
> - Modify the subject line and the changelog:
> timekeeping: Change the i
On 06/11/2015 09:34 PM, Andrew Morton wrote:
On Thu, 11 Jun 2015 15:21:30 -0400 Eric B Munson wrote:
Ditto mlockall(MCL_ONFAULT) followed by munlock(). I'm not sure
that even makes sense but the behaviour should be understood and
tested.
I have extended the kselftest for lock-on-fault to tr
Quentin Lambert writes:
> The dev_attrs field of struct bus_type is going away, sue dev_groups instead.
s/sue/use/
Andreas.
--
Andreas Schwab, sch...@linux-m68k.org
GPG Key fingerprint = 58CA 54C7 6D53 942B 1756 01D3 44D5 214B 8276 4ED5
"And now for something completely different."
_
On 12/06/2015 11:59, Andreas Schwab wrote:
Quentin Lambert writes:
The dev_attrs field of struct bus_type is going away, sue dev_groups instead.
s/sue/use/
I meant use do you need to fix something else or should I resend with
the typo correction ?
Quentin
Although this init call checks for device tree properties before doing
anything, it should still only run on powernv machines.
Signed-off-by: Michael Ellerman
---
arch/powerpc/platforms/powernv/idle.c | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/arch/powerpc/platforms/po
On Thu, 2015-11-06 at 09:25:29 UTC, Alistair Popple wrote:
> opal_init() is called via a machine_subsys_initcall(). Due to a hack
> in the eeh code the eeh driver is initialised with at the same
> initcall level. This means depending on link ordering the following
> error can occur because the opal
That makes sense. Thanks for pointing out.
Thanks,
Yuantian
> -Original Message-
> From: Paul Bolle [mailto:pebo...@tiscali.nl]
> Sent: Friday, June 12, 2015 4:58 PM
> To: Tang Yuantian-B29983
> Cc: Wood Scott-B07421; linuxppc-dev@lists.ozlabs.org; linux-
> ker...@vger.kernel.org; devicet
On 06/12/2015 12:56 PM, Madhavan Srinivasan wrote:
>
> On Friday 12 June 2015 12:32 PM, Anshuman Khandual wrote:
>> > On 06/11/2015 07:39 AM, Daniel Axtens wrote:
>>> >> Hi,
>>> >>
>>> >> On Mon, 2015-06-08 at 17:08 +0530, Anshuman Khandual wrote:
>>> diff --git a/tools/testing/selftests/powe
Just a nit.
On Thu, 2015-06-11 at 14:32 +0800, yuantian.t...@freescale.com wrote:
> --- /dev/null
> +++ b/arch/powerpc/sysdev/fsl_rcpm.c
> +int fsl_rcpm_init(void)
This is used only through early_initcall(). I took the cargo cult
approach of looking at the other uses of early_initcall() in
arch/
The dev_attrs field of struct bus_type is going away, sue dev_groups instead.
This converts the soundbus code to use the correct field.
These modifications were made using Coccinelle.
Signed-off-by: Quentin Lambert
---
Changes since v2:
- Revert to the version of the patch where the files wer
The cputime_to_timespec() and timespec_to_cputime() functions are
not year 2038 safe on 32bit systems due to the struct timepsec will
overflow in 2038 year. Introduce cputime_to_timespec64() and
timespec64_to_cputime() functions which use struct timespec64,
as well as for arch/s390 and arch/powerpc
On Thu, Jun 11, 2015 at 08:51:07AM -0700, Nicolin Chen wrote:
> On Thu, Jun 11, 2015 at 07:10:00PM +0800, Zidan Wang wrote:
>
> > > > This imx-wm8960 device-tree-only machine driver works with sai driver
> > > > and have below feature.
> > > > * support codec master and slave mode
> > > > * suppor
On 11/06/2015 14:25, Takashi Iwai wrote:
At Thu, 11 Jun 2015 14:04:45 +0200,
Quentin Lambert wrote:
On 11/06/2015 12:02, Takashi Iwai wrote:
At Thu, 11 Jun 2015 10:03:38 +0200,
Quentin Lambert wrote:
The dev_attrs field of struct bus_type is going away, use dev_groups instead.
This convert
On 06/12/2015 12:27 AM, Scott Wood wrote:
> Dropping the upper bits of the size harms the ability to detect error
> scenarios where unmappably large -- but not power-of-two -- regions
> are requested to be mapped.
>
> However, this patch doesn't fix that. It just postpones the loss of
> the up
Fix the memory leak in create_gatt_table:
we've lost a kfree on the exit path for the pages array allocated
in uninorth_create_gatt_table
Signed-off-by: Denis Kirjanov
---
drivers/char/agp/uninorth-agp.c | 16 ++--
1 file changed, 10 insertions(+), 6 deletions(-)
diff --git a/driver
On Friday 12 June 2015 12:32 PM, Anshuman Khandual wrote:
> On 06/11/2015 07:39 AM, Daniel Axtens wrote:
>> Hi,
>>
>> On Mon, 2015-06-08 at 17:08 +0530, Anshuman Khandual wrote:
>>> diff --git a/tools/testing/selftests/powerpc/pmu/bhrb/bhrb_filters.c
>>> b/tools/testing/selftests/powerpc/pmu/bhr
This patch series changes the 32-bit time types (timespec/itimerspec) to
the 64-bit types (timespec64/itimerspec64), since 32-bit time types will
break in the year 2038 on 32bit systems.
This patch series introduces new methods with timespec64/itimerspec64 type,
and removes the old ones with times
Le 10/06/2015 20:17, Rob Herring a écrit :
On Wed, Jun 10, 2015 at 10:12 AM, leroy christophe
wrote:
Le 06/06/2015 17:32, Rob Herring a écrit :
On Sat, Jun 6, 2015 at 6:20 AM, christophe leroy
wrote:
I've got a MPC8323 RDB evaluation platform from freescale
kernel 4.0 doesn't boot
kernel 3
On 06/11/2015 09:02 AM, Daniel Axtens wrote:
+
/* Processing BHRB entries */
static void power_pmu_bhrb_read(struct cpu_hw_events *cpuhw)
{
- u64 val;
- u64 addr;
+ u64 val, addr, tmp;
>>> Please don't use 'tmp' here. As far as I can tell, you use this varia
On 06/11/2015 08:58 AM, Daniel Axtens wrote:
>
- if (!(ppmu->flags & PPMU_ARCH_207S)) {
+ if (!(ppmu->flags & PPMU_ARCH_207S) || cpuhw->bhrb_users)
>>
>>> You're using cpuhw->bhrb_users as a bool here, where it's an int. Could
>>> you make the test more specific so that it's cle
On 06/11/2015 06:49 AM, Daniel Axtens wrote:
>> if (sw_filter & PERF_SAMPLE_BRANCH_PLM_ALL) {
>> +flag = false;
> Would it be possible to use a more meaningful name than flag? Perhaps
> indicating what is it flagging?
sure, will change it with "select_branch"
>> +
>> +
On 06/11/2015 07:39 AM, Daniel Axtens wrote:
> Hi,
>
> On Mon, 2015-06-08 at 17:08 +0530, Anshuman Khandual wrote:
>> diff --git a/tools/testing/selftests/powerpc/pmu/bhrb/bhrb_filters.c
>> b/tools/testing/selftests/powerpc/pmu/bhrb/bhrb_filters.c
>> new file mode 100644
>> index 000..13e6b72
26 matches
Mail list logo