On Mon, Nov 17, 2014 at 12:23 PM, Michael Ellerman
wrote:
> On Fri, 2014-11-14 at 14:42 +0530, Vineeth Vijayan wrote:
> > Now there is no way to disable TEXT randomization on a PPC32/PPC64
> > machine. Text randomization happens even in the case of "echo 0 >
> > /proc/sys/kernel/randomize_va_spac
On 2014/11/17 18:08, Arnd Bergmann wrote:
> On Monday 17 November 2014 18:21:35 Yijing Wang wrote:
>> - list_for_each_entry(window, resources, list)
>> - if (window->res->flags & IORESOURCE_BUS) {
>> - found = true;
>> - break;
>> -
On Mon, Nov 17, 2014 at 12:23 PM, Michael Ellerman wrote:
> On Fri, 2014-11-14 at 14:42 +0530, Vineeth Vijayan wrote:
>> Now there is no way to disable TEXT randomization on a PPC32/PPC64
>> machine. Text randomization happens even in the case of "echo 0 >
>> /proc/sys/kernel/randomize_va_space"
>
Although we are now selecting NO_BOOTMEM, we still have some traces of
bootmem lying around. That is because even with NO_BOOTMEM there is
still a shim that converts bootmem calls into memblock calls, but
ultimately we want to remove all traces of bootmem.
Most of the patch is conversions from all
Hi Michael,
This patch added no new functionality so I haven't put the test
results (of course I ran the test suite to check the patch).
The output :
[ 650.198958] test_bpf: Summary: 60 PASSED, 0 FAILED
On 11/18/14, Michael Ellerman wrote:
> On Mon, 2014-11-17 at 23:07 +0300, Denis Kirjanov wr
Commit dcb18694 "Fix ipi on palmeto" disabled fastsleep at boot time.
Revert this commit since we no longer need this fix. However we can
continue to use powersave_nap parameter to control entry into deep
idle states beyond snooze.
Signed-off-by: Preeti U. Murthy
---
drivers/cpuidle/cpuidle-pow
On 二, 2014-11-18 at 15:33 +1100, Michael Ellerman wrote:
> On Mon, 2014-17-11 at 02:52:30 UTC, Li Zhong wrote:
> > It seems nvram_pstore_info's buf_lock is not initialized before
> > registering, which causes some strange behavior when trying to obtain
> > the lock during kdump process.
>
> What k
On Mon, Oct 27, 2014 at 2:44 PM, Preeti U Murthy
wrote:
> On 10/17/2014 01:00 AM, kernelf...@gmail.com wrote:
>> Signed-off-by: Liu Ping Fan
>> ---
>> arch/powerpc/kvm/Kconfig | 4
>> 1 file changed, 4 insertions(+)
>>
>> diff --git a/arch/powerpc/kvm/Kconfig b/arch/powerpc/kvm/Kconfig
>> i
On Mon, Oct 27, 2014 at 2:40 PM, Preeti U Murthy
wrote:
> On 10/17/2014 12:59 AM, kernelf...@gmail.com wrote:
>> (This is a place holder patch.)
>> We need to store the time base for host on secondary hwthread.
>> Later when switching back, we need to reprogram it with elapse
>> time.
>>
>> Signed
On Mon, Oct 27, 2014 at 1:32 PM, Preeti U Murthy
wrote:
> Hi Liu,
>
> On 10/17/2014 12:59 AM, kernelf...@gmail.com wrote:
>> Nowadays, powerKVM runs with secondary hwthread offline. Although
>> we can make all secondary hwthread online later, we still preserve
>> this behavior for dedicated KVM en
On Mon, Oct 27, 2014 at 12:45 PM, Preeti U Murthy
wrote:
> On 10/17/2014 12:59 AM, kernelf...@gmail.com wrote:
>> (This patch is a place holder.)
>>
>> If there is only one vcpu thread is ready(the other vcpu thread can
>> wait for it to execute), the primary thread can enter tickless mode,
>
> We
Highlights include a bunch of 8xx optimizations, device tree bindings for
Freescale BMan, QMan, and FMan datapath components, misc device tree
updates, and inbound rio window support.
The following changes since commit 0df1f2487d2f0d04703f142813d53615d62a1da4:
Linux 3.18-rc3 (2014-11-02 15:01:5
On Mon, Oct 27, 2014 at 12:04 PM, Preeti U Murthy
wrote:
> Hi Liu,
>
> On 10/17/2014 12:59 AM, kernelf...@gmail.com wrote:
>> When kvm is enabled on a core, we migrate all external irq to primary
>> thread. Since currently, the kvmirq logic is handled by the primary
>> hwthread.
>>
>> Todo: this p
On Wed, Nov 12, 2014 at 5:22 PM, Srikar Dronamraju
wrote:
> * kernelf...@gmail.com [2014-10-16 15:29:50]:
>
>> Some system such as powerpc, some tsk (vcpu thread) can only run on
>> the dedicated cpu. Since we adapt some asymmetric method to monitor the
>> whole physical cpu. (powerKVM only allow
This patch fixes a crash (introduced in v3.18-rc1) in the FSL MSI driver
when threaded IRQs are enabled.
The following changes since commit 8a97577a5967c1234ccc3bc1b45e4b1a58b39ea8:
Merge branch 'for-linus' of
git://git.kernel.org/pub/scm/linux/kernel/git/mpe/linux (2014-11-04 11:18:29
-0800)
On Mon, 2014-17-11 at 02:52:30 UTC, Li Zhong wrote:
> It seems nvram_pstore_info's buf_lock is not initialized before
> registering, which causes some strange behavior when trying to obtain
> the lock during kdump process.
What kind of strange behaviour? Does it still work and just print a warning
On Tue, Nov 18, 2014 at 12:46:56PM +1100, Michael Ellerman wrote:
> On Mon, 2014-11-17 at 11:18 -0800, Paul E. McKenney wrote:
> > On Thu, Nov 13, 2014 at 01:42:12PM +1100, Michael Ellerman wrote:
> > > On Mon, 2014-11-10 at 14:58 -0600, Paul Clarke wrote:
> > > > On 11/10/2014 04:08 AM, Benjamin H
Hi Nathan,
I tried to apply these to Linus' tree and Mpes tree and to stable and
got several problems, I got stuck at the third hunk in patch 5.
Could you point out where I'm going wrong?
Thanks,
Cyril
On Mon, 2014-11-17 at 15:44 -0600, Nathan Fontenot wrote:
> In order to better support devic
On Mon, 2014-11-17 at 23:07 +0300, Denis Kirjanov wrote:
> Reduce duplicated code by unifying
> BPF_ALU | BPF_MOD | BPF_X and BPF_ALU | BPF_DIV | BPF_X
>
> CC: Alexei Starovoitov
> CC: Daniel Borkmann
> CC: Philippe Bergheaud
> Signed-off-by: Denis Kirjanov
Please include the output of the test
On Mon, 2014-11-17 at 11:18 -0800, Paul E. McKenney wrote:
> On Thu, Nov 13, 2014 at 01:42:12PM +1100, Michael Ellerman wrote:
> > On Mon, 2014-11-10 at 14:58 -0600, Paul Clarke wrote:
> > > On 11/10/2014 04:08 AM, Benjamin Herrenschmidt wrote:
> > > > On Tue, 2014-10-07 at 14:13 -0500, Paul Clarke
On Fri, 2014-11-14 at 09:28 +0100, Wolfram Sang wrote:
> > >
> > > If we're going to change the device tree I'd rather just add a property
> > > to say what the prescaler is.
> >
> > We would however, leave the boards' device trees that use things like
> > "fsl,mpc8543-i2c" as is and introduce t
>>
>> -bus->domain_nr = domain;
>> +void pci_bus_assign_domain_nr(struct pci_bus *bus, struct device *parent)
>> +{
>> +bus->domain_nr = pci_get_domain_nr(parent);
>> }
>> #endif
>
> This code is superseded by the last patches I sent to move the domain
> assignment to PCI core code.
>
On Mon, Nov 17, 2014 at 03:51:42PM -0600, Nathan Fontenot wrote:
>Create a new entry point for device hotplug on pseries that will
>work for both PowerVM and PowerKVM systems.
>
>The current process to hotplug (or dlpar) devices (generally the same
>process for memory, cpu, and pci devices) on Powe
On Mon, 2014-11-17 at 04:31 -0600, Emil Medve wrote:
> Hello Scott,
>
>
> On 11/13/2014 03:42 PM, Scott Wood wrote:
> > On Thu, 2014-11-13 at 03:21 -0600, Emil Medve wrote:
> >> From: Kumar Gala
> >>
> >> Signed-off-by: Kumar Gala
> >> Signed-off-by: Geoff Thorpe
> >> Signed-off-by: Hai-Ying W
Move handling of memory hotplug remove on pseries completely into the kernel.
The current memory hotplug remove path involves the drmgr command doing part
of this work in userspace and requesting the kernel to do additional pieces.
This patch allows us to handle the act completely in the kernel vi
Move handling of memory hotplug add on pseries completely into the kernel.
The current memory hotplug add path involves the drmgr command doing part
of this work in userspace and requesting the kernel to do additional pieces.
This patch allows us to handle the act completely in the kernel via rtas
Export the routines to acquire and release a drc index.
Signed-off-by: Nathan Fontenot
---
arch/powerpc/platforms/pseries/pseries.h |2 ++
1 file changed, 2 insertions(+)
diff --git a/arch/powerpc/platforms/pseries/pseries.h
b/arch/powerpc/platforms/pseries/pseries.h
index 1796c54..239bee5
Create a new entry point for device hotplug on pseries that will
work for both PowerVM and PowerKVM systems.
The current process to hotplug (or dlpar) devices (generally the same
process for memory, cpu, and pci devices) on PowerVM systems is initiated
from the HMC, which communicates the request
The of_drconf_cell defines each LMB for a system in the device tree property
ibm,dynamic-reconfiguration-memory/ibm,dynamic-memory. The values are
in BE format by definition, this patch updates the of_drconf_cell struct
to reflect the proper endian-ness.
Signed-off-by: Nathan Fontenot
---
arch/p
In order to handle device hotplug in the kernel on pseries hotplug
notifications will be communicated to the kernel in the form of a
rtas hotplug events. This patch adds the definition of rtas hotplug event
sections.
Signed-off-by: Nathan Fontenot
---
arch/powerpc/include/asm/rtas.h | 26 +
In order to better support device hotplug (cpu, memory, and pci) in the
PowerVM and PowerKVM environments, the handling of device hotplug
could be updated so that the act of hotplugging a device occurs entirely
in the kernel. This patch set begins to address this by moving
memory hotplug to the ker
Reduce duplicated code by unifying
BPF_ALU | BPF_MOD | BPF_X and BPF_ALU | BPF_DIV | BPF_X
CC: Alexei Starovoitov
CC: Daniel Borkmann
CC: Philippe Bergheaud
Signed-off-by: Denis Kirjanov
---
arch/powerpc/net/bpf_jit_comp.c | 27 ---
1 file changed, 8 insertions(+), 19 del
On Thu, Nov 13, 2014 at 01:42:12PM +1100, Michael Ellerman wrote:
> On Mon, 2014-11-10 at 14:58 -0600, Paul Clarke wrote:
> > On 11/10/2014 04:08 AM, Benjamin Herrenschmidt wrote:
> > > On Tue, 2014-10-07 at 14:13 -0500, Paul Clarke wrote:
> > >> This patch short-circuits the reset of the decrement
The first argument to vphn_unpack_associativity() is a const long *, but the
parsing code expects __be64 values actually. This is inconsistent. We should
either pass a const __be64 * or change vphn_unpack_associativity() so that
it fixes endianness by itself.
This patch does the latter, since the
According to PAPR+ 14.11.6.1 H_HOME_NODE_ASSOCIATIVITY, the hypervisor is
supposed to pack significant fields first and fill the remaining unused
fields with "all ones". It means that the first unused field can be viewed
as an end-of-list marker.
The "ibm,associativity" property in the DT isn't pad
The number of values returned by the H_HOME_NODE_ASSOCIATIVITY h_call deserves
to be explicitly defined, for a better understanding of the code.
Signed-off-by: Greg Kurz
---
arch/powerpc/mm/numa.c |8 ++--
1 file changed, 6 insertions(+), 2 deletions(-)
diff --git a/arch/powerpc/mm/numa
Repost with Cc: for Michael and Ben...
The following commit fixed an endianness issue in the VPHN code:
commit 5c9fb1899400096c6818181c525897a31d57e488
Author: Greg Kurz
Date: Wed Oct 15 12:42:58 2014 +0200
powerpc/vphn: NUMA node code expects big-endian
It was discussed at the time that
On Mon, Nov 17, 2014 at 10:21:43AM +, Yijing Wang wrote:
> From: Yijing Wang
>
> Signed-off-by: Yijing Wang
> ---
> drivers/pci/host-bridge.c |1 +
> include/linux/pci.h |2 ++
> 2 files changed, 3 insertions(+), 0 deletions(-)
>
> diff --git a/drivers/pci/host-bridge.c b/dri
On Monday 17 November 2014 18:21:34 Yijing Wang wrote:
> This series is based Linux 3.18-rc1 and Lorenzo Pieralisi's
> arm PCI domain cleanup patches, link:
> https://patchwork.ozlabs.org/patch/407585/
>
> Current pci scan interfaces like pci_scan_root_bus() and directly
> call pci_create_root_bu
On Mon, Nov 17, 2014 at 10:21:48AM +, Yijing Wang wrote:
> Signed-off-by: Yijing Wang
> ---
> arch/arm/include/asm/mach/pci.h |9 +
> arch/arm/kernel/bios32.c|8 ++--
> 2 files changed, 15 insertions(+), 2 deletions(-)
>
> diff --git a/arch/arm/include/asm/mach/pc
On Monday 17 November 2014 18:21:41 Yijing Wang wrote:
> There are some common PCI infos like domain, msi_controller, these
> infos are saved in arch PCI sysdata, and lots arch specific functions
> like pci_domain_nr() and pcibios_msi_controller() required.
> We could separate pci_host_bridge creat
Hello Scott,
On 11/13/2014 03:42 PM, Scott Wood wrote:
> On Thu, 2014-11-13 at 03:21 -0600, Emil Medve wrote:
>> From: Kumar Gala
>>
>> Signed-off-by: Kumar Gala
>> Signed-off-by: Geoff Thorpe
>> Signed-off-by: Hai-Ying Wang
>> Signed-off-by: Chunhe Lan
>> Signed-off-by: Poonam Aggrwal
>> S
On Monday 17 November 2014 18:21:35 Yijing Wang wrote:
> - list_for_each_entry(window, resources, list)
> - if (window->res->flags & IORESOURCE_BUS) {
> - found = true;
> - break;
> - }
> + if (!resources) {
> +
Signed-off-by: Yijing Wang
---
arch/powerpc/kernel/pci-common.c | 81 ++---
1 files changed, 48 insertions(+), 33 deletions(-)
diff --git a/arch/powerpc/kernel/pci-common.c b/arch/powerpc/kernel/pci-common.c
index e5dad9a..5b0f078 100644
--- a/arch/powerpc/kerne
Signed-off-by: Yijing Wang
---
arch/ia64/pci/pci.c | 84 +++---
1 files changed, 39 insertions(+), 45 deletions(-)
diff --git a/arch/ia64/pci/pci.c b/arch/ia64/pci/pci.c
index aac3220..c7d97ae 100644
--- a/arch/ia64/pci/pci.c
+++ b/arch/ia64/pci/pci.
This series is based Linux 3.18-rc1 and Lorenzo Pieralisi's
arm PCI domain cleanup patches, link:
https://patchwork.ozlabs.org/patch/407585/
Current pci scan interfaces like pci_scan_root_bus() and directly
call pci_create_root_bus()/pci_scan_child_bus() lack flexiblity.
Some platform infos like
Signed-off-by: Yijing Wang
---
arch/arm/include/asm/mach/pci.h |9 +
arch/arm/kernel/bios32.c|8 ++--
2 files changed, 15 insertions(+), 2 deletions(-)
diff --git a/arch/arm/include/asm/mach/pci.h b/arch/arm/include/asm/mach/pci.h
index f19f627..370b3bd 100644
--- a/a
Signed-off-by: Yijing Wang
---
arch/arm/include/asm/mach/pci.h |1 +
arch/arm/kernel/bios32.c| 52 +++---
2 files changed, 32 insertions(+), 21 deletions(-)
diff --git a/arch/arm/include/asm/mach/pci.h b/arch/arm/include/asm/mach/pci.h
index 370b3bd.
Rip out pci_bus_add_devices() from pci_scan_root_bus()
for following reasons.
1. pci_scan_root_bus() means we only do the scan, we should
not add pci busses.
2. A lots of drviers which use pci_scan_root_bus() call
pci_bus_size_bridges(), pci_bus_assign_resources() after
pci_scan_root_bus(). But str
There are some common PCI infos like domain, msi_controller, these
infos are saved in arch PCI sysdata, and lots arch specific functions
like pci_domain_nr() and pcibios_msi_controller() required.
We could separate pci_host_bridge creation out of pci_create_root_bus(),
then we could put the common
Now we could use pci_scan_host_bridge() to refactor
pci_acpi_scan_root().
Signed-off-by: Yijing Wang
---
arch/x86/pci/acpi.c | 65 ++---
arch/x86/pci/common.c | 23 -
2 files changed, 56 insertions(+), 32 deletions(-)
diff --git
Currently, we use int type for bus number in
pci_create_root_bus() and pci_scan_root_bus().
Because bus number is <= 255, so we could
change the bus number argument type to u32,
and combine PCI domain and bus number, we will
save the domain number in pci_host_bridge in
later patch, and eliminate th
Signed-off-by: Yijing Wang
---
arch/ia64/pci/pci.c |3 +--
1 files changed, 1 insertions(+), 2 deletions(-)
diff --git a/arch/ia64/pci/pci.c b/arch/ia64/pci/pci.c
index 291a582..aac3220 100644
--- a/arch/ia64/pci/pci.c
+++ b/arch/ia64/pci/pci.c
@@ -424,7 +424,6 @@ struct pci_bus *pci_acpi_sc
Now we can remove the deprecated pci_scan_bus_parented(),
and use pci_scan_root_bus() instead.
Signed-off-by: Yijing Wang
---
drivers/pci/probe.c| 19 ---
drivers/pci/xen-pcifront.c |6 +++---
include/linux/pci.h|2 --
3 files changed, 3 insertions(+), 2
From: Yijing Wang
Now pci_host_bridge has been ripped out from pci root
bus creation. Currently pci_scan_root_bus() lacks
scalability, so platform host drivers have no proper
way to configure pci_host_bridge. E.g we should assign
msi_controller to pci_host_bridge, add argument for
pci_scan_root_b
From: Yijing Wang
Now we could use pci_scan_root_bus() instead of
pci_scan_bus(), pass NULL resources means use the default
io/mem.
Signed-off-by: Yijing Wang
---
arch/alpha/include/asm/pci.h |2 +-
arch/alpha/kernel/sys_nautilus.c |2 +-
arch/cris/include/asm/pci.h |2
No one uses it, clean up.
Signed-off-by: Yijing Wang
---
drivers/pci/probe.c | 20
include/linux/pci.h |1 -
2 files changed, 0 insertions(+), 21 deletions(-)
diff --git a/drivers/pci/probe.c b/drivers/pci/probe.c
index fc99e88..0a02fc2 100644
--- a/drivers/pci/probe.
From: Yijing Wang
Signed-off-by: Yijing Wang
---
drivers/pci/host-bridge.c |1 +
include/linux/pci.h |2 ++
2 files changed, 3 insertions(+), 0 deletions(-)
diff --git a/drivers/pci/host-bridge.c b/drivers/pci/host-bridge.c
index 49b6c21..872cae1 100644
--- a/drivers/pci/host-bri
Add of_scan_bus() to support some platforms
scan bus by of_node.
Signed-off-by: Yijing Wang
---
drivers/pci/host-bridge.c |1 +
drivers/pci/probe.c | 10 +++---
include/linux/pci.h |3 +++
3 files changed, 11 insertions(+), 3 deletions(-)
diff --git a/drivers/pci/host-
From: Yijing Wang
Pci_scan_root_bus(), pci_scan_bus() and pci_scan_bus_parented()
are very similar. But the latter two use the default
io/mem resources. Enhance pci_scan_root_bus() to support
default io/mem resources, then we could use
pci_scan_root_bus() instead of them, and clean them up.
Sign
Mel Gorman writes:
> This is follow up from the "pipe/page fault oddness" thread.
>
> Automatic NUMA balancing depends on being able to protect PTEs to trap a
> fault and gather reference locality information. Very broadly speaking it
> would mark PTEs as not present and use another bit to distin
61 matches
Mail list logo