On Tue, Oct 14, 2014 at 02:25:39PM +0800, Wei Yang wrote:
>On Fri, Sep 19, 2014 at 08:18:02PM +1000, Gavin Shan wrote:
>>On Fri, Sep 19, 2014 at 05:25:22PM +0800, Wei Yang wrote:
>>>pci_bus_find_capability() is decleared in pci.h, so it is not necessary to do
>>>it again.
>>>
>>>This patch removes
On Fri, Sep 19, 2014 at 08:18:02PM +1000, Gavin Shan wrote:
>On Fri, Sep 19, 2014 at 05:25:22PM +0800, Wei Yang wrote:
>>pci_bus_find_capability() is decleared in pci.h, so it is not necessary to do
>>it again.
>>
>>This patch removes it.
>>
>>Signed-off-by: Wei Yang
>
>Reviewed-by: Gavin Shan
>
From: Guenter Roeck
> arch/m32r/kernel/process.c | 8
Acked-by: Hirokazu Takata
Thank you.
-- takata
___
Linuxppc-dev mailing list
Linuxppc-dev@lists.ozlabs.org
https://lists.ozlabs.org/listinfo/linuxppc-dev
On Tue, 2014-10-14 at 10:39 +0800, Li Zhong wrote:
> On 二, 2014-10-07 at 08:33 -0700, Nishanth Aravamudan wrote:
> > On 07.10.2014 [17:28:38 +1100], Michael Ellerman wrote:
> > > On Fri, 2014-10-03 at 16:26 -0700, Nishanth Aravamudan wrote:
> > > > On 03.10.2014 [10:50:20 +1000], Michael Ellerman w
On 二, 2014-10-07 at 08:33 -0700, Nishanth Aravamudan wrote:
> On 07.10.2014 [17:28:38 +1100], Michael Ellerman wrote:
> > On Fri, 2014-10-03 at 16:26 -0700, Nishanth Aravamudan wrote:
> > > On 03.10.2014 [10:50:20 +1000], Michael Ellerman wrote:
> > > > On Thu, 2014-10-02 at 14:13 -0700, Nishanth A
On Mon, 2014-10-13 at 21:30 +0200, Yann Droneaud wrote:
> This patch replaces calls to get_unused_fd() with equivalent call to
> get_unused_fd_flags(0) to preserve current behavor for existing code.
>
> In a further patch, get_unused_fd() will be removed so that new code
> start using get_unused_f
ppc64_boot_msg is meant to be a boot debug aid, but
is only used in one spot. Get rid of it, and save
ourseleves a couple of lines in the kernel log
buffer.
Signed-off-by: Anton Blanchard
---
arch/powerpc/include/asm/machdep.h | 10 --
arch/powerpc/kernel/setup_64.c | 29
We have an extra level of indirection on memory hot remove which is not
matched on memory hot add. Memory hotplug is book3s only, so there is
no need for it.
This also enables means remove_memory() (ie memory hot unplug) works
on powernv.
Signed-off-by: Anton Blanchard
---
arch/powerpc/include/
Newer POWER designs do not implement PCI I/O space, so we
expect to see a number of these.
Reduce the severity of the warning so it doesn't mask other
real issues.
Signed-off-by: Anton Blanchard
---
Index: b/arch/powerpc/kernel/pci-common.c
==
Am 13.10.2014 um 13:17 schrieb leroy christophe:
Le 12/10/2014 18:22, Jochen Rollwagen a écrit :
This patch
https://lists.ozlabs.org/pipermail/linuxppc-dev/2014-September/121144.html
only compiles after putting an #ifndef ARCH_HAS_CSUM_ADD around the
definition in include/net/checksum.h
Thi
On Mon, Oct 13, 2014 at 2:11 PM, Benjamin Herrenschmidt
wrote:
> On Wed, 2014-10-08 at 16:28 +1100, Benjamin Herrenschmidt wrote:
>
>> > Further discussion with the hw teams have revealed that this is still
>> > an issue on newer asics so I think your original patch is correct
>> > after all. Jus
On Mon, Oct 13, 2014 at 4:11 PM, Benjamin Herrenschmidt
wrote:
> On Wed, 2014-10-08 at 16:28 +1100, Benjamin Herrenschmidt wrote:
>
>> > Further discussion with the hw teams have revealed that this is still
>> > an issue on newer asics so I think your original patch is correct
>> > after all. Jus
On Wed, 2014-10-08 at 16:28 +1100, Benjamin Herrenschmidt wrote:
> > Further discussion with the hw teams have revealed that this is still
> > an issue on newer asics so I think your original patch is correct
> > after all. Just disable 64 bit MSIs on all AMD audio PCI ids.
>
> Allright, I won't
Hi,
Please find the 9th revision of my patchset to remove
get_unused_fd() macro.
In linux-next, tag next-20141013, they're currently:
- 33 calls to fd_install()
with one call part of anon_inode_getfd()
- 27 calls to get_unused_fd_flags()
with one call part of anon_inode_
This patch replaces calls to get_unused_fd() with equivalent call to
get_unused_fd_flags(0) to preserve current behavor for existing code.
In a further patch, get_unused_fd() will be removed so that new code
start using get_unused_fd_flags(), with the hope O_CLOEXEC could be
used, either by defaul
Le 17/09/2014 22:34, Scott Wood a écrit :
On Wed, 2014-09-17 at 22:33 +0200, christophe leroy wrote:
Le 17/09/2014 18:40, Scott Wood a écrit :
On Wed, 2014-09-17 at 18:36 +0200, Christophe Leroy wrote:
This patchset:
1) provides several MMU TLB handling optimisation on MPC8xx.
2) adds support
On Fri, Oct 10, 2014 at 1:05 PM, Scott Wood wrote:
> There are many changes in here that ought to be separate patches with
> separate justification.
>
> Also, some of the QE changes seem to be reasonable cleanup, but not
> related to making the code work on ARM.
I agree with Scott. This patch al
On 10/13/2014 07:01 AM, Alexander Graf wrote:
The generic Linux framework to power off the machine is a function pointer
called pm_power_off. The trick about this pointer is that device drivers can
potentially implement it rather than board files.
Today on PowerPC we set pm_power_off to invoke o
On 10/13/2014 07:01 AM, Alexander Graf wrote:
The generic Linux framework to power off the machine is a function pointer
called pm_power_off. The trick about this pointer is that device drivers can
potentially implement it rather than board files.
Today on PowerPC we set pm_power_off to invoke o
The generic power off callback is pm_power_off. Use that one rather than
the powerpc specific ppc_md.power_off.
Signed-off-by: Alexander Graf
---
v1 -> v2:
- write pm_power_off in probe function
---
arch/powerpc/platforms/ps3/setup.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
di
The generic power off callback is pm_power_off. Use that one rather than
the powerpc specific ppc_md.power_off.
Signed-off-by: Alexander Graf
---
v1 -> v2:
- write pm_power_off in probe function
---
arch/powerpc/platforms/pseries/setup.c | 59 +-
1 file chang
The generic power off callback is pm_power_off. Use that one rather than
the powerpc specific ppc_md.power_off.
Signed-off-by: Alexander Graf
---
v1 -> v2:
- write pm_power_off in probe function
---
arch/powerpc/platforms/cell/setup.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
d
The generic power off callback is pm_power_off. Use that one rather than
the powerpc specific ppc_md.power_off.
Signed-off-by: Alexander Graf
---
v1 -> v2:
- write pm_power_off in probe function
---
arch/powerpc/platforms/maple/setup.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(
The generic power off callback is pm_power_off. Use that one rather than
the powerpc specific ppc_md.power_off.
Signed-off-by: Alexander Graf
---
arch/powerpc/platforms/powernv/setup.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/arch/powerpc/platforms/powernv/setup.c
The generic power off callback is pm_power_off. Use that one rather than
the powerpc specific ppc_md.power_off.
Signed-off-by: Alexander Graf
---
v1 -> v2:
- write pm_power_off in probe function
---
arch/powerpc/platforms/chrp/setup.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
The generic power off callback is pm_power_off. Use that one rather than
the powerpc specific ppc_md.power_off.
Signed-off-by: Alexander Graf
---
v1 -> v2:
- write pm_power_off in probe function
---
arch/powerpc/platforms/powermac/setup.c | 147
1 file chang
The generic power off callback is pm_power_off. Use that one rather than
the powerpc specific ppc_md.power_off.
Signed-off-by: Alexander Graf
---
v1 -> v2:
- write pm_power_off in probe function
---
arch/powerpc/platforms/embedded6xx/wii.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletio
The generic power off callback is pm_power_off. Use that one rather than
the powerpc specific ppc_md.power_off.
Signed-off-by: Alexander Graf
---
arch/powerpc/platforms/embedded6xx/gamecube.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/arch/powerpc/platforms/embedded6xx
Now that we have all implementations of ppc_md.power_off converted to
pm_power_off we can remove the ppc_md variant.
While at it, also set the default for pm_power_off to NULL so that non
machine drivers can implement overrides.
Signed-off-by: Alexander Graf
---
arch/powerpc/include/asm/machdep
The generic power off callback is pm_power_off. Use that one rather than
the powerpc specific ppc_md.power_off.
Signed-off-by: Alexander Graf
---
v1 -> v2:
- write pm_power_off in probe function
---
arch/powerpc/platforms/cell/qpace_setup.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion
The generic power off callback is pm_power_off. Use that one rather than
the powerpc specific ppc_md.power_off.
Signed-off-by: Alexander Graf
---
arch/powerpc/platforms/85xx/corenet_generic.c | 2 +-
arch/powerpc/sysdev/fsl_soc.c | 2 +-
2 files changed, 2 insertions(+), 2 deleti
The pm_power_off callback is what drivers are supposed to modify when they
implement power off support for the system.
Support a modified callback on powerpc. That way power off support code can
now either override ppc_md.power_off or pm_power_off.
Signed-off-by: Alexander Graf
---
arch/powerpc
The generic power off callback is pm_power_off. Use that one rather than
the powerpc specific ppc_md.power_off.
Signed-off-by: Alexander Graf
---
arch/powerpc/platforms/83xx/mcu_mpc8349emitx.c | 8
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/arch/powerpc/platforms/83xx
The generic power off callback is pm_power_off. Use that one rather than
the powerpc specific ppc_md.power_off.
Signed-off-by: Alexander Graf
---
v1 -> v2:
- write pm_power_off in probe function
---
arch/powerpc/platforms/embedded6xx/linkstation.c | 4 +++-
1 file changed, 3 insertions(+),
The generic power off callback is pm_power_off. Use that one rather than
the powerpc specific ppc_md.power_off.
Signed-off-by: Alexander Graf
---
arch/powerpc/platforms/85xx/sgy_cts1000.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/arch/powerpc/platforms/85xx/sgy_cts1
The generic power off callback is pm_power_off. Use that one rather than
the powerpc specific ppc_md.power_off.
Signed-off-by: Alexander Graf
---
v1 -> v2:
- fix typo
---
arch/powerpc/platforms/44x/ppc476.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/arch/powerpc/pla
The generic power off callback is pm_power_off. Use that one rather than
the powerpc specific ppc_md.power_off.
Signed-off-by: Alexander Graf
---
v1 -> v2:
- write pm_power_off in probe function
---
arch/powerpc/platforms/cell/celleb_setup.c | 4 ++--
1 file changed, 2 insertions(+), 2 dele
The generic Linux framework to power off the machine is a function pointer
called pm_power_off. The trick about this pointer is that device drivers can
potentially implement it rather than board files.
Today on PowerPC we set pm_power_off to invoke our generic full machine power
off logic which th
Xmon can manually turn off the machine. We now have 2 code paths for this:
1) ppc_md.power_off
2) pm_power_off
This patch allows xmon to support both and makes sure it graciously allows
a path to not be implemented.
Signed-off-by: Alexander Graf
---
arch/powerpc/xmon/xmon.c | 5 -
1 fi
The generic power off callback is pm_power_off. Use that one rather than
the powerpc specific ppc_md.power_off.
Signed-off-by: Alexander Graf
---
v1 -> v2:
- write pm_power_off in probe function
---
arch/powerpc/platforms/52xx/efika.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
Le 12/10/2014 18:22, Jochen Rollwagen a écrit :
This patch
https://lists.ozlabs.org/pipermail/linuxppc-dev/2014-September/121144.html
only compiles after putting an #ifndef ARCH_HAS_CSUM_ADD around the
definition in include/net/checksum.h
This is missing from the patch
This is already in
We really don't want to take a pagefault in show_instructions,
so use probe_kernel_address instead of __get_user.
Signed-off-by: Anton Blanchard
---
arch/powerpc/kernel/process.c | 8 ++--
1 file changed, 2 insertions(+), 6 deletions(-)
diff --git a/arch/powerpc/kernel/process.c b/arch/powe
Signed-off-by: Anton Blanchard
---
arch/powerpc/kernel/setup_64.c | 32
1 file changed, 16 insertions(+), 16 deletions(-)
diff --git a/arch/powerpc/kernel/setup_64.c b/arch/powerpc/kernel/setup_64.c
index cd07d79..4f3cfe1 100644
--- a/arch/powerpc/kernel/setup_64
Now KVM is working on LE, enable it. Also enable transarent
hugepage which has already been enabled on BE.
Signed-off-by: Anton Blanchard
---
arch/powerpc/configs/pseries_le_defconfig | 7 ++-
1 file changed, 6 insertions(+), 1 deletion(-)
diff --git a/arch/powerpc/configs/pseries_le_defcon
Use dma_set_mask_and_coherent() to set both the DMA and coherent
DMA mask.
Signed-off-by: Anton Blanchard
---
drivers/scsi/ipr.c | 11 ++-
1 file changed, 6 insertions(+), 5 deletions(-)
diff --git a/drivers/scsi/ipr.c b/drivers/scsi/ipr.c
index 3aa28bd..15f4575 100644
--- a/drivers/scs
Even though the ipr driver is only used on PCI, convert it
to use the generic DMA API.
Signed-off-by: Anton Blanchard
---
drivers/scsi/ipr.c | 101 +++--
drivers/scsi/ipr.h | 2 +-
2 files changed, 53 insertions(+), 50 deletions(-)
diff --git a/
On Mon, 2014-10-13 at 18:14 +1100, Anton Blanchard wrote:
> Hi Scott,
>
> > Platform code can call limit_zone_pfn() to set appropriate limits
> > for ZONE_DMA and ZONE_DMA32, and dma_direct_alloc_coherent() will
> > select a suitable zone based on a device's mask and the pfn limits
> > that platfo
We can use the simpler dump_stack() instead of
show_stack(current, __get_SP())
Signed-off-by: Anton Blanchard
---
arch/powerpc/platforms/pseries/iommu.c | 11 +--
1 file changed, 5 insertions(+), 6 deletions(-)
diff --git a/arch/powerpc/platforms/pseries/iommu.c
b/arch/powerpc/platform
Michael points out that __get_SP() is a pretty horrible
function name. Let's give it a better name.
Signed-off-by: Anton Blanchard
---
arch/powerpc/include/asm/perf_event.h | 2 +-
arch/powerpc/include/asm/reg.h| 2 +-
arch/powerpc/kernel/irq.c | 2 +-
arch/powerpc/kernel/mis
Li Zhong points out an issue with our current __get_SP()
implementation. If ftrace function tracing is enabled (ie -pg
profiling using _mcount) we spill a stack frame on 64bit all the
time.
If a function calls __get_SP() and later calls a function that is
tail call optimised, we will pop the stack
On Mon, 2014-10-13 at 18:14 +1100, Anton Blanchard wrote:
> Hi Scott,
>
> > Platform code can call limit_zone_pfn() to set appropriate limits
> > for ZONE_DMA and ZONE_DMA32, and dma_direct_alloc_coherent() will
> > select a suitable zone based on a device's mask and the pfn limits
> > that platfo
Hi Scott,
> Platform code can call limit_zone_pfn() to set appropriate limits
> for ZONE_DMA and ZONE_DMA32, and dma_direct_alloc_coherent() will
> select a suitable zone based on a device's mask and the pfn limits
> that platform code has configured.
This patch breaks my POWER8 box:
ipr 0001:08
52 matches
Mail list logo