[PATCH] powerpc/zImage: make the "OF" wrapper support ePAPR boot

2013-09-23 Thread Benjamin Herrenschmidt
This makes the "OF" zImage wrapper (zImage.pseries, zImage.pmac, zImage.maple) work if booted via a flat device-tree (ePAPR boot mode), and thus potentially usable with kexec. Signed-off-by: Benjamin Herrenschmidt --- arch/powerpc/boot/Makefile| 4 ++-- arch/powerpc/boot/epapr-wrapper.c

[PATCH v2] powerpc/irq: Run softirqs off the top of the irq stack

2013-09-23 Thread Benjamin Herrenschmidt
Nowadays, irq_exit() calls __do_softirq() pretty much directly instead of calling do_softirq() which switches to the decicated softirq stack. This has lead to observed stack overflows on powerpc since we call irq_enter() and irq_exit() outside of the scope that switches to the irq stack. This fix

[PATCH] powerpc: Remove ksp_limit on ppc64

2013-09-23 Thread Benjamin Herrenschmidt
We've been keeping that field in thread_struct for a while, it contains the "limit" of the current stack pointer and is meant to be used for detecting stack overflows. It has a few problems however: - First, it was never actually *used* on 64-bit. Set and updated but not actually exploited - W

[PATCH v3 3/3] powerpc/85xx: use one kernel option for all the CoreNet_Generic boards

2013-09-23 Thread Kevin Hao
Currently all these boards use the same machine struct and also select the same kernel options, so it seems a bit of redundant to keep one separate kernel option for each board. Also update the defconfigs according to this change. Signed-off-by: Kevin Hao --- A new patch in v3. arch/powerpc/con

[PATCH v3 2/3] powerpc/85xx: rename the corenet_ds.c to corenet_generic.c

2013-09-23 Thread Kevin Hao
This file is also used by some RDB and QDS boards. So the name seems not so accurate. Rename it to corenet_generic.c. Also update the function names in this file according to the change. Signed-off-by: Kevin Hao --- v3: No change. v2: A new patch in v2. arch/powerpc/platforms/85xx/Makefile

[PATCH v3 0/3] powerpc/85xx: introduce corenet_generic machine

2013-09-23 Thread Kevin Hao
v3: - Update the patch 1 according to Scoot's comment. - Introduce one new patch to combine the board kernel options into one. v2: - Fold the original patch 2 into patch 1. - Update the patch 1 according to Scott and Kumar's comments. - Introduce a new patch to rename the corenet_ds.c to

[PATCH v3 1/3] powerpc/85xx: introduce corenet_generic machine

2013-09-23 Thread Kevin Hao
In the current kernel, the board files for p2041rdb, p3041ds, p4080ds, p5020ds, p5040ds, t4240qds and b4qds are almost the same except the machine name. So this introduces a cornet_generic machine to support all these boards to avoid the code duplication. With these changes the file corenet_ds.h b

Re: [PATCH v2 1/2] powerpc/85xx: introduce corenet_generic machine

2013-09-23 Thread Kevin Hao
On Mon, Sep 23, 2013 at 05:33:58PM -0500, Scott Wood wrote: > On Sun, 2013-09-22 at 15:42 +0800, Kevin Hao wrote: > > In the current kernel, the board files for p2041rdb, p3041ds, p4080ds, > > p5020ds, p5040ds, t4240qds and b4qds are almost the same except the > > machine name. So this introduces a

Re: [PATCH] powerpc/85xx: DTS - re-organize the SPI partitions property

2013-09-23 Thread Scott Wood
On Tue, 2013-09-17 at 06:06 -0500, Hu Mingkai-B21284 wrote: > Scott, > Sorry for the delayed response. > Please fine my comments. > Thanks, > Mingkai > > > -Original Message- > > From: Wood Scott-B07421 > > Sent: Thursday, September 12, 2013 9:16 AM > > To: Hu Mingkai-B21284 > > Cc: Wood S

Re: [PATCH v2 1/2] powerpc/85xx: introduce corenet_generic machine

2013-09-23 Thread Scott Wood
On Sun, 2013-09-22 at 15:42 +0800, Kevin Hao wrote: > In the current kernel, the board files for p2041rdb, p3041ds, p4080ds, > p5020ds, p5040ds, t4240qds and b4qds are almost the same except the > machine name. So this introduces a cornet_generic machine to support > all these boards to avoid the c

Re: [PATCH 5/6 v7] kvm: booke: clear host tlb reference flag on guest tlb invalidation

2013-09-23 Thread Scott Wood
On Mon, 2013-09-23 at 09:12 +0530, Bharat Bhushan wrote: > On booke, "struct tlbe_ref" contains host tlb mapping information > (pfn: for guest-pfn to pfn, flags: attribute associated with this mapping) > for a guest tlb entry. So when a guest creates a TLB entry then > "struct tlbe_ref" is set to p

Re: [PATCH] powerpc/irq: Run softirqs off the top of the irq stack

2013-09-23 Thread Benjamin Herrenschmidt
On Mon, 2013-09-23 at 09:47 -0700, Linus Torvalds wrote: > On Sun, Sep 22, 2013 at 9:35 PM, Benjamin Herrenschmidt > wrote: > > > > This is the "band aid" discussed so far for the stack overflow > > problem for powerpc. > > I don't think it's a "band-aid" in any way, except perhaps in the > sense

Re: [PATCH] powerpc/irq: Run softirqs off the top of the irq stack

2013-09-23 Thread Linus Torvalds
On Sun, Sep 22, 2013 at 9:35 PM, Benjamin Herrenschmidt wrote: > > This is the "band aid" discussed so far for the stack overflow > problem for powerpc. I don't think it's a "band-aid" in any way, except perhaps in the sense that there are certainly other things we can also do in this series (ie

Re: [PATCH 36/51] DMA-API: usb: use dma_set_coherent_mask()

2013-09-23 Thread Russell King - ARM Linux
On Mon, Sep 23, 2013 at 02:27:39PM -0400, Alan Stern wrote: > On Thu, 19 Sep 2013, Russell King wrote: > > > The correct way for a driver to specify the coherent DMA mask is > > not to directly access the field in the struct device, but to use > > dma_set_coherent_mask(). Only arch and bus code s

Re: [PATCH 36/51] DMA-API: usb: use dma_set_coherent_mask()

2013-09-23 Thread Alan Stern
On Thu, 19 Sep 2013, Russell King wrote: > The correct way for a driver to specify the coherent DMA mask is > not to directly access the field in the struct device, but to use > dma_set_coherent_mask(). Only arch and bus code should access this > member directly. > > Convert all direct write acc

Re: [PATCH 1/2][v3] powerpc/fsl-booke: Add initial T104x_QDS board support

2013-09-23 Thread Scott Wood
On Fri, 2013-09-20 at 19:23 -0500, Timur Tabi wrote: > Scott Wood wrote: > > The patch is not "lying". It is describing the board, not what the > > patch supports. This was something you used to constantly tell people > > to do... > > The patch says: > > "DIU supports video at up to 1280x

Re: [PATCH v10 2/3] DMA: Freescale: Add new 8-channel DMA engine device tree nodes

2013-09-23 Thread Stephen Warren
On 09/18/2013 04:15 AM, hongbo.zh...@freescale.com wrote: > From: Hongbo Zhang > > Freescale QorIQ T4 and B4 introduce new 8-channel DMA engines, this patch adds > the device tree nodes for them. > diff --git a/Documentation/devicetree/bindings/powerpc/fsl/dma.txt > b/Documentation/devicetree/b

[PATCH] ppc, vio fix modalias_show return values

2013-09-23 Thread Prarit Bhargava
[2nd try at this ... 1st one seems to have gone AWOL] modalias_show() should return an empty string on error, not -ENODEV. This causes the following false and annoying error: > find /sys/devices -name modalias -print0 | xargs -0 cat >/dev/null cat: /sys/devices/vio/4000/modalias: No such device

[PATCH] ppc, vio fix modalias_show return values

2013-09-23 Thread Prarit Bhargava
modalias_show() should return an empty string on error, not -ENODEV. This causes the following false and annoying error: > find /sys/devices -name modalias -print0 | xargs -0 cat >/dev/null cat: /sys/devices/vio/4000/modalias: No such device cat: /sys/devices/vio/4001/modalias: No such device cat

Re: [PATCH 37/51] DMA-API: usb: use new dma_coerce_mask_and_coherent()

2013-09-23 Thread Nicolas Ferre
On 20/09/2013 00:02, Russell King : Signed-off-by: Russell King --- drivers/usb/chipidea/ci_hdrc_imx.c |4 +--- drivers/usb/dwc3/dwc3-exynos.c |4 +--- drivers/usb/host/ehci-atmel.c |4 +--- For Atmel driver: Acked-by: Nicolas Ferre [..] diff --git a/drivers/usb/ho

Re: [PATCH 36/51] DMA-API: usb: use dma_set_coherent_mask()

2013-09-23 Thread Nicolas Ferre
On 20/09/2013 00:01, Russell King : The correct way for a driver to specify the coherent DMA mask is not to directly access the field in the struct device, but to use dma_set_coherent_mask(). Only arch and bus code should access this member directly. Convert all direct write accesses to using t

[PATCH] powerpc/kernel: fix endian issue in rtas_pci

2013-09-23 Thread Cédric Le Goater
Signed-off-by: Cédric Le Goater --- arch/powerpc/kernel/rtas_pci.c |6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/arch/powerpc/kernel/rtas_pci.c b/arch/powerpc/kernel/rtas_pci.c index 6e7b7cd..7d4c717 100644 --- a/arch/powerpc/kernel/rtas_pci.c +++ b/arch/powerpc/ker

Re: [alsa-devel] [PATCH 43/51] DMA-API: dma: edma.c: no need to explicitly initialize DMA masks

2013-09-23 Thread Russell King - ARM Linux
On Mon, Sep 23, 2013 at 03:55:33PM +0530, Vinod Koul wrote: > On Fri, Sep 20, 2013 at 12:15:39AM +0100, Russell King wrote: > > register_platform_device_full() can setup the DMA mask provided the > > appropriate member is set in struct platform_device_info. So lets > > make that be the case. This

Re: [alsa-devel] [PATCH 24/51] DMA-API: dma: pl330: add dma_set_mask_and_coherent() call

2013-09-23 Thread Vinod Koul
On Sat, Sep 21, 2013 at 09:00:00PM +0100, Russell King - ARM Linux wrote: > On Fri, Sep 20, 2013 at 07:26:27PM +0200, Heiko Stübner wrote: > > Am Donnerstag, 19. September 2013, 23:49:01 schrieb Russell King: > > > The DMA API requires drivers to call the appropriate dma_set_mask() > > > functions

Re: [alsa-devel] [PATCH 43/51] DMA-API: dma: edma.c: no need to explicitly initialize DMA masks

2013-09-23 Thread Vinod Koul
On Fri, Sep 20, 2013 at 12:15:39AM +0100, Russell King wrote: > register_platform_device_full() can setup the DMA mask provided the > appropriate member is set in struct platform_device_info. So lets > make that be the case. This avoids a direct reference to the DMA > masks by this driver. > > S

Re: [alsa-devel] [PATCH 23/51] DMA-API: dma: pl08x: add dma_set_mask_and_coherent() call

2013-09-23 Thread Vinod Koul
On Thu, Sep 19, 2013 at 10:48:01PM +0100, Russell King wrote: > The DMA API requires drivers to call the appropriate dma_set_mask() > functions before doing any DMA mapping. Add this required call to > the AMBA PL08x driver. > > Signed-off-by: Russell King Acked-by: Vinod Koul ~Vinod > --- >

Re: [PATCH] powerpc/irq: Run softirqs off the top of the irq stack

2013-09-23 Thread Benjamin Herrenschmidt
On Mon, 2013-09-23 at 17:56 +1000, Stephen Rothwell wrote: > Hi Ben, > > On Mon, 23 Sep 2013 14:35:58 +1000 Benjamin Herrenschmidt > wrote: > > > > diff --git a/arch/powerpc/kernel/irq.c b/arch/powerpc/kernel/irq.c > > index c69440c..0c9646f 100644 > > --- a/arch/powerpc/kernel/irq.c > > +++ b/a

Re: [PATCH V2 0/6] perf: New conditional branch filter

2013-09-23 Thread Anshuman Khandual
On 09/21/2013 12:25 PM, Stephane Eranian wrote: > On Tue, Sep 10, 2013 at 4:06 AM, Michael Ellerman > wrote: >> > >> > On Fri, 2013-08-30 at 09:54 +0530, Anshuman Khandual wrote: >>> > > This patchset is the re-spin of the original branch stack sampling >>> > > patchset which introduced new

RE: [PATCH 2/2] powerpc: make ftrace endian-safe.

2013-09-23 Thread David Laight
> --- a/arch/powerpc/kernel/ftrace.c > +++ b/arch/powerpc/kernel/ftrace.c > @@ -174,7 +174,11 @@ __ftrace_make_nop(struct module *mod, > > pr_devel(" %08x %08x\n", jmp[0], jmp[1]); > > +#ifdef __LITTLE_ENDIAN__ > + ptr = ((unsigned long)jmp[1] << 32) + jmp[0]; > +#else > ptr = ((u

RE: [PATCH 1/2] powerpc: make kernel module helper endian-safe.

2013-09-23 Thread David Laight
> --- a/arch/powerpc/kernel/module_64.c > +++ b/arch/powerpc/kernel/module_64.c > @@ -62,6 +62,16 @@ struct ppc64_stub_entry > r2) into the stub. */ > static struct ppc64_stub_entry ppc64_stub = > { .jump = { > +#ifdef __LITTLE_ENDIAN__ > + 0x00, 0x00, 0x82, 0x3d, /* addis r12,r2, */ >

Re: [PATCH v2 07/10] of/irq: Propagate errors in of_irq_to_resource_table()

2013-09-23 Thread Thierry Reding
On Sun, Sep 22, 2013 at 04:08:26PM -0500, Rob Herring wrote: > On Wed, Sep 18, 2013 at 8:24 AM, Thierry Reding > wrote: > > Now that all helpers return precise error codes, this function can > > propagate these errors to the caller properly. > > > > Signed-off-by: Thierry Reding > > --- > > Chang

Re: [PATCH v2 04/10] irqdomain: Return errors from irq_create_of_mapping()

2013-09-23 Thread Thierry Reding
On Sun, Sep 22, 2013 at 04:14:43PM -0500, Rob Herring wrote: > On Wed, Sep 18, 2013 at 8:24 AM, Thierry Reding > wrote: > > Instead of returning 0 for all errors, allow the precise error code to > > be propagated. This will be used in subsequent patches to allow further > > propagation of error co

Re: [PATCH] powerpc/irq: Run softirqs off the top of the irq stack

2013-09-23 Thread Stephen Rothwell
Hi Ben, On Mon, 23 Sep 2013 14:35:58 +1000 Benjamin Herrenschmidt wrote: > > diff --git a/arch/powerpc/kernel/irq.c b/arch/powerpc/kernel/irq.c > index c69440c..0c9646f 100644 > --- a/arch/powerpc/kernel/irq.c > +++ b/arch/powerpc/kernel/irq.c > @@ -443,46 +443,7 @@ void migrate_irqs(void) > >

Device tree node for Freescale Gianfar PTP reference clock source selection

2013-09-23 Thread Aida Mynzhasova
Hi, Currently, Freescale Gianfar PTP reference clock source is determined through hard-coded value in gianfar_ptp driver. I don't think that recompilation of the entire module (or even worse - the kernel) is a god idea when we want to change one clock source to another. So, I want to add new