[PATCH 1/1] [v3] Add support 2 SATA ports for Maui and change filename from sata_dwc_460ex.c to sata_dwc_4xx.c

2012-04-05 Thread Thang Q. Nguyen
Signed-off-by: Thang Q. Nguyen --- Changes for v2: - Use git rename feature to change the driver to the newname and for easier review. Changes for v3: - Remove materials not related to 2 SATA ports support. They will be added in another patches. drivers/ata/Mak

RE: [RFC] powerpc/fsl-pci: Document the "fsl,has-isa" property for Freescale PCI

2012-04-05 Thread Jia Hongtao-B38951
> -Original Message- > From: Kumar Gala [mailto:ga...@kernel.crashing.org] > Sent: Wednesday, April 04, 2012 9:09 PM > To: Jia Hongtao-B38951 > Cc: linuxppc-dev@lists.ozlabs.org; Li Yang-R58472; devicetree- > disc...@lists.ozlabs.org > Subject: Re: [RFC] powerpc/fsl-pci: Document the "fsl,

Re: [PATCH 03/12] powerpc: Rework runlatch code

2012-04-05 Thread Andreas Schwab
Benjamin Herrenschmidt writes: > Have you verified that you can "fix" it with reverting just the above > patch ? Yes. (Currently running 3.4-rc1 with fe1952f reverted and irq_set_irq_type removed from mpic_host_map.) Andreas. -- Andreas Schwab, sch...@linux-m68k.org GPG Key fingerprint = 58C

Re: [PATCH 03/12] powerpc: Rework runlatch code

2012-04-05 Thread Benjamin Herrenschmidt
On Thu, 2012-04-05 at 23:38 +0200, Andreas Schwab wrote: > Benjamin Herrenschmidt writes: > > > This moves the inlines into system.h and changes the runlatch > > code to use the thread local flags (non-atomic) rather than > > the TIF flags (atomic) to keep track of the latch state. > > > > The co

Re: [PATCH v5 06/27] irq_domain/powerpc: eliminate irq_map; use irq_alloc_desc() instead

2012-04-05 Thread Andreas Schwab
Grant Likely writes: > Can you attach console output logs for each of configs above and also > with NR_IRQS=128? That might give me some clues as to which specific > code is causing the issues. It really looks like the issue starts when irq_expand_nr_irqs is called the first time to make nr_irq

Re: [PATCH 03/12] powerpc: Rework runlatch code

2012-04-05 Thread Andreas Schwab
Benjamin Herrenschmidt writes: > This moves the inlines into system.h and changes the runlatch > code to use the thread local flags (non-atomic) rather than > the TIF flags (atomic) to keep track of the latch state. > > The code to turn it back on in an asynchronous interrupt is > now simplified

Re: kilauea compilation breaks with v3.3 kernel and ELDK 4.2

2012-04-05 Thread Wolfgang Denk
Dear Stephen Rothwell, In message <20120405100228.9ca940aa4739e81540bb2...@canb.auug.org.au> you wrote: > > > ELDK 4.2 is based on gcc version 4.2.2 / binutils version 2.17.50.0.12 > > 20070128. This is obviously to old for this code. I do not see an > > actual problem with that - nobody can exp

[PATCH 3/4 v2] powerpc: Better scheduling of CR save code in system call path

2012-04-05 Thread Anton Blanchard
At the moment system call entry looks like: crclr so ... mfcrr9 ... std r9,_CCR(r1) commit bd19c8994a82 ([POWERPC] system call micro optimisation) put some space between the crclr and mfcr in order to avoid a stall. There is still a stall seen between the mfcr and std. We can avoid th

Re: [PATCH v5 06/27] irq_domain/powerpc: eliminate irq_map; use irq_alloc_desc() instead

2012-04-05 Thread Andreas Schwab
Benjamin Herrenschmidt writes: > Hrm, odd.. I'll dbl check today that I didn't b0rk something in my test > (like loading the wrong kernel :-) I'll also try with your config. Do you have anything that triggers loading the sound drivers? That's exactly the point where the irq problems start. And

Re: [PATCH v5 06/27] irq_domain/powerpc: eliminate irq_map; use irq_alloc_desc() instead

2012-04-05 Thread Andreas Schwab
Grant Likely writes: > I bet it is NR_IRQS related. You have SPARSE_IRQ enabled, which means > the maximum number of irq_descs is IRQ_BITMAP_BITS (NR_IRQS + 8192). The actual definition uses NR_IRQS + 8196. Guess that's a typo. (Does it really make sense to add NR_IRQS here?) > diff --git a/