Re: [RFC][PATCH 1/2] uio: allow drivers to override the pgprot for mmap

2011-10-28 Thread Greg KH
On Fri, Oct 28, 2011 at 11:48:12PM +0200, Hans J. Koch wrote: > On Fri, Oct 28, 2011 at 10:50:29AM -0500, Kumar Gala wrote: > > For some devices, the default behavior of pgprot_noncached() is not > > appropriate for all of its mappable regions. This provides a means for > > the kernel side of the U

Re: Kernel hang on PS3 with SMP

2011-10-28 Thread Geoff Levand
Hi, On Thu, 2011-10-27 at 18:17 -0700, Geoff Levand wrote: > I verified that indeed 317f394160e9beb97d19a84c39b7e5eb3d7815a8 > 'sched: Move the second half of ttwu() to the remote cpu' introduces > the hang. After some more digging I found that it seems a short while after startup ps3_smp_messag

Re: [RFC][PATCH 1/2] uio: allow drivers to override the pgprot for mmap

2011-10-28 Thread Hans J. Koch
On Fri, Oct 28, 2011 at 10:50:29AM -0500, Kumar Gala wrote: > For some devices, the default behavior of pgprot_noncached() is not > appropriate for all of its mappable regions. This provides a means for > the kernel side of the UIO driver to override the flags without having > to implement its own

Re: [RFC][PATCH 2/2] Example to show use of uio pgprot

2011-10-28 Thread Hans J. Koch
On Fri, Oct 28, 2011 at 10:50:30AM -0500, Kumar Gala wrote: A few remarks below. > +static void __init dpa_uio_portal_init(struct dpa_uio_portal *p, > + const struct dpa_uio_class *c) This can't be "void". You have to return apropiate errors. > +{ > + struct dpa_

RFC: ESR_I/DLK processing

2011-10-28 Thread Jimi Xenidis
arch/powerpc/kernel/head_fsl_booke.S has the following code: > /* Data Storage Interrupt */ > START_EXCEPTION(DataStorage) > NORMAL_EXCEPTION_PROLOG > mfspr r5,SPRN_ESR /* Grab the ESR, save it, pass arg3 */ > stw r5,_ESR(r11) > mfspr r4,SPRN_

Re: [1/4] powerpc: Revert show_regs() define for readability

2011-10-28 Thread Jimi Xenidis
On Oct 5, 2011, at 9:53 PM, Kumar Gala wrote: > We had an existing ifdef for 4xx & BOOKE processors that got changed to > CONFIG_PPC_ADV_DEBUG_REGS. The define has nothing to do with > CONFIG_PPC_ADV_DEBUG_REGS. The define really should be: > > #if defined(CONFIG_4xx) || defined(CONFIG_BOOKE)

Re: [4/4] powerpc/booke: Re-organize debug code

2011-10-28 Thread Jimi Xenidis
On Oct 5, 2011, at 9:53 PM, Kumar Gala wrote: > * set_dabr/do_dabr are no longer used when CNFIG_PPC_ADV_DEBUG_REGS is set > refactor code a bit such that we only build the dabr code for > !CONFIG_PPC_ADV_DEBUG_REGS and removed some CONFIG_PPC_ADV_DEBUG_REGS > code in set_dabr that would never

Re: [RFC][PATCH 2/2] Example to show use of uio pgprot

2011-10-28 Thread Kumar Gala
On Oct 28, 2011, at 11:37 AM, Greg KH wrote: > On Fri, Oct 28, 2011 at 10:50:30AM -0500, Kumar Gala wrote: >> --- >> drivers/uio/uio_dpa.c | 200 >> + >> 1 files changed, 200 insertions(+), 0 deletions(-) >> create mode 100644 drivers/uio/uio_dpa.c

Re: [RFC][PATCH 2/2] Example to show use of uio pgprot

2011-10-28 Thread Greg KH
On Fri, Oct 28, 2011 at 10:50:30AM -0500, Kumar Gala wrote: > --- > drivers/uio/uio_dpa.c | 200 > + > 1 files changed, 200 insertions(+), 0 deletions(-) > create mode 100644 drivers/uio/uio_dpa.c You do realize this does not build, right? thank

[RFC][PATCH 2/2] Example to show use of uio pgprot

2011-10-28 Thread Kumar Gala
--- drivers/uio/uio_dpa.c | 200 + 1 files changed, 200 insertions(+), 0 deletions(-) create mode 100644 drivers/uio/uio_dpa.c diff --git a/drivers/uio/uio_dpa.c b/drivers/uio/uio_dpa.c new file mode 100644 index 000..19360f2 --- /dev/null +++

[RFC][PATCH 1/2] uio: allow drivers to override the pgprot for mmap

2011-10-28 Thread Kumar Gala
For some devices, the default behavior of pgprot_noncached() is not appropriate for all of its mappable regions. This provides a means for the kernel side of the UIO driver to override the flags without having to implement its own full mmap callback. Signed-off-by: Kumar Gala Signed-off-by: Geoff

[PATCH] NUMA topology support for powernv

2011-10-28 Thread Dipankar Sarma
This patch adds support for numa topology on powernv platforms running OPAL formware. It checks for the type of platform at run time and sets the affinity form correctly so that NUMA topology can be discovered correctly. Signed-off-by: Dipankar Sarma --- arch/powerpc/mm/numa.c | 24 ++

Re: [PATCH 2/2] powerpc/fsl-pci: Only scan PCI bus if configured as a host

2011-10-28 Thread Kumar Gala
On Oct 28, 2011, at 3:03 AM, Jia Hongtao wrote: > If we're an agent/end-point or fsl_add_bridge doesn't succeed due to some > resource failure we should not scan the PCI bus. We change fsl_add_bridge() > to return -ENODEV in the case we're an agent/end-point. > > Signed-off-by: Jia Hongtao > Si

[PATCH SDK1.1 ] Do not hide resource for pci/pcie when configured as Agent/EP

2011-10-28 Thread Jia Hongtao
From: Jason Jin Current pci/pcie init code will hide the pci/pcie host resource. But did not judge it is host/RC or agent/EP. If configured as agent/EP, we should avoid hiding its resource in the host side. In PCI system, the Programing Interface can be used to judge the host/agent status: Progr

[PATCH] Do not hide resource for pci/pcie when configured as Agent/EP

2011-10-28 Thread Jia Hongtao
From: Jason Jin Current pci/pcie init code will hide the pci/pcie host resource. But did not judge it is host/RC or agent/EP. If configured as agent/EP, we should avoid hiding its resource in the host side. In PCI system, the Programing Interface can be used to judge the host/agent status: Progr

[PATCH 2/2] powerpc/fsl-pci: Only scan PCI bus if configured as a host

2011-10-28 Thread Jia Hongtao
If we're an agent/end-point or fsl_add_bridge doesn't succeed due to some resource failure we should not scan the PCI bus. We change fsl_add_bridge() to return -ENODEV in the case we're an agent/end-point. Signed-off-by: Jia Hongtao Signed-off-by: Li Yang --- arch/powerpc/sysdev/fsl_pci.c | 1

[PATCH 1/2] Unify pci/pcie initialization code

2011-10-28 Thread Jia Hongtao
In previous version pci/pcie initialization is in platform code which Initialize PCI bridge base on EP/RC or host/agent settings. We unified pci/pcie initialization as common APIs named fsl_pci_setup which can be called by platform code. Signed-off-by: Jia Hongtao Signed-off-by: Li Yang --- We o