If firmware does not setup the "GPS Port Configuration Register"
and the "CDM 48MHz Fractional Divider Configuration Register",
it can be corrected through DTS.
Signed-off-by: Heiko Schocher
cc: devictree-disc...@lists.ozlabs.org
cc: linuxppc-dev@lists.ozlabs.org
cc: Grant Likely
cc: Wolfgang De
On 04/17/2011 11:12 PM, Rafael J. Wysocki wrote:
> From: Rafael J. Wysocki
>
> Convert some MIPS architecture's code to using struct syscore_ops
> objects for power management instead of sysdev classes and sysdevs.
>
> This simplifies the code and reduces the kernel's memory footprint.
> It also
On Mon, 2011-04-18 at 17:30 -0500, Kumar Gala wrote:
> > On Mon, 2011-04-18 at 07:42 -0500, Kumar Gala wrote:
> >> Let's rename this function to something 'linear_map'. As on FSL
> >> Book-E 64 we do things a bit differently and have more covered in
> >> linear map than 1G
> >
> > It's not quite
On Apr 18, 2011, at 4:41 PM, Benjamin Herrenschmidt wrote:
> On Mon, 2011-04-18 at 07:42 -0500, Kumar Gala wrote:
>> Let's rename this function to something 'linear_map'. As on FSL
>> Book-E 64 we do things a bit differently and have more covered in
>> linear map than 1G
>
> It's not quite line
> >> Seems like this should have a MMU Feature bit or something for A2.
> >
> > Too early. We haven't detected the CPU and are establishing the initial
> > TLB entry here.
>
> How about wrapping with CONFIG_PPC_A2
YUCK :-)
> > Any reason why that wouldn't work on something else anyways ?
>
>
On Apr 18, 2011, at 4:40 PM, Benjamin Herrenschmidt wrote:
> On Mon, 2011-04-18 at 07:43 -0500, Kumar Gala wrote:
>> On Apr 15, 2011, at 3:32 AM, Michael Ellerman wrote:
>>
>>> From: Benjamin Herrenschmidt
>>>
>>> An erratum on A2 can lead to the bolted entry we insert for the linear
>>> mappi
On Monday, April 18, 2011, Mike Frysinger wrote:
> On Sun, Apr 17, 2011 at 17:11, Rafael J. Wysocki wrote:
> > Convert some Blackfin architecture's code to using struct syscore_ops
> > objects for power management instead of sysdev classes and sysdevs.
> >
> > This simplifies the code and reduces t
On Mon, 2011-04-18 at 07:42 -0500, Kumar Gala wrote:
> Let's rename this function to something 'linear_map'. As on FSL
> Book-E 64 we do things a bit differently and have more covered in
> linear map than 1G
It's not quite linear_map. It's whatever can be accessed without taking
exceptions. IE. W
On Mon, 2011-04-18 at 07:43 -0500, Kumar Gala wrote:
> On Apr 15, 2011, at 3:32 AM, Michael Ellerman wrote:
>
> > From: Benjamin Herrenschmidt
> >
> > An erratum on A2 can lead to the bolted entry we insert for the linear
> > mapping being evicted, to avoid that write the bolted entry to way 3.
On Mon, 2011-04-18 at 07:46 -0500, Kumar Gala wrote:
>
> Can this be moved into kernel/cpu_setup_a2.S. This and the debug
> patch that follows are bit ugly.
Well, the code per-se is not really A2 specific... the labels and
comments are :-)
Cheers,
Ben.
On Mon, 2011-04-18 at 08:30 +0200, Richard Cochran wrote:
> This patch adds support for the PTP clock found on the DP83640.
> The basic clock operations and one external time stamp have
> been implemented.
[...]
> --- /dev/null
> +++ b/drivers/net/phy/dp83640.c
[...]
> +static int match(struct sk_b
On Mon, 2011-04-18 at 08:29 +0200, Richard Cochran wrote:
> This patch adds a driver for the hardware time stamping unit found on the
> IXP465. The basic clock operations and an external trigger are implemented.
[...]
> --- a/drivers/net/arm/ixp4xx_eth.c
> +++ b/drivers/net/arm/ixp4xx_eth.c
[...]
>
On Monday, April 18, 2011, Ralf Baechle wrote:
> This patch breaks the Alchemy kernel compile; below patch on top of it fixes
> that again.
>
> Signed-off-by: Ralf Baechle
Thanks! If you don't mind, I'd like to fold your patch into [10/14].
Rafael
> ---
> arch/mips/alchemy/common/irq.c |
On 18/04/2011 07:38 μμ, Stratos Psomadakis wrote:
> variable 'old' is set but not used, which results to a warning
> (-Werror=unused-but-set-variable) when compiling with gcc-4.6.0, and
> subsequent
> build failure.
> Remove the variable 'old', since it's not used anyway.
Something went wrong with
Signed-off-by: Stratos Psomadakis
--
Stratos Psomadakis
___
Linuxppc-dev mailing list
Linuxppc-dev@lists.ozlabs.org
https://lists.ozlabs.org/listinfo/linuxppc-dev
variable 'old' is set but not used, which results to a warning
(-Werror=unused-but-set-variable) when compiling with gcc-4.6.0, and subsequent
build failure.
Remove the variable 'old', since it's not used anyway.
---
arch/powerpc/include/asm/pgtable-ppc64.h | 13 ++---
1 files changed,
The build error was reported at the Gentoo Bugzilla [1].
When compiling with gcc-4.6.0, a build error occurs:
"variable ‘old’ set but not used [-Werror=unused-but-set-variable]
cc1: all warnings being treated as errors"
This patch removes the unnecessary assignments to the variable, which cause
On Apr 15, 2011, at 3:32 AM, Michael Ellerman wrote:
> diff --git a/arch/powerpc/kernel/exceptions-64e.S
> b/arch/powerpc/kernel/exceptions-64e.S
> index ab5c4dd..8e5d2c1 100644
> --- a/arch/powerpc/kernel/exceptions-64e.S
> +++ b/arch/powerpc/kernel/exceptions-64e.S
> @@ -864,6 +864,20 @@ have_
On Apr 15, 2011, at 3:32 AM, Michael Ellerman wrote:
> From: Benjamin Herrenschmidt
>
> An erratum on A2 can lead to the bolted entry we insert for the linear
> mapping being evicted, to avoid that write the bolted entry to way 3.
>
> Signed-off-by: Benjamin Herrenschmidt
> Signed-off-by: Mic
On Apr 15, 2011, at 3:32 AM, Michael Ellerman wrote:
> From: Michael Ellerman
>
> On BOOK3E we don't have an SLB 0, but the equivalent concept is the
> bolted entry mapping the kernel. Currently this is a 1G entry, so
> for now hardcode that. This will probably need to be reworked in
> future.
On Apr 15, 2011, at 3:32 AM, Michael Ellerman wrote:
> From: Michael Ellerman
>
> Where they belong with all the others. Remove SMT which may not be
> true for all BOOK3E parts.
>
> Currently the FTRS_POSSIBLE & FTRS_ALWAYS are defined for 64 or 32 bit.
> Now that we have BOOK3E we need to spl
This patch breaks the Alchemy kernel compile; below patch on top of it fixes
that again.
Signed-off-by: Ralf Baechle
---
arch/mips/alchemy/common/irq.c |4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
Index: linux-mips/arch/mips/alchemy/common/irq.c
On Sun, 2011-04-17 at 23:06 +0200, Rafael J. Wysocki wrote:
> From: Rafael J. Wysocki
>
> Device suspend/resume infrastructure is used not only by the suspend
> and hibernate code in kernel/power, but also by , APM, Xen and the
> kexec jump feature. However, commit 40dc166cb5dddbd36aa4ad11c03915
On Monday 18 April 2011, Arnd Bergmann wrote:
> On Monday 18 April 2011, Richard Cochran wrote:
> > On Mon, Apr 18, 2011 at 08:56:03AM +0200, Arnd Bergmann wrote:
> > > On Monday 18 April 2011, Richard Cochran wrote:
> > > > +
> > > > + lo = __raw_readl(®s->channel[ch].src_uuid_lo);
> > > > +
On Monday 18 April 2011, Richard Cochran wrote:
> On Mon, Apr 18, 2011 at 08:56:03AM +0200, Arnd Bergmann wrote:
> > On Monday 18 April 2011, Richard Cochran wrote:
> > > +
> > > + lo = __raw_readl(®s->channel[ch].src_uuid_lo);
> > > + hi = __raw_readl(®s->channel[ch].src_uuid_hi);
> >
Also, I forgot to add Krzysztof's ack to the commit message, but he
did ack V12.
Thanks,
Richard
___
Linuxppc-dev mailing list
Linuxppc-dev@lists.ozlabs.org
https://lists.ozlabs.org/listinfo/linuxppc-dev
On Mon, Apr 18, 2011 at 08:56:03AM +0200, Arnd Bergmann wrote:
> On Monday 18 April 2011, Richard Cochran wrote:
> > +
> > + lo = __raw_readl(®s->channel[ch].src_uuid_lo);
> > + hi = __raw_readl(®s->channel[ch].src_uuid_hi);
> > +
>
> I guess you should use readl(), not __raw_readl() h
On Monday 18 April 2011, Richard Cochran wrote:
> This patch adds an infrastructure for hardware clocks that implement
> IEEE 1588, the Precision Time Protocol (PTP). A class driver offers a
> registration method to particular hardware clock drivers. Each clock is
> presented as a standard POSIX cl
28 matches
Mail list logo