Re: [Patch v2] kexec: increase max of kexec segments and use dynamic allocation

2010-07-28 Thread Cong Wang
On 07/27/10 18:00, Milton Miller wrote: [ Added kexec at lists.infradead.org and linuxppc-dev@lists.ozlabs.org ] Currently KEXEC_SEGMENT_MAX is only 16 which is too small for machine with many memory ranges. When hibernate on a machine with disjoint memory we do need one segment for each memo

[PATCH 3/6] leds: Remove owner field from attribute initialization in bd2802 driver

2010-07-28 Thread Guenter Roeck
Signed-off-by: Guenter Roeck --- drivers/leds/leds-bd2802.c |4 +--- 1 files changed, 1 insertions(+), 3 deletions(-) diff --git a/drivers/leds/leds-bd2802.c b/drivers/leds/leds-bd2802.c index 5dcdf9d..19dc4b6 100644 --- a/drivers/leds/leds-bd2802.c +++ b/drivers/leds/leds-bd2802.c @@ -351,7

[PATCH 2/6] scsi: Remove owner field from attribute initialization in ARCMSR driver

2010-07-28 Thread Guenter Roeck
Signed-off-by: Guenter Roeck --- drivers/scsi/arcmsr/arcmsr_attr.c |3 --- 1 files changed, 0 insertions(+), 3 deletions(-) diff --git a/drivers/scsi/arcmsr/arcmsr_attr.c b/drivers/scsi/arcmsr/arcmsr_attr.c index 07fdfe5..a4e04c5 100644 --- a/drivers/scsi/arcmsr/arcmsr_attr.c +++ b/drivers/

[PATCH 6/6] Remove owner field from sysfs struct attribute

2010-07-28 Thread Guenter Roeck
Signed-off-by: Guenter Roeck --- include/linux/sysfs.h |6 -- 1 files changed, 0 insertions(+), 6 deletions(-) diff --git a/include/linux/sysfs.h b/include/linux/sysfs.h index f2694eb..880fa1a 100644 --- a/include/linux/sysfs.h +++ b/include/linux/sysfs.h @@ -22,14 +22,8 @@ struct kobjec

[PATCH 5/6] powerpc/pci: Remove owner field from attribute initialization in PCI bridge init

2010-07-28 Thread Guenter Roeck
Signed-off-by: Guenter Roeck --- arch/powerpc/sysdev/mv64x60_pci.c |1 - 1 files changed, 0 insertions(+), 1 deletions(-) diff --git a/arch/powerpc/sysdev/mv64x60_pci.c b/arch/powerpc/sysdev/mv64x60_pci.c index 198f288..77bb3f4 100644 --- a/arch/powerpc/sysdev/mv64x60_pci.c +++ b/arch/power

[PATCH 1/6] scsi: Remove owner field from attribute initialization in LPFC driver

2010-07-28 Thread Guenter Roeck
Signed-off-by: Guenter Roeck --- drivers/scsi/lpfc/lpfc_attr.c |1 - 1 files changed, 0 insertions(+), 1 deletions(-) diff --git a/drivers/scsi/lpfc/lpfc_attr.c b/drivers/scsi/lpfc/lpfc_attr.c index bf33b31..8f89edf 100644 --- a/drivers/scsi/lpfc/lpfc_attr.c +++ b/drivers/scsi/lpfc/lpfc_attr

[PATCH 0/6] Remove owner field from sysfs attribute structure

2010-07-28 Thread Guenter Roeck
The following comment is found in include/linux/sysfs.h: /* FIXME * The *owner field is no longer used. * x86 tree has been cleaned up. The owner * attribute is still left for other arches. */ As it turns out, the *owner field is (again?) initialized in several modules, suggest

[PATCH v2] powerpc/kexec: Fix orphaned offline CPUs across kexec

2010-07-28 Thread Matt Evans
When CPU hotplug is used, some CPUs may be offline at the time a kexec is performed. The subsequent kernel may expect these CPUs to be already running, and will declare them stuck. On pseries, there's also a soft-offline (cede) state that CPUs may be in; this can also cause problems as the kexece

Re: [PATCH 0/2 v1.04] Add support for DWC OTG driver.

2010-07-28 Thread Greg KH
On Wed, Jul 28, 2010 at 05:28:41PM -0700, Fushen Chen wrote: > [PATCH 1/2 v1.04] > 1. License information is under clarification. What do you mean by this? I fail to see a change here, why just repost the same code again? What is being done to resolve the issues I outlined previously? greg k-h

[PATCH 0/2 v1.04] Add support for DWC OTG driver.

2010-07-28 Thread Fushen Chen
[PATCH 1/2 v1.04] 1. License information is under clarification. 2. Difference in v1.04 patch. Added drivers/usb/dwc_otg/dwc_otg_param.c to [PATCH 1/2 v1.03] patch. Coding style: Added space line after declaration. drivers/usb/dwc_otg/Kconfig:

Re: [PATCH 2/3] USB: add of_platform glue driver for FSL USB DR controller

2010-07-28 Thread Greg KH
On Wed, Jul 28, 2010 at 12:14:14PM -0600, Grant Likely wrote: > On Wed, Jul 28, 2010 at 5:58 AM, Anatolij Gustschin wrote: > > Hi Grant, > > > > On Wed, 28 Jul 2010 02:16:08 -0600 > > Grant Likely wrote: > > > >> On Thu, Jul 22, 2010 at 10:25 AM, Anatolij Gustschin wrote: > >> > The driver creat

Re: [PATCH 2/3] USB: add of_platform glue driver for FSL USB DR controller

2010-07-28 Thread Grant Likely
On Wed, Jul 28, 2010 at 5:58 AM, Anatolij Gustschin wrote: > Hi Grant, > > On Wed, 28 Jul 2010 02:16:08 -0600 > Grant Likely wrote: > >> On Thu, Jul 22, 2010 at 10:25 AM, Anatolij Gustschin wrote: >> > The driver creates platform devices based on the information >> > from USB nodes in the flat d

Re: Please pull my perf.git urgent branch

2010-07-28 Thread Kumar Gala
On Jul 27, 2010, at 11:47 PM, Paul Mackerras wrote: > On Tue, Jul 27, 2010 at 11:28:54AM -0500, Scott Wood wrote: > >> Doesn't the setting of .period need to be maintained (it is in the other >> powerpc perf_event implementation that this is derived from)? > > Gah, yes it does. > >> I don't se

Re: [PATCH] powerpc: Replace hardcoded offset by BREAK_INSTR_SIZE

2010-07-28 Thread Jason Wessel
On 07/28/2010 04:18 AM, Michal Simek wrote: > kgdb_handle_breakpoint checks the first arch_kgdb_breakpoint > which is not known by gdb that's why is necessary jump over > it. The jump lenght is equal to BREAK_INSTR_SIZE that's > why is cleaner to use defined macro instead of hardcoded > non-describ

Re: Memory Mapping Buffers smaller than page size?

2010-07-28 Thread Simon Richter
Hi, On Wed, Jul 28, 2010 at 06:44:10PM +0530, Ravi Gupta wrote: > I am new to linux device drivers development. I have created 16 buffers of > size 256 bytes each(using kmalloc()) in my device driver code. I want to > memory map these buffers to user space. Now is it possible to memory map > thes

Re: [PATCH 6/8] v3 Update the node sysfs code

2010-07-28 Thread Brian King
On 07/19/2010 10:57 PM, Nathan Fontenot wrote: > Index: linux-2.6/include/linux/node.h > === > --- linux-2.6.orig/include/linux/node.h 2010-07-19 21:10:25.0 > -0500 > +++ linux-2.6/include/linux/node.h2010-07-19 21:1

Memory Mapping Buffers smaller than page size?

2010-07-28 Thread Ravi Gupta
Hi, I am new to linux device drivers development. I have created 16 buffers of size 256 bytes each(using kmalloc()) in my device driver code. I want to memory map these buffers to user space. Now is it possible to memory map these buffer(16*256 = 4096 = 1 page on 32 bit linux) into a single page i

Re: [PATCH 2/3] USB: add of_platform glue driver for FSL USB DR controller

2010-07-28 Thread Anatolij Gustschin
Hi Grant, On Wed, 28 Jul 2010 02:16:08 -0600 Grant Likely wrote: > On Thu, Jul 22, 2010 at 10:25 AM, Anatolij Gustschin wrote: > > The driver creates platform devices based on the information > > from USB nodes in the flat device tree. This is the replacement > > for old arch fsl_soc usb code r

[GIT/PATCH 0/4] Do not use IRQF_TIMER for non timer interrupts

2010-07-28 Thread Ian Campbell
Hi Thomas, A small number of users of IRQF_TIMER are using it for the implied no suspend behaviour on interrupts which are not timer interrupts. Therefore the following series renames the IRQF_TIMER flag to IRQF_NO_SUSPEND and updates the users which are not timer interrupts to use the new name.

[PATCH 1/4] irq: rename IRQF_TIMER to IRQF_NO_SUSPEND

2010-07-28 Thread Ian Campbell
Continue to provide IRQF_TIMER as an alias to IRQF_NO_SUSPEND since I think it is worth preserving the nice self-documenting name (where it is used appropriately). It also avoid needing to patch all the many users who are using the flag for an actual timer interrupt. Signed-off-by: Ian Campbell C

[PATCH 3/4] powerpc: Use IRQF_NO_SUSPEND not IRQF_TIMER for non-timer interrupts

2010-07-28 Thread Ian Campbell
kw_i2c_irq and via_pmu_interrupt are not timer interrupts and therefore should not use IRQF_TIMER. Use the recently introduced IRQF_NO_SUSPEND instead since that is the actual desired behaviour. Signed-off-by: Ian Campbell Cc: Thomas Gleixner Cc: Benjamin Herrenschmidt Cc: Paul Mackerras Cc: G

RE: [PATCH 3/3] mmc: Add ESDHC weird register workaround

2010-07-28 Thread Zang Roy-R61911
> -Original Message- > From: Anton Vorontsov [mailto:cbouatmai...@gmail.com] > Sent: Wednesday, July 28, 2010 16:03 PM > To: Zang Roy-R61911 > Cc: linux-mmc-appro...@vger.kernel.org; linuxppc-...@ozlabs.org > Subject: Re: [PATCH 3/3] mmc: Add ESDHC weird register workaround > > On Wed,

Problems using UART on MPC5200

2010-07-28 Thread Sven Batzer
Hello, I am using a PowerPC MPC5200 from Freescale (with STK5200-Board), ELDK 4.2 from DENX and the Kernel 2.6.34-rc5. My Kernel is running fine. The console output is coming over the device ttyPSC0. In future I want to login over telnet. So I deactivated the Kerneloption to output the console o

[PATCH] powerpc: Replace hardcoded offset by BREAK_INSTR_SIZE

2010-07-28 Thread Michal Simek
kgdb_handle_breakpoint checks the first arch_kgdb_breakpoint which is not known by gdb that's why is necessary jump over it. The jump lenght is equal to BREAK_INSTR_SIZE that's why is cleaner to use defined macro instead of hardcoded non-described offset. Signed-off-by: Michal Simek CC: Jason Wes

Re: [PATCH 2/3] USB: add of_platform glue driver for FSL USB DR controller

2010-07-28 Thread Anton Vorontsov
On Wed, Jul 28, 2010 at 02:16:08AM -0600, Grant Likely wrote: [...] > > +static int __devinit fsl_usb2_mph_dr_of_probe(struct of_device *ofdev, > > +                                          const struct of_device_id *match) > > +{ > > +       struct device_node *np = ofdev->dev.of_node; > > +    

Re: [PATCH 3/3] USB: add USB EHCI support for MPC5121 SoC

2010-07-28 Thread Grant Likely
On Thu, Jul 22, 2010 at 10:25 AM, Anatolij Gustschin wrote: > Extends FSL EHCI platform driver glue layer to support > MPC5121 USB controllers. MPC5121 Rev 2.0 silicon EHCI > registers are in big endian format. The appropriate flags > are set using the information in the platform data structure. >

Re: [PATCH 2/3] USB: add of_platform glue driver for FSL USB DR controller

2010-07-28 Thread Grant Likely
On Thu, Jul 22, 2010 at 10:25 AM, Anatolij Gustschin wrote: > The driver creates platform devices based on the information > from USB nodes in the flat device tree. This is the replacement > for old arch fsl_soc usb code removed by the previous patch. > It uses usual of-style binding, available EH

Re: [PATCH 3/3] mmc: Add ESDHC weird register workaround

2010-07-28 Thread Anton Vorontsov
On Wed, Jul 28, 2010 at 01:54:21PM +0800, Roy Zang wrote: > P4080 ESDHC controller induces weird register setting. > This patch adds the workaround to correct the weird register setting. > > Signed-off-by: Roy Zang > --- > drivers/mmc/host/sdhci-of-core.c |5 + > drivers/mmc/host/sdhci.c

Re: [PATCH v4 1/5] fsl-diu-fb: fix issue with re-enabling DIU area descriptor

2010-07-28 Thread Anatolij Gustschin
On Wed, 28 Jul 2010 01:02:59 -0600 Grant Likely wrote: ... > >  drivers/video/fsl-diu-fb.c |   38 +++--- > >  1 files changed, 23 insertions(+), 15 deletions(-) > > > > diff --git a/drivers/video/fsl-diu-fb.c b/drivers/video/fsl-diu-fb.c > > index 27455ce..9b8c991 1

Re: [PATCH] xilinxfb: update tft comp versions

2010-07-28 Thread Grant Likely
On Tue, Jul 27, 2010 at 3:24 PM, Adrian Alonso wrote: > * Add tft display module compatibility for new >  hardware modules > > Signed-off-by: Adrian Alonso > --- >  drivers/video/xilinxfb.c |    2 ++ >  1 files changed, 2 insertions(+), 0 deletions(-) > > diff --git a/drivers/video/xilinxfb.c b/d

Re: [PATCH v4 1/5] fsl-diu-fb: fix issue with re-enabling DIU area descriptor

2010-07-28 Thread Grant Likely
On Fri, Jul 23, 2010 at 8:00 AM, Anatolij Gustschin wrote: > On MPC5121e Rev 2.0 re-configuring the DIU area descriptor > by writing new descriptor address doesn't always work. > As a result, DIU continues to display using old area descriptor > even if the new one has been written to the descripto