On Fri, Mar 19, 2010 at 12:06 AM, Jason Gunthorpe
wrote:
> On Fri, Mar 19, 2010 at 04:50:38PM +1100, Benjamin Herrenschmidt wrote:
>> On Tue, 2010-03-09 at 12:30 -0700, Jason Gunthorpe wrote:
>> > NOPs within the property section are skipped, but NOPs between
>> > OF_DT_END_NODE and OF_DT_BEGIN_NO
On Fri, Mar 19, 2010 at 04:50:38PM +1100, Benjamin Herrenschmidt wrote:
> On Tue, 2010-03-09 at 12:30 -0700, Jason Gunthorpe wrote:
> > NOPs within the property section are skipped, but NOPs between
> > OF_DT_END_NODE and OF_DT_BEGIN_NODE were not. My firmware NOPs out
> > entire nodes depending on
Hello,
Some time ago (July 24th 2009 my mailbox says) I emailed you and the
linuxppc-dev list about my problems booting from the mesh SCSI controller.
I just compiled 2.6.31 (actually, gentoo-sources-2.6.31-r10); but the
problem remains
I know that 2.6.33 is out, but as I didn't see any chang
On Tue, 2010-03-09 at 12:30 -0700, Jason Gunthorpe wrote:
> NOPs within the property section are skipped, but NOPs between
> OF_DT_END_NODE and OF_DT_BEGIN_NODE were not. My firmware NOPs out
> entire nodes depending on various environment parameters.
>
> of_scan_flat_dt already handles NOP more g
On Thu, 2010-03-18 at 09:53 -0500, Kumar Gala wrote:
> From: Lan Chunhe-B25806
>
> Freescale QorIQ P4080 has three MSI banks and the original code
> can not work well. This patch adds multiple MSI banks support for
> Freescale processor.
>
> Signed-off-by: Lan Chunhe-B25806
> Signed-off-by: Roy
On Fri, 2010-03-19 at 12:08 +1100, Nick Piggin wrote:
> > - ISYNC_ON_SMP
> > + PPC_ACQUIRE_BARRIER
>
> I wonder if this shouldn't be called PPC_ISYNC_ACQUIRE_BARRIER ?
>
> Unlike PPC_RELEASE_BARRIER, it is not an acquire barrier unless it
> is used like an isync.
Right. The semantic of i
Use #define IW_HANDLER from wireless.h instead
Signed-off-by: Joe Perches
---
drivers/net/ps3_gelic_wireless.c | 35 +++---
drivers/net/wireless/ipw2x00/ipw2200.c | 83
2 files changed, 58 insertions(+), 60 deletions(-)
diff --git a/drivers/net
Create a IW_HANDLER macro for iw_handler array entries in wireless.h
Use the wireless.h macros in various wireless files
Use starting index define SIOCIWFIRST where appropriate
Remove local #defines of IW_IOCTL
Remove STD_IW_HANDLER macro in orinoco, use IW_HANDLER instead
Joe Perches (9):
incl
On Wed, Feb 10, 2010 at 10:04:06PM +1100, Anton Blanchard wrote:
>
> For performance reasons we are about to change ISYNC_ON_SMP to sometimes be
> lwsync. Now that the macro name doesn't make sense, change it and
> LWSYNC_ON_SMP
> to better explain what the barriers are doing.
>
> Signed-off-by:
On Fri, 2010-03-19 at 00:21 +0100, Stef Simoens wrote:
> Hello,
>
> Some time ago (July 24th 2009 my mailbox says) I emailed you and the
> linuxppc-dev list about my problems booting from the mesh SCSI
> controller.
>
> I just compiled 2.6.31 (actually, gentoo-sources-2.6.31-r10); but the
> probl
On Thu, Mar 18, 2010 at 04:05:13PM +1100, Paul Mackerras wrote:
> This implements a powerpc version of perf_arch_fetch_caller_regs.
> It's implemented in assembly because that way we can be sure there
> isn't a stack frame for perf_arch_fetch_caller_regs. If it was in
> C, gcc might or might not c
Hi Henk,
On Mon, Mar 8, 2010 at 8:20 AM, Henk Stegeman wrote:
> I'm trying to make use of the GPT as interrupt controller.
> My driver is getting most, but not all of the interrupts, besides that
> I'm getting a whole bunch of spurious IRQs, so I'm trying to figure
> out what's wrong.
>
>
Recently I 'm using cpio filesystem (kernel and filesystem compressed
as a whole) on ppc8270 .
However I found that the bigger the size of uImage is , the easier
kernel failed when booting.
Everytime it failed when calling "populate_rootfs" when booting, so I
guess maybe the size of uImage effec
On Thu, 18 Mar 2010 09:22:39 -0600
Grant Likely wrote:
> The following structure elements duplicate the information in
> 'struct device.of_node' and so are being eliminated. This patches
> makes all readers of the following elements use device.of_node
> instead.
Acked-by: Sean MacLennan
__
On Thu, 18 Mar 2010 11:07:35 -0600
Grant Likely wrote:
> On Thu, Mar 18, 2010 at 10:59 AM, Sean MacLennan
> wrote:
> > On Thu, 18 Mar 2010 09:22:39 -0600
> > Grant Likely wrote:
> >
> >> The following structure elements duplicate the information in
> >> 'struct device.of_node' and so are being
On Thu, Mar 18, 2010 at 10:59 AM, Sean MacLennan
wrote:
> On Thu, 18 Mar 2010 09:22:39 -0600
> Grant Likely wrote:
>
>> The following structure elements duplicate the information in
>> 'struct device.of_node' and so are being eliminated. This patches
>> makes all readers of the following element
On Wed, 2010-03-17 at 23:21 -0700, Joe Perches wrote:
> Move the STD_IW_HANDLER macro from orinoco to wireless.h
> Use the wireless.h macros in various wireless files
> Remove local #defines of IW_IOCTL
I really don't want to debug any breakage here, but otherwise I don't
care and this is fine wit
On Thu, 18 Mar 2010 09:22:39 -0600
Grant Likely wrote:
> The following structure elements duplicate the information in
> 'struct device.of_node' and so are being eliminated. This patches
> makes all readers of the following elements use device.of_node
> instead.
The NDFC driver also needs a pat
Grant Likely wrote:
On Wed, Mar 17, 2010 at 6:09 PM, Benjamin Herrenschmidt
wrote:
Commit 7c7b60cb87547b1664a4385c187f029bf514a737
"of: put default string compare and #a/s-cell values into common header"
Breaks various things on powerpc due to using strncasecmp instead of
strcasecmp for compar
I have a Kilauea board with one custom PCIE card plugged
into the PCIE1 slot. The custom card contains four PCI
devices which are connected via a PCIE-PCI bridge to the
Kilauea.
These devices need to communicate directly with each other.
This is done by telling each device the PCI bus address of
On Thu, Mar 18, 2010 at 9:58 AM, Jochen Friedrich wrote:
> Hi Grant,
>
>> The following structure elements duplicate the information in
>> 'struct device.of_node' and so are being eliminated. This patches
>> makes all readers of the following elements use device.of_node instead.
>>
>> struct dev_
On Thu, Mar 18, 2010 at 9:47 AM, Anton Vorontsov
wrote:
> Hi Grant,
>
> On Thu, Mar 18, 2010 at 09:22:50AM -0600, Grant Likely wrote:
>> Both dev_archdata.of_node and of_device.node are duplications of the
>> device.of_node value. This patch removes them.
>
> Yeah, they're plain duplications sinc
Hi Grant,
The following structure elements duplicate the information in
'struct device.of_node' and so are being eliminated. This patches
makes all readers of the following elements use device.of_node instead.
struct dev_archdata.prom_node (sparc)
struct dev_archdata.of_node (powerpc)
struct o
Hi Grant,
On Thu, Mar 18, 2010 at 09:22:50AM -0600, Grant Likely wrote:
> Both dev_archdata.of_node and of_device.node are duplications of the
> device.of_node value. This patch removes them.
Yeah, they're plain duplications since you introduced dev.of_node.
I wonder what was the problem with us
On Thu, Mar 18, 2010 at 9:22 AM, Grant Likely wrote:
> Currently, each of_device has a copy of the device tree node pointer in both
> .node, and in .dev.archdata.of_node (microblaze and powerpc) or
> .dev.archdata.prom_node (sparc). Also, other architectures will be adding
> CONFIG_OF support, an
Both dev_archdata.prom_node and of_device.node are duplications of the
device.of_node value. This patch removes them.
Signed-off-by: Grant Likely
---
arch/sparc/include/asm/device.h| 15 ---
arch/sparc/include/asm/of_device.h |1 -
arch/sparc/kernel/of_device_32.c |
Both dev_archdata.of_node and of_device.node are duplications of the
device.of_node value. This patch removes them.
Signed-off-by: Grant Likely
---
arch/microblaze/include/asm/device.h| 14 --
arch/microblaze/include/asm/of_device.h |1 -
arch/microblaze/kernel/of_device.
Both dev_archdata.of_node and of_device.node are duplications of the
device.of_node value. This patch removes them.
Signed-off-by: Grant Likely
---
arch/powerpc/include/asm/device.h | 15 ---
arch/powerpc/include/asm/of_device.h|1 -
arch/powerpc/kernel/of_device.c
At this point, there are no more users of the archdata node pointer,
so the calls to set it can be dropped.
Signed-off-by: Grant Likely
---
drivers/of/of_i2c.c |1 -
drivers/of/of_mdio.c |1 -
drivers/of/of_spi.c |1 -
3 files changed, 0 insertions(+), 3 deletions(-)
diff --git a
The following structure elements duplicate the information in
'struct device.of_node' and so are being eliminated. This patch
makes all readers of the following elements use device.of_node instead.
struct of_device.node
struct dev_archdata.of_node
Signed-off-by: Grant Likely
---
arch/microbla
The following structure elements duplicate the information in
'struct device.of_node' and so are being eliminated. This patch
makes all readers of the following elements use device.of_node instead.
struct of_device.node
struct dev_archdata.of_node
Signed-off-by: Grant Likely
---
arch/powerpc/
The following structure elements duplicate the information in
'struct device.of_node' and so are being eliminated. This patch
makes all readers of the following elements use device.of_node instead.
struct of_device.node
struct dev_archdata.prom_node
Signed-off-by: Grant Likely
---
arch/sparc/
The struct device_node *of_node pointer is moving out of dev->archdata
and into the struct device proper. of_i2c.c needs to set the of_node
pointer before the device is registered. Since the i2c subsystem
doesn't allow 2 stage allocation and registration of i2c devices, the
of_node pointer needs
Currently, platforms using CONFIG_OF add a 'struct device_node *of_node'
to dev->archdata. However, with CONFIG_OF becoming generic for all
architectures, it makes sense for commonality to move it out of archdata
and into struct device proper.
This patch adds a struct device_node *of_node member
Currently, each of_device has a copy of the device tree node pointer in both
.node, and in .dev.archdata.of_node (microblaze and powerpc) or
.dev.archdata.prom_node (sparc). Also, other architectures will be adding
CONFIG_OF support, and they will also need a reference to the device tree
node poin
From: Lan Chunhe-B25806
Freescale QorIQ P4080 has three MSI banks and the original code
can not work well. This patch adds multiple MSI banks support for
Freescale processor.
Signed-off-by: Lan Chunhe-B25806
Signed-off-by: Roy Zang
---
arch/powerpc/sysdev/fsl_msi.c | 42
Hi Linus, I've updated my merge branch to add a build fix (mpc52xx)
and an OF regression (fix comparison...). Please pull.
Thanks,
g.
The following changes since commit 57d54889cd00db2752994b389ba714138652e60c:
Linus Torvalds (1):
Linux 2.6.34-rc1
are available in the git repository
On Wed, Mar 10, 2010 at 3:03 PM, Jeff Mahoney wrote:
> mpc52xx_gpt_wdt_setup is defined as 0, which causes the following build
> failure with gcc 4.5, since it's built with -Werror.
>
> arch/powerpc/platforms/52xx/mpc52xx_gpt.c:761:3: error: statement with no
> effect
>
> Defining it as do { } wh
On Thu, 2010-03-18 at 01:05 +0800, Jianbin Hu wrote:
> My board have a PCIe switch(PLX PEX8608), which have a AMCC 460EX
> processor. I have parted the dts source file from canyonlands.dts. But
> I have no idea for the PCI bridge device node. Is anyone have a
> suggestion ?
Hi !
First, you don't
Kumar Gala wrote:
We shouldn't be always setting 'M' in the TLB entry since its reasonable
for somethings to be mapped non-coherent. The PTE should have 'M' set
properly.
properly = not at all? AFAICS the patch only removes the setting of the
bit; so where is that 'M' bit set then?
Micha
__
On Mar 18, 2010, at 2:02 AM, Micha Nelissen wrote:
> Kumar Gala wrote:
>> We shouldn't be always setting 'M' in the TLB entry since its reasonable
>> for somethings to be mapped non-coherent. The PTE should have 'M' set
>> properly.
>
> properly = not at all? AFAICS the patch only removes the s
41 matches
Mail list logo