Re: i2c_powermac: Kernel access of bad area

2010-01-06 Thread Christian Kujau
Hi Jean, On Wed, 6 Jan 2010 at 17:37, Jean Delvare wrote: > I think that sysfs files creation should be moved to the end of > probe_thermostat() and sysfs files removal should be moved to the > beginning of remove_thermostat(). Something like the totally untested > patch below (no ppc machine at h

[PATCH] proc_devtree: fix THIS_MODULE without module.h

2010-01-06 Thread Jeremy Kerr
Commit e22f628395432b967f2f505858c64450f7835365 introduced a build breakage for ARM devtree work: the THIS_MODULE macro was added, but we don't have module.h This change adds the necessary #include to get THIS_MODULE defined. While we could just replace it with NULL (PROC_FS is a bool, not a trist

Re: [PATCH] nodmask.h: remove macro any_online_node

2010-01-06 Thread KAMEZAWA Hiroyuki
On Wed, 6 Jan 2010 16:24:58 -0700 H Hartley Sweeten wrote: > nodmask.h: remove macro any_online_node > > The macro any_online_node is prone to producing sparse warnings > due to the local symbol 'node'. Since all the in-tree users are really > requesting the first online node (the mask argument

Re: [PATCH] nodmask.h: remove macro any_online_node

2010-01-06 Thread David Rientjes
On Wed, 6 Jan 2010, H Hartley Sweeten wrote: > nodmask.h: remove macro any_online_node > > The macro any_online_node is prone to producing sparse warnings > due to the local symbol 'node'. Since all the in-tree users are really > requesting the first online node (the mask argument is either > NOD

[PATCH] nodmask.h: remove macro any_online_node

2010-01-06 Thread H Hartley Sweeten
nodmask.h: remove macro any_online_node The macro any_online_node is prone to producing sparse warnings due to the local symbol 'node'. Since all the in-tree users are really requesting the first online node (the mask argument is either NODE_MASK_ALL or node_online_map) just use the first_online_n

[PATCH 7/8] fsldma: rename fsl_chan to chan

2010-01-06 Thread Ira W. Snyder
The name fsl_chan seems too long, so it has been shortened to chan. There are only a few places where the higher level "struct dma_chan *chan" name conflicts. These have been changed to "struct dma_chan *dchan" instead. Signed-off-by: Ira W. Snyder --- drivers/dma/fsldma.c | 550 +++

[PATCH 8/8] fsldma: major cleanups and fixes

2010-01-06 Thread Ira W. Snyder
Fix locking. Use two queues in the driver, one for pending transacions, and one for transactions which are actually running on the hardware. Call dma_run_dependencies() on descriptor cleanup so that the async_tx API works correctly. There are a number of places throughout the code where lists of d

[PATCH 5/8] fsldma: clean up the OF subsystem routines

2010-01-06 Thread Ira W. Snyder
This fixes some errors in the cleanup paths of the OF subsystem, including missing checks for ioremap failing. Also, some variables were renamed for brevity. Signed-off-by: Ira W. Snyder --- drivers/dma/fsldma.c | 259 + drivers/dma/fsldma.h |

[PATCH 6/8] fsldma: simplify IRQ probing and handling

2010-01-06 Thread Ira W. Snyder
The IRQ probing is needlessly complex. All off the 83xx device trees in arch/powerpc/boot/dts/ specify 5 interrupts per DMA controller: one for the controller, and one for each channel. These interrupts are all attached to the same IRQ line. This causes an interesting situation if two channels int

[PATCH 3/8] fsldma: rename struct fsl_dma_chan to struct fsldma_chan

2010-01-06 Thread Ira W. Snyder
This is the beginning of a cleanup which will change all instances of "fsl_dma" to "fsldma" to match the name of the driver itself. Signed-off-by: Ira W. Snyder --- drivers/dma/fsldma.c | 128 ++--- drivers/dma/fsldma.h | 26 +- 2 files chan

[PATCH 2/8] fsldma: remove unused structure members

2010-01-06 Thread Ira W. Snyder
Remove some unused members from the fsldma data structures. A few trivial uses of struct resource were converted to use the stack rather than keeping the memory allocated for the lifetime of the driver. Signed-off-by: Ira W. Snyder --- drivers/dma/fsldma.c | 17 - drivers/dma/f

[PATCH 1/8] fsldma: reduce kernel text size

2010-01-06 Thread Ira W. Snyder
Some of the functions are written in a way where they use multiple reads and writes where a single read/write pair could suffice. This shrinks the kernel text size measurably, while making the functions easier to understand. add/remove: 0/0 grow/shrink: 1/4 up/down: 4/-196 (-192) function

[PATCH 4/8] fsldma: rename dest to dst for uniformity

2010-01-06 Thread Ira W. Snyder
Most functions in the standard library use "dst" as a parameter, rather than "dest". This renames all use of "dest" to "dst" to match the usual convention. Signed-off-by: Ira W. Snyder --- drivers/dma/fsldma.c | 32 drivers/dma/fsldma.h |2 +- 2 files chang

[PATCH 0/8 v2] fsldma: cleanup driver and fix async_tx compatibility

2010-01-06 Thread Ira W. Snyder
This patch series cleans up the Freescale DMAEngine driver, including verifying the locking and making sure that all code paths are correct. There were a few places that seemed suspicious, and they have been fixed. I have written a quick memory->memory DMAEngine test driver, and the performance is

Re: [PATCH] Fix spelling in comments and documentation

2010-01-06 Thread Jiri Kosina
On Wed, 6 Jan 2010, Andrew Morton wrote: > > Replace platfrom -> platform. > > > > This is a frequent spelling bug. > > I have a "no spelling fixes unless they're in documentation or printks" > policy ;) > > triv...@kernel.org would be a suitable recipient for this patch. Yup, I am usually app

Re: [PATCH] Fix spelling in comments and documentation

2010-01-06 Thread Andrew Morton
On Thu, 7 Jan 2010 00:03:52 +0100 Stefan Weil wrote: > Replace platfrom -> platform. > > This is a frequent spelling bug. I have a "no spelling fixes unless they're in documentation or printks" policy ;) triv...@kernel.org would be a suitable recipient for this patch.

[PATCH] Fix spelling in comments and documentation

2010-01-06 Thread Stefan Weil
Replace platfrom -> platform. This is a frequent spelling bug. Signed-off-by: Stefan Weil --- Documentation/driver-model/platform.txt |2 +- arch/arm/mach-davinci/include/mach/i2c.h |2 +- arch/arm/mach-s3c2410/include/mach/spi-gpio.h |2 +- arch/arm/plat-s3c/include/plat

Re: [PATCH 6/8] fsldma: simplify IRQ probing and handling

2010-01-06 Thread Scott Wood
Ira W. Snyder wrote: I don't think this would break any existing hardware. The 83xx all shares one IRQ line, and the 85xx/86xx only have per-channel interrupts, right? (I'm not an 85xx/86xx guy, I've only got 83xx experience). This is what the device trees suggest, anyway. Right. It looks lik

Re: [PATCH 0/2] Create an of_i2c_gpiochip_add()

2010-01-06 Thread Bill Gatliff
Wolfram Sang wrote: >> Does the lack of response mean I'll be seeing these in an upcoming >> kernel release? I'd like to, because then I could more easily push >> > > As long as nobody said "I picked it up", it will probably not. Patches > regarding GPIO sometimes need a bit of time. Also, of

Re: [PATCH 0/2] Create an of_i2c_gpiochip_add()

2010-01-06 Thread Wolfram Sang
> Does the lack of response mean I'll be seeing these in an upcoming > kernel release? I'd like to, because then I could more easily push As long as nobody said "I picked it up", it will probably not. Patches regarding GPIO sometimes need a bit of time. Also, of_platform was in the discussion of

Re: [PATCH 0/2] Create an of_i2c_gpiochip_add()

2010-01-06 Thread Bill Gatliff
Bill Gatliff wrote: > This patch series creates an of_i2c_gpiochip_add() function, to allow > i2c-based GPIO expanders to work with device tree gpio specifications. > So nobody has any yays or nays on this? I was expecting at least _something_! :) Does the lack of response mean I'll be seein

Re: i2c_powermac: Kernel access of bad area

2010-01-06 Thread Christian Kujau
On Wed, 6 Jan 2010 at 17:37, Jean Delvare wrote: > Christian, did you happen to try removing the i2c-powermac driver > before? Well, I definitely removed the driver before, but I'm not sure if I ever read the /sys files after doing this :-\ > I am curious if this is a recent problem, possibly ca

Re: [PATCH 7/8] fsldma: rename fsl_chan to fchan

2010-01-06 Thread Ira W. Snyder
On Wed, Jan 06, 2010 at 12:27:11PM -0600, Scott Wood wrote: > Ira W. Snyder wrote: > > On Wed, Jan 06, 2010 at 12:04:22PM -0600, Scott Wood wrote: > >> On Thu, Dec 31, 2009 at 10:10:45PM -0800, Ira W. Snyder wrote: > >>> The name fsl_chan seems too long, so it has been shortened to fchan. > >> Coul

Re: [PATCH 6/8] fsldma: simplify IRQ probing and handling

2010-01-06 Thread Ira W. Snyder
On Wed, Jan 06, 2010 at 12:02:26PM -0600, Scott Wood wrote: > On Thu, Dec 31, 2009 at 10:10:44PM -0800, Ira W. Snyder wrote: > > The IRQ probing is needlessly complex. All off the 83xx device trees in > > arch/powerpc/boot/dts/ specify 5 interrupts per DMA controller: one for the > > controller, an

Re: [PATCH 7/8] fsldma: rename fsl_chan to fchan

2010-01-06 Thread Scott Wood
Ira W. Snyder wrote: On Wed, Jan 06, 2010 at 12:04:22PM -0600, Scott Wood wrote: On Thu, Dec 31, 2009 at 10:10:45PM -0800, Ira W. Snyder wrote: The name fsl_chan seems too long, so it has been shortened to fchan. Could be just "chan", no need for namespacing here. True. A few functions have

Re: [PATCH 7/8] fsldma: rename fsl_chan to fchan

2010-01-06 Thread Ira W. Snyder
On Wed, Jan 06, 2010 at 12:04:22PM -0600, Scott Wood wrote: > On Thu, Dec 31, 2009 at 10:10:45PM -0800, Ira W. Snyder wrote: > > The name fsl_chan seems too long, so it has been shortened to fchan. > > Could be just "chan", no need for namespacing here. > True. A few functions have a parameter "

Re: [PATCH 7/8] fsldma: rename fsl_chan to fchan

2010-01-06 Thread Scott Wood
On Thu, Dec 31, 2009 at 10:10:45PM -0800, Ira W. Snyder wrote: > The name fsl_chan seems too long, so it has been shortened to fchan. Could be just "chan", no need for namespacing here. -Scott ___ Linuxppc-dev mailing list Linuxppc-dev@lists.ozlabs.org

Re: [PATCH 6/8] fsldma: simplify IRQ probing and handling

2010-01-06 Thread Scott Wood
On Thu, Dec 31, 2009 at 10:10:44PM -0800, Ira W. Snyder wrote: > The IRQ probing is needlessly complex. All off the 83xx device trees in > arch/powerpc/boot/dts/ specify 5 interrupts per DMA controller: one for the > controller, and one for each channel. These interrupts are all attached to > the s

Re: i2c_powermac: Kernel access of bad area

2010-01-06 Thread Jean Delvare
Hi Christian, hi Ben, On Tue, 29 Dec 2009 20:34:15 +1100, Benjamin Herrenschmidt wrote: > On Mon, 2009-12-28 at 20:40 -0800, Christian Kujau wrote: > > Hi there, > > > > I was trying to find out if I still need i2c_powermac to get details off > > /sys/devices/temperatures, since lm-sensors isn't

[git pull] defconfig updates

2010-01-06 Thread Kumar Gala
The following changes since commit 74d2e4f8d79ae0c4b6ec027958d5b18058662eea: Linus Torvalds (1): Linux 2.6.33-rc3 are available in the git repository at: git://git.kernel.org/pub/scm/linux/kernel/git/galak/powerpc.git merge Kumar Gala (1): powerpc: 2.6.33 update of defconfigs f

[PATCH] PPC: use helpers for rlimits

2010-01-06 Thread Jiri Slaby
Make sure compiler won't do weird things with limits. E.g. fetching them twice may return 2 different values after writable limits are implemented. I.e. either use rlimit helpers added in 3e10e716abf3c71bdb5d86b8f507f9e72236c9cd or ACCESS_ONCE if not applicable. Signed-off-by: Jiri Slaby Cc: Ben

Re: [PATCH net-next v2 0/3] can: mscan-mpc5xxx: add support for the Freescale MPC512x

2010-01-06 Thread Wolfram Sang
> > It still works here and, as I see it, all issues were resolved as discussed. > > OK, fine if I add your acked-by then? I wanted to add a 'Reviewed-by' after I checked V3. Regards, Wolfram -- Pengutronix e.K. | Wolfram Sang| Industrial Linux Sol

[PATCH] spi_mpc8xxx: fix WARN_ON on remove after 4c1fba44296

2010-01-06 Thread Peter Korsgaard
Commit 4c1fba44296 (Add support for QE DMA mode and CPM1/CPM2 chips) added unconditional calls to _cpm_init() / _cpm_free() from probe()/remove(), but only checked if we're actually using CPM mode in _init(), causing the WARN_ON in mpc8xxx_spi_free_dummy_rx() for !CPM. Fix it by adding the same ch

Re: [PATCH net-next v2 0/3] can: mscan-mpc5xxx: add support for the Freescale MPC512x

2010-01-06 Thread Wolfgang Grandegger
Wolfram Sang wrote: >> Wolfram, is it OK from your point of view now? I will roll out v3 after >> some more thorough testing tomorrow. > > It still works here and, as I see it, all issues were resolved as discussed. OK, fine if I add your acked-by then? Thanks, Wolfgang. __

Re: How to set GPIO state in the dts or in platform

2010-01-06 Thread Bill Gatliff
Ayman El-Khashab wrote: > On 1/5/2010 10:38 PM, Bill Gatliff wrote: >> Ayman El-Khashab wrote: >> >>> I've got a custom board akin to the walnut. I've successfully got >>> u-boot, >>> the kernel, and a working filesystem. The only thing I lack is a >>> clear idea >>> of how to set a GPIO. >>>

Re: [PATCH net-next v2 0/3] can: mscan-mpc5xxx: add support for the Freescale MPC512x

2010-01-06 Thread Wolfram Sang
> Wolfram, is it OK from your point of view now? I will roll out v3 after > some more thorough testing tomorrow. It still works here and, as I see it, all issues were resolved as discussed. Thanks, Wolfram -- Pengutronix e.K. | Wolfram Sang| Indust

Re: [PATCH net-next v2 1/3] can: mscan: fix improper return if dlc < 8 in start_xmit function

2010-01-06 Thread Wolfram Sang
On Tue, Jan 05, 2010 at 08:19:27PM +0100, Wolfgang Grandegger wrote: > From: Wolfgang Grandegger > > The start_xmit function of the MSCAN Driver did return improperly if > the CAN dlc check failed (skb not freed and invalid return code). This > patch adds a proper check of the frame lenght and da

Re: [PATCH net-next v2 0/3] can: mscan-mpc5xxx: add support for the Freescale MPC512x

2010-01-06 Thread Wolfgang Grandegger
Wolfgang Grandegger wrote: > This patch series adds support for the MPC512x from Freescale to > the mpc5xxx_can MSCAN driver. > > Changes since v1: > > - Various coding style issues, printk formats, variable names and > error messagaes and typos fixes or improved > > - MPC5xxx specific data ar