On Sun 26 Jun 00:28 PDT 2016, Stephen Boyd wrote:
> In the case of ULPI devices, we want to be able to load the
> driver before registering the device so that we don't get stuck
> in a loop waiting for the phy module to appear and failing usb
> controller probe. Currently we request the ulpi modul
On Sun 26 Jun 00:28 PDT 2016, Stephen Boyd wrote:
> We need to pick the correct phy at runtime based on how the SoC
> has been wired onto the board. If the secondary phy is used, take
> it out of reset and mux over to it by writing into the TCSR
> register. Make sure to do this on reset too, becau
this by assigning the dma_mem and dma_ops based on the parent's DeviceTree
node.
Cc: Stephen Boyd
Signed-off-by: Bjorn Andersson
---
Hi Peter,
After (once more) debugging why USB doesn't work up on the 64-bit Qualcomm
systems I realized that we never concluded on this patch. Unfortunate
On Fri 21 Oct 10:38 PDT 2016, Stephen Boyd wrote:
> On 10/21, Bjorn Andersson wrote:
> > hcd_alloc_coherent() and usb_alloc_coherent() ends up allocating coherent
> > memory on behalf of ci_hdrc driver. But as the ci_hdrc is instantiated
> > manually
> > it will not
On certain platforms (e.g. ARM64) the dma_ops needs to be explicitly set
to be able to do DMA allocations, so use the of_dma_configure() helper
to populate the dma properties and assign an appropriate dma_ops.
Signed-off-by: Bjorn Andersson
---
drivers/usb/chipidea/core.c | 4
1 file
On Sun 21 Feb 22:02 PST 2016, Peter Chen wrote:
> On Sun, Feb 21, 2016 at 09:32:13PM -0800, Bjorn Andersson wrote:
> > On certain platforms (e.g. ARM64) the dma_ops needs to be explicitly set
> > to be able to do DMA allocations, so use the of_dma_configure() helper
> >
On Mon 22 Feb 02:03 PST 2016, Srinivas Kandagatla wrote:
>
>
> On 22/02/16 05:32, Bjorn Andersson wrote:
> >On certain platforms (e.g. ARM64) the dma_ops needs to be explicitly set
> >to be able to do DMA allocations, so use the of_dma_configure() helper
> >to popu
On Tue, Mar 8, 2016 at 11:52 AM, Li Yang wrote:
> On Wed, Mar 2, 2016 at 4:59 PM, Li Yang wrote:
>> On Mon, Feb 22, 2016 at 4:07 PM, Bjorn Andersson
>> wrote:
>>> On Mon 22 Feb 02:03 PST 2016, Srinivas Kandagatla wrote:
>>>
>>>>
>>>>
On Fri, Oct 2, 2015 at 10:23 AM, Felipe Balbi via device-mainlining
wrote:
[..]
> The real difficulty here is coming up with an interface which we're agreeing
> to
> supporting for the next 30 years. Whatever that is, as soon as it gets exposed
> to userland, we will have to support it.
>
Isn't
On Fri 20 Nov 15:47 PST 2015, Tim Bird wrote:
> Add support for async_irq to wake up driver from low power mode.
> Without this, the power management code never calls resume.
> Remove a spurious interrupt enable in the driver resume function.
>
> Signed-off-by: Tim Bird
Sorry Tim for missing th
The function regulator_set_optimum_mode() is changing name to
regulator_set_load(), so update the code accordingly.
Signed-off-by: Bjorn Andersson
---
drivers/usb/phy/phy-msm-usb.c | 15 +--
1 file changed, 5 insertions(+), 10 deletions(-)
diff --git a/drivers/usb/phy/phy-msm-usb.c
The function regulator_set_optimum_mode() is changing name to
regulator_set_load(), so update the code accordingly.
Signed-off-by: Bjorn Andersson
---
drivers/usb/phy/phy-ab8500-usb.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/usb/phy/phy-ab8500-usb.c b
Changing the name of the regulator_set_optimum_mode() to
regulator_set_load() better reflects that the API is doing.
This series does the name change and move the current consumers
over.
Bjorn Andersson (5):
regulator: s/regulator_set_optimum_mode/regulator_set_load/
ufs: Rename of
On Wed, Feb 11, 2015 at 7:35 PM, Bjorn Andersson
wrote:
> Changing the name of the regulator_set_optimum_mode() to
> regulator_set_load() better reflects that the API is doing.
>
Any comments on this?
I'm going to propose a patch to the mmc framework calling this api, so
it wo
On Wed 19 Jul 08:59 PDT 2017, Philipp Zabel wrote:
> From: Vivek Gautam
>
> Many devices may want to request a bunch of resets and control them. So
> it's better to manage them as an array. Add APIs to _get() an array of
> reset_control, reusing the _assert(), _deassert(), and _reset() APIs for
On Thu 26 Oct 08:06 PDT 2017, Alan Stern wrote:
> On Thu, 26 Oct 2017, Alex Elder wrote:
>
> > No Qualcomm SoC requires the "ehci-msm.c" code any more. So remove it.
>
> What about old Qualcomm SoCs? What should they use instead?
>
These drivers where unfortunately broken by design (host and
On Fri 20 Oct 05:20 PDT 2017, Philipp Zabel wrote:
> Hi,
>
> On Thu, 2017-10-19 at 11:54 -0700, Bjorn Andersson wrote:
> > On Wed 19 Jul 08:59 PDT 2017, Philipp Zabel wrote:
> >
> > > From: Vivek Gautam
> > >
> > > Many devices may want t
On Sat 19 Aug 01:22 PDT 2017, Bhumika Goyal wrote:
> Make this const as it is only stored in the type field of a device
> structure, which is const.
> Done using Coccinelle.
>
> Signed-off-by: Bhumika Goyal
Applied, thanks.
Regards,
Bjorn
> ---
> drivers/remoteproc/remoteproc_core.c | 2 +-
>
On Tue 21 Aug 06:55 PDT 2018, Loic Poulain wrote:
> Some hardware implementations require to configure pins differently
> according to the USB role (host/device), this can be an update of the
> pins routing or a simple GPIO value change.
>
> This patch introduces new optional "host" and "device"
On Tue 21 Aug 06:55 PDT 2018, Loic Poulain wrote:
> Phy power on/off cycle can happen several times during device life.
> We then need to balance the extcon notifier registration accordingly.
>
> Fixes: f0b5c2c96370 ("phy: qcom-usb-hs: Replace the extcon API")
> Signed-off-by: Loic Poulain
> ---
pat_ioctl = rpmsg_ctrldev_ioctl,
> + .compat_ioctl = generic_compat_ioctl_ptrarg,
> };
>
For rpmsg part
Acked-by: Bjorn Andersson
Regards,
Bjorn
ot;qcom,sdm845-qmp-usb3-phy" must contain:
> "aux", "cfg_ahb", "ref", "com_aux".
> For "qcom,sdm845-qmp-usb3-uni-phy" must contain:
> @@ -60,6 +63,8 @@ Required properties:
> For "
On Mon 14 Jan 08:36 PST 2019, Jeffrey Hugo wrote:
> msm8998 USB has a dwc3 controller just like the existing sdm845 support
>
Reviewed-by: Bjorn Andersson
> Signed-off-by: Jeffrey Hugo
> ---
> Documentation/devicetree/bindings/usb/qcom,dwc3.txt | 1 +
> 1 file ch
On Mon 14 Jan 08:36 PST 2019, Jeffrey Hugo wrote:
> MSM8998 contains one QUSB2 PHY which is very similar to the existing
> sdm845 support.
>
Reviewed-by: Bjorn Andersson
> Signed-off-by: Jeffrey Hugo
> ---
> drivers/phy/qualcomm/phy
On Mon 14 Jan 08:36 PST 2019, Jeffrey Hugo wrote:
> MSM8998 contains a single QMP v3 USB3 phy similar to the existing sdm845
> support.
>
> Signed-off-by: Jeffrey Hugo
Reviewed-by: Bjorn Andersson
Regards,
Bjorn
On Mon 14 Jan 08:37 PST 2019, Jeffrey Hugo wrote:
> Add a MSM8998 specific DT compatible so that we can properly bind to the
> device and enable the USB controller.
>
Reviewed-by: Bjorn Andersson
> Signed-off-by: Jeffrey Hugo
> ---
> drivers/usb/dwc3/dwc3-qcom.c | 1 +
&g
On Mon 14 Jan 08:37 PST 2019, Jeffrey Hugo wrote:
> Add nodes for USB and related PHYs.
>
> Signed-off-by: Jeffrey Hugo
Reviewed-by: Bjorn Andersson
Regards,
Bjorn
> ---
> arch/arm64/boot/dts/qcom/msm8998-mtp.dtsi | 22
> arch/arm64/boot/dts/qcom/msm
On Tue 29 Jan 03:35 PST 2019, Jorge Ramirez-Ortiz wrote:
> diff --git a/drivers/phy/qualcomm/phy-qcom-usb-ss.c
> b/drivers/phy/qualcomm/phy-qcom-usb-ss.c
> new file mode 100644
> index 000..e6ae96e
> --- /dev/null
> +++ b/drivers/phy/qualcomm/phy-qcom-usb-ss.c
> @@ -0,0 +1,347 @@
> +// SPDX-Li
On Tue 29 Jan 03:35 PST 2019, Jorge Ramirez-Ortiz wrote:
> Binding description for Qualcomm's Synopsys 1.0.0 super-speed PHY
SuperSpeed
> controller embedded in QCS404.
>
> Based on Sriharsha Allenki's original
> definitions.
>
> Signed-off-by: Jorge Ramirez-Ortiz
> ---
> .../devicetree/bin
On Thu 07 Feb 03:17 PST 2019, Jorge Ramirez-Ortiz wrote:
> Binding description for Qualcomm's Synopsys 1.0.0 SuperSpeed phy
> controller embedded in QCS404.
>
> Based on Sriharsha Allenki's original
> definitions.
>
> Signed-off-by: Jorge Ramirez-Ortiz
> ---
> .../bindings/phy/qcom,snps-usb-s
30 matches
Mail list logo