śr., 31 lip 2019 o 22:06 Arnd Bergmann napisał(a):
>
> The driver uses hardwire MMIO addresses instead of the data
> that is passed in device tree. Change it over to only
> hardcode the register offset values and allow compile-testing.
>
> Signed-off-by: Arnd Bergmann
Hi Arnd,
thanks for workin
pt., 2 sie 2019 o 13:20 Arnd Bergmann napisał(a):
>
> On Fri, Aug 2, 2019 at 9:10 AM Bartosz Golaszewski
> wrote:
> > > -#include
> > > -#include
> > > +#define _GPREG(x) (x)
> >
> > What purpose
From: Bartosz Golaszewski
In order to drop the hard-coded GPIO base values from the davinci GPIO
driver's platform data, we first need to get rid of all calls to the
legacy GPIO functions.
This series moves the GPIO logic related to da8xx-ohci out of the board
files and into the driver
From: Bartosz Golaszewski
There are no more users of these callbacks.
Signed-off-by: Bartosz Golaszewski
---
include/linux/platform_data/usb-davinci.h | 14 --
1 file changed, 14 deletions(-)
diff --git a/include/linux/platform_data/usb-davinci.h
b/include/linux/platform_data
From: Bartosz Golaszewski
Add lookup entries for vbus and overcurrent gpios for da830-evm.
Signed-off-by: Bartosz Golaszewski
---
arch/arm/mach-davinci/board-da830-evm.c | 10 ++
1 file changed, 10 insertions(+)
diff --git a/arch/arm/mach-davinci/board-da830-evm.c
b/arch/arm/mach
From: Bartosz Golaszewski
The logic implemented by these routines now lives in the da8xx-ohci
driver. Remove dead code.
Signed-off-by: Bartosz Golaszewski
---
arch/arm/mach-davinci/board-da830-evm.c | 67 -
1 file changed, 67 deletions(-)
diff --git a/arch/arm/mach
From: Bartosz Golaszewski
The logic implemented by these routines now lives in the da8xx-ohci
driver. Remove dead code.
Signed-off-by: Bartosz Golaszewski
---
arch/arm/mach-davinci/board-omapl138-hawk.c | 75 +
1 file changed, 1 insertion(+), 74 deletions(-)
diff --git a
From: Bartosz Golaszewski
This improves the coding style.
Signed-off-by: Bartosz Golaszewski
---
drivers/usb/host/ohci-da8xx.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/usb/host/ohci-da8xx.c b/drivers/usb/host/ohci-da8xx.c
index a55cbba40a5a..c492c7e6f746 100644
--- a
From: Bartosz Golaszewski
There are two users upstream which register external callbacks for
switching the port power on/off and overcurrent protection. Both
users only use two GPIOs for that. Instead of having that functionality
in the board files, move the logic into the OHCI driver
From: Bartosz Golaszewski
Add lookup entries for the vbus and overcurrent gpios for omapl138-hawk.
Signed-off-by: Bartosz Golaszewski
---
arch/arm/mach-davinci/board-omapl138-hawk.c | 10 ++
1 file changed, 10 insertions(+)
diff --git a/arch/arm/mach-davinci/board-omapl138-hawk.c
b
From: Bartosz Golaszewski
This improves readability by removing all the &pdev->dev dereferencing.
Signed-off-by: Bartosz Golaszewski
---
drivers/usb/host/ohci-da8xx.c | 18 +-
1 file changed, 9 insertions(+), 9 deletions(-)
diff --git a/drivers/usb/host/ohci-da8xx.c b/
From: Bartosz Golaszewski
In order to drop the hard-coded GPIO base values from the davinci GPIO
driver's platform data, we first need to get rid of all calls to the
legacy GPIO functions.
This series moves the GPIO logic related to da8xx-ohci out of the board
files and into the driver
From: Bartosz Golaszewski
There are two users upstream which register external callbacks for
switching the port power on/off and overcurrent protection. Both
users only use two GPIOs for that. Instead of having that functionality
in the board files, move the logic into the OHCI driver
From: Bartosz Golaszewski
There are no more users of the platform_data callbacks in ohci-da8xx.
Remove them.
Signed-off-by: Bartosz Golaszewski
Acked-by: Alan Stern
---
include/linux/platform_data/usb-davinci.h | 14 --
1 file changed, 14 deletions(-)
diff --git a/include/linux
From: Bartosz Golaszewski
Add a helper pointer to &pdev->dev. This improves readability by
removing all the &pdev->dev dereferencing.
Signed-off-by: Bartosz Golaszewski
Acked-by: Alan Stern
---
drivers/usb/host/ohci-da8xx.c | 18 +-
1 file changed, 9 in
From: Bartosz Golaszewski
Add lookup entries for vbus and overcurrent gpios for da830-evm.
Signed-off-by: Bartosz Golaszewski
Reviewed-by: Linus Walleij
---
arch/arm/mach-davinci/board-da830-evm.c | 10 ++
1 file changed, 10 insertions(+)
diff --git a/arch/arm/mach-davinci/board
From: Bartosz Golaszewski
Add lookup entries for the vbus and overcurrent gpios for omapl138-hawk.
Signed-off-by: Bartosz Golaszewski
Reviewed-by: Linus Walleij
---
arch/arm/mach-davinci/board-omapl138-hawk.c | 10 ++
1 file changed, 10 insertions(+)
diff --git a/arch/arm/mach
From: Bartosz Golaszewski
The logic implemented by these routines now lives in the da8xx-ohci
driver. Remove dead code.
Signed-off-by: Bartosz Golaszewski
---
arch/arm/mach-davinci/board-omapl138-hawk.c | 75 +
1 file changed, 1 insertion(+), 74 deletions(-)
diff --git a
From: Bartosz Golaszewski
The logic implemented by these routines now lives in the da8xx-ohci
driver. Remove dead code.
Signed-off-by: Bartosz Golaszewski
---
arch/arm/mach-davinci/board-da830-evm.c | 67 -
1 file changed, 67 deletions(-)
diff --git a/arch/arm/mach
From: Bartosz Golaszewski
Add a new line after local variables. This improves the coding style.
Signed-off-by: Bartosz Golaszewski
Acked-by: Alan Stern
---
drivers/usb/host/ohci-da8xx.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/usb/host/ohci-da8xx.c b/drivers/usb/host/ohci
20 matches
Mail list logo