This enum is only used in drivers/usb/dwc3/dwc3-omap3.c
Signed-off-by: Masahiro Yamada
---
drivers/usb/dwc3/dwc3-omap.c| 7 +++-
include/linux/platform_data/dwc3-omap.h | 43 -
2 files changed, 6 insertions(+), 44 deletions(-)
delete mode 100644 include/lin
On Fri, Jul 19, 2019 at 04:04:20PM -0600, shuah wrote:
> On 7/5/19 10:43 AM, Suwan Kim wrote:
> > There are bugs on vhci with usb 3.0 storage device. Originally, vhci
> > doesn't supported SG, so USB storage driver on vhci breaks SG list
> > into multiple URBs and it causes error that a transfer go
struct oxu210hp_platform_data is defined, but not used at all.
$ git grep oxu210hp_platform_data
include/linux/oxu210hp.h:struct oxu210hp_platform_data {
include/linux/oxu210hp.h exists just for defining an unused structure,
so it can go away.
Signed-off-by: Masahiro Yamada
---
drivers/usb/ho
The header, oxu210hp.h is only included from oxu210hp-hcd.c
so squash it.
When I moved the code, I also fixed the following warnings from
scripts/checkpatch.pl:
drivers/usb/host/oxu210hp-hcd.c:117: warning: __packed is preferred over
__attribute__((packed))
drivers/usb/host/oxu210hp-hcd.c:196: w
Hi,
>>Pawel Laszczak writes:
> diff --git a/include/linux/usb/otg.h b/include/linux/usb/otg.h
> index 69f1b6328532..c156817672c4 100644
> --- a/include/linux/usb/otg.h
> +++ b/include/linux/usb/otg.h
> @@ -129,4 +129,20 @@ enum usb_dr_mode {
> */
> extern enum usb_d
On Fri 2019-07-19 19:27:48, Greg KH wrote:
> On Thu, Jul 18, 2019 at 10:17:13PM +0200, Pavel Machek wrote:
> > From: Tony Lindgren
> >
> > Droid starts to have useful support in linux-next. Modem is tricky to
> > play with, but this is enough to get basic support.
> >
> > Signed-off-by: Pavel Ma
Controller for OUT endpoints has shared on-chip buffers for all incoming
packets, including ep0out. It's FIFO buffer, so packets must be handled
by DMA in correct order. If the first packet in the buffer will not be
handled, then the following packets directed for other endpoints and
functions will
Patch adds usb_decode_test_mode and usb_decode_device_feature functions,
which allow to make more readable and simplify the
usb_decode_set_clear_feature function.
Signed-off-by: Pawel Laszczak
---
drivers/usb/common/debug.c | 89 ++
1 file changed, 43 insertio
Patch moves switch responsible for decoding descriptor type
outside snprintf. It improves code readability a little.
Signed-off-by: Pawel Laszczak
---
drivers/usb/common/debug.c | 113 +++--
1 file changed, 58 insertions(+), 55 deletions(-)
diff --git a/drivers/u
Patch moves some decoding functions from driver/usb/dwc3/debug.h driver
to driver/usb/common/debug.c file. These moved functions include:
dwc3_decode_get_status
dwc3_decode_set_clear_feature
dwc3_decode_set_address
dwc3_decode_get_set_descriptor
dwc3_decode_get_configuration
This patch introduce new Cadence USBSS DRD driver to linux kernel.
The Cadence USBSS DRD Controller is a highly configurable IP Core which
can be instantiated as Dual-Role Device (DRD), Peripheral Only and
Host Only (XHCI)configurations.
The current driver has been validated with FPGA burned. We
This patch aim at documenting USB related dt-bindings for the
Cadence USBSS-DRD controller.
Signed-off-by: Pawel Laszczak
Reviewed-by: Rob Herring
---
.../devicetree/bindings/usb/cdns-usb3.txt | 45 +++
1 file changed, 45 insertions(+)
create mode 100644 Documentation/devic
Hi!
> This patch introduce new Cadence USBSS DRD driver to linux kernel.
>
> The Cadence USBSS DRD Controller is a highly configurable IP Core which
> can be instantiated as Dual-Role Device (DRD), Peripheral Only and
> Host Only (XHCI)configurations.
I see you are using debugfs to select betwee
On Sun, 2019-07-21 at 19:32 +0100, Pawel Laszczak wrote:
> Patch moves some decoding functions from driver/usb/dwc3/debug.h driver
> to driver/usb/common/debug.c file. These moved functions include:
[]
> diff --git a/drivers/usb/common/debug.c b/drivers/usb/common/debug.c
[]
> +static void usb_deco
On Sun, 2019-07-21 at 19:32 +0100, Pawel Laszczak wrote:
> Patch adds usb_decode_test_mode and usb_decode_device_feature functions,
> which allow to make more readable and simplify the
> usb_decode_set_clear_feature function.
I need to read entire patch series before
commenting more I guess...
The typec class claims to provide comprehensive info about ports,
cables, and plugs. While there is code to register cables and plugs, I
can't find any users of these APIs.
I'd like to write some userland tools that help debug issues with Type-C
(e.g. wrong cable type). However none of drivers s
On Sun, 21 Jul 2019, Joe Perches wrote:
> On Sun, 2019-07-21 at 19:32 +0100, Pawel Laszczak wrote:
> > Patch moves some decoding functions from driver/usb/dwc3/debug.h driver
> > to driver/usb/common/debug.c file. These moved functions include:
> []
> > diff --git a/drivers/usb/common/debug.c b/dr
On Sun, 2019-07-21 at 16:45 -0400, Alan Stern wrote:
> On Sun, 21 Jul 2019, Joe Perches wrote:
>
> > On Sun, 2019-07-21 at 19:32 +0100, Pawel Laszczak wrote:
> > > Patch moves some decoding functions from driver/usb/dwc3/debug.h driver
> > > to driver/usb/common/debug.c file. These moved functions
18 matches
Mail list logo