LINK_OFF_WAKE_EN should be cleared after autoresume, otherwise after
system suspend, the system would wake up when linking off occurs.
Signed-off-by: Hayes Wang
---
drivers/net/usb/r8152.c | 11 +++
1 file changed, 11 insertions(+)
diff --git a/drivers/net/usb/r8152.c b/drivers/net/usb/
NOP_USB_XCEIV is used not only by gadget drivers but by
host drivers as well e.g. EHCI_OMAP.
commit 5a8d651a2bde ("usb: gadget: move gadget API functions to udc-core")
made it so that NOP_USB_XCEIV can't be built-in if USB_GADGET is 'm'.
But this prevents EHCI_OMAP to be built-in if USB_GADGET is
Hi,
> From: Rob Herring
> Sent: Wednesday, June 29, 2016 5:57 AM
>
> On Mon, Jun 27, 2016 at 09:09:19PM +0900, Yoshihiro Shimoda wrote:
> > This patch uses devm_usb_get_phy_by_phandle() instead of usb_get_phy()
> > for device tree environment. This change is not compabile with the
> > previous co
On Wed, Jun 29, 2016 at 12:13:45PM -0700, Stephen Boyd wrote:
> Quoting Peter Chen (2016-06-29 01:26:48)
> > On Sun, Jun 26, 2016 at 12:28:33AM -0700, Stephen Boyd wrote:
> > > When the RESET bit is set in the USBCMD register it resets quite
> > > @@ -21,11 +23,22 @@
> > > #define HS_PHY_SEC_CTRL
When usb gadget is set gadget serial function, it will be crash in below
situation.
It will clean the 'port->port_usb' pointer in gserial_disconnect() function
when usb link is inactive, but it will release lock for disabling the endpoints
in this function. Druing the lock release period, it maybe
On Wed, Jun 29, 2016 at 12:17:12PM -0700, Stephen Boyd wrote:
> Quoting Peter Chen (2016-06-29 04:29:25)
> > On Sun, Jun 26, 2016 at 12:28:34AM -0700, Stephen Boyd wrote:
> > > @@ -204,7 +201,7 @@ static int ci_hdrc_msm_probe(struct platform_device
> > > *pdev)
> > > of_node_put(ulpi_node);
On Wed, Jun 29, 2016 at 07:02:32PM -0700, Stephen Boyd wrote:
> Quoting Peter Chen (2016-06-29 02:43:47)
> > On Mon, Jun 27, 2016 at 06:18:27PM -0700, Stephen Boyd wrote:
> > It introduces circular locking after applying it, otg_statemachine calls
> > otg_leave_state, and otg_leave_state calls otg_
On Sat, Jun 25, 2016 at 08:38:58AM +, Stefan Wahren wrote:
> Since there is no dependency from this busy wait in the reset ISR
> we could remove it.
>
> Signed-off-by: Stefan Wahren
> ---
> drivers/usb/chipidea/udc.c |4
> 1 file changed, 4 deletions(-)
>
> diff --git a/drivers/usb
On Sat, Jun 25, 2016 at 08:38:55AM +, Stefan Wahren wrote:
> This patch series aim to improve the ChipIdea UDC driver in regards to
> readability and runtime behavior.
>
> Stefan Wahren (4):
> usb: chipidea: udc: move write barrier into hw_ep_prime
> usb: chipidea: udc: Don't flush endpoin
Hi,
Greg Kroah-Hartman writes:
> On Wed, Jun 29, 2016 at 04:11:31PM +0300, Felipe Balbi wrote:
>>
>> Hi Greg,
>>
>> here's the big pull request for gadget API and related UDC drivers.
>>
>> Nothing really scary lately. Patches have been in linux-next for a while
>> without outstanding reports
Hi,
Roger Quadros writes:
> NOP_USB_XCEIV is used not only by gadget drivers but by
> host drivers as well e.g. EHCI_OMAP.
>
> commit 5a8d651a2bde ("usb: gadget: move gadget API functions to udc-core")
> made it so that NOP_USB_XCEIV can't be built-in if USB_GADGET is 'm'.
> But this prevents EH
On 30/06/16 13:04, Felipe Balbi wrote:
>
> Hi,
>
> Greg Kroah-Hartman writes:
>> On Wed, Jun 29, 2016 at 04:11:31PM +0300, Felipe Balbi wrote:
>>>
>>> Hi Greg,
>>>
>>> here's the big pull request for gadget API and related UDC drivers.
>>>
>>> Nothing really scary lately. Patches have been in li
Hi,
Baolin Wang writes:
> +static ssize_t charger_state_show(struct device *dev,
> + struct device_attribute *attr,
> + char *buf)
> +{
> + struct usb_charger *uchger = dev_to_uchger(dev);
> + int cnt;
> +
> + switch (uchger
Hi,
Roger Quadros writes:
here's the big pull request for gadget API and related UDC drivers.
Nothing really scary lately. Patches have been in linux-next for a while
without outstanding reports.
Let me know if you want any changes, but things seem to be calming
>>>
On 30/06/16 13:32, Felipe Balbi wrote:
>
> Hi,
>
> Roger Quadros writes:
> here's the big pull request for gadget API and related UDC drivers.
>
> Nothing really scary lately. Patches have been in linux-next for a while
> without outstanding reports.
>
> Let me know if yo
Greg, Felipe,
On 30/06/16 13:45, Roger Quadros wrote:
> On 30/06/16 13:32, Felipe Balbi wrote:
>>
>> Hi,
>>
>> Roger Quadros writes:
>> here's the big pull request for gadget API and related UDC drivers.
>>
>> Nothing really scary lately. Patches have been in linux-next for a while
>>
Hi Felipe,
On 30 June 2016 at 18:30, Felipe Balbi wrote:
>
> Hi,
>
> Baolin Wang writes:
>> +static ssize_t charger_state_show(struct device *dev,
>> + struct device_attribute *attr,
>> + char *buf)
>> +{
>> + struct usb_charger *uc
Add a quirk to configure the core to support the
UTMI+ PHY with an 8- or 16-bit interface. UTMI+ PHY
interface is hardware property, and it's platform
dependent. Normall, the PHYIf can be configured
during coreconsultant. But for some specific usb
cores(e.g. rk3399 soc dwc3), the default PHYIf
conf
Add a quirk to clear the GUSB2PHYCFG.U2_FREECLK_EXISTS bit,
which specifies whether the USB2.0 PHY provides a free-running
PHY clock, which is active when the clock control input is active.
Signed-off-by: William Wu
---
Changes in v5:
- None
Changes in v4:
- rebase on top of balbi testing/next,
Add a quirk to clear the GUSB3PIPECTL.DELAYP1TRANS bit,
which specifies whether disable delay PHY power change
from P0 to P1/P2/P3 when link state changing from U0
to U1/U2/U3 respectively.
Signed-off-by: William Wu
---
Changes in v5:
- None
Changes in v4:
- rebase on top of balbi testing/next,
This series add support for rockchip dwc3 driver,
and add additional optional properties for specific
platforms (e.g., rockchip rk3399 platform).
William Wu (5):
usb: dwc3: of-simple: add compatible for rockchip rk3399
usb: dwc3: add dis_u2_freeclk_exists_quirk
usb: dwc3: add phyif_utmi_quir
Rockchip platform merely enable usb3 clocks and
populate its children. So we can use this generic
glue layer to support Rockchip dwc3.
Signed-off-by: William Wu
---
Changes in v5:
- change compatible from "rockchip,dwc3" to "rockchip,rk3399-dwc3" (Heiko)
Changes in v4:
- None
Changes in v3:
- N
This patch adds the devicetree documentation required for Rockchip
USB3.0 core wrapper consisting of USB3.0 IP from Synopsys.
It supports DRD mode, and could operate in device mode (SS, HS, FS)
and host mode (SS, HS, FS, LS).
Signed-off-by: William Wu
---
Changes in v5:
- rename clock-names, and
Hi,
Roger Quadros writes:
>>> Roger Quadros writes:
>>> here's the big pull request for gadget API and related UDC drivers.
>>>
>>> Nothing really scary lately. Patches have been in linux-next for a while
>>> without outstanding reports.
>>>
>>> Let me know if you want a
Looks like we lost all changes related to
commit 9522def40065 ("usb: dwc3: core: cleanup IRQ resources") in host.c
when Felipe's next branch was merged into Greg's next branch.
Fixes 215db948181 ("Merge tag 'usb-for-v4.8' of
git://git.kernel.org/pub/scm/linux/kernel/git/balbi/usb into usb-next")
Hi,
Roger Quadros writes:
> Looks like we lost all changes related to
> commit 9522def40065 ("usb: dwc3: core: cleanup IRQ resources") in host.c
> when Felipe's next branch was merged into Greg's next branch.
>
> Fixes 215db948181 ("Merge tag 'usb-for-v4.8' of
> git://git.kernel.org/pub/scm/lin
Hi William,
Am Donnerstag, 30. Juni 2016, 19:16:40 schrieb William Wu:
> This patch adds the devicetree documentation required for Rockchip
> USB3.0 core wrapper consisting of USB3.0 IP from Synopsys.
>
> It supports DRD mode, and could operate in device mode (SS, HS, FS)
> and host mode (SS, HS,
gcc warns about what first looks like a reference to an uninitialized
variable:
drivers/usb/host/xhci-ring.c: In function 'handle_cmd_completion':
drivers/usb/host/xhci-ring.c:753:4: error: 'ep_ring' may be used uninitialized
in this function [-Werror=maybe-uninitialized]
xhci_unmap_td_bounce
Hi Felipe,
On 30/06/16 13:14, Felipe Balbi wrote:
>
> Hi,
>
> Roger Quadros writes:
>> NOP_USB_XCEIV is used not only by gadget drivers but by
>> host drivers as well e.g. EHCI_OMAP.
>>
>> commit 5a8d651a2bde ("usb: gadget: move gadget API functions to udc-core")
>> made it so that NOP_USB_XCEI
On Wed, Jun 29, 2016 at 03:56:23PM -0300, Bruno Herrera wrote:
> On Tue, Jun 28, 2016 at 5:54 PM, Rob Herring wrote:
> > On Fri, Jun 24, 2016 at 03:51:18PM -0300, Bruno Herrera wrote:
> >> On Fri, Jun 24, 2016 at 12:41 PM, Rob Herring wrote:
> >> > On Tue, Jun 21, 2016 at 11:25:49PM -0300, Bruno
On 30.06.2016 15:26, Arnd Bergmann wrote:
gcc warns about what first looks like a reference to an uninitialized
variable:
drivers/usb/host/xhci-ring.c: In function 'handle_cmd_completion':
drivers/usb/host/xhci-ring.c:753:4: error: 'ep_ring' may be used uninitialized
in this function [-Werror=m
On 30 June 2016 at 01:54, Peter Chen wrote:
> On Wed, Jun 29, 2016 at 12:13:45PM -0700, Stephen Boyd wrote:
>> Quoting Peter Chen (2016-06-29 01:26:48
>> > Why not using ci->platdata->vbus_extcon directly?
>>
>> Because ci->platdata->vbus_extcon is assigned after the child platform
>> driver probe
On Wed, Jun 29, 2016 at 04:38:37PM +0300, Heikki Krogerus wrote:
> The purpose of USB Type-C connector class is to provide
> unified interface for the user space to get the status and
> basic information about USB Type-C connectors on a system,
> control over data role swapping, and when the port s
This adds tracepoints to dump musb interrupt events.
Signed-off-by: Bin Liu
---
drivers/usb/musb/musb_core.c | 4 +---
drivers/usb/musb/musb_trace.h | 21 +
2 files changed, 22 insertions(+), 3 deletions(-)
diff --git a/drivers/usb/musb/musb_core.c b/drivers/usb/musb/musb_
musb core already exports the register read/write wrappers, so clean up
the duplication in dsps glue.
Signed-off-by: Bin Liu
---
drivers/usb/musb/musb_dsps.c | 112 +--
1 file changed, 44 insertions(+), 68 deletions(-)
diff --git a/drivers/usb/musb/musb_d
Switch dev_dbg() to tracepoint debug musb_dbg().
Signed-off-by: Bin Liu
---
drivers/usb/musb/cppi_dma.c| 50 +
drivers/usb/musb/musb_core.c | 64 +++---
drivers/usb/musb/musb_cppi41.c | 12 ++---
drivers/usb/musb/musb_gadget.c | 97 ++
This adds tracepoints to musb register read/write wrappers to get
trace log for register access.
The default tacepoint log prefix here would be musb_readX/writeX(),
which is not much helpful. So this patch let the tracepoints use
__buildin_return_address(0) to print the caller funciton name to
pro
Add urb tracepoints for host mode.
Signed-off-by: Bin Liu
---
drivers/usb/musb/musb_host.c | 34 ++-
drivers/usb/musb/musb_trace.h | 63 +++
2 files changed, 71 insertions(+), 26 deletions(-)
diff --git a/drivers/usb/musb/musb_host.c
To avoid printk() overhead while debugging, this patch implements the
foundation of tracepoints logging for musb driver to make debug
easier.
Signed-off-by: Bin Liu
---
drivers/usb/musb/Makefile | 5 +++-
drivers/usb/musb/musb_debug.h | 2 ++
drivers/usb/musb/musb_trace.c | 33
Hi Greg,
This musb patch set is for next v4.8. It adds tracepoints to musb drivers
to help debugging.
This v2 is rebased on v4.7-rc4, to solve a merge conflict, and adds two more
patches for musb sunxi glue layer. Please let me know if any change is needed.
Regards,
-Bin.
---
Ben Dooks (1):
davinci.h is not required by cppi_dma.h but cppi_dma.c, so move the
include to the right place.
Signed-off-by: Bin Liu
---
drivers/usb/musb/cppi_dma.c | 1 +
drivers/usb/musb/cppi_dma.h | 8
2 files changed, 1 insertion(+), 8 deletions(-)
diff --git a/drivers/usb/musb/cppi_dma.c b/driv
Add tracepoints for cppi41 dma channels.
Signed-off-by: Bin Liu
---
drivers/usb/musb/musb_cppi41.c | 22 ++---
drivers/usb/musb/musb_trace.h | 70 ++
2 files changed, 80 insertions(+), 12 deletions(-)
diff --git a/drivers/usb/musb/musb_cppi41.c b
Move struct cppi41_dma_channel to the header file so other modules can
use it.
Signed-off-by: Bin Liu
---
drivers/usb/musb/cppi_dma.h| 23 ++-
drivers/usb/musb/musb_cppi41.c | 21 +
2 files changed, 23 insertions(+), 21 deletions(-)
diff --git a/drive
From: Hans de Goede
phy-sun4i-usb now has proper dr_mode handling, it always registers an
extcon, and sends a notify with the mode (even when in peripheral- /
host-only mode) at least once.
So we can simply the sunxi musb glue by always registering its extcon
notifier and relying on sunxi_musb_w
Add usb_request tracepoints for gadget mode.
Signed-off-by: Bin Liu
---
drivers/usb/musb/musb_gadget.c | 35 ---
drivers/usb/musb/musb_trace.h | 76 ++
2 files changed, 90 insertions(+), 21 deletions(-)
diff --git a/drivers/usb/musb/musb_
From: Ben Dooks
The sunxi_musb_dma_controller_create and _destroy are not exported
or used outside the driver, so fix sparse warnings by making these
two static:
drivers/usb/musb/sunxi.c:357:23: warning: symbol
'sunxi_musb_dma_controller_create' was not declared. Should it be static?
drivers/us
On Thu, Jun 30, 2016 at 02:00:40PM +0300, Roger Quadros wrote:
> Greg, Felipe,
>
> On 30/06/16 13:45, Roger Quadros wrote:
> > On 30/06/16 13:32, Felipe Balbi wrote:
> >>
> >> Hi,
> >>
> >> Roger Quadros writes:
> >> here's the big pull request for gadget API and related UDC drivers.
> >>
On Wed, Jun 29, 2016 at 04:38:37PM +0300, Heikki Krogerus wrote:
> The purpose of USB Type-C connector class is to provide
> unified interface for the user space to get the status and
> basic information about USB Type-C connectors on a system,
> control over data role swapping, and when the port s
On Tue, Jun 28, 2016 at 03:09:21PM -0700, Stephen Boyd wrote:
> Quoting Rob Herring (2016-06-28 13:56:42)
> > On Sun, Jun 26, 2016 at 12:28:19AM -0700, Stephen Boyd wrote:
> > > The qcom HSIC ulpi phy doesn't have any bits set in the vendor or
> > > product id ulpi registers. This makes it impossib
Dear Heiko,
On 06/30/2016 08:15 PM, Heiko Stuebner wrote:
Hi William,
Am Donnerstag, 30. Juni 2016, 19:16:40 schrieb William Wu:
This patch adds the devicetree documentation required for Rockchip
USB3.0 core wrapper consisting of USB3.0 IP from Synopsys.
It supports DRD mode, and could operat
The following changes since commit aa5e94a2e13377e374795de5400e346c978f46be:
Revert "usb: ohci-at91: Forcibly suspend ports while USB suspend" (2016-06-20
07:42:07 -0700)
are available in the git repository at:
git://git.kernel.org/pub/scm/linux/kernel/git/peter.chen/usb.git/
tags/usb-v4.8
On Thu, Jun 30, 2016 at 07:12:53PM +0800, William Wu wrote:
> Add a quirk to clear the GUSB2PHYCFG.U2_FREECLK_EXISTS bit,
> which specifies whether the USB2.0 PHY provides a free-running
> PHY clock, which is active when the clock control input is active.
>
> Signed-off-by: William Wu
> ---
> Cha
On Thu, Jun 30, 2016 at 07:12:54PM +0800, William Wu wrote:
> Add a quirk to configure the core to support the
> UTMI+ PHY with an 8- or 16-bit interface. UTMI+ PHY
> interface is hardware property, and it's platform
> dependent. Normall, the PHYIf can be configured
> during coreconsultant. But for
Dear Rob,
On 07/01/2016 10:32 AM, Rob Herring wrote:
On Thu, Jun 30, 2016 at 07:12:53PM +0800, William Wu wrote:
Add a quirk to clear the GUSB2PHYCFG.U2_FREECLK_EXISTS bit,
which specifies whether the USB2.0 PHY provides a free-running
PHY clock, which is active when the clock control input is
Dear Rob,
On 07/01/2016 10:38 AM, Rob Herring wrote:
On Thu, Jun 30, 2016 at 07:12:55PM +0800, William Wu wrote:
Add a quirk to clear the GUSB3PIPECTL.DELAYP1TRANS bit,
which specifies whether disable delay PHY power change
from P0 to P1/P2/P3 when link state changing from U0
to U1/U2/U3 respec
On Thu, Jun 30, 2016 at 07:12:55PM +0800, William Wu wrote:
> Add a quirk to clear the GUSB3PIPECTL.DELAYP1TRANS bit,
> which specifies whether disable delay PHY power change
> from P0 to P1/P2/P3 when link state changing from U0
> to U1/U2/U3 respectively.
>
> Signed-off-by: William Wu
> ---
> C
On Thu, Jun 30, 2016 at 01:30:54PM -0700, Stephen Boyd wrote:
> Quoting Peter Chen (2016-06-29 18:39:01)
> > On Wed, Jun 29, 2016 at 05:43:30PM -0700, Stephen Boyd wrote:
> > > Quoting Peter Chen (2016-06-28 23:46:00)
> > > > On Sun, Jun 26, 2016 at 12:28:29AM -0700, Stephen Boyd wrote:
> > > > > S
For supporting the usb charger, it adds the usb_charger_init() and
usb_charger_exit() functions for usb charger initialization and exit.
It will report to the usb charger when the gadget state is changed,
then the usb charger can do the power things.
Signed-off-by: Baolin Wang
Reviewed-by: Li Ju
Integrate with the newly added USB charger interface to limit the current
we draw from the USB input based on the input device configuration
identified by the USB stack, allowing us to charge more quickly from high
current inputs without drawing more current than specified from others.
Signed-off-
This patch introduces the usb charger driver based on usb gadget that
makes an enhancement to a power driver. It works well in practice but
that requires a system with suitable hardware.
The basic conception of the usb charger is that, when one usb charger
is added or removed by reporting from the
When the usb gadget supporting for usb charger is ready, the usb charger
can implement the usb_charger_plug_by_gadget() function, usb_charger_exit()
function and dev_to_uchger() function by getting 'struct usb_charger' from
'struct gadget'.
Signed-off-by: Baolin Wang
Reviewed-by: Li Jun
Tested-b
Currently the Linux kernel does not provide any standard integration of this
feature that integrates the USB subsystem with the system power regulation
provided by PMICs meaning that either vendors must add this in their kernels
or USB gadget devices based on Linux (such as mobile phones) may not b
62 matches
Mail list logo