Hello,
On Tue, Oct 27, 2015 at 12:41:43AM +, John Youn wrote:
> On 10/26/2015 2:29 AM, Alexander Aring wrote:
> > This patch changes devm_phy_get to devm_phy_optional_get. Which fixes the
> > error handling when trying to get the phy. Currently on all errors we
> > try to look for an old style
Hello,
On Mon, Oct 26, 2015 at 08:08:58PM -0600, Stephen Warren wrote:
> On 10/26/2015 03:28 AM, Alexander Aring wrote:
> > This patch changes devm_phy_get to devm_phy_optional_get. Which fixes the
> > error handling when trying to get the phy. Currently on all errors we
> > try to look for an old
Since we have dynamic debug support, delete static debug for chipidea
Signed-off-by: Peter Chen
---
drivers/usb/chipidea/Kconfig | 5 -
drivers/usb/chipidea/Makefile | 2 --
2 files changed, 7 deletions(-)
diff --git a/drivers/usb/chipidea/Kconfig b/drivers/usb/chipidea/Kconfig
index 5619b
This patchset fixes checkpatch issues, for ipath_common.h and
ipath_cq.c
SirnamSwetha (8):
Staging: rdma ipath: Removing multiple blank lines
Staging: rdma ipath: __aligned(size) is preferred over
__attribute__((aligned(size)))
Staging : rdma ipath: spaces preferred around that '<<'
This patch fixes the checkpatch issue
CHECK: Please don't use multiple blank lines
Signed-off-by: SirnamSwetha
---
drivers/staging/rdma/ipath/ipath_common.h | 4
1 file changed, 4 deletions(-)
diff --git a/drivers/staging/rdma/ipath/ipath_common.h
b/drivers/staging/rdma/ipath/ipath_commo
This patch fixes the checkpatch issue:
WARNING: __aligned(size) is preferred over __attribute__((aligned(size)))
Signed-off-by: SirnamSwetha
---
drivers/staging/rdma/ipath/ipath_common.h | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/rdma/ipath/ipath_com
This patch fixes the checkpatch issue:
CHECK: spaces preferred around that '<<'
Signed-off-by: SirnamSwetha
---
drivers/staging/rdma/ipath/ipath_common.h | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/rdma/ipath/ipath_common.h
b/drivers/staging/rdma/ipa
This patch fixes:
ERROR: "foo * bar" should be "foo *bar"
Signed-off-by: SirnamSwetha
---
drivers/staging/rdma/ipath/ipath_common.h | 8
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/rdma/ipath/ipath_common.h
b/drivers/staging/rdma/ipath/ipath_common.h
Fix: CHECK: 'explict' may be misspelled - perhaps 'explicit'?
Signed-off-by: SirnamSwetha
---
drivers/staging/rdma/ipath/ipath_common.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/rdma/ipath/ipath_common.h
b/drivers/staging/rdma/ipath/ipath_common.h
index
This patch fixes:
CHECK: no space before tabs
WARNING: line over 80 characters
Signed-off-by: SirnamSwetha
---
drivers/staging/rdma/ipath/ipath_common.h | 11 +++
1 file changed, 7 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/rdma/ipath/ipath_common.h
b/drivers/staging/
This patch fixes the issue:
CHECK: No space is necessary after a cast
Signed-off-by: SirnamSwetha
---
drivers/staging/rdma/ipath/ipath_cq.c | 18 +-
1 file changed, 9 insertions(+), 9 deletions(-)
diff --git a/drivers/staging/rdma/ipath/ipath_cq.c
b/drivers/staging/rdma/ipath/
Fix all instances of the following checkpatch.pl check:
CHECK: braces {} should be used on all arms of this statement
Signed-off-by: SirnamSwetha
---
drivers/staging/rdma/ipath/ipath_cq.c | 10 ++
1 file changed, 6 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/rdma/ipath/i
On Tue, Oct 27, 2015 at 02:28:46PM +0530, SirnamSwetha wrote:
> This patchset fixes checkpatch issues, for ipath_common.h and
> ipath_cq.c
Why did you cc: the linux-usb mailing list on these? They have nothing
to do with the USB subsystem.
Please use scripts/get_maintainer.pl to determine mailin
Hi Robert,
On 27/10/15 06:53, Robert Baldyga wrote:
> On 10/26/2015 05:55 PM, Felipe F. Tonello wrote:
>> This function is shared between gadget functions, so this avoid unnecessary
>> duplicated code and potentially avoid memory leaks.
>>
>> Signed-off-by: Felipe F. Tonello
>> ---
>> drivers/us
Hi Robert,
On 27/10/15 06:47, Robert Baldyga wrote:
> On 10/26/2015 11:53 PM, Felipe Tonello wrote:
>> Hi Robert,
>>
>> On Mon, Oct 26, 2015 at 10:30 PM, Robert Baldyga
>> wrote:
>>> On 10/26/2015 05:55 PM, Felipe F. Tonello wrote:
This avoids duplication of USB requests for OUT endpoint and
Hi Robert,
On 27/10/15 06:41, Robert Baldyga wrote:
> On 10/26/2015 11:49 PM, Felipe Tonello wrote:
>> Hi Robert,
>>
>> On Mon, Oct 26, 2015 at 10:13 PM, Robert Baldyga
>> wrote:
>>> Hi Felipe,
>>>
>>> On 10/26/2015 05:55 PM, Felipe F. Tonello wrote:
This makes sure f_midi doesn't try to enq
Hi Peter,
Have you seen this patch? I saw that you didn't apply it to your tree,
so I wonder if it is good or do I have to change anything.
This patch is a bug fix for a memory leak, so it is quite important.
--
Felipe
On 18/09/15 18:30, e...@felipetonello.com wrote:
> From: "Felipe F. Tonello
> Hi Peter,
>
> Have you seen this patch? I saw that you didn't apply it to your tree, so I
> wonder if it is good or do I have to change anything.
>
> This patch is a bug fix for a memory leak, so it is quite important.
>
Would you please create it based on my tree, branch ci-for-usb-next?
I
From: Nicholas Bellinger
This patch adds the missing tcm_usbg_drop_nexus() to properly
release tcm_usbg_nexus memory during typical ->fabric_drop_tpg()
callback shutdown.
Reported-by: Andrzej Pietrasiewicz
Cc: Andrzej Pietrasiewicz
Cc: Sebastian Andrzej Siewior
Signed-off-by: Nicholas Belling
Dear All,
This series adds support to tcm usb gadget for composing it with configfs.
@target-devel folks: You might be wondering why add configfs for something
which already supports configfs. In tcm_usb_gadget configfs has beeen
used for configuring the SCSI target part, but the usb gadget part
Prepare for splitting tcm_usb_gadget into legacy gadget proper and f_tcm.
Signed-off-by: Andrzej Pietrasiewicz
---
drivers/usb/gadget/legacy/tcm_usb_gadget.c | 28 ++--
1 file changed, 14 insertions(+), 14 deletions(-)
diff --git a/drivers/usb/gadget/legacy/tcm_usb_gadge
Prepare for converting tcm to new function registration interface.
Signed-off-by: Andrzej Pietrasiewicz
---
drivers/usb/gadget/function/f_tcm.c| 2168
drivers/usb/gadget/function/tcm.h | 132 ++
drivers/usb/gadget/legacy/tcm_usb_gadget.c | 2150 +---
From: Nicholas Bellinger
Fix up tcm_usbg_tpg_store_enable() return value to propagate
usbg_attach() failure up to user-space if no HDC is found.
Reported-by: Andrzej Pietrasiewicz
Cc: Andrzej Pietrasiewicz
Cc: Sebastian Andrzej Siewior
Signed-off-by: Nicholas Bellinger
[split unrelated chang
Allow using the tcm function as a component of a gadget composed with
ConfigFS.
Signed-off-by: Andrzej Pietrasiewicz
---
Documentation/ABI/testing/configfs-usb-gadget-tcm | 6 ++
drivers/usb/gadget/Kconfig| 14 +
drivers/usb/gadget/function/f_tcm.c | 72
Converting tcm to the new function interface requires converting
USB tcm's function code and its users.
This patch converts the f_tcm.c to the new function interface.
The file can be now compiled into a separate module usb_f_tcm.ko.
The old function interface is provided by means of preprocessor
Prepare for factoring out f_tcm from a legacy gadget.
Signed-off-by: Andrzej Pietrasiewicz
---
drivers/usb/gadget/legacy/tcm_usb_gadget.c | 25 +
drivers/usb/gadget/legacy/tcm_usb_gadget.h | 3 +--
2 files changed, 22 insertions(+), 6 deletions(-)
diff --git a/drivers/u
The only instance is guaranteed with TPG_INSTANCES defined to 1.
Signed-off-by: Andrzej Pietrasiewicz
---
drivers/usb/gadget/function/f_tcm.c | 9 -
drivers/usb/gadget/function/tcm.h | 2 --
2 files changed, 11 deletions(-)
diff --git a/drivers/usb/gadget/function/f_tcm.c
b/drivers/u
There are no old function interface users left.
Signed-off-by: Andrzej Pietrasiewicz
---
drivers/usb/gadget/function/f_tcm.c | 87 +++--
1 file changed, 6 insertions(+), 81 deletions(-)
diff --git a/drivers/usb/gadget/function/f_tcm.c
b/drivers/usb/gadget/functi
Convert the only user of old tcm function interface so that the old
interface can be removed.
Signed-off-by: Andrzej Pietrasiewicz
---
drivers/usb/gadget/legacy/Kconfig | 1 +
drivers/usb/gadget/legacy/tcm_usb_gadget.c | 62 +-
2 files changed, 53 insertions
Do not directly use file static strings definitions in instances of f_tcm.
Instead use usb_gstrings_attach.
Signed-off-by: Andrzej Pietrasiewicz
---
drivers/usb/gadget/function/f_tcm.c | 18 +++---
1 file changed, 7 insertions(+), 11 deletions(-)
diff --git a/drivers/usb/gadget/func
From: Nicholas Bellinger
Avoid stripping off the 'naa.' I_T nexus prefix from configfs
attribute store input, so that user-space will get back what
it originaly wrote into ../usb_gadget/$WWPN/$TPGT/nexus.
Note the SCSI initiator WWPN is purely symbolic for UAS + BOT,
so it will not effect host s
Simplify the function.
Signed-off-by: Andrzej Pietrasiewicz
---
drivers/usb/gadget/legacy/tcm_usb_gadget.c | 10 --
1 file changed, 4 insertions(+), 6 deletions(-)
diff --git a/drivers/usb/gadget/legacy/tcm_usb_gadget.c
b/drivers/usb/gadget/legacy/tcm_usb_gadget.c
index a60ef8f..62b121
Simplify function code.
Signed-off-by: Andrzej Pietrasiewicz
---
drivers/usb/gadget/legacy/tcm_usb_gadget.c | 22 +++---
1 file changed, 7 insertions(+), 15 deletions(-)
diff --git a/drivers/usb/gadget/legacy/tcm_usb_gadget.c
b/drivers/usb/gadget/legacy/tcm_usb_gadget.c
index 6
W dniu 26.10.2015 o 16:35, Krzysztof Opasiak pisze:
Hi Christoph,
I have just updated this patch but it turned out that to applying your
remarks I should split this into a few commits. That's why I decided to
send it as a separate series[1].
@Andrzej
Could you please rebase your series on
On 10/27/2015 10:18 AM, Felipe Ferreri Tonello wrote:
> Hi Robert,
>
> On 27/10/15 06:53, Robert Baldyga wrote:
>> On 10/26/2015 05:55 PM, Felipe F. Tonello wrote:
>>> This function is shared between gadget functions, so this avoid unnecessary
>>> duplicated code and potentially avoid memory leaks
_hardware_enqueue() didn't check for errors when using
add_td_to_list() which can fail if dma_pool_alloc fails, thus
causing a kernel panic when lastnode->ptr is NULL.
Signed-off-by: Felipe F. Tonello
---
drivers/usb/chipidea/udc.c | 19 ++-
1 file changed, 14 insertions(+), 5 de
Hello.
On 10/27/2015 2:23 AM, Nathan Sullivan wrote:
The USB gadget support currently depends on power management
(CONFIG_PM) being enabled, but does not actually need it enabled.
Remove this dependency.
Tested on Bay Trail hardware with dwc3 USB.
Signed-off-by: Nathan Sullivan
---
drivers
Hi Robert,
On 27/10/15 09:47, Robert Baldyga wrote:
> On 10/27/2015 10:18 AM, Felipe Ferreri Tonello wrote:
>> Hi Robert,
>>
>> On 27/10/15 06:53, Robert Baldyga wrote:
>>> On 10/26/2015 05:55 PM, Felipe F. Tonello wrote:
This function is shared between gadget functions, so this avoid unneces
Hi Balbi,
On 26/10/15 16:55, Felipe F. Tonello wrote:
> Patch 7 has changes on how to transmit IN USB requests. It implements a FIFO
> of pre-allocated usb requests and uses then as needed, instead of allocating
> then on demand. This is my initial implementation and is open for
> suggestions and
On Sat, 17 Oct 2015, Vladimir Zapolskiy wrote:
> The changeset contains a couple of fixes in the LPC32xx OHCI driver
> related to clock enable/disable usage and one more fix of improper
> phy device release on driver removal.
>
> Vladimir Zapolskiy (3):
> usb: host: lpc32xx: fix warnings caused
Hi,
this is v11 of an attempt to make it easier for devices to remain in
runtime PM when the system goes to sleep, mainly to reduce the time
spent resuming devices.
For this, we interpret the absence of all PM callback implementations as
it being safe to do direct_complete, so their ancestors are
Have dev_pm_ops.prepare return 1 for USB devices and ports so that USB
devices can remain runtime-suspended when the system goes to a sleep
state, if their wakeup state is correct and they have runtime PM enabled.
Signed-off-by: Tomeu Vizoso
Reviewed-by: Ulf Hansson
Acked-by: Alan Stern
---
Ch
Hi,
Yoshihiro Shimoda writes:
> Hi,
>
>> From: Felipe Balbi [mailto:ba...@ti.com]
>> Sent: Monday, October 26, 2015 11:27 PM
>>
>> Hi,
>>
>> Yoshihiro Shimoda writes:
>> > This patch fixes the hcd private size to sutabile size.
>>
>>
On Thu, Oct 22, 2015 at 10:25:26AM +0800, Peter Hung wrote:
> Hi Johan,
>
> Johan Hovold 於 2015/9/14 下午 09:33 寫道:
> > On Tue, Jul 21, 2015 at 09:58:19AM +0800, Peter Hung wrote:
>
> >>4. RS422 Mode
> >> 1. The RTS mode is dont care.
> >> 2. Set M2/M1/M0 as 0/0/0
> >
>
Hi,
the theory that the lack of support for put_char() is a
major contributor to character loss in cdc-acm can be tested.
Sven, could you test the attached patch? It implements
the support.
Regards
Oliver
From f3871a76d7e2876b0e6ad66aee91085ecf9b2785 Mon Sep 17 00:00:00 2
On 10/27/2015 01:41 AM, Uwe Kleine-König wrote:
Hello,
On Mon, Oct 26, 2015 at 08:08:58PM -0600, Stephen Warren wrote:
On 10/26/2015 03:28 AM, Alexander Aring wrote:
This patch changes devm_phy_get to devm_phy_optional_get. Which fixes the
error handling when trying to get the phy. Currently o
On Thu, Oct 22, 2015 at 04:12:00PM -0500, Konstantin Shkolnyy wrote:
> cp2108 GET_LINE_CTL returns the 16-bit value with the 2 bytes swapped.
> However, SET_LINE_CTL functions properly. When the driver tries to modify
> the register, it reads it, modifies some bits and writes back. Because the
> re
Hey Oliver,
On 27/10/15 16:07, Oliver Neukum wrote:
> the theory that the lack of support for put_char() is a
> major contributor to character loss in cdc-acm can be tested.
> Sven, could you test the attached patch? It implements
> the support.
Thanks a lot for caring about this. I applied the pa
Hello,
On Tue, Oct 27, 2015 at 09:08:27AM -0600, Stephen Warren wrote:
> On 10/27/2015 01:41 AM, Uwe Kleine-König wrote:
> >Hello,
> >
> >On Mon, Oct 26, 2015 at 08:08:58PM -0600, Stephen Warren wrote:
> >>On 10/26/2015 03:28 AM, Alexander Aring wrote:
> >>>This patch changes devm_phy_get to devm_
otg_dev->extcon was referenced before otg_dev was initialized. Fix.
Cc: sta...@vger.kernel.org
Fixes: a2fd2423240f ("usb: phy: omap-otg: Replace deprecated API of extcon")
Signed-off-by: Aaro Koskinen
---
drivers/usb/phy/phy-omap-otg.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff
cp2108 GET_LINE_CTL returns the 16-bit value with the 2 bytes swapped.
However, SET_LINE_CTL functions properly. When the driver tries to modify
the register, it reads it, modifies some bits and writes back. Because the
read bytes were swapped, this often results in an invalid value to be
written.
This change is preparation for implementing a cp2108 bug workaround.
The workaround requires storing some private data. Right now the data is
attached to the USB interface and allocated in the attach() callback.
The bug detection requires USB I/O which is done easier from port_probe()
callback rath
Occasionally, writing data and immediately closing the port makes cp2108
stop responding. The device has to be unplugged to clear the error.
The failure is induced by shutting down the device while its Tx queue
still has unsent data. This condition is avoided by issuing PURGE command
from the close
The USB OTG support currently depends on power management
(CONFIG_PM) being enabled, but does not actually need it enabled.
Remove this dependency.
Tested on Bay Trail hardware with dwc3 USB.
Signed-off-by: Nathan Sullivan
---
drivers/usb/core/Kconfig |2 --
1 file changed, 2 deletions(-)
Adding support for device 0x07e8 (SP4 Type Cover)
Signed-off-by: savoca
---
drivers/hid/hid-core.c | 2 ++
drivers/hid/hid-ids.h | 1 +
drivers/hid/hid-microsoft.c | 2 ++
drivers/hid/usbhid/hid-quirks.c | 1 +
4 files changed, 6 insertions(+)
diff --git a/drivers/hid/hid
On Mon, Oct 26, 2015 at 11:11 AM, Alan Stern wrote:
> Michael:
>
> In the absence of any suggestions, we might as well try to verify my
> idea about what's going wrong. The patch below adds a little more
> debugging information; please try repeating the last test with this
> patch in place of the
Hi Aaro,
On 2015년 10월 28일 06:26, Aaro Koskinen wrote:
> otg_dev->extcon was referenced before otg_dev was initialized. Fix.
>
> Cc: sta...@vger.kernel.org
> Fixes: a2fd2423240f ("usb: phy: omap-otg: Replace deprecated API of extcon")
> Signed-off-by: Aaro Koskinen
> ---
> drivers/usb/phy/phy-om
On Tue, Oct 27, 2015 at 05:21:11PM -0500, Nathan Sullivan wrote:
> The USB OTG support currently depends on power management
> (CONFIG_PM) being enabled, but does not actually need it enabled.
> Remove this dependency.
>
> Tested on Bay Trail hardware with dwc3 USB.
>
> Signed-off-by: Nathan Sull
Function ep_ring_is_processing() checks the dequeue pointer
in endpoint context to know whether an endpoint is busy with
processing TRBs. This is not correct since dequeue pointer
field in an endpoint context is only valid when the endpoint
is in Halted or Stopped states. This buggy code causes aud
On driver detach, devm_phy_release() will put a refcount to
the phy, so gets a refconut to it before return.
Signed-off-by: Chunfeng Yun
---
drivers/phy/phy-core.c | 21 +++--
1 file changed, 15 insertions(+), 6 deletions(-)
diff --git a/drivers/phy/phy-core.c b/drivers/phy/phy-
60 matches
Mail list logo