On Wed, Sep 30, 2015 at 02:24:30PM -0700, Duc Dang wrote:
> On Thu, Sep 17, 2015 at 11:19 AM, Duc Dang wrote:
> > The xhci platform driver does not work with system that only supports
> > 64-bit DMA as it requests 32-bit DMA mask during driver initialization.
> > This patch set addresses this issu
On Thu, Oct 01, 2015 at 06:40:30PM +0300, Mathias Nyman wrote:
> This patchseries adds the USB 3.1 groundwork.
>
> USB 3.1 specification includes a new SuperSpeedPlus protocol supporting
> up to 10Gbps speeds. USB 3.1 devices using the new SuperSpeedPlus protocol
> are called USB 3.1 Gen2 devices.
On Fri, Jul 31, 2015 at 12:49:10AM +0530, Muthu M wrote:
> Fixed the issue in displaying lengthy string descriptor (more than 128 bytes)
>
> Signed-off-by: Muthu M
> ---
> usbmisc.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
Applied, thanks.
greg k-h
--
To unsubscribe from this li
On Mon, Sep 07, 2015 at 02:13:57PM +0800, Peter Chen wrote:
> The bulk queue tests are used to show 'best performance' for bulk
> transfer, we are often asked this question by users. The implementation
> is the same with iso test, that is queue request at interrupt completion,
> so we reuse the iso
On Sun, Sep 27, 2015 at 03:48:24PM +0200, Rafael J. Wysocki wrote:
> On Sun, Sep 27, 2015 at 12:04 AM, Viresh Kumar
> wrote:
> > global_lock is defined as an unsigned long and accessing only its lower
> > 32 bits from sysfs is incorrect, as we need to consider other 32 bits
> > for big endian 64-
On Sat, Oct 03, 2015 at 05:19:39PM +0200, Christoph Hellwig wrote:
> Signed-off-by: Christoph Hellwig
> ---
> Documentation/DMA-API.txt | 13 -
> drivers/usb/host/ehci-hcd.c | 2 +-
> drivers/usb/host/fotg210-hcd.c | 2 +-
> drivers/usb/host/fusbh200-hcd.c | 2 +-
> driv
On Fri, Oct 2, 2015 at 7:52 PM, Alan Stern wrote:
> On Fri, 2 Oct 2015, Felipe Balbi wrote:
>
>> On Mon, Sep 21, 2015 at 05:01:10PM +0200, Peter Senna Tschudin wrote:
>> > msleep under 20ms can result in sleeping up to 20ms, which may not be
>> > intended. Replace msleep(5) by usleep_range(5000, 6
On 30 September 2015 at 13:07, Austin S Hemmelgarn wrote:
> On 2015-09-29 18:11, Eric Curtin wrote:
>>
>> On 25 September 2015 at 16:45, Austin S Hemmelgarn
>> wrote:
>>>
>>> On 2015-09-25 08:02, Jiri Kosina wrote:
On Fri, 25 Sep 2015, Felipe Tonello wrote:
> Maybe a bette
On Sun, 4 Oct 2015, Peter Senna Tschudin wrote:
> On Fri, Oct 2, 2015 at 7:52 PM, Alan Stern wrote:
> > On Fri, 2 Oct 2015, Felipe Balbi wrote:
> >
> >> On Mon, Sep 21, 2015 at 05:01:10PM +0200, Peter Senna Tschudin wrote:
> >> > msleep under 20ms can result in sleeping up to 20ms, which may not
On Sun, 4 Oct 2015, Eric Curtin wrote:
> Ok so for the fun of it, I changed the VENDOR_ID and DEVICE_ID of my
> keyboard to use the driver for this samsung Wireless keyboard and
> mouse, crazy I know since I have a different piece of hardware, but I
> wanted to see what happens or at least does it
Fix using the bare numbers to set the 'bDescriptorType' descriptor fields
while the values are #define'd in .
Signed-off-by: Sergei Shtylyov
---
The patch is against the 'usb-next' branch of Greg KH's 'usb.git' repo.
I's been laying around from the end of March. :-(
drivers/usb/core/hcd.c
Hello.
Here's a set of 8 patches against the 'usb-next' branch of Greg KH's
'usb.git' repo. It's to eliminate the use of the PCI_DEVICE() macro where
less verbose PCI_VDEVICE() should have been used.
[1/8] ehci-pci: use PCI_VDEVICE() instead of PCI_DEVICE()
[2/8] ohci-pci:-use-PCI_VDEVICE() i
Fix using the PCI_DEVICE() macro instead of less verbose PCI_VDEVICE().
Signed-off-by: Sergei Shtylyov
---
drivers/usb/host/ehci-pci.c |6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
Index: usb/drivers/usb/host/ehci-pci.c
=
Fix using the PCI_DEVICE() macro instead of less verbose PCI_VDEVICE().
Signed-off-by: Sergei Shtylyov
---
drivers/usb/host/ohci-pci.c | 20 ++--
1 file changed, 10 insertions(+), 10 deletions(-)
Index: usb/drivers/usb/host/ohci-pci.c
=
Fix using the PCI_DEVICE() macro instead of less verbose PCI_VDEVICE().
Signed-off-by: Sergei Shtylyov
---
drivers/usb/chipidea/ci_hdrc_pci.c |6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
Index: usb/drivers/usb/chipidea/ci_hdrc_pci.c
===
Fix using the PCI_DEVICE() macro instead of less verbose PCI_VDEVICE().
Signed-off-by: Sergei Shtylyov
---
drivers/usb/dwc2/pci.c |5 ++---
1 file changed, 2 insertions(+), 3 deletions(-)
Index: usb/drivers/usb/dwc2/pci.c
===
Fix using the PCI_DEVICE() macro instead of less verbose PCI_VDEVICE().
Signed-off-by: Sergei Shtylyov
---
drivers/usb/dwc3/dwc3-pci.c | 17 +++--
1 file changed, 7 insertions(+), 10 deletions(-)
Index: usb/drivers/usb/dwc3/dwc3-pci.c
=
On Sat, 3 Oct 2015, Felipe Balbi wrote:
> > The WiiU adapter from Mayflash (see
> > http://www.mayflash.com/Products/NINTENDOWiiU/W009.html) is not
> > working correctly.
> >
> > The "XInput" mode works fine, the controller is recognized as a xbox
> > controller. But it is only possible to conn
Fix using the PCI_DEVICE() macro instead of less verbose PCI_VDEVICE().
Signed-off-by: Sergei Shtylyov
---
drivers/usb/gadget/udc/amd5536udc.c |2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
Index: usb/drivers/usb/gadget/udc/amd5536udc.c
===
Fix using the PCI_DEVICE() macro instead of less verbose PCI_VDEVICE().
Signed-off-by: Sergei Shtylyov
---
drivers/usb/gadget/udc/pch_udc.c |9 -
1 file changed, 4 insertions(+), 5 deletions(-)
Index: usb/drivers/usb/gadget/udc/pch_udc.c
Fix using the PCI_DEVICE() macro instead of less verbose PCI_VDEVICE().
Signed-off-by: Sergei Shtylyov
---
drivers/usb/gadget/udc/bdc/bdc_pci.c |2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
Index: usb/drivers/usb/gadget/udc/bdc/bdc_pci.c
=
On Fri, Oct 02, 2015 at 02:11:25PM -0500, Felipe Balbi wrote:
> On Fri, Oct 02, 2015 at 07:49:09PM +0100, Mark Brown wrote:
> > On Fri, Oct 02, 2015 at 12:23:11PM -0500, Felipe Balbi wrote:
> > > > Things more difficult, if nothing else it means we need to get whatever
> > > > userspace component
Hi Balbi,
>> John Feng-Hsin Chiang, can you confirm that from your side the
>> fusbh200 driver can be deleted?
>... but let's get this confirmation.
Yes, you can delete fusbh200.
Best Regards,
John Chiang
-Original Message-
From: Felipe Balbi [mailto:ba...@ti.com]
Sent: Sunday, October
On Mon, Oct 05, 2015 at 12:08:26AM +0300, Sergei Shtylyov wrote:
> Fix using the PCI_DEVICE() macro instead of less verbose PCI_VDEVICE().
Why? I hate PCI_VDEVICE(), it's impossible to grep for things and does
not help with readability and is pointless. My one wish was that when I
was the PCI ma
Hi Shawn,
Regarding below patch, Felipe has suggested to talk to you:
> [PATCH 3/3][v4] arm: dts: ls1021a: Add quirk for Erratum A009116
talk to you ARM-SoC maintainer.
https://lkml.org/lkml/2015/9/4/7
Please provide your comments. Inform me in case, if a resend is required.
Best Regards,
Raj
25 matches
Mail list logo