[PATCH v1] usb: phy: generic: migrate to gpio_desc

2014-11-09 Thread Robert Jarzmik
Change internal gpio handling from integer gpios into gpio descriptors. This change only addresses the internal API and device-tree/ACPI, while the legacy platform data remains integer space based. This change is only build compile tested, and very prone to error. I leave this comment for now in t

Re: [PATCH v1] usb: phy: generic: migrate to gpio_desc

2014-11-09 Thread Robert Jarzmik
Robert Jarzmik writes: > } else if (pdata) { > type = pdata->type; > clk_rate = pdata->clk_rate; > needs_vcc = pdata->needs_vcc; > - nop->gpio_reset = pdata->gpio_reset; > - } else { > - nop->gpio_reset = -1; > +

[PATCH v1] usb: phy: nop: device tree documentation for vbus

2014-11-09 Thread Robert Jarzmik
Enhance the phy documentation by adding 2 new optional bindings : - the vbus gpio, which detects usb insertion - the vbus regulator, which provides current drawn from the usb cable Signed-off-by: Robert Jarzmik --- Documentation/devicetree/bindings/usb/usb-nop-xceiv.txt | 8 1 file ch

[PATCH v1] usb: phy: generic: add vbus support

2014-11-09 Thread Robert Jarzmik
Add support for vbus detection and power supply. This code is more or less stolen from phy-gpio-vbus-usb.c, and aims at providing a detection mechanism for VBus (ie. usb cable plug) based on a GPIO line, and a power supply activation which draws current from the VBus. Signed-off-by: Robert Jarzmik

RE: [PATCH net-next 2/2] r8152: adjust rtl_start_rx

2014-11-09 Thread Hayes Wang
David Miller [mailto:da...@davemloft.net] > Sent: Saturday, November 08, 2014 12:35 AM [...] > Does this even work? > > If you leave a hole in the ring, the device is going to stop there > anyways. Excuse me. I don't sure I understand your meaning clearly. The behavior is different for PCI(e)

RE: [PATCH net-next v2 2/3] r8152: cleartheflagofSCHEDULE_TASKLETintasklet

2014-11-09 Thread Hayes Wang
Francois Romieu [mailto:rom...@fr.zoreil.com] > Sent: Sunday, November 09, 2014 6:12 AM [...] > The performance explanation leaves me a bit unconvinced. Without any > figure one could simply go for the always locked clear_bit because of: > 1. the "I'm racy" message that the open-coded test + set

Re: btusb_intr_complete returns -EPIPE

2014-11-09 Thread Naveen Kumar Parna
I am sorry for the late response. I applied the patch and here is the dmesg log: [ 713.125709] ehci-pci :00:1a.0: split intr info2 42821c01 token 80108d46 overlay token 80108d46 [ 713.125796] ehci-pci :00:1a.0: split intr info2 42821c01 token 80108d46 overlay token 80108d46 [ 713.12585