[PATCH net-next] r8152: nway reset after setting eee

2014-10-02 Thread Hayes Wang
Restart autonegotiation is necessary after setting EEE. Signed-off-by: Hayes Wang --- drivers/net/usb/r8152.c | 3 +++ 1 file changed, 3 insertions(+) diff --git a/drivers/net/usb/r8152.c b/drivers/net/usb/r8152.c index a4d4c4a..e4dcfc1 100644 --- a/drivers/net/usb/r8152.c +++ b/drivers/net/usb

[PATCH 1/2] usb: renesas_usbhs: rename phy to usb_phy in usbhs_priv

2014-10-02 Thread Yoshihiro Shimoda
To support a generic phy driver in this driver later, this patch renames "struct usb_phy *phy" to "struct usb_phy *usb_phy". This patch also cleans up this code. Signed-off-by: Yoshihiro Shimoda --- drivers/usb/renesas_usbhs/common.h |2 +- drivers/usb/renesas_usbhs/rcar2.c | 48

[PATCH 0/2] add support for generic PHY

2014-10-02 Thread Yoshihiro Shimoda
This patch series adds support for the generic PHY. This series is based on the origin/testing/next branch in Felipe's git. (commit id : 0255b031447df5a81988e2f312588d0e2c8c3688) Yoshihiro Shimoda (2): usb: renesas_usbhs: rename phy to usb_phy in usbhs_priv usb: renesas_usbhs: add support for

[PATCH 2/2] usb: renesas_usbhs: add support for generic PHY

2014-10-02 Thread Yoshihiro Shimoda
This patch adds support for the generic PHY. The generic PHY will be used in multiplatform environment. Signed-off-by: Yoshihiro Shimoda --- drivers/usb/renesas_usbhs/common.h |1 + drivers/usb/renesas_usbhs/rcar2.c | 29 + 2 files changed, 30 insertions(+) di

[PATCH 2/2] arm: shmobile: lager: enable HS-USB

2014-10-02 Thread Yoshihiro Shimoda
Signed-off-by: Yoshihiro Shimoda --- arch/arm/boot/dts/r8a7790-lager.dts |5 + 1 file changed, 5 insertions(+) diff --git a/arch/arm/boot/dts/r8a7790-lager.dts b/arch/arm/boot/dts/r8a7790-lager.dts index 1698591..4badd0a 100644 --- a/arch/arm/boot/dts/r8a7790-lager.dts +++ b/arch/arm/bo

[PATCH 0/2] arm: shimobile: add HS-USB device node on r8a7790

2014-10-02 Thread Yoshihiro Shimoda
This series is based on Simon's renesas.git branch and renesas-devel-20141002-v3.17-rc7 tag. If we use the generic phy driver for R-Car Gen2 (drivers/phy/phy-rcar-gen2.c), we can use the HS-USB on lager. Yoshihiro Shimoda (2): arm: shimobile: r8a7790: add HS-USB device node arm: shm

[PATCH 1/2] arm: shimobile: r8a7790: add HS-USB device node

2014-10-02 Thread Yoshihiro Shimoda
Signed-off-by: Yoshihiro Shimoda --- arch/arm/boot/dts/r8a7790.dtsi | 10 ++ 1 file changed, 10 insertions(+) diff --git a/arch/arm/boot/dts/r8a7790.dtsi b/arch/arm/boot/dts/r8a7790.dtsi index 2380fd5..fd9fc37 100644 --- a/arch/arm/boot/dts/r8a7790.dtsi +++ b/arch/arm/boot/dts/r8a7790.

[PATCH 1/3] arm: shimobile: r8a7791: add HS-USB device node

2014-10-02 Thread Yoshihiro Shimoda
Signed-off-by: Yoshihiro Shimoda --- arch/arm/boot/dts/r8a7791.dtsi | 10 ++ 1 file changed, 10 insertions(+) diff --git a/arch/arm/boot/dts/r8a7791.dtsi b/arch/arm/boot/dts/r8a7791.dtsi index d343099..393adcb 100644 --- a/arch/arm/boot/dts/r8a7791.dtsi +++ b/arch/arm/boot/dts/r8a7791.

[PATCH 0/3] arm: shimobile: add HS-USB device node on r8a7791

2014-10-02 Thread Yoshihiro Shimoda
This series is based on Simon's renesas.git branch and renesas-devel-20141002-v3.17-rc7 tag. If we use the generic phy driver for R-Car Gen2 (drivers/phy/phy-rcar-gen2.c), we can use the HS-USB on koelsch and henninger. Yoshihiro Shimoda (3): arm: shimobile: r8a7791: add HS-USB device

[PATCH 2/3] arm: shmobile: koelsch: enable HS-USB

2014-10-02 Thread Yoshihiro Shimoda
Signed-off-by: Yoshihiro Shimoda --- arch/arm/boot/dts/r8a7791-koelsch.dts |5 + 1 file changed, 5 insertions(+) diff --git a/arch/arm/boot/dts/r8a7791-koelsch.dts b/arch/arm/boot/dts/r8a7791-koelsch.dts index 3f55c16..b3dac1a 100644 --- a/arch/arm/boot/dts/r8a7791-koelsch.dts +++ b/arc

[PATCH 3/3] arm: shmobile: henninger: enable HS-USB

2014-10-02 Thread Yoshihiro Shimoda
Signed-off-by: Yoshihiro Shimoda --- arch/arm/boot/dts/r8a7791-henninger.dts |5 + 1 file changed, 5 insertions(+) diff --git a/arch/arm/boot/dts/r8a7791-henninger.dts b/arch/arm/boot/dts/r8a7791-henninger.dts index fee8bef..d0800d2 100644 --- a/arch/arm/boot/dts/r8a7791-henninger.dts +

[PATCH net] r8152: autoresume before setting MAC address

2014-10-02 Thread Hayes Wang
Resume the device before setting the MAC address. Signed-off-by: Hayes Wang --- drivers/net/usb/r8152.c | 16 +--- 1 file changed, 13 insertions(+), 3 deletions(-) diff --git a/drivers/net/usb/r8152.c b/drivers/net/usb/r8152.c index 604ef21..e823358 100644 --- a/drivers/net/usb/r815

Re: [PATCH net] r8152: autoresume before setting MAC address

2014-10-02 Thread Oliver Neukum
On Thu, 2014-10-02 at 16:26 +0800, Hayes Wang wrote: > Resume the device before setting the MAC address. > > Signed-off-by: Hayes Wang > --- > drivers/net/usb/r8152.c | 16 +--- > 1 file changed, 13 insertions(+), 3 deletions(-) > > diff --git a/drivers/net/usb/r8152.c b/drivers/net

[PATCH net v2] r8152: autoresume before setting MAC address

2014-10-02 Thread Hayes Wang
Resume the device before setting the MAC address. Signed-off-by: Hayes Wang --- drivers/net/usb/r8152.c | 11 +-- 1 file changed, 9 insertions(+), 2 deletions(-) diff --git a/drivers/net/usb/r8152.c b/drivers/net/usb/r8152.c index 604ef21..5ee7582 100644 --- a/drivers/net/usb/r8152.c ++

Re: [PATCH v2 10/24] uas: zap_pending: data urbs should have completed at this time

2014-10-02 Thread Oliver Neukum
On Sun, 2014-09-14 at 11:34 +0100, James Bottomley wrote: > I'm agnostic on that. I was just combatting the impression that you had > to be careful about side effects in known macro statements. No you haven't. But it is very good practice to not have side effects in warnings, as people, not comp

Re: [PATCH 1/2] usb: renesas_usbhs: rename phy to usb_phy in usbhs_priv

2014-10-02 Thread Sergei Shtylyov
Hello. On 10/2/2014 12:02 PM, Yoshihiro Shimoda wrote: To support a generic phy driver in this driver later, this patch renames "struct usb_phy *phy" to "struct usb_phy *usb_phy". This patch also cleans up this code. I think it's better to do rename and "cleanup" in separate patches.

Re: [PATCH 1/2] arm: shimobile: r8a7790: add HS-USB device node

2014-10-02 Thread Sergei Shtylyov
On 10/2/2014 12:04 PM, Yoshihiro Shimoda wrote: Signed-off-by: Yoshihiro Shimoda --- arch/arm/boot/dts/r8a7790.dtsi | 10 ++ 1 file changed, 10 insertions(+) diff --git a/arch/arm/boot/dts/r8a7790.dtsi b/arch/arm/boot/dts/r8a7790.dtsi index 2380fd5..fd9fc37 100644 --- a/arch/arm

Re: [PATCH 1/2] arm: shimobile: r8a7790: add HS-USB device node

2014-10-02 Thread Sergei Shtylyov
On 10/2/2014 12:04 PM, Yoshihiro Shimoda wrote: Signed-off-by: Yoshihiro Shimoda --- arch/arm/boot/dts/r8a7790.dtsi | 10 ++ 1 file changed, 10 insertions(+) diff --git a/arch/arm/boot/dts/r8a7790.dtsi b/arch/arm/boot/dts/r8a7790.dtsi index 2380fd5..fd9fc37 100644 --- a/arch/arm

Re: [PATCH 2/3] arm: shmobile: koelsch: enable HS-USB

2014-10-02 Thread Sergei Shtylyov
On 10/2/2014 12:05 PM, Yoshihiro Shimoda wrote: Signed-off-by: Yoshihiro Shimoda --- arch/arm/boot/dts/r8a7791-koelsch.dts |5 + 1 file changed, 5 insertions(+) diff --git a/arch/arm/boot/dts/r8a7791-koelsch.dts b/arch/arm/boot/dts/r8a7791-koelsch.dts index 3f55c16..b3dac1a 10064

[PATCH 2/2] uas: Make uas work with blk-mq

2014-10-02 Thread Hans de Goede
With uas over usb-3 the tags inside the uas iu-s must match the usb-3 stream ids, and those go from 1 - qdepth. Before blk-mq calling scsi_activate_tcq(sdev, qdepth) guaranteed that we would only get cmnd->request->tag from 0 - (qdepth - 1), and we used those as uas-tags / stream-ids. With blk-mq

[PATCH 1/2] uas: Reduce number of function arguments for uas_alloc_foo functions

2014-10-02 Thread Hans de Goede
The stream_id and pipe are already present in uas_cmd_info resp uas_dev_info, so there is no need to pass a copy along. Signed-off-by: Hans de Goede --- drivers/usb/storage/uas.c | 29 ++--- 1 file changed, 14 insertions(+), 15 deletions(-) diff --git a/drivers/usb/stora

Re: [PATCH 1/2] usb: renesas_usbhs: rename phy to usb_phy in usbhs_priv

2014-10-02 Thread Yoshihiro Shimoda
Hello. (2014/10/02 18:52), Sergei Shtylyov wrote: > Hello. > > On 10/2/2014 12:02 PM, Yoshihiro Shimoda wrote: > >> To support a generic phy driver in this driver later, this patch >> renames "struct usb_phy *phy" to "struct usb_phy *usb_phy". > >> This patch also cleans up this code. > >I

Re: [PATCH 1/2] uas: Reduce number of function arguments for uas_alloc_foo functions

2014-10-02 Thread Christoph Hellwig
On Thu, Oct 02, 2014 at 12:04:39PM +0200, Hans de Goede wrote: > The stream_id and pipe are already present in uas_cmd_info resp uas_dev_info, > so there is no need to pass a copy along. > > Signed-off-by: Hans de Goede Looks good, Reviewed-by: Christoph Hellwig -- To unsubscribe from this lis

Re: [PATCH 2/2] uas: Make uas work with blk-mq

2014-10-02 Thread Christoph Hellwig
Looks fine to me (and actually removes code..) Reviewed-by: Christoph Hellwig It's fairly late in 3.17 to get something like this in, but would you consider Ccing it to stable so we can get it into the first 3.17 stable release? -- To unsubscribe from this list: send the line "unsubscribe linux-

Re: [PATCH 1/2] arm: shimobile: r8a7790: add HS-USB device node

2014-10-02 Thread Yoshihiro Shimoda
Hello. (2014/10/02 18:59), Sergei Shtylyov wrote: > On 10/2/2014 12:04 PM, Yoshihiro Shimoda wrote: > >> Signed-off-by: Yoshihiro Shimoda >> --- >> arch/arm/boot/dts/r8a7790.dtsi | 10 ++ >> 1 file changed, 10 insertions(+) > >> diff --git a/arch/arm/boot/dts/r8a7790.dtsi b/arch/ar

Re: [PATCH 1/2] arm: shimobile: r8a7790: add HS-USB device node

2014-10-02 Thread Yoshihiro Shimoda
Hello. (2014/10/02 18:58), Sergei Shtylyov wrote: > On 10/2/2014 12:04 PM, Yoshihiro Shimoda wrote: > >> Signed-off-by: Yoshihiro Shimoda >> --- >> arch/arm/boot/dts/r8a7790.dtsi | 10 ++ >> 1 file changed, 10 insertions(+) > >> diff --git a/arch/arm/boot/dts/r8a7790.dtsi b/arch/ar

Re: [PATCH 2/3] arm: shmobile: koelsch: enable HS-USB

2014-10-02 Thread Yoshihiro Shimoda
Hello. (2014/10/02 19:02), Sergei Shtylyov wrote: > On 10/2/2014 12:05 PM, Yoshihiro Shimoda wrote: > >> Signed-off-by: Yoshihiro Shimoda >> --- >> arch/arm/boot/dts/r8a7791-koelsch.dts |5 + >> 1 file changed, 5 insertions(+) > >> diff --git a/arch/arm/boot/dts/r8a7791-koelsch.dts

Re: [PATCH 1/2] arm: shimobile: r8a7790: add HS-USB device node

2014-10-02 Thread Sergei Shtylyov
Hello. On 10/02/2014 03:40 PM, Yoshihiro Shimoda wrote: Signed-off-by: Yoshihiro Shimoda --- arch/arm/boot/dts/r8a7790.dtsi | 10 ++ 1 file changed, 10 insertions(+) diff --git a/arch/arm/boot/dts/r8a7790.dtsi b/arch/arm/boot/dts/r8a7790.dtsi index 2380fd5..fd9fc37 100644 ---

Re: [PATCH 2/2] uas: Make uas work with blk-mq

2014-10-02 Thread Hans de Goede
Hi, On 10/02/2014 01:26 PM, Christoph Hellwig wrote: > Looks fine to me (and actually removes code..) > > Reviewed-by: Christoph Hellwig > > It's fairly late in 3.17 to get something like this in, but would you > consider Ccing it to stable so we can get it into the first 3.17 stable > release?

Re: [PATCH 2/2] uas: Make uas work with blk-mq

2014-10-02 Thread Christoph Hellwig
On Thu, Oct 02, 2014 at 02:35:10PM +0200, Hans de Goede wrote: > This patch sits on top of a whole bunch of uas cleanups / fixes which > are going into 3.18, and which are to big of a change to backport. Can add a patch to set disable_blk_mq for uas on 3.17 then? -- To unsubscribe from this list:

Re: [PATCH 2/2] uas: Make uas work with blk-mq

2014-10-02 Thread Hans de Goede
Hi, On 10/02/2014 03:06 PM, Christoph Hellwig wrote: > On Thu, Oct 02, 2014 at 02:35:10PM +0200, Hans de Goede wrote: >> This patch sits on top of a whole bunch of uas cleanups / fixes which >> are going into 3.18, and which are to big of a change to backport. > > Can add a patch to set disable_b

Re: [PATCH 2/2] uas: Make uas work with blk-mq

2014-10-02 Thread Christoph Hellwig
On Thu, Oct 02, 2014 at 03:08:40PM +0200, Hans de Goede wrote: > Yes, although that likely would need to go through stable, without > going into 3.18 . > > Greg, is this ok with you and how do I get a patch in stable which > is not in upstream (because upstream will get a better fix) ? This is a

Re: [PATCH 2/2] uas: Make uas work with blk-mq

2014-10-02 Thread Hans de Goede
Hi, On 10/02/2014 03:12 PM, Christoph Hellwig wrote: > On Thu, Oct 02, 2014 at 03:08:40PM +0200, Hans de Goede wrote: >> Yes, although that likely would need to go through stable, without >> going into 3.18 . >> >> Greg, is this ok with you and how do I get a patch in stable which >> is not in ups

Re: [PATCH 2/2] uas: Make uas work with blk-mq

2014-10-02 Thread James Bottomley
On Thu, 2014-10-02 at 15:18 +0200, Hans de Goede wrote: > Hi, > > On 10/02/2014 03:12 PM, Christoph Hellwig wrote: > > On Thu, Oct 02, 2014 at 03:08:40PM +0200, Hans de Goede wrote: > >> Yes, although that likely would need to go through stable, without > >> going into 3.18 . > >> > >> Greg, is th

Re: [PATCH 2/2] uas: Make uas work with blk-mq

2014-10-02 Thread Greg Kroah-Hartman
On Thu, Oct 02, 2014 at 06:12:59AM -0700, Christoph Hellwig wrote: > On Thu, Oct 02, 2014 at 03:08:40PM +0200, Hans de Goede wrote: > > Yes, although that likely would need to go through stable, without > > going into 3.18 . > > > > Greg, is this ok with you and how do I get a patch in stable whic

Re: [PATCH 2/2] uas: Make uas work with blk-mq

2014-10-02 Thread Hans de Goede
Hi, On 10/02/2014 03:25 PM, James Bottomley wrote: > On Thu, 2014-10-02 at 15:18 +0200, Hans de Goede wrote: >> Hi, >> >> On 10/02/2014 03:12 PM, Christoph Hellwig wrote: >>> On Thu, Oct 02, 2014 at 03:08:40PM +0200, Hans de Goede wrote: Yes, although that likely would need to go through stab

[PATCH] usb: musb: cppi41: restart hrtimer only if not yet done

2014-10-02 Thread Sebastian Andrzej Siewior
From: Thomas Gleixner commit c58d80f52 ("usb: musb: Ensure that cppi41 timer gets armed on premature DMA TX irq") fixed hrtimer scheduling bug. There is one left which does not trigger that often. The following scenario is still possible: lock(&x->lock); hrtimer_start(&x->t); unlock(

Re: [PATCH v3 0/4] Allow xHCI drivers to be built as separate modules

2014-10-02 Thread Mathias Nyman
On 09/09/2014 05:27 PM, Mathias Nyman wrote: > On 09/03/2014 10:51 PM, Andrew Bresticker wrote: >> Mathias, >> >> On Tue, Aug 19, 2014 at 10:01 AM, Andrew Bresticker >> wrote: >>> It was suggested in the review of the Tegra xHCI driver [1] that we >>> allow xHCI drivers to be built as individual m

Re: [PATCH v3 0/4] Allow xHCI drivers to be built as separate modules

2014-10-02 Thread Greg Kroah-Hartman
On Thu, Oct 02, 2014 at 07:31:03PM +0300, Mathias Nyman wrote: > On 09/09/2014 05:27 PM, Mathias Nyman wrote: > > On 09/03/2014 10:51 PM, Andrew Bresticker wrote: > >> Mathias, > >> > >> On Tue, Aug 19, 2014 at 10:01 AM, Andrew Bresticker > >> wrote: > >>> It was suggested in the review of the Teg

RE: [PATCH] dwc2: Bits in bitfield should add up to 32

2014-10-02 Thread Paul Zimmerman
> From: Charles Manning [mailto:cdhmann...@gmail.com] > Sent: Wednesday, October 01, 2014 7:36 PM > > The unioned u32 is used for clearing etc. Having the number of > bitfield bits add up to more than 32 is broken, even if benign. > > Signed-off-by: Charles Manning > --- > drivers/usb/dwc2/core

Re: [PATCH] dwc2: Bits in bitfield should add up to 32

2014-10-02 Thread Felipe Balbi
On Thu, Oct 02, 2014 at 06:43:49PM +, Paul Zimmerman wrote: > > From: Charles Manning [mailto:cdhmann...@gmail.com] > > Sent: Wednesday, October 01, 2014 7:36 PM > > > > The unioned u32 is used for clearing etc. Having the number of > > bitfield bits add up to more than 32 is broken, even if b

Re: [PATCH] usb, misc: Fix a warning for using an uninitialized variable

2014-10-02 Thread Don Zickus
On Wed, Oct 01, 2014 at 09:15:23PM -0400, Don Zickus wrote: > Recently our build environment changed and started turning some warnings into > errors. One of the fallouts is this warning: > > CC [M] drivers/usb/misc/usb3503.o > drivers/usb/misc/usb3503.c: In function ‘usb3503_probe’: > drivers/

[PATCH] USB: serial: cp210x: Add Silicon Labs 358x VID and PID.

2014-10-02 Thread Nathaniel Ting
From: Nathaniel Ting Enable Silicon Labs Ember VID chips to enumerate with the cp210x usb serial driver. EM358x devices operating with the Ember Z-Net 5.1.2 stack may now connect to host PCs over a USB serial link. Signed-off-by: Nathaniel Ting --- drivers/usb/serial/cp210x.c | 1 + 1 file cha

Re: [PATCH] USB: serial: cp210x: Add Silicon Labs 358x VID and PID.

2014-10-02 Thread Greg KH
On Thu, Oct 02, 2014 at 05:38:17PM -0400, Nathaniel Ting wrote: > From: Nathaniel Ting > > Enable Silicon Labs Ember VID chips to enumerate with the cp210x usb serial > driver. EM358x devices operating with the Ember Z-Net 5.1.2 stack may now > connect to host PCs over a USB serial link. > > Sig

Re: [PATCH 1/2] arm: shimobile: r8a7790: add HS-USB device node

2014-10-02 Thread Sergei Shtylyov
On 10/02/2014 12:04 PM, Yoshihiro Shimoda wrote: Signed-off-by: Yoshihiro Shimoda --- arch/arm/boot/dts/r8a7790.dtsi | 10 ++ 1 file changed, 10 insertions(+) diff --git a/arch/arm/boot/dts/r8a7790.dtsi b/arch/arm/boot/dts/r8a7790.dtsi index 2380fd5..fd9fc37 100644 --- a/arch/ar

Re: [PATCH v6 2/4] i2c: add support for Diolan DLN-2 USB-I2C adapter

2014-10-02 Thread Wolfram Sang
Hi, > diff --git a/drivers/i2c/busses/Kconfig b/drivers/i2c/busses/Kconfig > index 2ac87fa..6afc17e 100644 > --- a/drivers/i2c/busses/Kconfig > +++ b/drivers/i2c/busses/Kconfig > @@ -1021,4 +1021,14 @@ config SCx200_ACB > This support is also available as a module. If so, the module >