On Thu, Sep 18, 2014 at 06:54:34PM +0300, Octavian Purdila wrote:
> On Thu, Sep 18, 2014 at 3:46 PM, Johan Hovold wrote:
> > On Thu, Sep 18, 2014 at 03:43:07PM +0300, Octavian Purdila wrote:
> >> On Thu, Sep 18, 2014 at 1:54 PM, Johan Hovold wrote:
> >> > On Tue, Sep 09, 2014 at 10:24:46PM +0300,
If the hw is in ALDPS mode, the hw may have no response for accessing
the most registers. Therefore, the ALDPS should be disabled before
accessing the hw in rtl_ops.init(), rtl_ops.disable(), rtl_ops.up(),
and rtl_ops.down(). Regardless of rtl_ops.enable(), because the hw
wouldn't enter ALDPS mode
According to user manual, pcs_tx_deemph_3p5db field in PHYPARAM1
register is 6bits wide, so mask value should be 0x3f instead
of 0x1f.
Signed-off-by: Anton Tikhomirov
---
drivers/phy/phy-exynos5-usbdrd.c |2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/phy/phy-exyno
On Friday, September 19, 2014 4:36 PM, Anton Tikhomirov wrote:
>
> According to user manual, pcs_tx_deemph_3p5db field in PHYPARAM1
> register is 6bits wide, so mask value should be 0x3f instead
> of 0x1f.
>
> Signed-off-by: Anton Tikhomirov
Reviewed-by: Jingoo Han
Best regards,
Jingoo Han
>
Hi Anton,
On Fri, Sep 19, 2014 at 1:05 PM, Anton Tikhomirov
wrote:
> According to user manual, pcs_tx_deemph_3p5db field in PHYPARAM1
> register is 6bits wide, so mask value should be 0x3f instead
> of 0x1f.
>
> Signed-off-by: Anton Tikhomirov
> ---
> drivers/phy/phy-exynos5-usbdrd.c |2 +-
Hi Michael,
On 08/04/2014 06:27 PM, Michael Welling wrote:
> On Mon, Aug 04, 2014 at 12:34:16PM +0300, Roger Quadros wrote:
>> On 08/02/2014 02:51 AM, Michael Welling wrote:
>>> On Fri, Aug 1, 2014 at 6:04 PM, Michael Welling
>>> wrote:
On Wed, Jul 30, 2014 at 12:03:22PM +0300, Roger Quadro
Hi Roger
On Fri, Sep 19, 2014 at 11:22 AM, Roger Quadros wrote:
> Hi Michael,
>
> On 08/04/2014 06:27 PM, Michael Welling wrote:
>> On Mon, Aug 04, 2014 at 12:34:16PM +0300, Roger Quadros wrote:
>>> On 08/02/2014 02:51 AM, Michael Welling wrote:
On Fri, Aug 1, 2014 at 6:04 PM, Michael Wellin
--
To unsubscribe from this list: send the line "unsubscribe linux-usb" in
the body of a message to majord...@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
On 09/19/2014 12:37 PM, Michael Trimarchi wrote:
> Hi Roger
>
> On Fri, Sep 19, 2014 at 11:22 AM, Roger Quadros wrote:
>> Hi Michael,
>>
>
> It should be noted that the external HUB must be prevented from
> autosuspend
> otherwise the resume fails.
OK. I was able to
We have a USB dongle with the cp210x chip on.
And we have put our own USB id into it.
Signed-off-by: Andreas Bomholtz
---
diff --git a/drivers/usb/serial/cp210x.c b/drivers/usb/serial/cp210x.c
index e4bb622..abd7577 100644
--- a/drivers/usb/serial/cp210x.c
+++ b/drivers/usb/serial/cp210x.c
@@ -1
On Fri, Sep 19, 2014 at 01:23:03PM +0200, Andreas Bomholtz wrote:
> We have a USB dongle with the cp210x chip on.
> And we have put our own USB id into it.
>
> Signed-off-by: Andreas Bomholtz
Thanks for the patch. There are just two minor issues. Your patch appear
to have been line wrapped by yo
On 9/12/14, 11:28 AM, Bartlomiej Zolnierkiewicz wrote:
>
> [ added linux-kernel ML to cc: ]
>
> Hi,
>
> On Tuesday, August 26, 2014 11:19:59 AM dingu...@opensource.altera.com wrote:
>> From: Dinh Nguyen
>>
>> Since the dwc2 hcd driver is currently not looking for a clock node during
>> init,
Hi,
On Thursday, September 18, 2014 10:54:24 AM Dinh Nguyen wrote:
> Hi Bartlomiej,
>
> On 09/12/2014 10:49 AM, Bartlomiej Zolnierkiewicz wrote:
> >
> > [ added linux-kernel ML to cc: ]
> >
> > Hi,
> >
> > On Tuesday, August 26, 2014 11:19:52 AM dingu...@opensource.altera.com
> > wrote:
> >>
On Thu, Sep 18, 2014 at 09:31:32AM -0500, Felipe Balbi wrote:
> This reverts commit f2267089ea17fa97b796b1b4247e3f8957655df3.
>
> That commit causes more problem than fixes. Firstly, kfree()
> should be called after usb_ep_dequeue() and secondly, the way
> things are, we will try to dequeue a requ
We would like to convert khubd kthread to a workqueue. As a result hub_events()
will handle only one event per call.
In fact, we could do this already now because there is another cycle in
hub_thread(). It calls hub_events() until hub_event_list is empty.
This patch renames the function to hub_ev
This is just a small optimization of the fix from the commit c605f3cdff53a743f6
("usb: hub: take hub->hdev reference when processing from eventlist).
We do not need to take the reference for each event. Instead we could get it
when struct usb_hub is allocated and put it when it is released. By oth
It seems that only choose_devnum() was not ready to process more hub
events at the same time.
All should be fine if we take bus->usb_address0_mutex there. It will
make sure that more devnums will not be chosen for the given bus and
the related devices at the same time.
Signed-off-by: Petr Mladek
USB hub has started to use a workqueue instead of kthread. Let's update
the documentation and comments here and there.
This patch mostly just replaces "khubd" with "hub_wq". There are only few
exceptions where the whole sentence was updated. These more complicated
changes can be found in the follo
There is no need to have separate kthread for handling USB hub events.
It is more elegant to use the workqueue framework.
The workqueue is allocated as freezable because the original thread was
freezable as well.
Also it is allocated as ordered because the code is not ready for parallel
processin
USB hub started to use a workqueue instead of kthread. Let's make it clear from
the function names.
Signed-off-by: Petr Mladek
---
drivers/usb/core/hcd.c | 4 ++--
drivers/usb/core/hub.c | 2 +-
drivers/usb/core/usb.h | 2 +-
3 files changed, 4 insertions(+), 4 deletions(-)
diff --git a/drivers
The 3rd version of the patchset is slightly reordered and refactored
as suggested earlier. See below for more details.
IMHO, the result is more clean. But feel free to ask me to revert it.
I do not want to make the review more complicated. Well, I double checked
the diff of patches files between v
> From: Bartlomiej Zolnierkiewicz [mailto:b.zolnier...@samsung.com]
> Sent: Friday, September 19, 2014 7:50 AM
>
> Unfortunately after second look there are even more problems with Kconfig
> changes, please see below.
>
> > >
> > >> if USB_DWC2
> > >>
> > >> +choice
> > >> +bool "DWC2 Mo
On Fri, 19 Sep 2014, Petr Mladek wrote:
> The 3rd version of the patchset is slightly reordered and refactored
> as suggested earlier. See below for more details.
>
> IMHO, the result is more clean. But feel free to ask me to revert it.
> I do not want to make the review more complicated. Well, I
As the udc clock controls both the output signals and the internal IP,
it must be enabled before any UDC register is touched.
The bug is revealed when the clock framework disables the clock for a
couple of milliseconds during the boot sequence, and the endpoint
configuration is lost. The bug is hi
Use devm_* helpers in the probe function to simplify the error path and
the remove path.
Signed-off-by: Robert Jarzmik
Cc: Sergei Shtylyov
---
Since V1: Addressed Sergei's comments
Since V2: Addressed Sergei's comments on includes
Since V4: Addressed Sergei's comment on clk_uprepare in probe()
Add support for device-tree device discovery. If devicetree is not
provided, fallback to legacy platform data "discovery".
Signed-off-by: Robert Jarzmik
Cc: devicet...@vger.kernel.org
---
Since V1: change OF id mrvl,pxa27x_udc -> marvell,pxa27x-udc
This is a consequence of other DT rev
Add documentation for device-tree binding of arm PXA 27x udc (usb
device) driver.
Signed-off-by: Robert Jarzmik
Cc: devicet...@vger.kernel.org
---
Since V1: change OF id mrvl,pxa27x_udc -> marvell,pxa27x-udc
This is a consequence of other DT reviews on the marvell
namings.
Si
The pxa27x_udc should support 2 modes of initialization :
- one through legacy platform data
- one new through device-tree
Prepare the double support by moving the initialization data, ie. the
gpios, into the udc control structure.
Signed-off-by: Robert Jarzmik
---
Since v5: This new patch, s
This patch series adds support for Diolan USB-I2C/GPIO Master Adapter
DLN-2. Details about device can be found here:
https://www.diolan.com/i2c/i2c_interface.html.
Changes since v4:
* Add a new gpiolib chip flag to allow blocking chips with non threaded
IRQ handlers
* MFD: set GPLv2 as licens
This patch implements the USB part of the Diolan USB-I2C/SPI/GPIO
Master Adapter DLN-2. Details about the device can be found here:
https://www.diolan.com/i2c/i2c_interface.html.
Information about the USB protocol can be found in the Programmer's
Reference Manual [1], see section 1.7.
Because th
Some GPIO chips (e.g. the DLN2 USB adapter) have blocking get/set
operation but do not need a threaded irq handler.
Signed-off-by: Octavian Purdila
---
drivers/gpio/gpiolib.c | 2 +-
include/linux/gpio/driver.h | 3 +++
2 files changed, 4 insertions(+), 1 deletion(-)
diff --git a/drivers/g
From: Laurentiu Palcu
This patch adds support for the Diolan DLN-2 I2C master module. Due
to hardware limitations it does not support SMBUS quick commands.
Information about the USB protocol interface can be found in the
Programmer's Reference Manual [1], see section 6.2.2 for the I2C
master mod
From: Daniel Baluta
This patch adds GPIO and IRQ support for the Diolan DLN-2 GPIO module.
Information about the USB protocol interface can be found in the
Programmer's Reference Manual [1], see section 2.9 for the GPIO
module commands and responses.
[1] https://www.diolan.com/downloads/dln-api
Hi,
On Fri, Sep 19, 2014 at 09:46:22PM +0200, Robert Jarzmik wrote:
> The pxa27x_udc should support 2 modes of initialization :
> - one through legacy platform data
> - one new through device-tree
>
> Prepare the double support by moving the initialization data, ie. the
> gpios, into the udc co
Felipe Balbi writes:
> On Fri, Sep 19, 2014 at 09:46:22PM +0200, Robert Jarzmik wrote:
>> Since v5: This new patch, split out of the first DT patch
>
> please resend once v3.18-rc1 is out. But...
There are 2 -rc left for v3.17, can't this serie make it for 3.18 merge window ?
>> +if
Hi Greg,
How would you feel about Felipe taking the dwc2 driver into his tree?
There has been quite a bit of increased activity with dwc2 lately, and
I know you already have more than enough stuff on your plate already.
So this would mean one less thing for you to worry about. Plus it
would mean a
On Fri, Sep 19, 2014 at 08:52:07PM +, Paul Zimmerman wrote:
> Hi Greg,
>
> How would you feel about Felipe taking the dwc2 driver into his tree?
> There has been quite a bit of increased activity with dwc2 lately, and
> I know you already have more than enough stuff on your plate already.
> So
Hi,
On Fri, Sep 19, 2014 at 10:48:25PM +0200, Robert Jarzmik wrote:
> Felipe Balbi writes:
>
> > On Fri, Sep 19, 2014 at 09:46:22PM +0200, Robert Jarzmik wrote:
> >> Since v5: This new patch, split out of the first DT patch
> >
> > please resend once v3.18-rc1 is out. But...
> There are 2 -rc le
On Fri, Sep 19, 2014 at 02:01:50PM -0700, gre...@linuxfoundation.org wrote:
> On Fri, Sep 19, 2014 at 08:52:07PM +, Paul Zimmerman wrote:
> > Hi Greg,
> >
> > How would you feel about Felipe taking the dwc2 driver into his tree?
> > There has been quite a bit of increased activity with dwc2 la
Starting with v3.18-rc, patches for dwc2 will go through Felipe's
tree. Add a T: line to MAINTAINERS to document this.
Signed-off-by: Paul Zimmerman
---
MAINTAINERS | 1 +
1 file changed, 1 insertion(+)
diff --git a/MAINTAINERS b/MAINTAINERS
index 809ecd6..bffd59c 100644
--- a/MAINTAINERS
+++ b
On Thu, Sep 18, 2014 at 09:46:11AM -0500, Felipe Balbi wrote:
> Hi Greg,
>
> Here you go. This one should be good to go. Sorry for the last minute
> change but it was better to revert those patches than having a broken
> v3.17 final. Let me know if you want any changes.
>
> cheers
>
> The follow
On Fri, Sep 19, 2014 at 02:49:36PM -0700, Paul Zimmerman wrote:
> Starting with v3.18-rc, patches for dwc2 will go through Felipe's
> tree. Add a T: line to MAINTAINERS to document this.
>
> Signed-off-by: Paul Zimmerman
Now applied. I've caught up with all pending dwc2 patches that I know
of.
On Friday 19 September 2014, Octavian Purdila wrote:
> +struct dln2_gpio_pin {
> + __le16 pin;
> +} __packed;
This does not need to be marked packed, since it is never embedded in another
structure.
> +struct dln2_gpio_pin_val {
> + __le16 pin;
> + u8 value;
> +} __packed;
It's enoug
Hello Maintainers:
Please help check this patch, when you have time.
Thanks.
On 09/08/2014 01:20 PM, Michal Simek wrote:
> On 09/03/2014 05:50 PM, Chen Gang wrote:
>> Need include it for irq_of_parse_and_map(), the related error with
>> allmodconfig under microblaze:
>>
>> drivers/usb/host/ehc
On Sat, Sep 20, 2014 at 5:48 AM, Arnd Bergmann wrote:
> On Friday 19 September 2014, Octavian Purdila wrote:
>> +struct dln2_gpio_pin {
>> + __le16 pin;
>> +} __packed;
>
> This does not need to be marked packed, since it is never embedded in another
> structure.
>
Will do.
>> +struct dln2_g
45 matches
Mail list logo