On Tue, Sep 03, 2013 at 08:59:59AM +0530, Kumar Gaurav wrote:
> I tried applying this patch on linux-next and it applies well.
> i used
> git apply --apply
>
The merge window is open. No one is applying patches until -rc1 comes
out.
This one is not redone in the right way. The subject is w
Add suspend/resume API for system suspend/resume procedure.
Signed-off-by: Peter Chen
---
drivers/usb/chipidea/ci_hdrc_imx.c | 72 +++-
1 files changed, 71 insertions(+), 1 deletions(-)
diff --git a/drivers/usb/chipidea/ci_hdrc_imx.c
b/drivers/usb/chipidea/ci_
It is used to let the PHY enters low power mode at
controller suspend routine.
Signed-off-by: Peter Chen
---
drivers/usb/chipidea/bits.h |1 +
drivers/usb/chipidea/core.c | 14 ++
include/linux/usb/chipidea.h |1 +
3 files changed, 16 insertions(+), 0 deletions(-)
diff -
On Tue, Sep 3, 2013 at 6:26 AM, Peter Chen wrote:
> +static const struct dev_pm_ops ci_hdrc_imx_pm_ops = {
> + SET_SYSTEM_SLEEP_PM_OPS(ci_hdrc_imx_suspend, ci_hdrc_imx_resume)
What about using the macro SIMPLE_DEV_PM_OPS instead?
--
To unsubscribe from this list: send the line "unsubscribe
Hi,
This patch series enables uas support in the linux kernel. First patch
fixes usb3 streams support in xhci, patches 2-4 improve uas error
handling and patch 5 removes BROKEN from the uas kernel config.
v2 changes:
- use WARN_ON_ONCE() instead of BUG_ON()
- make checkpatch happy (codestyle
xhci maintains a radix tree for each stream endpoint because it must
be able to map a trb address to the stream ring. Each ring segment
must be added to the ring for this to work. Currently xhci sticks
only the first segment of each stream ring into the radix tree.
Result is that things work ini
This patch prepares for the addition of another list and renames the
work list lock and the list_head field in struct uas_cmd_info.
Signed-off-by: Gerd Hoffmann
---
drivers/usb/storage/uas.c | 50 +++
1 file changed, 25 insertions(+), 25 deletions(-)
xhci streams support is fixed, unblock usb attached scsi.
Signed-off-by: Gerd Hoffmann
---
drivers/usb/storage/Kconfig | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/usb/storage/Kconfig b/drivers/usb/storage/Kconfig
index 8470e1b..4761a28 100644
--- a/drivers/usb/sto
This patch adds a new list where all requests which are canceled are
added to, so we don't loose them. Then, after killing all inflight
urbs on bus reset (and disconnect) we'll walk over the list and clean
them up.
Without this we can end up with aborted requests lingering around in
case of statu
Signed-off-by: Gerd Hoffmann
---
drivers/usb/storage/uas.c | 5 +
1 file changed, 5 insertions(+)
diff --git a/drivers/usb/storage/uas.c b/drivers/usb/storage/uas.c
index d966b59..fc08ee9 100644
--- a/drivers/usb/storage/uas.c
+++ b/drivers/usb/storage/uas.c
@@ -85,6 +85,8 @@ static int uas_
Hello,
Just wanted to check if anyone has this USB controller: Etron
Technology, Inc. EJ168 USB 3.0 Host Controller (rev 01) working on
linux.
Any thoughts on patch you had to use, etc., please?
Thanks
Joe
On Sun, Sep 1, 2013 at 4:14 PM, joe M wrote:
> Hello,
>
> I am not able to figure out ho
On Thu, 29 Aug 2013, James Stone wrote:
> At 32 frames/period (reported round-trip latency 1.33ms), it starts up
> but there are too many xruns for it to be usable.
After further testing (off-list), it turns out that 32 frames/period
works okay with three periods/buffer instead of two. Not surpr
On 08/29/2013 07:46 AM, Giovanni wrote:
https://bugzilla.kernel.org/show_bug.cgi?id=60810
Bug ID: 60810
Summary: Kernel oops with controller XHCI while wait usb packet
Hi
I'm looking into the NULL pointer issue after timed out address device
commands as well, but
On Tue, Sep 03, 2013 at 08:55:23PM +0530, Kishon Vijay Abraham I wrote:
> Hi Greg,
>
> On Wednesday 28 August 2013 12:50 AM, Felipe Balbi wrote:
> > Hi,
> >
> > On Mon, Aug 26, 2013 at 01:44:49PM +0530, Kishon Vijay Abraham I wrote:
> >> On Wednesday 21 August 2013 11:16 AM, Kishon Vijay Abraham
Hi Greg,
On Wednesday 28 August 2013 12:50 AM, Felipe Balbi wrote:
> Hi,
>
> On Mon, Aug 26, 2013 at 01:44:49PM +0530, Kishon Vijay Abraham I wrote:
>> On Wednesday 21 August 2013 11:16 AM, Kishon Vijay Abraham I wrote:
>>> Added a generic PHY framework that provides a set of APIs for the PHY
>>
I'm confused. I said the last version of this patch didn't apply
against usb-next, and you should rebase it. Why did you put "No Change"
in the subject prefix?
On Sat, Aug 31, 2013 at 11:02:45PM +0530, Kumar Gaurav wrote:
> This patch redefine function xhci_readl. xhci_readl function doesn't use
> > On Tue, Sep 03, 2013 at 02:14:14AM +0800, Giovanni
> wrote:
> > > > On Sat, Aug 31, 2013 at 12:11:49AM
> > > > +0800, Giovanni wrote:
> > > > >
> > > >
> > > > I drafted a patch, please have a test and
> enable
> > > > CONFIG_XHCI_HCD_DEBUGGING in kernel
> configuration at same
> > > > time.
Hi Joe,
I'm the xHCI driver maintainer, can you please Cc me on any future bug
reports for xHCI hosts? Otherwise it gets lost in my mailing list
inbox.
On Sun, Sep 01, 2013 at 04:14:52PM -0500, joe M wrote:
> Hello,
>
> I am not able to figure out how to connect a 1.11 usb full speed
> device t
On Sun, Sep 01, 2013 at 09:34:13PM -0400, Alan Stern wrote:
> On Mon, 2 Sep 2013, Xenia Ragiadakou wrote:
>
> > This patch adds a check to ensure that the device's state is not
> > NOTATTACHED,
> > ATTACHED, POWERED or RECONNECTING before trying to disable lpm, because if
> > the device is in one
On Mon, Sep 02, 2013 at 11:07:35AM +0530, Pratyush Anand wrote:
> On Fri, Aug 30, 2013 at 02:58:25AM +0800, Alan Stern wrote:
> > On Thu, 29 Aug 2013, Sarah Sharp wrote:
> >
> > > On Thu, Aug 29, 2013 at 10:06:16AM -0700, Greg Kroah-Hartman wrote:
> > > > Hi Sarah,
> > > >
> > > > I'm getting the
On Tue, Sep 03, 2013 at 10:34:56AM +0800, Huang Rui wrote:
> Please apply this patch based my last patch, and have a test again.
>
> 8<-- cut here
>
> diff --git a/drivers/usb/host/xhci-mem.c b/drivers/usb/host/xhci-mem.c
> index f2e57a1..61a95
On Tue, Sep 03, 2013 at 08:52:27AM -0500, joe M wrote:
> Hello,
Hi Joe,
I'm the xHCI driver maintainer, and it helps if you Cc me on questions.
Otherwise it can get lost in my mailing list inbox. You can find the
email addresses of other maintainers in the MAINTAINERS file:
http://lxr.free-elec
This patch updates the iso_stream_schedule() routine in ehci-sched.c
to handle cases where an underrun causes an isochronous endpoint's
queue to empty out, but the client driver wants to maintain
synchronization with the device (i.e., the URB_ISO_ASAP flag is not
set). This could not happen until
Greg:
This series of three patches modifies the isochronous scheduling
routine in ehci-hcd, adding changes that we need for proper operation
with tasklets (with a new inline routine needed in usbcore).
The problem is that we have to maintain the existing API guarantee that
URBs submitted in a com
Now that URBs can be completed inside tasklets, we need a way of
determining whether a completion handler for a given endpoint is
currently running. Otherwise it's not possible to maintain the API
guarantee about keeping isochronous streams synchronous when an
underrun occurs.
This patch adds a f
This patch interchanges the "if" and "else" branches of the big "if"
statement in iso_stream_schedule(), in preparation for the next patch
in this series. That is, it changes
if (likely(!...)) {
A
} else {
B
}
to
if (unlikely(...))
On Mon, Sep 02, 2013 at 08:40:47PM -0500, Daniel Santos wrote:
> On 09/02/2013 06:07 PM, Greg KH wrote:
> >On Mon, Sep 02, 2013 at 05:46:58PM -0500, Daniel Santos wrote:
> >>Hello guys. I didn't get a response the last time so hopefully with
> >>3.11 out I'll get one this time.
> >>
> >>I need to
On Tue, Sep 03, 2013 at 01:58:23PM -0400, Alan Stern wrote:
> Greg:
>
> This series of three patches modifies the isochronous scheduling
> routine in ehci-hcd, adding changes that we need for proper operation
> with tasklets (with a new inline routine needed in usbcore).
>
> The problem is that w
Don't you need to send an ABORT TASK message to the device to cancel the
outstanding request for that stream ID? I don't see that in this code.
I see lots of URB cancellation code, but nothing to remove the request
from the device-side queue.
Does this code currently handle the case where a devic
On Tue, 3 Sep 2013, Sarah Sharp wrote:
> > With the USB 2.0 hub, I could use usbmon to check out why the device
> > does not work. Using usbmon on a USB 3.0 hub does not seem to show any
> > valuable output. I tried both usbmon client and 'cat 6u' (where 6 is
> > the bus id) to check usbmon output
On Tue, 3 Sep 2013, Greg KH wrote:
> On Tue, Sep 03, 2013 at 01:58:23PM -0400, Alan Stern wrote:
> > Greg:
> >
> > This series of three patches modifies the isochronous scheduling
> > routine in ehci-hcd, adding changes that we need for proper operation
> > with tasklets (with a new inline routin
On Fri, Aug 23, 2013 at 11:15:14AM +0300, Xenia Ragiadakou wrote:
> This patch replaces 'xhci->cmd_ring->dequeue' with 'trb', the address of
> the command TRB, since it is available to reduce line length.
>
> Signed-off-by: Xenia Ragiadakou
Acked-by: Sarah Sharp
> ---
> drivers/usb/host/xhci-
Hello Alan,
Thanks for responding.
> The lack of output from usbmon is probably because the kernel isn't
> sending any URBs to the new device. The Set-Address request is sent
> automatically by the xHCI controller, and if it doesn't work then
> there's nothing for the kernel to communicate with.
On Fri, Aug 23, 2013 at 11:15:15AM +0300, Xenia Ragiadakou wrote:
> Since the Slot ID field in the command completion event matches the Slot ID
> field in the associated command TRB for the Stop Endpoint, Set Dequeue Pointer
> and Reset Endpoint commands, this patch adds in the handlers of their
>
On 09/02/2013 06:07 PM, Greg KH wrote:
On Mon, Sep 02, 2013 at 05:46:58PM -0500, Daniel Santos wrote:
Hello guys. I didn't get a response the last time so hopefully with
3.11 out I'll get one this time.
I need to be able to generate interrupts from a USB device driver while
servicing the compl
Hi Xenia,
Thanks for adding this. It should be a big help for debugging issues
with isochronous transfers to avoid massive log spam on missed service
intervals.
On Fri, Aug 23, 2013 at 11:15:18AM +0300, Xenia Ragiadakou wrote:
> This patch adds a trace event to the class 'xhci_log_msg', called
>
On Tue, 3 Sep 2013, joe M wrote:
> Hello Alan,
>
> Thanks for responding.
>
> > The lack of output from usbmon is probably because the kernel isn't
> > sending any URBs to the new device. The Set-Address request is sent
> > automatically by the xHCI controller, and if it doesn't work then
> > t
On Tue, 3 Sep 2013, joe M wrote:
> output of passing cases (when the device is connected directly to a
> 1.1 PCI USB card): working-lsusb-v_of_the_device_only.txt,
> working-lsusb-t_and_lsusb-v.txt
Looking at the lsusb -v output for your device, I noticed that although
there are 3 configuration
On 09/03/2013 12:59 PM, Greg KH wrote:
Hm, I thought we used to have some of them, I guess people have been
saying they would write a driver for this type of hardware for a long
time now :(
Well, on the bright side, we have one now, albeit in a "this is my first
driver that nobody has reviewe
On Fri, Aug 23, 2013 at 11:15:16AM +0300, Xenia Ragiadakou wrote:
> This patch replaces the 'event' argument of xhci_handle_cmd_set_deq() and
> xhci_handle_cmd_reset_ep(), which is used to retrieve the command completion
> status code, with the cmd_comp_code directly since it is available.
>
> Sig
Hello Sarah,
Just as an fyi, attached is the syslog output with a different device
attached to the xHCI port. That device works fine though it still has
a timeout message on set address request.
Thanks
Joe
Sep 3 15:30:13 master kernel: [168111.576186] xhci_hcd :03:00.0: xHCI Host
Controller
Hello,
I was just browsing xhci.c and noticed that you are the author.
> Just as an fyi, attached is the syslog output with a different device
> attached to the xHCI port. That device works fine though it still has
> a timeout message on set address request.
Just wanted to check if you could giv
On Tue, Sep 03, 2013 at 08:25:43AM -0300, Fabio Estevam wrote:
> On Tue, Sep 3, 2013 at 6:26 AM, Peter Chen wrote:
>
> > +static const struct dev_pm_ops ci_hdrc_imx_pm_ops = {
> > + SET_SYSTEM_SLEEP_PM_OPS(ci_hdrc_imx_suspend, ci_hdrc_imx_resume)
>
> What about using the macro SIMPLE_DEV_P
On 09/02/2013 05:58 PM, Pavel Machek wrote:
> Hi!
>
> checkpatch.pl has some valid complaints about style in s3c-hsotg.c :
> macro with if should be really enclosed in do {} while, and puts is
> going to be slightly faster.
>
> Here's suggested patch. I don't have the hardware, so it is completely
From: liujunliang_...@163.com
Date: Sun, 1 Sep 2013 19:38:08 +0800
> From: Liu Junliang
>
> Signed-off-by: Liu Junliang
Applied, thanks.
--
To unsubscribe from this list: send the line "unsubscribe linux-usb" in
the body of a message to majord...@vger.kernel.org
More majordomo info at http:/
On Tue, Sep 3, 2013 at 10:16 PM, Peter Chen wrote:
> On Tue, Sep 03, 2013 at 08:25:43AM -0300, Fabio Estevam wrote:
>> On Tue, Sep 3, 2013 at 6:26 AM, Peter Chen wrote:
>>
>> > +static const struct dev_pm_ops ci_hdrc_imx_pm_ops = {
>> > + SET_SYSTEM_SLEEP_PM_OPS(ci_hdrc_imx_suspend, ci_hdrc
On Tue, Sep 03, 2013 at 11:45:44PM -0300, Fabio Estevam wrote:
> On Tue, Sep 3, 2013 at 10:16 PM, Peter Chen wrote:
> > On Tue, Sep 03, 2013 at 08:25:43AM -0300, Fabio Estevam wrote:
> >> On Tue, Sep 3, 2013 at 6:26 AM, Peter Chen
> >> wrote:
> >>
> >> > +static const struct dev_pm_ops ci_hdrc_i
Dear David Miller :
Thanks a lot.
I'm sorry that I just wonder to know which kernel
version will release this driver, thanks again.
2013-09-04
liujunliang_ljl
发件人: David Miller
发送时间: 2013-09-04 10:27:14
收件人: liujunliang_ljl
This patch adds a new variable 'cmd_trb' to hold the address of the
command TRB, that is associated with the command completion event,
and to replace repetitions of xhci->cmd_ring->dequeue into the code.
Signed-off-by: Xenia Ragiadakou
Acked-by: Sarah Sharp
---
drivers/usb/host/xhci-ring.c | 17
The function that handles xHCI command completion is much too long and
there is need to be broken up into individual functions for each command
completion to improve code readablity.
This patch refactors the code in TRB_CONFIG_EP switch case, in
handle_cmd_completion(), into a fuction named xhci_ha
This patch adds the label 'update_ring' for the common code path:
inc_deq(xhci, xhci->cmd_ring);
return;
Signed-off-by: Xenia Ragiadakou
---
Differences from v3:
remove return statement
drivers/usb/host/xhci-ring.c | 7 +++
1 file changed, 3 insertions(+), 4 deletions(-)
diff --git a/dri
The function that handles xHCI command completion is much too long and
there is need to be broken up into individual functions for each command
completion to improve code readablity.
This patch refactors the code in TRB_DISABLE_SLOT switch case in
handle_cmd_completion() into a fuction named xhci_h
This patch renames the function handlers of a triggered Command Completion
Event that correspond to each command type into 'xhci_handle_cmd_'.
That is done to give a consistent naming space to all the functions that
handle Command Completion Events and that will permit the code reader to
reference
This patch removes the variable 'ep_ring' that is assigned in
TRB_CONFIG_EP switch case but never used.
Signed-off-by: Xenia Ragiadakou
---
drivers/usb/host/xhci-ring.c | 2 --
1 file changed, 2 deletions(-)
diff --git a/drivers/usb/host/xhci-ring.c b/drivers/usb/host/xhci-ring.c
index f9d377a.
Since the Slot ID field in the command completion event matches the Slot ID
field in the associated command TRB for the Stop Endpoint, Set Dequeue Pointer
and Reset Endpoint commands, this patch adds in the handlers of their
completion events a 'slot_id' argument and removes the slot id calculation
This patch replaces 'xhci->cmd_ring->dequeue' with 'trb', the address of
the command TRB, since it is available to reduce line length.
Signed-off-by: Xenia Ragiadakou
Acked-by: Sarah Sharp
---
drivers/usb/host/xhci-ring.c | 6 ++
1 file changed, 2 insertions(+), 4 deletions(-)
diff --git a
The function that handles xHCI command completion is much too long and
there is need to be broken up into individual functions for each command
completion to improve code readablity.
This patch refactors the code in TRB_NEC_GET_FW switch case in
handle_cmd_completion() into a fuction named xhci_han
The function that handles xHCI command completion is much too long and
there is need to be broken up into individual functions for each command
completion to improve code readablity.
This patch refactors the code in TRB_RESET_DEV switch case in
handle_cmd_completion() into a fuction named xhci_hand
This patch adds a new variable 'cmd_type' to hold the command type so that
switch cases can be simplified by removing TRB_TYPE() macro improving
code readability.
Signed-off-by: Xenia Ragiadakou
---
Differences from v3:
update changelog to report the reason for such change
drivers/usb/host/xh
The function that handles xHCI command completion is much too long and
there is need to be broken up into individual functions for each command
completion to improve code readablity.
This patch refactors the code in TRB_EVAL_CONTEXT switch case in
handle_cmd_completion() into a fuction named xhci_h
This patch adds a new variable 'cmd_comp_code' to hold the command completion
status code aiming to reduce code duplication and to improve code readability.
Signed-off-by: Xenia Ragiadakou
Acked-by: Sarah Sharp
---
drivers/usb/host/xhci-ring.c | 20
1 file changed, 8 insert
There are situations under which xHC is unable to service an isochronous
endpoint within its service interval. For an IN isoc endpoint, this is the case
when its ring is full, while for an OUT isoc endpoint when its ring is empty.
This patch adds a trace event to the class 'xhci_log_msg', called
'x
This patch replaces the 'event' argument of xhci_handle_cmd_set_deq() and
xhci_handle_cmd_reset_ep(), which is used to retrieve the command completion
status code, with the cmd_comp_code directly, since it is available.
Signed-off-by: Xenia Ragiadakou
Acked-by: Sarah Sharp
---
drivers/usb/host/
This patch removes the "adjective" argument from xhci_giveback_urb_in_irq(),
since it is not used in the function anymore.
Signed-off-by: Xenia Ragiadakou
Acked-by: Sarah Sharp
---
drivers/usb/host/xhci-ring.c | 8
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/drivers/u
The function that handles xHCI command completion is much too long and
there is need to be broken up into individual functions for each command
completion to improve code readablity.
This patch refactors the code in TRB_ENABLE_SLOT switch case in
handle_cmd_completion() into a fuction named xhci_ha
Since the slot id retrieved from the command TRB matches the one in Slot ID
field of the command completion event, which is available, there is no need
to determine it again.
This patch removes the uneccessary reassignment to slot id and adds a WARN_ON
in case the two Slot ID fields differ.
Signed
The function that handles xHCI command completion is much too long and
there is need to be broken up into individual functions for each command
completion to improve code readablity.
This patch refactors the code in TRB_ADDR_DEV switch case in
handle_cmd_completion() into a fuction named xhci_handl
On Tuesday 03 September 2013 09:34 PM, Sarah Sharp wrote:
I'm confused. I said the last version of this patch didn't apply
against usb-next, and you should rebase it. Why did you put "No Change"
in the subject prefix?
I miss understood what Dan said. he said me to add no change if there's
no c
68 matches
Mail list logo