Re: [PATCH 06/30] usb/gadget: add some infracture to register/unregister functions

2013-01-27 Thread Sebastian Andrzej Siewior
* Andrzej Pietrasiewicz | 2013-01-15 16:26:20 [+0100]: >On Tuesday, January 15, 2013 1:03 PM Sebastian Andrzej Siewior wrote: > > > >> >usb_function_driver. >> > >> >I would call the structure in question "usb_function_module". >> >Or even better: "usb_function_pool" - you get usb_functions from i

RE: [PATCH 06/30] usb/gadget: add some infracture to register/unregister functions

2013-01-15 Thread Andrzej Pietrasiewicz
On Tuesday, January 15, 2013 1:03 PM Sebastian Andrzej Siewior wrote: > >usb_function_driver. > > > >I would call the structure in question "usb_function_module". > >Or even better: "usb_function_pool" - you get usb_functions from it. > >Please see inline for what it looks like. > > Not sure I

Re: [PATCH 06/30] usb/gadget: add some infracture to register/unregister functions

2013-01-15 Thread Sebastian Andrzej Siewior
* Andrzej Pietrasiewicz | 2013-01-03 16:37:45 [+0100]: >Hello Sebastian, Hello Andrzej, >On Sunday, December 23, 2012 9:10 PM Sebastian Andrzej Siewior wrote: > >> Subject: [PATCH 06/30] usb/gadget: add some infracture to >> register/unregister functions >>

RE: [PATCH 06/30] usb/gadget: add some infracture to register/unregister functions

2013-01-03 Thread Andrzej Pietrasiewicz
Hello Sebastian, Please see below On Thursday, January 03, 2013 4:38 PM I wrote: > Subject: RE: [PATCH 06/30] usb/gadget: add some infracture to > register/unregister functions > > > +#define DECLARE_USB_FUNCTION(_name, _inst_alloc, _func_alloc) > > \

RE: [PATCH 06/30] usb/gadget: add some infracture to register/unregister functions

2013-01-03 Thread Andrzej Pietrasiewicz
Hello Sebastian, On Sunday, December 23, 2012 9:10 PM Sebastian Andrzej Siewior wrote: > Subject: [PATCH 06/30] usb/gadget: add some infracture to > register/unregister functions > > This patch provides an infrastructure to register & unregister a USB > function. This allows

[PATCH 06/30] usb/gadget: add some infracture to register/unregister functions

2012-12-23 Thread Sebastian Andrzej Siewior
This patch provides an infrastructure to register & unregister a USB function. This allows to turn a function into a module and avoid the '#include "f_.*.c"' magic and we get a clear API / cut between the bare gadget and its functions. The concept is simple: Each function defines the DECLARE_USB_FU