t; include/linux/memblock.h | 35 ---
> kernel/dma/swiotlb.c | 2 +-
> kernel/printk/printk.c | 9 +----
For printk:
Reviewed-by: Petr Mladek
Acked-by: Petr Mladek
Best Regards,
Petr
> mm/memblock.c | 35 --
On Wed 2019-01-16 15:44:21, Mike Rapoport wrote:
> As all the memblock allocation functions return NULL in case of error
> rather than panic(), the duplicates with _nopanic suffix can be removed.
[...]
> diff --git a/kernel/printk/printk.c b/kernel/printk/printk.c
> index c4f0a41..ae65221 100644
On Wed 2015-04-29 09:18:50, Chris Bainbridge wrote:
> Regression in commit 638139eb95d2d241781330a321e88c8dafe46078
> Author: Petr Mladek
> Date: Fri Sep 19 17:32:24 2014 +0200
>
> usb: hub: allow to process more usb hub events in parallel
Anyway, I would suggest to revert
On Mon 2014-11-10 10:58:56, Joe Perches wrote:
> diff --git a/ipc/util.c b/ipc/util.c
> index 106bed0..4f726b7 100644
> --- a/ipc/util.c
> +++ b/ipc/util.c
> @@ -837,8 +837,10 @@ static int sysvipc_proc_show(struct seq_file *s, void
> *it)
> struct ipc_proc_iter *iter = s->private;
> s
Linus' tree or linux-next.
Petr Mladek (6):
usb: hub: keep hub->dev reference all the time when struct usb_hub
lives
usb: hub: rename hub_events() to hub_event() and handle only one event
there
usb: hub: convert khubd into workqueue
usb: hub: rename usb_kick_khubd() to u
h. This patch already is complex enough.
Thanks a lot Alan Stern for code review, many useful
tips and guidance. Also thanks to Tejun Heo for hints how to
allocate the workqueue.
Signed-off-by: Petr Mladek
---
drivers/usb/core/hub.c | 143 +
driv
It seems that only choose_devnum() was not ready to process more hub
events at the same time.
All should be fine if we take bus->usb_address0_mutex there. It will
make sure that more devnums will not be chosen for the given bus and
the related devices at the same time.
Signed-off-by: Petr Mla
anges can be found in the following files:
Documentation/usb/hotplug.txt
drivers/net/usb/usbnet.c
drivers/usb/core/hcd.c
drivers/usb/host/ohci-hcd.c
drivers/usb/host/xhci.c
Signed-off-by: Petr Mladek
---
Documentation/DocBook/usb.tmpl
USB hub started to use a workqueue instead of kthread. Let's make it clear from
the function names.
Signed-off-by: Petr Mladek
---
drivers/usb/core/hcd.c | 4 ++--
drivers/usb/core/hub.c | 2 +-
drivers/usb/core/usb.h | 2 +-
3 files changed, 4 insertions(+), 4 deletions(-)
diff --
ased. By other words,
we could handle it the same way as the reference for hub->intfdev.
The motivation is that it will make the life easier when switching from khubd
kthread to a workqueue.
Suggested-by: Alan Stern
Signed-off-by: Petr Mladek
---
drivers/usb/core/hub.c | 6 +++---
1 file
hub_event(), removes the while cycle, and
renames the goto targets from loop* to out*.
When touching the code, it fixes also formatting of dev_err() and dev_dbg()
calls to make checkpatch.pl happy :-)
Signed-off-by: Petr Mladek
---
drivers/usb/core/hub.c | 236
of dev_err() and dev_dbg()
calls to make checkpatch.pl happy :-)
Signed-off-by: Petr Mladek
---
drivers/usb/core/hub.c | 199 -
1 file changed, 96 insertions(+), 103 deletions(-)
diff --git a/drivers/usb/core/hub.c b/drivers/usb/core/hub.c
index
anges can be found in the following files:
Documentation/usb/hotplug.txt
drivers/net/usb/usbnet.c
drivers/usb/core/hcd.c
drivers/usb/host/ohci-hcd.c
drivers/usb/host/xhci.c
Signed-off-by: Petr Mladek
---
Documentation/DocBook/usb.tmpl
USB hub started to use a workqueue instead of kthread. Let's make it clear from
the function names.
Signed-off-by: Petr Mladek
---
drivers/usb/core/hcd.c | 4 ++--
drivers/usb/core/hub.c | 2 +-
drivers/usb/core/usb.h | 2 +-
3 files changed, 4 insertions(+), 4 deletions(-)
diff --
ts() when needed.
Note that the source file is still full of the obsolete "khubd" strings.
Let's remove them in a follow up patch. This patch already is complex enough.
Thanks a lot Alan Stern for very useful tips
and guidance.
Signed-off-by: Petr Mladek
---
driv
ore
the thread is scheduled. This is why I kept the order of patches
as is to do not break bisection.
Thanks a lot Alan Stern for hint and guidance.
The patches can be applied either against Linus' tree or linux-next.
Petr Mladek (4):
usb: hub: convert khubd into workqueue
usb: hub
On Fri 2014-09-12 10:16:21, Alan Stern wrote:
> On Fri, 12 Sep 2014, Petr Mladek wrote:
>
> > There is no need to have separate kthread for handling USB hub events.
> > It is more elegant to use the workqueue framework.
> >
> > The workqueue is allocated as unbound
On Fri 2014-09-12 10:06:03, Alan Stern wrote:
> On Fri, 12 Sep 2014, Petr Mladek wrote:
>
> > usb_autopm_put_interface() must be called only when
> > usb_autopm_get_interface()
> > succeeded before. There was wrong ordering of the goto targets.
>
> No, you are wro
anges can be found in the following files:
Documentation/usb/hotplug.txt
drivers/net/usb/usbnet.c
drivers/usb/core/hcd.c
drivers/usb/host/ohci-hcd.c
drivers/usb/host/xhci.c
Signed-off-by: Petr Mladek
---
Documentation/DocBook/usb.tmpl
USB hub started to use a workqueue instead of kthread. Let's make it clear from
the function names.
Signed-off-by: Petr Mladek
---
drivers/usb/core/hcd.c | 4 ++--
drivers/usb/core/hub.c | 16
drivers/usb/core/usb.h | 2 +-
3 files changed, 11 insertions(+), 11 dele
from "loop*"
to "out*".
When touching the code, it fixes also formatting of dev_err() and dev_dbg()
calls to make checkpatch.pl happy :-)
Signed-off-by: Petr Mladek
---
drivers/usb/core/hub.c | 199 +++--
1 file changed, 95 insertio
straightforward.
Note that the source file is still full of the obsolete "khubd" strings.
Let's remove them in a follow up patch to keep this one "simple".
Signed-off-by: Petr Mladek
---
drivers/usb/core/hub.c | 114 +
drivers/usb/cor
when processing" that was sent few minutes before.
It can be applied also on Linus' tree but you need to apply
the commit c605f3cdff53a743f6d875 ("usb: hub: take hub->hdev reference
when processing from eventlist") first.
Petr Mladek (4):
usb: hub: convert khubd into workq
usb_autopm_put_interface() must be called only when usb_autopm_get_interface()
succeeded before. There was wrong ordering of the goto targets.
The funny thing is that the names of the goto targets and the related comments
were correct.
Signed-off-by: Petr Mladek
---
drivers/usb/core/hub.c | 4
24 matches
Mail list logo