Dne 31.3.2017 v 11:01 Laurent Pinchart napsal(a):
> Hi Felipe and Petr,
>
> On Tuesday 28 Mar 2017 16:48:46 Felipe Balbi wrote:
>> Petr Cvek writes:
>>> Dne 7.3.2017 v 06:58 Laurent Pinchart napsal(a):
>>>> On Tuesday 07 Mar 2017 00:57:20 Petr Cvek wrote:
&g
nition to use "cname", name of variables.
Signed-off-by: Petr Cvek
---
drivers/usb/gadget/function/uvc_configfs.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/usb/gadget/function/uvc_configfs.c
b/drivers/usb/gadget/function/uvc_configfs.c
index 4e037d2
Dne 8.3.2017 v 11:46 Ganesh Biradar napsal(a):
> Hi Petr,
>
> I saw your patch and at the same time I saw Laurent suggestion.
>
> I have tried both patches both are working but I'm going with Laurent
> suggestion
>
> UVC_ATTR(f_uvc_opts_, cname, cname).
>
That's OK, they are equivalent (as I
) were named "aname".
Add the definition of "aname" to the main macro and name the filenames as
originaly intended.
Signed-off-by: Petr Cvek
---
drivers/usb/gadget/function/uvc_configfs.c | 14 +++---
1 file changed, 7 insertions(+), 7 deletions(-)
diff --git a/drivers
Hi,
During the testing of the g_webcam on PXA27x (HTC Magician machine) I found a
race condition. In the situations when the UDC receives a SETUP DATA packet
sooner than it is "requested" by usb_ep_queue() it will block itself from the
reading the FIFO.
Below I suggest the fix, but it is very
inition of "aname" to the main macro and name the filenames as
originaly intended.
Signed-off-by: Petr Cvek
---
drivers/usb/gadget/function/uvc_configfs.c | 14 +++---
1 file changed, 7 insertions(+), 7 deletions(-)
diff --git a/drivers/usb/gadget/function/uvc_configfs.c
b/dr
Dne 7.3.2017 v 06:58 Laurent Pinchart napsal(a):
> Hi Petr,
>
> Thank you for the patch.
>
> On Tuesday 07 Mar 2017 00:57:20 Petr Cvek wrote:
>> Commit 76e0da34c7ce ("usb-gadget/uvc: use per-attribute show and store
>> methods") caused a stringification
Dne 2.3.2017 v 09:19 Roger Quadros napsal(a):
> Petr,
>
> On 02/03/17 06:57, Petr Cvek wrote:
>> Dne 2.3.2017 v 00:22 Laurent Pinchart napsal(a):
>>> Hi Roger,
>>>
>>> On Wednesday 01 Mar 2017 17:09:51 Roger Quadros wrote:
>>>> Hi,
>>&
Dne 24.1.2017 v 19:20 Felipe Balbi napsal(a):
>
> Hi,
>
> Petr Cvek writes:
>>> Greg KH writes:
>>>>>>> fine by me. Just lsusb will look funky ;-)
>>>>>>
>>>>>> Heh, true, but I thought lsusb would use a string if t
the control endpoint.
>>
>> If I revert the following commit everything works fine.
>> commit 4fbac5206afd01b717d4bdc58793d471f3391b4b
>> Author: Petr Cvek
>> Date: Wed Aug 17 12:36:57 2016 +0200
>>
>> usb: gadget: uvc: Add missing call for addition
A call usb_put_phy(udc->transceiver) must be tested for a valid pointer.
Use an already existing test for usb_unregister_notifier call.
Reported-by: Robert Jarzmik
Signed-off-by: Petr Cvek
---
drivers/usb/gadget/udc/pxa27x_udc.c | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)
d
Functions udc_enable() and udc_disable() have a duplicated prototype.
Remove it.
Signed-off-by: Petr Cvek
---
drivers/usb/gadget/udc/pxa27x_udc.c | 3 ---
1 file changed, 3 deletions(-)
diff --git a/drivers/usb/gadget/udc/pxa27x_udc.c
b/drivers/usb/gadget/udc/pxa27x_udc.c
index e1335ad5bce9
Two simple fixes for pxa27x gadget UDC. First one remove function declaration
duplication, second one add test for a valid pointer before function call as
it can be called with an error value in the pointer.
Changes from v1:
* Shorter titles, corrected Robert Jarzmik's signature
Petr Cv
Remove duplicated function declaration for udc_enable() and udc_disable().
Signed-off-by: Petr Cvek
---
drivers/usb/gadget/udc/pxa27x_udc.c | 3 ---
1 file changed, 3 deletions(-)
diff --git a/drivers/usb/gadget/udc/pxa27x_udc.c
b/drivers/usb/gadget/udc/pxa27x_udc.c
index 7fa60f5b7ae4
Dne 22.2.2017 v 21:46 Robert Jarzmik napsal(a):
> Petr Cvek writes:
>
> Hi Petr,
>
>> I found a few problems with the PXA27x UDC.
>>
>> usb_function_activate() in drivers/usb/gadget/composite.c
>>
>> does spin_lock_irqsave() and then calls
>&
Two simple fixes for pxa27x gadget UDC. First one remove function declaration
duplication, second one add test for a valid pointer before function call as
it can be called with an error value in the pointer.
Petr Cvek (2):
[TRIVIAL] usb: gadget: Remove duplicated function declaration in
Move call usb_put_phy(udc->transceiver) inside a valid pointer test.
Reported-by: robert.jarz...@free.fr
Signed-off-by: Petr Cvek
---
drivers/usb/gadget/udc/pxa27x_udc.c | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)
diff --git a/drivers/usb/gadget/udc/pxa27x_udc.c
b/drivers/
Hi,
I found a few problems with the PXA27x UDC.
usb_function_activate() in drivers/usb/gadget/composite.c
does spin_lock_irqsave() and then calls
gadget->ops->pullup() in drivers/usb/gadget/udc/core.c
which is set to pxa_udc_pullup(), which should be called not in interrupt
Dne 12.2.2017 v 13:02 Robert Jarzmik napsal(a):
> Petr Cvek writes:
>
>> Hi
>>
>> any news?
>
> Yeah, I don't have the error on my mainstone, which kind of hinders my debug
> capability.
>
> I have tried your script, and this is what I get :
>
Hi
any news?
Petr
Dne 4.2.2017 v 23:42 Robert Jarzmik napsal(a):
> Petr Cvek writes:
>
>> Setting the UVC gadget with configfs and then reloading UDC controler driver
>> (pxa27x_udc) causes kernel to fail.
>>
>> UDC subsystem was patched only in decreasing ma
Dne 4.2.2017 v 23:42 Robert Jarzmik napsal(a):
> Petr Cvek writes:
>
>> Setting the UVC gadget with configfs and then reloading UDC controler driver
>> (pxa27x_udc) causes kernel to fail.
>>
>> UDC subsystem was patched only in decreasing maxpacket size for UVC,
Setting the UVC gadget with configfs and then reloading UDC controler driver
(pxa27x_udc) causes kernel to fail.
UDC subsystem was patched only in decreasing maxpacket size for UVC, addition
of more predefined endpoints for pxa27x_udc and addition of some debugging
pr_info.
Practically same beha
Dne 23.1.2017 v 15:27 Felipe Balbi napsal(a):
>
> Hi,
>
> Greg KH writes:
> fine by me. Just lsusb will look funky ;-)
Heh, true, but I thought lsusb would use a string if the device provided
it. Haven't looked at that portion of the code in a very long time...
>>>
>>> M
Dne 23.1.2017 v 12:32 Greg KH napsal(a):
I know it is only a cosmetic change on a legacy driver, but I assume
it would be better to have some default value for configfs API than to
borrow a PID from a whole different gadget.
>>>
>>> For class devices, they really don't need a new id,
and
changing it to new one.
Signed-off-by: Petr Cvek
---
drivers/usb/gadget/legacy/webcam.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/usb/gadget/legacy/webcam.c
b/drivers/usb/gadget/legacy/webcam.c
index f9661cd627c8..988814f2e1c7 100644
--- a/drivers/usb/ga
Some UVC commands require additional data (non zero uvc->event_length).
Add usb_ep_queue() call, so uvc_function_ep0_complete() can be called
and send received data to the userspace.
Signed-off-by: Petr Cvek
---
drivers/usb/gadget/function/f_uvc.c | 7 +++
1 file changed, 7 inserti
Some UVC commands require additional data (non zero uvc->event_length).
Add usb_ep_queue() call, so uvc_function_ep0_complete() can be called
and send received data to the userspace.
Signed-off-by: Petr Cvek
---
drivers/usb/gadget/function/f_uvc.c | 7 +++
1 file changed, 7 inserti
Some UVC commands require additional data. Add usb_ep_queue(), so
uvc_function_ep0_complete() can be called and send received data
to the userspace.
Fixing maxpacket variable inicialization value to be inside USB
full speed range.
Signed-off-by: Petr Cvek
---
drivers/usb/gadget/function
On 26.7.2015 17:14, Alan Stern wrote:
> On Sun, 26 Jul 2015, Petr Cvek wrote:
>
>> What about higher speeds (not relevant on PXA, but ep_matches() is
>> called from usb_ep_autoconfig_ss() )? According to
>>
>> http://wiki.osdev.org/Universal_Serial_Bus#Maximum_
On 25.7.2015 23:36, Alan Stern wrote:
> On Sat, 25 Jul 2015, Petr Cvek wrote:
>
>> On 25.7.2015 19:04, Robert Jarzmik wrote:
>>> Alan Stern writes:
>>>
>>> Hi Alan,
>>>
>>>> On Sat, 25 Jul 2015, Robert Jarzmik wrote:
>>>>
&g
On 25.7.2015 13:04, Robert Jarzmik wrote:
> Petr Cvek writes:
>
>> On 23.7.2015 21:46, Alan Stern wrote:
>>>> It seems that it allows using a BULK endpoint for requested INT
>>>> endpoint. For my PXA27x machine the original code returns BULK EP
>>
On 25.7.2015 20:08, Robert Baldyga wrote:
>>
>> Let me give you another example :
>> - pxa27x_udc offers 3 endpoints : ep-in, ep-out, ep-iso-in
>> - a gadget driver does :
>> - request an ep-in
>> - request an ep-out
>> - request an ep-in
>> - request an ep-iso-in
>> In that cas
On 25.7.2015 19:04, Robert Jarzmik wrote:
> Alan Stern writes:
>
> Hi Alan,
>
>> On Sat, 25 Jul 2015, Robert Jarzmik wrote:
>>
>>> Petr Cvek writes:
>>>
>>>> On 23.7.2015 21:46, Alan Stern wrote:
>>>>>> It seems that i
On 23.7.2015 21:46, Alan Stern wrote:
> On Thu, 23 Jul 2015, Petr Cvek wrote:
>
>> Hello,
>>
>> Is this:
>>
>> case USB_ENDPOINT_XFER_INT:
>> /* Bulk endpoints handle interrupt transfers,
>>
On 23.7.2015 16:36, Felipe Balbi wrote:
> Hi,
>
> On Thu, Jul 23, 2015 at 06:40:40AM +0200, Petr Cvek wrote:
>> Hello,
>>
>> Is this:
>>
>> case USB_ENDPOINT_XFER_INT:
>> /* Bulk endpoints handle interrupt transfers,
>>
K EP even with valid INT
endpoint definition (because BULK EPs are defined earlier than INT EPs).
This part of the code is from pre git era
1da177e4c3f41524e886b7f1b8a0c1fc7321cac2
before pxa27x driver was written and only few chips was supported. Does anyone
know if the INT endpoints works
36 matches
Mail list logo