Re: [PATCH 2/2] net: qmi_wwan: fix checkpatch warnings

2013-09-26 Thread Fabio Porcedda
NAK from me for this part. Which changes do you think do not improve the readability? I'm sure that at least some of them actually improve the readability. Best regards Fabio Porcedda > Fabio Porcedda writes: > >> Signed-off-by: Fabio Porcedda

[PATCH 1/2] net: qmi_wwan: add Telit LE920 newer firmware support

2013-09-25 Thread Fabio Porcedda
Newer firmware use a new pid and a different interface. Signed-off-by: Fabio Porcedda --- drivers/net/usb/qmi_wwan.c | 1 + 1 file changed, 1 insertion(+) diff --git a/drivers/net/usb/qmi_wwan.c b/drivers/net/usb/qmi_wwan.c index 6312332..5f6b6fa 100644 --- a/drivers/net/usb/qmi_wwan.c +++ b

[PATCH 2/2] net: qmi_wwan: fix checkpatch warnings

2013-09-25 Thread Fabio Porcedda
Signed-off-by: Fabio Porcedda --- drivers/net/usb/qmi_wwan.c | 56 +- 1 file changed, 36 insertions(+), 20 deletions(-) diff --git a/drivers/net/usb/qmi_wwan.c b/drivers/net/usb/qmi_wwan.c index 5f6b6fa..0e59f9e 100644 --- a/drivers/net/usb/qmi_wwan.c

[PATCH 2/3] net: usb: cdc_ether: fix checkpatch errors and warnings

2013-09-16 Thread Fabio Porcedda
Signed-off-by: Fabio Porcedda --- drivers/net/usb/cdc_ether.c | 47 +++-- 1 file changed, 20 insertions(+), 27 deletions(-) diff --git a/drivers/net/usb/cdc_ether.c b/drivers/net/usb/cdc_ether.c index 98aef3b..c36b1c3 100644 --- a/drivers/net/usb

[PATCH 0/3] net: usb: cdc_ether: improve telit support and code cleanups

2013-09-16 Thread Fabio Porcedda
Some patches to improve telit modules support and to cleanup the code. Best regards Fabio Porcedda (3): net: usb: cdc_ether: Use wwan interface for Telit modules net: usb: cdc_ether: fix checkpatch errors and warnings net: usb: cdc_ether: use usb.h macros whenever possible drivers/net

[PATCH 3/3] net: usb: cdc_ether: use usb.h macros whenever possible

2013-09-16 Thread Fabio Porcedda
Use USB_DEVICE_AND_INTERFACE_INFO and USB_VENDOR_AND_INTERFACE_INFO macros to reduce boilerplate. Signed-off-by: Fabio Porcedda --- drivers/net/usb/cdc_ether.c | 63 - 1 file changed, 17 insertions(+), 46 deletions(-) diff --git a/drivers/net/usb

[PATCH 1/3] net: usb: cdc_ether: Use wwan interface for Telit modules

2013-09-16 Thread Fabio Porcedda
Signed-off-by: Fabio Porcedda Cc: # 3.0+ as far back as it applies cleanly --- drivers/net/usb/cdc_ether.c | 5 + 1 file changed, 5 insertions(+) diff --git a/drivers/net/usb/cdc_ether.c b/drivers/net/usb/cdc_ether.c index 03ad4dc..98aef3b 100644 --- a/drivers/net/usb/cdc_ether.c +++ b

Re: [PATCH 1/3] driver core: add helper macro for platform_driver_probe() boilerplate

2013-01-10 Thread Fabio Porcedda
Hi Greg, I'm sorry, In the previous email I used your wrong email address, in this email I've used your correct email address. Best regards Fabio Porcedda On Wed, Jan 9, 2013 at 12:15 PM, Fabio Porcedda wrote: > For simple modules that contain a single platform_driver without any

[PATCH 2/3] watchdog: convert drivers/watchdog/* to use module_platform_driver_probe

2013-01-09 Thread Fabio Porcedda
This makes the code a bit smaller by getting rid of some boilerplate code. Signed-off-by: Fabio Porcedda Cc: linux-watch...@vger.kernel.org Cc: Wim Van Sebroeck Cc: Linus Walleij --- drivers/watchdog/at32ap700x_wdt.c | 12 +--- drivers/watchdog/at91sam9_wdt.c | 13

[PATCH 3/3] usb: converto drivers/usb/* to use module_platform_driver_probe()

2013-01-09 Thread Fabio Porcedda
This patch converts the drivers in drivers/usb/* to use the module_platform_driver_probe() macro which makes the code smaller and a bit simpler. Signed-off-by: Fabio Porcedda Cc: linux-usb@vger.kernel.org Cc: Greg Kroah-Hartman Cc: Felipe Balbi Cc: Nicolas Ferre Cc: Eric Miao Cc: Russell

[PATCH 1/3] driver core: add helper macro for platform_driver_probe() boilerplate

2013-01-09 Thread Fabio Porcedda
macro use the same idea of module_platform_driver(). This macro is useful to stop the misuse of module_platform_driver() for removing the platform_driver_probe() boilerplate. Signed-off-by: Fabio Porcedda Cc: Greg Kroah-Hartman --- include/linux/platform_device.h | 18 ++ 1

[PATCH 0/3] Add and use new macro module_platform_driver_probe()

2013-01-09 Thread Fabio Porcedda
. This macro use the same idea of module_platform_driver(). This macro is useful to stop the misuse of module_platform_driver() for removing the platform_driver_probe() boilerplate. Convert drivers/usb/* and drivers/watchdog/* to use module_platform_driver_probe(). Best regards Fabio Porcedda

[PATCH v2] usb: gadget: at91_udc: dt: fix platform_data check

2012-09-11 Thread Fabio Porcedda
Don't fail the initialization check for the platform_data if there is avaiable an associated device tree node. This patch fix the dt support introduced in 3.4-rc1 by commit ("d1494a3 USB: at91: Device udc add dt support"). Tested on a at91sam9260 based board (PRO3-EVK). Signe

[PATCH] usb: gadget: at91_udc: fix dt support

2012-09-07 Thread Fabio Porcedda
Don't fail the initialization check for the platform_data if there is avaiable an associated device tree node. Signed-off-by: Fabio Porcedda --- drivers/usb/gadget/at91_udc.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/usb/gadget/at91_udc.c b/drivers/usb/g

Re: [RFC PATCH for v3.5 0/2] usb: gadget: at91_udc: fix oops regression

2012-07-24 Thread Fabio Porcedda
On Mon, Jul 23, 2012 at 12:53 PM, Felipe Balbi wrote: > On Fri, Jul 20, 2012 at 10:33:24AM +0200, Fabio Porcedda wrote: >> On Fri, Jul 20, 2012 at 12:50 AM, Greg Kroah-Hartman >> wrote: >> > On Thu, Jul 19, 2012 at 07:16:54PM +0200, Sebastian Andrzej Siewior wrote: >&

Re: [RFC PATCH for v3.5 0/2] usb: gadget: at91_udc: fix oops regression

2012-07-20 Thread Fabio Porcedda
On Fri, Jul 20, 2012 at 12:50 AM, Greg Kroah-Hartman wrote: > On Thu, Jul 19, 2012 at 07:16:54PM +0200, Sebastian Andrzej Siewior wrote: >> On Thu, Jul 19, 2012 at 03:50:54PM +0200, Fabio Porcedda wrote: >> > > I would prefer to fix the bug causing the oops instead of reve

Re: [PATCH 2/2] usb/at91udc: Don't check for ep->ep.desc

2012-07-20 Thread Fabio Porcedda
tmp |= AT91_UDP_EPEDS; > __raw_writel(tmp, ep->creg); > > - ep->ep.desc = desc; > ep->ep.maxpacket = maxpacket; > > /* > -- > 1.7.10.4 > Now the driver works fine. Tested-by: Fabio Porcedda Regards -- Fabio Porcedda -- To unsu

Re: [PATCH 1/2] usb/at91udc: don't overwrite driver data

2012-07-20 Thread Fabio Porcedda
_stop(struct usb_gadget *gadget, > spin_unlock_irqrestore(&udc->lock, flags); > > udc->gadget.dev.driver = NULL; > - dev_set_drvdata(&udc->gadget.dev, NULL); > udc->driver = NULL; > > DBG("unbound from %s\n",

Re: [RFC PATCH for v3.5 0/2] usb: gadget: at91_udc: fix oops regression

2012-07-19 Thread Fabio Porcedda
On Wed, Jul 18, 2012 at 11:56 AM, Sebastian Andrzej Siewior wrote: > On Mon, Jul 16, 2012 at 02:50:29PM +0200, Fabio Porcedda wrote: >> PROBLEM: >> 1. >> usb: gadget: at91_udc: kernel oops regression when connecting the usb cable >> >> 2. >> Every time i

[RFC PATCH for v3.5 2/2] usb: gadget: at91_udc: fix regression when connecting the usb cable

2012-07-16 Thread Fabio Porcedda
|| desc->bDescriptorType != USB_DT_ENDPOINT || (maxpacket = usb_endpoint_maxp(desc)) == 0 Signed-off-by: Fabio Porcedda Reported-And-Tested-by: Fabio Porcedda Reported-by: Mario Jorge Isidoro Cc: linux-usb@vger.kernel.org Cc: Sebastian Andrzej Siewior Cc: Felipe Balbi C

[RFC PATCH for v3.5 1/2] usb: gadget: at91_udc: fix oops regression when connecting usb cable

2012-07-16 Thread Fabio Porcedda
e 1490) -> handle_ep0 (line 1289) -> handle_setup (line 1264) -> composite_setup" Signed-off-by: Fabio Porcedda Reported-And-Tested-by: Fabio Porcedda Reported-And-Tested-by: Mario Jorge Isidoro Cc: linux-usb@vger.kernel.org Cc: Sebastian Andrzej Siewior Cc: Felipe Balbi Cc: Gre

[RFC PATCH for v3.5 0/2] usb: gadget: at91_udc: fix oops regression

2012-07-16 Thread Fabio Porcedda
ommits, i suggest for the v3.5 release to just revert those three commits: f3d8bf34c2c925867322197096ed501ceab8085a 5eaee54b1c52a83dc74445792cf49900a8050da8 5a6506f00efa4b38b181152b69a072e766c7ce92 More details in the folloing patches. Fabio Porcedda (2): usb: gadget: at91_udc: fix oops regres

Re: NULL pointer dereference in at91_udc on start of connection

2012-07-12 Thread Fabio Porcedda
> -Original Message- > From: Sebastian Andrzej Siewior [mailto:sebast...@breakpoint.cc] > Sent: terça-feira, 10 de Julho de 2012 16:37 > To: Mario Jorge Isidoro > Cc: Fabio Porcedda; Sebastian Andrzej Siewior; ba...@ti.com; > gre...@linuxfoundation.org; linux-usb@vger.k

Re: NULL pointer dereference in at91_udc on start of connection

2012-07-10 Thread Fabio Porcedda
Now the at91_udc driver with g_ether it's working again. I don't understand the reason, but now it seems to work fine. If there isn't a better solution i propose to revert the commit f3d8bf34c2c925867322197096ed501ceab8085a and remove the line on the at91_udc driver. Best regards -- Fa

Re: NULL pointer dereference in at91_udc on start of connection

2012-07-06 Thread Fabio Porcedda
NFIG_RTC_CLASS=y CONFIG_RTC_DRV_AT91SAM9=y CONFIG_EXT2_FS=y CONFIG_VFAT_FS=y CONFIG_TMPFS=y CONFIG_UBIFS_FS=y CONFIG_CRAMFS=y CONFIG_NLS_CODEPAGE_437=y CONFIG_NLS_CODEPAGE_850=y CONFIG_NLS_ISO8859_1=y CONFIG_DEBUG_KERNEL=y CONFIG_DEBUG_USER=y CONFIG_DEBUG_LL=y Best regards -- Fabio Porcedda -- To unsubscribe from this list: send the line "unsubscribe linux-usb" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html