Re: [PATCH] usb: Fix typo in `struct usb_host_interface' comment

2015-01-15 Thread Chris Rorvick
On Thu, Jan 15, 2015 at 6:54 AM, Chris Rorvick wrote: > On Thu, Jan 15, 2015 at 5:03 AM, Oliver Neukum wrote: >> On Wed, 2015-01-14 at 21:52 -0600, Chris Rorvick wrote: >>> The descriptor member `bNumEndpoints' is plural. >> >> I am afraid that is not a good

Re: [PATCH] usb: Fix typo in `struct usb_host_interface' comment

2015-01-15 Thread Chris Rorvick
On Thu, Jan 15, 2015 at 5:03 AM, Oliver Neukum wrote: > On Wed, 2015-01-14 at 21:52 -0600, Chris Rorvick wrote: >> The descriptor member `bNumEndpoints' is plural. > > I am afraid that is not a good idea. The name of a > member of a structure mentioned in the specificatio

[PATCH] usb: Fix typo in `struct usb_host_interface' comment

2015-01-14 Thread Chris Rorvick
The descriptor member `bNumEndpoints' is plural. Signed-off-by: Chris Rorvick --- include/linux/usb.h | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/include/linux/usb.h b/include/linux/usb.h index f89c24a..4add566 100644 --- a/include/linux/usb.h +++ b/include/linux/

Re: [RFC RESEND 00/10] Create separate header for ehci-dbgp driver

2014-11-04 Thread Chris Rorvick
On Mon, Nov 3, 2014 at 5:09 PM, Greg Kroah-Hartman wrote: > It deletes lines of code overall, which looks good to me. Feel free to > resend without the "RFC" and I will queue it up. > > thanks, > > greg k-h Done. I went through the patches by hand to double check spelling based on Daniele catch

[PATCH 01/10] usb: Create separate header for ehci-dbgp

2014-11-04 Thread Chris Rorvick
first step towards removing this redundancy. Signed-off-by: Chris Rorvick --- include/linux/usb/ehci-dbgp.h | 84 +++ include/linux/usb/ehci_def.h | 65 ++--- 2 files changed, 86 insertions(+), 63 deletions(-) create mode 100644

[PATCH 03/10] fusbh200: Remove superfluous macro definitions

2014-11-04 Thread Chris Rorvick
The fusbh200_dbg_port struct is a copy of the ehci_dbg_port definition in the header. Embedded in this definition are a number of macros which came along for the ride. These macros are not used in the fusbh200 driver and will conflict those in the new header. Signed-off-by: Chris Rorvick

[PATCH 02/10] fusbh200: Make Xen notificaiton consistent with EHCI

2014-11-04 Thread Chris Rorvick
fusbh200 consistent with ehci-dbgp as a step towards consolidating this code duplication. Signed-off-by: Chris Rorvick --- drivers/usb/host/fusbh200.h | 5 + 1 file changed, 5 insertions(+) diff --git a/drivers/usb/host/fusbh200.h b/drivers/usb/host/fusbh200.h index 6b719e0..6e7b8c1 100644 --- a

[PATCH 04/10] fusbh200: Remove duplicate ehci-dbgp declarations

2014-11-04 Thread Chris Rorvick
Now that ehci-dbgp has its own header, use it rather than duplicating the declarations, etc. Signed-off-by: Chris Rorvick --- drivers/usb/host/fusbh200.h | 40 ++-- 1 file changed, 2 insertions(+), 38 deletions(-) diff --git a/drivers/usb/host/fusbh200.h b

[PATCH 00/10] Create separate header for ehci-dbgp driver

2014-11-04 Thread Chris Rorvick
necessary declarations from , each driver copies this code into their own header. The goal of this series is to pull the ehci-dbgp related code into its own header to remove the need for this redundancy. Regards, Chris Rorvick Chris Rorvick (10): usb: Create separate header for ehci-dbgp

[PATCH 09/10] fotg210: Use ehci_dbg_port struct

2014-11-04 Thread Chris Rorvick
The FUSBH200 debug port has a EHCI-compatible register layout so there is no need to define a custom struct. Signed-off-by: Chris Rorvick --- drivers/usb/host/fotg210.h | 13 + 1 file changed, 1 insertion(+), 12 deletions(-) diff --git a/drivers/usb/host/fotg210.h b/drivers/usb

[PATCH 07/10] fotg210: Remove superfluous macro definitions

2014-11-04 Thread Chris Rorvick
The fotg210_dbg_port struct is a copy of the ehci_dbg_port definition in the header. Embedded in this definition are a number of macros which came along for the ride. These macros are not used in the fotg210 driver and will conflict those in the new header. Signed-off-by: Chris Rorvick

[PATCH 06/10] fotg210: Make Xen notification consistent with EHCI

2014-11-04 Thread Chris Rorvick
consistent with ehci-dbgp as a step towards consolidating this code duplication. Signed-off-by: Chris Rorvick --- drivers/usb/host/fotg210.h | 5 + 1 file changed, 5 insertions(+) diff --git a/drivers/usb/host/fotg210.h b/drivers/usb/host/fotg210.h index ac6cd1b..98c9670 100644 --- a/drivers

[PATCH 05/10] fusbh200: Use ehci_dbg_port struct

2014-11-04 Thread Chris Rorvick
The FUSBH200 debug port has a EHCI-compatible register layout so there is no need to define a custom struct. Signed-off-by: Chris Rorvick --- drivers/usb/host/fusbh200.h | 13 + 1 file changed, 1 insertion(+), 12 deletions(-) diff --git a/drivers/usb/host/fusbh200.h b/drivers/usb

[PATCH 10/10] usb: Remove __init from early_dbgp_init() prototype

2014-11-04 Thread Chris Rorvick
: https://lkml.org/lkml/2006/1/14/305 Signed-off-by: Chris Rorvick --- include/linux/usb/ehci-dbgp.h | 3 +-- 1 file changed, 1 insertion(+), 2 deletions(-) diff --git a/include/linux/usb/ehci-dbgp.h b/include/linux/usb/ehci-dbgp.h index 796c1cd..7344d9e 100644 --- a/include/linux/usb/ehci

[PATCH 08/10] fotg210: Remove duplicate ehci-dbgp declarations

2014-11-04 Thread Chris Rorvick
Now that ehci-dbgp has its own header, use it rather than duplicating the declarations, etc. Signed-off-by: Chris Rorvick --- drivers/usb/host/fotg210.h | 40 ++-- 1 file changed, 2 insertions(+), 38 deletions(-) diff --git a/drivers/usb/host/fotg210.h b

[RFC RESEND 00/10] Create separate header for ehci-dbgp driver

2014-11-02 Thread Chris Rorvick
parameters. Regards, Chris Rorvick Chris Rorvick (10): usb: Create separate header for ehci-dbgp fusbh200: Make Xen notificaiton consistent with EHCI fusbh200: Remove superfluous macro definitions fusbh200: Remove duplicate ehci-dbgp declarations fusbh200: Use ehci_dbg_port struct fotg210

[RFC RESEND 05/10] fusbh200: Use ehci_dbg_port struct

2014-11-02 Thread Chris Rorvick
The FUSBH200 debug port has a EHCI-compatible register layout so there is no need to define a custom struct. Signed-off-by: Chris Rorvick --- drivers/usb/host/fusbh200.h | 13 + 1 file changed, 1 insertion(+), 12 deletions(-) diff --git a/drivers/usb/host/fusbh200.h b/drivers/usb

[RFC RESEND 03/10] fusbh200: Remove superfluous macro definitions

2014-11-02 Thread Chris Rorvick
The fusbh200_dbg_port struct is a copy of the ehci_dbg_port definition in the header. Embedded in this definition are a number of macros which came along for the ride. These macros are not used in the fusbh200 driver and will conflict those in the new header. Signed-off-by: Chris Rorvick

[RFC RESEND 02/10] fusbh200: Make Xen notificaiton consistent with EHCI

2014-11-02 Thread Chris Rorvick
fusbh200 consistent with ehci-dbgp as a step towards consolidating this code duplication. Signed-off-by: Chris Rorvick --- drivers/usb/host/fusbh200.h | 5 + 1 file changed, 5 insertions(+) diff --git a/drivers/usb/host/fusbh200.h b/drivers/usb/host/fusbh200.h index 6b719e0..6e7b8c1 100644 --- a

[RFC RESEND 04/10] fusbh200: Remove duplicate ehci-dbgp declarations

2014-11-02 Thread Chris Rorvick
Now that ehci-dbgp has its own header, use it rather than duplicating the declarations, etc. Signed-off-by: Chris Rorvick --- drivers/usb/host/fusbh200.h | 40 ++-- 1 file changed, 2 insertions(+), 38 deletions(-) diff --git a/drivers/usb/host/fusbh200.h b

[RFC RESEND 06/10] fotg210: Make Xen notificaiton consistent with EHCI

2014-11-02 Thread Chris Rorvick
consistent with ehci-dbgp as a step towards consolidating this code duplication. Signed-off-by: Chris Rorvick --- drivers/usb/host/fotg210.h | 5 + 1 file changed, 5 insertions(+) diff --git a/drivers/usb/host/fotg210.h b/drivers/usb/host/fotg210.h index ac6cd1b..98c9670 100644 --- a/drivers

[RFC RESEND 07/10] fotg210: Remove superfluous macro definitions

2014-11-02 Thread Chris Rorvick
The fotg210_dbg_port struct is a copy of the ehci_dbg_port definition in the header. Embedded in this definition are a number of macros which came along for the ride. These macros are not used in the fotg210 driver and will conflict those in the new header. Signed-off-by: Chris Rorvick

[RFC RESEND 09/10] fotg210: Use ehci_dbg_port struct

2014-11-02 Thread Chris Rorvick
The FUSBH200 debug port has a EHCI-compatible register layout so there is no need to define a custom struct. Signed-off-by: Chris Rorvick --- drivers/usb/host/fotg210.h | 13 + 1 file changed, 1 insertion(+), 12 deletions(-) diff --git a/drivers/usb/host/fotg210.h b/drivers/usb

[RFC RESEND 10/10] usb: Remove __init from early_dbgp_init() prototype

2014-11-02 Thread Chris Rorvick
: https://lkml.org/lkml/2006/1/14/305 Signed-off-by: Chris Rorvick --- include/linux/usb/ehci-dbgp.h | 3 +-- 1 file changed, 1 insertion(+), 2 deletions(-) diff --git a/include/linux/usb/ehci-dbgp.h b/include/linux/usb/ehci-dbgp.h index 796c1cd..7344d9e 100644 --- a/include/linux/usb/ehci

[RFC RESEND 08/10] fotg210: Remove duplicate ehci-dbgp declarations

2014-11-02 Thread Chris Rorvick
Now that ehci-dbgp has its own header, use it rather than duplicating the declarations, etc. Signed-off-by: Chris Rorvick --- drivers/usb/host/fotg210.h | 40 ++-- 1 file changed, 2 insertions(+), 38 deletions(-) diff --git a/drivers/usb/host/fotg210.h b

[RFC RESEND 01/10] usb: Create separate header for ehci-dbgp

2014-11-02 Thread Chris Rorvick
first step towards removing this redundancy. Signed-off-by: Chris Rorvick --- include/linux/usb/ehci-dbgp.h | 84 +++ include/linux/usb/ehci_def.h | 65 ++--- 2 files changed, 86 insertions(+), 63 deletions(-) create mode 100644

[RFC RESEND 00/10] Create separate header for ehci-dbgp driver

2014-09-28 Thread Chris Rorvick
parameters. Regards, Chris Rorvick Chris Rorvick (10): usb: Create separate header for ehci-dbgp fusbh200: Make Xen notificaiton consistent with EHCI fusbh200: Remove superfluous macro definitions fusbh200: Remove duplicate ehci-dbgp declarations fusbh200: Use ehci_dbg_port struct fot

[RFC RESEND 02/10] fusbh200: Make Xen notificaiton consistent with EHCI

2014-09-28 Thread Chris Rorvick
fusbh200 consistent with ehci-dbgp as a step towards consolidating this code duplication. Signed-off-by: Chris Rorvick --- drivers/usb/host/fusbh200.h | 5 + 1 file changed, 5 insertions(+) diff --git a/drivers/usb/host/fusbh200.h b/drivers/usb/host/fusbh200.h index 6b719e0..6e7b8c1 100644 --- a

[RFC RESEND 04/10] fusbh200: Remove duplicate ehci-dbgp declarations

2014-09-28 Thread Chris Rorvick
Now that ehci-dbgp has its own header, use it rather than duplicating the declarations, etc. Signed-off-by: Chris Rorvick --- drivers/usb/host/fusbh200.h | 40 ++-- 1 file changed, 2 insertions(+), 38 deletions(-) diff --git a/drivers/usb/host/fusbh200.h b

[RFC RESEND 06/10] fotg210: Make Xen notificaiton consistent with EHCI

2014-09-28 Thread Chris Rorvick
consistent with ehci-dbgp as a step towards consolidating this code duplication. Signed-off-by: Chris Rorvick --- drivers/usb/host/fotg210.h | 5 + 1 file changed, 5 insertions(+) diff --git a/drivers/usb/host/fotg210.h b/drivers/usb/host/fotg210.h index ac6cd1b..98c9670 100644 --- a/drivers

[RFC RESEND 05/10] fusbh200: Use ehci_dbg_port struct

2014-09-28 Thread Chris Rorvick
The FUSBH200 debug port has a EHCI-compatible register layout so there is no need to define a custom struct. Signed-off-by: Chris Rorvick --- drivers/usb/host/fusbh200.h | 13 + 1 file changed, 1 insertion(+), 12 deletions(-) diff --git a/drivers/usb/host/fusbh200.h b/drivers/usb

[RFC RESEND 01/10] usb: Create separate header for ehci-dbgp

2014-09-28 Thread Chris Rorvick
first step towards removing this redundancy. Signed-off-by: Chris Rorvick --- include/linux/usb/ehci-dbgp.h | 84 +++ include/linux/usb/ehci_def.h | 65 ++--- 2 files changed, 86 insertions(+), 63 deletions(-) create mode 100644

[RFC RESEND 03/10] fusbh200: Remove superfluous macro definitions

2014-09-28 Thread Chris Rorvick
The fusbh200_dbg_port struct is a copy of the ehci_dbg_port definition in the header. Embedded in this definition are a number of macros which came along for the ride. These macros are not used in the fusbh200 driver and will conflict those in the new header. Signed-off-by: Chris Rorvick

[RFC RESEND 07/10] fotg210: Remove superfluous macro definitions

2014-09-28 Thread Chris Rorvick
The fotg210_dbg_port struct is a copy of the ehci_dbg_port definition in the header. Embedded in this definition are a number of macros which came along for the ride. These macros are not used in the fotg210 driver and will conflict those in the new header. Signed-off-by: Chris Rorvick

[RFC RESEND 08/10] fotg210: Remove duplicate ehci-dbgp declarations

2014-09-28 Thread Chris Rorvick
Now that ehci-dbgp has its own header, use it rather than duplicating the declarations, etc. Signed-off-by: Chris Rorvick --- drivers/usb/host/fotg210.h | 40 ++-- 1 file changed, 2 insertions(+), 38 deletions(-) diff --git a/drivers/usb/host/fotg210.h b

[RFC RESEND 09/10] fotg210: Use ehci_dbg_port struct

2014-09-28 Thread Chris Rorvick
The FUSBH200 debug port has a EHCI-compatible register layout so there is no need to define a custom struct. Signed-off-by: Chris Rorvick --- drivers/usb/host/fotg210.h | 13 + 1 file changed, 1 insertion(+), 12 deletions(-) diff --git a/drivers/usb/host/fotg210.h b/drivers/usb

[RFC RESEND 10/10] usb: Remove __init from early_dbgp_init() prototype

2014-09-28 Thread Chris Rorvick
: https://lkml.org/lkml/2006/1/14/305 Signed-off-by: Chris Rorvick --- include/linux/usb/ehci-dbgp.h | 3 +-- 1 file changed, 1 insertion(+), 2 deletions(-) diff --git a/include/linux/usb/ehci-dbgp.h b/include/linux/usb/ehci-dbgp.h index 796c1cd..7344d9e 100644 --- a/include/linux/usb/ehci

[RFC 02/10] fusbh200: Make Xen notificaiton consistent with EHCI

2014-09-09 Thread Chris Rorvick
fusbh200 consistent with ehci-dbgp as a step towards consolidating this code duplication. Signed-off-by: Chris Rorvick --- drivers/usb/host/fusbh200.h | 5 + 1 file changed, 5 insertions(+) diff --git a/drivers/usb/host/fusbh200.h b/drivers/usb/host/fusbh200.h index 6b719e0..6e7b8c1 100644 --- a

[RFC 00/10] Create separate header for ehci-dbgp driver

2014-09-09 Thread Chris Rorvick
solidation. As I said above, I am not able to actually test these changes on either controller. First time submission, so I look forward to any feedback. If this is of any interest I will work on testing the various configations and boot parameters. Regards, Chris Rorvick Chris Rorvick (

[RFC 01/10] usb: Create separate header for ehci-dbgp

2014-09-09 Thread Chris Rorvick
first step towards removing this redundancy. Signed-off-by: Chris Rorvick --- include/linux/usb/ehci-dbgp.h | 84 +++ include/linux/usb/ehci_def.h | 65 ++--- 2 files changed, 86 insertions(+), 63 deletions(-) create mode 100644

[RFC 05/10] fusbh200: Use ehci_dbg_port struct

2014-09-09 Thread Chris Rorvick
The FUSBH200 debug port has a EHCI-compatible register layout so there is no need to define a custom struct. Signed-off-by: Chris Rorvick --- drivers/usb/host/fusbh200.h | 13 + 1 file changed, 1 insertion(+), 12 deletions(-) diff --git a/drivers/usb/host/fusbh200.h b/drivers/usb

[RFC 06/10] fotg210: Make Xen notificaiton consistent with EHCI

2014-09-09 Thread Chris Rorvick
consistent with ehci-dbgp as a step towards consolidating this code duplication. Signed-off-by: Chris Rorvick --- drivers/usb/host/fotg210.h | 5 + 1 file changed, 5 insertions(+) diff --git a/drivers/usb/host/fotg210.h b/drivers/usb/host/fotg210.h index ac6cd1b..98c9670 100644 --- a/drivers

[RFC 03/10] fusbh200: Remove superfluous macro definitions

2014-09-09 Thread Chris Rorvick
The fusbh200_dbg_port struct is a copy of the ehci_dbg_port definition in the header. Embedded in this definition are a number of macros which came along for the ride. These macros are not used in the fusbh200 driver and will conflict those in the new header. Signed-off-by: Chris Rorvick

[RFC 09/10] fotg210: Use ehci_dbg_port struct

2014-09-09 Thread Chris Rorvick
The FUSBH200 debug port has a EHCI-compatible register layout so there is no need to define a custom struct. Signed-off-by: Chris Rorvick --- drivers/usb/host/fotg210.h | 13 + 1 file changed, 1 insertion(+), 12 deletions(-) diff --git a/drivers/usb/host/fotg210.h b/drivers/usb

[RFC 08/10] fotg210: Remove duplicate ehci-dbgp declarations

2014-09-09 Thread Chris Rorvick
Now that ehci-dbgp has its own header, use it rather than duplicating the declarations, etc. Signed-off-by: Chris Rorvick --- drivers/usb/host/fotg210.h | 40 ++-- 1 file changed, 2 insertions(+), 38 deletions(-) diff --git a/drivers/usb/host/fotg210.h b

[RFC 07/10] fotg210: Remove superfluous macro definitions

2014-09-09 Thread Chris Rorvick
The fotg210_dbg_port struct is a copy of the ehci_dbg_port definition in the header. Embedded in this definition are a number of macros which came along for the ride. These macros are not used in the fotg210 driver and will conflict those in the new header. Signed-off-by: Chris Rorvick

[RFC 04/10] fusbh200: Remove duplicate ehci-dbgp declarations

2014-09-09 Thread Chris Rorvick
Now that ehci-dbgp has its own header, use it rather than duplicating the declarations, etc. Signed-off-by: Chris Rorvick --- drivers/usb/host/fusbh200.h | 40 ++-- 1 file changed, 2 insertions(+), 38 deletions(-) diff --git a/drivers/usb/host/fusbh200.h b

[RFC 10/10] usb: Remove __init from early_dbgp_init() prototype

2014-09-09 Thread Chris Rorvick
: https://lkml.org/lkml/2006/1/14/305 Signed-off-by: Chris Rorvick --- include/linux/usb/ehci-dbgp.h | 3 +-- 1 file changed, 1 insertion(+), 2 deletions(-) diff --git a/include/linux/usb/ehci-dbgp.h b/include/linux/usb/ehci-dbgp.h index 796c1cd..7344d9e 100644 --- a/include/linux/usb/ehci