On Wednesday 29 March 2017 09:39 PM, Alexandre Bailon wrote:
> The CPPI 4.1 DMA is sharing its clock with the USB OTG,
> and most of the time, the clock will be enabled by USB.
> But during the init of the DMA, USB is not enabled (waiting for DMA),
> and then we must enable the clock before to do a
Hi Vivek,
[auto build test WARNING on balbi-usb/next]
[also build test WARNING on v4.11-rc5 next-20170403]
[cannot apply to pza/reset/next]
[if your patch is applied to the wrong git tree, please drop us a note to help
improve the system]
url:
https://github.com/0day-ci/linux/commits/Vivek
drivers/usb/dwc3/dwc3-of-simple.c:53:43-49: ERROR: application of sizeof to
pointer
sizeof when applied to a pointer typed expression gives the size of
the pointer
Generated by: scripts/coccinelle/misc/noderef.cocci
CC: Vivek Gautam
Signed-off-by: Fengguang Wu
---
dwc3-of-simple.c |2
Hi Vivek,
[auto build test WARNING on balbi-usb/next]
[also build test WARNING on v4.11-rc5 next-20170403]
[cannot apply to pza/reset/next]
[if your patch is applied to the wrong git tree, please drop us a note to help
improve the system]
url:
https://github.com/0day-ci/linux/commits/Vivek
Remove unnecessary variable and update function prototype.
Acked-by: Michal Nazarewicz
Reviewed-by: Greg Kroah-Hartman
Signed-off-by: Gustavo A. R. Silva
---
Changes in v2:
None.
drivers/usb/gadget/udc/amd5536udc.c | 5 +
1 file changed, 1 insertion(+), 4 deletions(-)
diff --git a/drive
Rewrite udc_free_dma_chain() function to avoid use of pointer after free.
Addresses-Coverity-ID: 1091172
Acked-by: Michal Nazarewicz
Reviewed-by: Greg Kroah-Hartman
Signed-off-by: Gustavo A. R. Silva
---
Changes in v2:
Remove 'td->next = 0x00' inside for loop.
Remove unnecessary pointer nulli
On 04/04/2017 09:44 AM, kbuild test robot wrote:
Hi Vivek,
[auto build test WARNING on balbi-usb/next]
[also build test WARNING on v4.11-rc5 next-20170403]
[cannot apply to pza/reset/next]
[if your patch is applied to the wrong git tree, please drop us a note to help
improve the system]
url
Hi Vivek,
[auto build test ERROR on balbi-usb/next]
[also build test ERROR on v4.11-rc5 next-20170403]
[cannot apply to pza/reset/next]
[if your patch is applied to the wrong git tree, please drop us a note to help
improve the system]
url:
https://github.com/0day-ci/linux/commits/Vivek
Hi Vivek,
[auto build test WARNING on balbi-usb/next]
[also build test WARNING on v4.11-rc5 next-20170403]
[cannot apply to pza/reset/next]
[if your patch is applied to the wrong git tree, please drop us a note to help
improve the system]
url:
https://github.com/0day-ci/linux/commits/Vivek
Hi Vivek,
[auto build test WARNING on balbi-usb/next]
[also build test WARNING on v4.11-rc5 next-20170403]
[cannot apply to pza/reset/next]
[if your patch is applied to the wrong git tree, please drop us a note to help
improve the system]
url:
https://github.com/0day-ci/linux/commits/Vivek
Add missing continue in switch.
Addresses-Coverity-ID: 1248733
Cc: Alan Stern
Cc: Greg Kroah-Hartman
Signed-off-by: Gustavo A. R. Silva
---
Changes in v2:
None.
drivers/usb/misc/usbtest.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/usb/misc/usbtest.c b/drivers/usb/misc/usbtes
Code refactoring to make the flow easier to follow.
Cc: Alan Stern
Cc: Greg Kroah-Hartman
Signed-off-by: Gustavo A. R. Silva
---
Changes in v2:
Remove unfruitful changes in previous patch.
Revert change to comment.
drivers/usb/misc/usbtest.c | 49
Hi,
* Kishon Vijay Abraham I [170330 04:51]:
> On Monday 27 March 2017 08:35 PM, Tony Lindgren wrote:
> > Seems this can be also done when implementing PM runtime handling.
> > If you want some of these changes done for the initial patch,
> > please let me know.
>
> I think it's better we get ex
On Mon, Apr 3, 2017 at 5:54 AM, Minas Harutyunyan
wrote:
> On 4/3/2017 9:23 AM, John Youn wrote:
>> On 03/31/2017 04:04 PM, John Stultz wrote:
>>> On Thu, Mar 2, 2017 at 12:00 PM, John Stultz wrote:
Hey John,
We've noticed that when using usb ethernet adapters on HiKey, we
occasi
Hi Alan,
Quoting Alan Stern :
On Mon, 3 Apr 2017, Gustavo A. R. Silva wrote:
Code refactoring to make the flow easier to follow.
Cc: Alan Stern
Cc: Greg Kroah-Hartman
Signed-off-by: Gustavo A. R. Silva
---
drivers/usb/misc/usbtest.c | 67
+-
From: Greg Ungerer
Date: Mon, 3 Apr 2017 15:50:03 +1000
> Add support for the net stats64 counters to the usbnet core. With that
> in place put the hooks into every usbnet driver to use it.
>
> This is a strait forward addition of 64bit counters for RX and TX packet
> and byte counts. It is don
On Mon, 3 Apr 2017, Gustavo A. R. Silva wrote:
> Code refactoring to make the flow easier to follow.
>
> Cc: Alan Stern
> Cc: Greg Kroah-Hartman
> Signed-off-by: Gustavo A. R. Silva
> ---
> drivers/usb/misc/usbtest.c | 67
> +-
> 1 file changed, 30
On 03/27/2017 02:54 PM, Alexandre Bailon wrote:
> On 03/27/2017 07:38 PM, Grygorii Strashko wrote:
>>
>>
>> On 03/27/2017 11:39 AM, Alexandre Bailon wrote:
>>> Hello Grygorii,
>>> On 03/24/2017 06:26 PM, Grygorii Strashko wrote:
On 03/24/2017 09:36 AM, Alexandre Bailon wrote:
>
Code refactoring to make the flow easier to follow.
Cc: Alan Stern
Cc: Greg Kroah-Hartman
Signed-off-by: Gustavo A. R. Silva
---
drivers/usb/misc/usbtest.c | 67 +-
1 file changed, 30 insertions(+), 37 deletions(-)
diff --git a/drivers/usb/misc/usbt
Quoting Alan Stern :
On Mon, 3 Apr 2017, Greg Kroah-Hartman wrote:
On Mon, Apr 03, 2017 at 09:39:53AM -0500, Gustavo A. R. Silva wrote:
> -Code refactoring to make the flow easier to follow.
> -Add missing 'continue' for case USB_ENDPOINT_XFER_INT.
Don't do multiple things in the same patch,
Looks like new warnings in usbnet
** CID 751368: Null pointer dereferences (FORWARD_NULL)
/drivers/net/usb/usbnet.c: 1925 in __usbnet_read_cmd()
*** CID 751368: Null pointer dereferences
Add missing continue in switch.
Addresses-Coverity-ID: 1248733
Cc: Alan Stern
Cc: Greg Kroah-Hartman
Signed-off-by: Gustavo A. R. Silva
---
drivers/usb/misc/usbtest.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/usb/misc/usbtest.c b/drivers/usb/misc/usbtest.c
index 3525626..7bfb
Hi Roger,
[auto build test ERROR on balbi-usb/next]
[also build test ERROR on v4.11-rc5 next-20170403]
[if your patch is applied to the wrong git tree, please drop us a note to help
improve the system]
url:
https://github.com/0day-ci/linux/commits/Roger-Quadros/usb-dwc3-dual-role-support
On Mon, 3 Apr 2017, Greg Kroah-Hartman wrote:
> On Mon, Apr 03, 2017 at 09:39:53AM -0500, Gustavo A. R. Silva wrote:
> > -Code refactoring to make the flow easier to follow.
> > -Add missing 'continue' for case USB_ENDPOINT_XFER_INT.
>
> Don't do multiple things in the same patch, please make the
> > > > > ...1d.7: PCI fixup... pass 2
> > > > > ...1d.7: PCI fixup... pass 3
> > > > > ...1d.7: PCI fixup... pass 3 done
> > > > >
> > > > > ...followed by hang. So yes, it looks USB related.
> > > > >
> > > > > (Sometimes it hangs with some kind backtrace involving secondary CPU
> > > > > start
On Mon, Apr 03, 2017 at 09:39:53AM -0500, Gustavo A. R. Silva wrote:
> -Code refactoring to make the flow easier to follow.
> -Add missing 'continue' for case USB_ENDPOINT_XFER_INT.
Don't do multiple things in the same patch, please make these multiple
patches. And do the "add missing continue" f
-Code refactoring to make the flow easier to follow.
-Add missing 'continue' for case USB_ENDPOINT_XFER_INT.
Addresses-Coverity-ID: 1248733
Cc: Alan Stern
Signed-off-by: Gustavo A. R. Silva
---
drivers/usb/misc/usbtest.c | 68 +-
1 file changed, 31 in
On Fri, Mar 31, 2017 at 06:39:12PM +0530, Raviteja Garimella wrote:
> The device node is used for UDCs integrated into Broadcom's
> iProc family of SoCs'. The UDC is based on Synopsys Designware
> Cores AHB Subsystem USB Device Controller IP.
>
> Signed-off-by: Raviteja Garimella
> ---
> Documen
On Mon, 3 Apr 2017, Guan Xin wrote:
> Thank you for your analysis!
> I checked that the lost sector is not at the beginning, and I hope
> it's not in the middle either.
No, it's the very last sector.
> So I can avoid using the last few sectors and live with it.
>
> Thanks again and sorry for wa
Hi Vivek,
thank you for the patch series. A few comments below: I'd like to reduce
the API surface a bit and include the counting and array allocation in
the _get functions, if possible.
On Mon, 2017-04-03 at 19:12 +0530, Vivek Gautam wrote:
> Many devices may want to request a bunch of resets
>
Thank you for your analysis!
I checked that the lost sector is not at the beginning, and I hope
it's not in the middle either.
So I can avoid using the last few sectors and live with it.
Thanks again and sorry for wasting your time on a bug that's not in
the linux kernel.
On Mon, Apr 3, 2017 at 6
On Mon, 3 Apr 2017, Guan Xin wrote:
> Not sure if attachments can be sent around on a mailing list.
> I'll put it into the content if you don't see the attached "usbmon.log
> (14 bytes, 1398 lines)".
Here's your answer. From the usbmon trace:
8800765753c0 1906124951 S Bo:1:015:4 -115 32
On Thu, Feb 23, 2017 at 07:40:13PM +0100, Pavel Machek wrote:
> On Thu 2017-02-23 17:28:26, Frederic Weisbecker wrote:
> > On Tue, Feb 14, 2017 at 08:27:43PM +0100, Pavel Machek wrote:
> > > On Tue 2017-02-14 18:59:56, Pavel Machek wrote:
> > > > Hi!
> > > >
> > > > > > > > Hmm. I moved keyboard b
Hi
On 02/01/2017 02:25 AM, Bruno Herrera wrote:
The STM32F4x9 MCU family has two DWC2 USB OTG cores on it. One core is
USB OTG FS and other core is USB OTG HS. The USB FS core only works with
its internal phy whilst the USF HS core can work in HS with external ulpi
phy or in FS/LS speed with the
On Wed, Mar 29, 2017 at 06:24:31PM +0200, Alexandre Bailon wrote:
> Currently, only the PIO mode is supported.
> This add support of CPPI 4.1 to DA8xx.
> As the In DA8xx the CPPI 4.1 DMA is a part of the USB.
> Create the CPPI 4.1 device as a child of USB.
>
> Signed-off-by: Alexandre Bailon
> --
On Mon, 3 Apr 2017, Roger Quadros wrote:
> allow usb_del_gadget_udc() and usb add_gadget_udc() to be called
> repeatedly on the same gadget->dev structure.
>
> We need to clear the gadget->dev structure so that kobject_init()
> doesn't complain about already initialized object.
>
> Signed-off-by
Many devices may want to request a bunch of resets
and control them. So it's better to manage them as an
array. Add APIs to _get(), _assert(), and _deassert()
an array of reset_control.
Cc: Philipp Zabel
Signed-off-by: Vivek Gautam
---
Changes since v1:
- New patch added to the series.
drive
Count number of reset phandles available with the device node
to know the resets a given device has.
Cc: Philipp Zabel
Signed-off-by: Vivek Gautam
---
Changes since v1:
- Handling the error path by returning error code for failures
and ENODEV for count equal to 0.
- Moved the function to d
Set of patches to support getting and de/asserting a list (array)
of reset controllers available with the device.
These patches address the comments received for the earlier
posted series [1,2].
The users can pass a list of reset controllers and the number of
resets available in the driver or the
Add support to get a list of resets available for the device.
These resets must be kept de-asserted until the device is
in use.
Cc: Felipe Balbi
Cc: Philipp Zabel
Signed-off-by: Vivek Gautam
---
Changes since v1:
- Using new APIs for reset control array.
- Using the *_get_exclusive() API.
-
Make use of reset_control_array_*() set of APIs to manage
an array of reset controllers available with the device.
Cc: Thierry Reding
Cc: Philipp Zabel
Signed-off-by: Vivek Gautam
---
Changes since v1:
- New patch added to the series to enable this driver use the
newer set of APIs that man
On Mon, Apr 03, 2017 at 01:21:08PM +, Kalle Valo wrote:
> Johan Hovold writes:
>
> > On Mon, Apr 03, 2017 at 01:02:28PM +, Kalle Valo wrote:
> >> Kalle Valo writes:
> >>
> >> > Johan Hovold writes:
> >> >
> >> >> On Mon, Mar 13, 2017 at 01:44:20PM +0100, Johan Hovold wrote:
> >> >>> Ma
Johan Hovold writes:
> On Mon, Apr 03, 2017 at 01:02:28PM +, Kalle Valo wrote:
>> Kalle Valo writes:
>>
>> > Johan Hovold writes:
>> >
>> >> On Mon, Mar 13, 2017 at 01:44:20PM +0100, Johan Hovold wrote:
>> >>> Make sure to check the number of endpoints to avoid dereferencing a
>> >>> NULL-
On Mon, Apr 03, 2017 at 01:02:28PM +, Kalle Valo wrote:
> Kalle Valo writes:
>
> > Johan Hovold writes:
> >
> >> On Mon, Mar 13, 2017 at 01:44:20PM +0100, Johan Hovold wrote:
> >>> Make sure to check the number of endpoints to avoid dereferencing a
> >>> NULL-pointer or accessing memory beyo
Kalle Valo writes:
> Johan Hovold writes:
>
>> On Mon, Mar 13, 2017 at 01:44:20PM +0100, Johan Hovold wrote:
>>> Make sure to check the number of endpoints to avoid dereferencing a
>>> NULL-pointer or accessing memory beyond the endpoint array should a
>>> malicious device lack the expected endp
Hi,
On 4/3/2017 9:23 AM, John Youn wrote:
> On 03/31/2017 04:04 PM, John Stultz wrote:
>> On Thu, Mar 2, 2017 at 12:00 PM, John Stultz wrote:
>>> Hey John,
>>> We've noticed that when using usb ethernet adapters on HiKey, we
>>> occasionally see errors like:
>>>
>>> dwc2 f72c.usb: dwc2_hc_c
Hi,
Taking a simplistic approach this time. We don't use the OTG controller
block at all. Instead we just rely on ID events via extcon framework.
I tried to get rid of workqueue but unfortunately it causes too much pain
when the UDC is unregistered.
https://hastebin.com/upugaqogol.xml
https://ha
If dr_mode == "otg", we start by default in PERIPHERAL mode.
Keep track of current role in "current_dr_role" whenever dwc3_set_mode()
is called.
When debugfs/mode is changed AND we're in dual-role mode,
handle the switch by stopping and starting the respective
host/gadget controllers.
Signed-off-
allow usb_del_gadget_udc() and usb add_gadget_udc() to be called
repeatedly on the same gadget->dev structure.
We need to clear the gadget->dev structure so that kobject_init()
doesn't complain about already initialized object.
Signed-off-by: Roger Quadros
---
drivers/usb/gadget/udc/core.c | 1
If dr_mode is "otg" then support dual role mode of operation.
Currently this mode is only supported when an extcon handle is
present in the dwc3 device tree node. This is needed to
get the ID status events of the port.
We're using a workqueue to manage the dual-role state transitions
as the extcon
Not sure if attachments can be sent around on a mailing list.
I'll put it into the content if you don't see the attached "usbmon.log
(14 bytes, 1398 lines)".
Guan
On Sun, Apr 2, 2017 at 10:15 PM, Alan Stern wrote:
> On Sun, 2 Apr 2017, Guan Xin wrote:
>
>> Bus 002 Device 004: ID 0bc2:2322 Se
Drop redundant calls to tty_buffer_request_room and use the more
efficient tty_insert_flip_char when inserting single characters.
Signed-off-by: Johan Hovold
---
drivers/usb/serial/quatech2.c | 4 +---
1 file changed, 1 insertion(+), 3 deletions(-)
diff --git a/drivers/usb/serial/quatech2.c b/d
The transfer buffers and URBs are allocated and initialised by USB
serial core during probe, and there's no need to check for NULL transfer
buffers in the bulk-in completion handlers.
Signed-off-by: Johan Hovold
---
drivers/usb/serial/iuu_phoenix.c | 9 +++--
1 file changed, 3 insertions(+),
Johan Hovold writes:
> On Mon, Mar 13, 2017 at 01:44:20PM +0100, Johan Hovold wrote:
>> Make sure to check the number of endpoints to avoid dereferencing a
>> NULL-pointer or accessing memory beyond the endpoint array should a
>> malicious device lack the expected endpoints.
>>
>> Fixes: 36bcce4
On Mon, Mar 13, 2017 at 01:44:20PM +0100, Johan Hovold wrote:
> Make sure to check the number of endpoints to avoid dereferencing a
> NULL-pointer or accessing memory beyond the endpoint array should a
> malicious device lack the expected endpoints.
>
> Fixes: 36bcce430657 ("ath9k_htc: Handle stor
commit a8c06e407ef9 ("usb: separate out sysdev pointer from
usb_bus") converted to use hcd->self.sysdev for DMA
operations instead of hcd->self.controller but forgot to do
it for one instance.
This gets caught when DMA debugging is enabled since dma map
and unmap end up using different device poin
Greg Ungerer writes:
> Add support for the net stats64 counters to the usbnet core. With that
> in place put the hooks into every usbnet driver to use it.
>
> This is a strait forward addition of 64bit counters for RX and TX packet
> and byte counts. It is done in the same style as for the other
On Sun, Apr 02, 2017 at 10:12:38AM -0700, Joe Perches wrote:
> On Sun, 2017-04-02 at 18:57 +0200, Leif Neland wrote:
> > There is a patch
> > https://github.com/karlp/ch341-linux/blob/master/0001-usb-serial-ch341-Add-parity-support.patch
> > which enables parity selection for the ch341 USB-RS485 ad
Use the common mutex from driver/usb/host/pci-quirks.c in the
i2c-piix4 driver to synchronize access to the I/O port pair
0xcd6 / 0xcd7.
At the same time, remove the request_region() call to reserve
these I/O ports, so the sp5100_tco watchdog driver can also
load. The mutex is enough to protect th
This patch adds a common mutex in the USB PCI quirks code and starts
using it to synchronize access to the I/O port pair 0xcd6 / 0xcd7 on
SB800.
These I/O ports are also used by i2c-piix4 and sp5100_tco, the next
two patches port these drivers to use this common mutex.
v2: No extra header and no
Use the common mutex from usb/host/pci-quirks.c to synchronize
accesses to the SB800 I/O port pair (0xcd6 / 0xcd7) with the
PCI quirk for isochronous USB transfers and with the i2c-piix4
driver.
At the same time, remove the request_region() call to reserve
these I/O ports, similarly to i2c-piix4 s
Three drivers are accessing the same I/O ports (0xcd6 / 0xcd7) on
AMD SB800 based machines without synchronization or with excluding
each other out:
* the USB quirk for isochronous transfers on SB800 (no locking)
* sp5100_tco (request_region)
* i2c-piix4 (request_region)
Historically, the sp5100_
From: Cristian Birsan
Update Kconfig help for fifo_mode = 0 to explain the behavior better.
Signed-off-by: Cristian Birsan
Acked-by: Nicolas Ferre
---
drivers/usb/gadget/udc/Kconfig | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)
diff --git a/drivers/usb/gadget/udc/Kconfig b/drive
From: Cristian Birsan
Use dev_err() to display EP configuration error to avoid silent failure.
Signed-off-by: Cristian Birsan
Acked-by: Nicolas Ferre
---
drivers/usb/gadget/udc/atmel_usba_udc.c | 8
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/drivers/usb/gadget/udc/
From: Cristian Birsan
This patch series provides fixes, based on the feedback received on the mailing
list, for
the following:
- fifo table parameters validation against device tree values
- coding style
- message display for EP configuration error
- Kconfig comme
From: Cristian Birsan
Minor code cleanup based on feedback received on mailinglist.
Signed-off-by: Cristian Birsan
Acked-by: Nicolas Ferre
---
drivers/usb/gadget/udc/atmel_usba_udc.c | 17 +++--
1 file changed, 7 insertions(+), 10 deletions(-)
diff --git a/drivers/usb/gadget/udc/
From: Cristian Birsan
Check fifo configuration values against device tree values for endpoint fifo
in auto configuration mode (fifo_mode=0).
Signed-off-by: Cristian Birsan
Acked-by: Nicolas Ferre
---
drivers/usb/gadget/udc/atmel_usba_udc.c | 24 ++--
1 file changed, 22 ins
Hi,
Minas Harutyunyan writes:
>> Minas Harutyunyan writes:
>>> After data out stage gadget driver should not initate ZLP on control EP,
>>> because it is up to function driver.
>>
>> not true always, depends on return value from ->setup(). Which problem
>> did you have? Which gadget driver? How
68 matches
Mail list logo