On Fri, 28 Oct 2016, Bin Liu wrote:
> On Fri, Oct 28, 2016 at 04:53:03PM -0400, Greg Kroah-Hartman wrote:
> > On Fri, Oct 28, 2016 at 10:33:19PM +0200, Julia Lawall wrote:
> > >
> > >
> > > On Fri, 28 Oct 2016, Julia Lawall wrote:
> > >
> > > > The file drivers/usb/musb/musb_core.c contains the
On Fri, Oct 28, 2016 at 04:53:03PM -0400, Greg Kroah-Hartman wrote:
> On Fri, Oct 28, 2016 at 10:33:19PM +0200, Julia Lawall wrote:
> >
> >
> > On Fri, 28 Oct 2016, Julia Lawall wrote:
> >
> > > The file drivers/usb/musb/musb_core.c contains the code:
> > >
> > > static DEVICE_ATTR(srp, 0644, NU
On Fri, Oct 28, 2016 at 12:11:21PM -0500, David Lechner wrote:
> On 10/28/2016 07:39 AM, Alexandre Bailon wrote:
> >On 10/28/2016 04:56 AM, David Lechner wrote:
> >>On 10/26/2016 05:58 AM, Alexandre Bailon wrote:
> >>>When the phy is forced in host mode, only the first hot plug and
> >>>hot remove
mv_u3d_req_to_trb() does not check for dma mapping errors.
By the way, the patch improves readability of mv_u3d_start_queue()
by rearranging its code with two semantic modifications:
- assignment zero to ep->processing if usb_gadget_map_request() fails;
- propagation of error code from mv_u3d_req_
Some of the USB core files were missing explicit license information.
As all files in the kernel tree are implicitly licensed under the
GPLv2-only, be explicit in case someone get confused looking at
individual files by using the SPDX nomenclature.
Signed-off-by: Greg Kroah-Hartman
---
drivers/
On Fri, 28 Oct 2016, Greg Kroah-Hartman wrote:
> On Fri, Oct 28, 2016 at 10:33:19PM +0200, Julia Lawall wrote:
> >
> >
> > On Fri, 28 Oct 2016, Julia Lawall wrote:
> >
> > > The file drivers/usb/musb/musb_core.c contains the code:
> > >
> > > static DEVICE_ATTR(srp, 0644, NULL, musb_srp_store);
[Corrected email for Felipe]
On Fri, 28 Oct 2016, Greg Kroah-Hartman wrote:
> On Fri, Oct 28, 2016 at 10:33:19PM +0200, Julia Lawall wrote:
> >
> >
> > On Fri, 28 Oct 2016, Julia Lawall wrote:
> >
> > > The file drivers/usb/musb/musb_core.c contains the code:
> > >
> > > static DEVICE_ATTR(srp, 0
On Fri, Oct 28, 2016 at 10:33:19PM +0200, Julia Lawall wrote:
>
>
> On Fri, 28 Oct 2016, Julia Lawall wrote:
>
> > The file drivers/usb/musb/musb_core.c contains the code:
> >
> > static DEVICE_ATTR(srp, 0644, NULL, musb_srp_store);
> >
> > Is it correct to have NULL in the third argument for an
On Fri, 28 Oct 2016, Julia Lawall wrote:
> The file drivers/usb/musb/musb_core.c contains the code:
>
> static DEVICE_ATTR(srp, 0644, NULL, musb_srp_store);
>
> Is it correct to have NULL in the third argument for an attribute that can
> be read? Should the permission be 0444 instead?
Sorry, I
The file drivers/usb/musb/musb_core.c contains the code:
static DEVICE_ATTR(srp, 0644, NULL, musb_srp_store);
Is it correct to have NULL in the third argument for an attribute that can
be read? Should the permission be 0444 instead?
thanks,
julia
--
To unsubscribe from this list: send the line
* Johan Hovold [161028 02:45]:
> On Thu, Oct 27, 2016 at 12:15:52PM -0700, Tony Lindgren wrote:
> > * Johan Hovold [161027 11:46]:
> > > But then this looks like it could trigger an ABBA deadlock as musb->lock
> > > is held while queue_on_resume() takes musb->list_lock, and
> > > musb_run_pending
On 10/28/2016 07:39 AM, Alexandre Bailon wrote:
On 10/28/2016 04:56 AM, David Lechner wrote:
On 10/26/2016 05:58 AM, Alexandre Bailon wrote:
When the phy is forced in host mode, only the first hot plug and
hot remove works. That is actually because the driver execute the
OTG workaround, whereas
On 10/28/2016 8:52 AM, Leo Yan wrote:
> This reverts commit aa381a7259c3f53727bcaa8c5f9359e940a0e3fd.
>
> Reverting this patch, as it incorrectly assumes TX FIFO size is fixed
> and cannot change FIFO size; it removes all related dt binding code
> and have no chance to set FIFO size at init phase.
On 10/28/2016 04:31 AM, Alexandre Bailon wrote:
On 10/27/2016 08:44 PM, David Lechner wrote:
On 10/27/2016 12:16 PM, David Lechner wrote:
On 10/26/2016 05:58 AM, Alexandre Bailon wrote:
Currently, the USB OTG of the da8xx doesn't work.
This series intend to fix them.
Change in v2:
* Fix the e
On Fri, Oct 28, 2016 at 08:51:41PM +0800, Baolin Wang wrote:
> On 28 October 2016 at 06:00, NeilBrown wrote:
> > 1/ I think we agreed that it doesn't make sense for there to be
> > two chargers registered in a system.
> Yes, until now...
> > However usb_charger_register() still allows that, a
On Fri, Oct 28, 2016 at 01:16:13PM +0300, Felipe Balbi wrote:
>
> Hi,
>
> Ville Syrjälä writes:
> > On Thu, Oct 06, 2016 at 12:08:26PM +0300, Ville Syrjälä wrote:
> >> On Thu, Oct 06, 2016 at 10:36:09AM +0300, Felipe Balbi wrote:
> >> >
> >> > Hi,
> >> >
> >> > Felipe Balbi writes:
> >>
> >>
This reverts commit aa381a7259c3f53727bcaa8c5f9359e940a0e3fd.
Reverting this patch, as it incorrectly assumes TX FIFO size is fixed
and cannot change FIFO size; it removes all related dt binding code
and have no chance to set FIFO size at init phase.
As result, Hi6220 cannot set correct FIFO size
Brauchen Sie einen Kredit? Wenn ja, mailen Sie uns für weitere Informationen.
--
To unsubscribe from this list: send the line "unsubscribe linux-usb" in
the body of a message to majord...@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Hello Felipe,
If this series looks good, can you pick it up please?
Thanks,
2016-09-19 1:03 GMT+09:00 Masahiro Yamada :
> Replace the chain of list_empty() and list_first_entry()
> with list_first_entry_or_null().
>
> Changes in v2:
> - Split into per-driver patches
>
>
> Masahiro Yamada (3):
>
On Tue, 2016-10-18 at 14:07 +0200, Takashi Iwai wrote:
> On Wed, 12 Oct 2016 18:15:04 +0200,
> Bastien Nocera wrote:
> >
> > On Wed, 2016-10-12 at 18:06 +0200, Clemens Ladisch wrote:
> > > Bastien Nocera wrote:
> > > > On Wed, 2016-10-12 at 14:43 +0200, Clemens Ladisch wrote:
> > > > > Bastien Noc
Hi,
On 28 October 2016 at 06:00, NeilBrown wrote:
> On Thu, Oct 27 2016, Baolin Wang wrote:
>
>> Hi Felipe,
>>
>> On 19 October 2016 at 10:37, Baolin Wang wrote:
>>> Currently the Linux kernel does not provide any standard integration of this
>>> feature that integrates the USB subsystem with th
On 10/28/2016 04:56 AM, David Lechner wrote:
> On 10/26/2016 05:58 AM, Alexandre Bailon wrote:
>> When the phy is forced in host mode, only the first hot plug and
>> hot remove works. That is actually because the driver execute the
>> OTG workaround, whereas it is not applicable in host or device m
On Fri, Oct 28, 2016 at 01:30:07PM +0300, Felipe Balbi wrote:
> Mark Rutland writes:
> > On Thu, Oct 27, 2016 at 02:08:25PM -0700, John Youn wrote:
> >> On 10/26/2016 3:57 AM, Mark Rutland wrote:
> >> > On Tue, Oct 25, 2016 at 12:42:46PM -0700, John Youn wrote:
> >> >> Add interrupt moderation int
Hi Chunfeng,
On 10/19/2016 04:28 AM, Chunfeng Yun wrote:
These patches introduce the MediaTek USB3 dual-role controller
driver.
The driver can be configured as Dual-Role Device (DRD),
Peripheral Only and Host Only (xHCI) modes. It works well
with Mass Storage, RNDIS and g_zero on FS/HS and SS.
Hi,
Mark Rutland writes:
> On Thu, Oct 27, 2016 at 02:08:25PM -0700, John Youn wrote:
>> On 10/26/2016 3:57 AM, Mark Rutland wrote:
>> > On Tue, Oct 25, 2016 at 12:42:46PM -0700, John Youn wrote:
>> >> Add interrupt moderation interval binding for dwc3.
>
>> >> + - snps,imod_interval: the interr
On Thu, Oct 27, 2016 at 02:08:25PM -0700, John Youn wrote:
> On 10/26/2016 3:57 AM, Mark Rutland wrote:
> > On Tue, Oct 25, 2016 at 12:42:46PM -0700, John Youn wrote:
> >> Add interrupt moderation interval binding for dwc3.
> >> + - snps,imod_interval: the interrupt moderation interval.
> > What
Hi,
Ville Syrjälä writes:
> On Thu, Oct 06, 2016 at 12:08:26PM +0300, Ville Syrjälä wrote:
>> On Thu, Oct 06, 2016 at 10:36:09AM +0300, Felipe Balbi wrote:
>> >
>> > Hi,
>> >
>> > Felipe Balbi writes:
>>
>> > Okay, I have found a regression on dwc3 and another patch follows:
>> >
>> > commi
On 10/28/2016 11:31 AM, Alexandre Bailon wrote:
> On 10/27/2016 08:44 PM, David Lechner wrote:
>> On 10/27/2016 12:16 PM, David Lechner wrote:
>>> On 10/26/2016 05:58 AM, Alexandre Bailon wrote:
Currently, the USB OTG of the da8xx doesn't work.
This series intend to fix them.
Ch
Hi,
John Youn writes:
> On 10/27/2016 3:47 AM, Felipe Balbi wrote:
>>
>> Hi,
>>
>> John Youn writes:
>>> Add interrupt moderation interval binding for dwc3.
>>>
>>> Signed-off-by: John Youn
>>> ---
>>> Documentation/devicetree/bindings/usb/dwc3.txt | 1 +
>>> 1 file changed, 1 insertion(+)
On Thu, Oct 27, 2016 at 12:15:52PM -0700, Tony Lindgren wrote:
> * Johan Hovold [161027 11:46]:
> > On Thu, Oct 27, 2016 at 10:40:17AM -0700, Tony Lindgren wrote:
> > > diff --git a/drivers/usb/musb/musb_gadget.c
> > > b/drivers/usb/musb/musb_gadget.c
> > > --- a/drivers/usb/musb/musb_gadget.c
>
On 10/27/2016 08:44 PM, David Lechner wrote:
> On 10/27/2016 12:16 PM, David Lechner wrote:
>> On 10/26/2016 05:58 AM, Alexandre Bailon wrote:
>>> Currently, the USB OTG of the da8xx doesn't work.
>>> This series intend to fix them.
>>>
>>> Change in v2:
>>> * Fix the error path da8xx_musb_init()
>
This is a note to let you know that I've just added the patch titled
tty: vgacon+sisusb, move scrolldelta to a common helper
to my tty git tree which can be found at
git://git.kernel.org/pub/scm/linux/kernel/git/gregkh/tty.git
in the tty-next branch.
The patch will show up in the next r
This is a note to let you know that I've just added the patch titled
tty: vt, cleanup and document con_scroll
to my tty git tree which can be found at
git://git.kernel.org/pub/scm/linux/kernel/git/gregkh/tty.git
in the tty-next branch.
The patch will show up in the next release of the l
Hi,
Joseph Kogut writes:
> Hi Felipe,
>
> That's some great information, thanks!
>
> At first glance, the DSDT table has two interesting bits. (I would
> paste the decompiled source, but I think it may be copyrighted?
> Correct me if I'm wrong.) The first is the USB mux, an SMSC USB3750
> connec
34 matches
Mail list logo