Re: [PATCH v2 1/3] usb: core: lpm: fix usb3_hardware_lpm sysfs node

2015-11-13 Thread Lu Baolu
On 11/13/2015 11:28 PM, Alan Stern wrote: On Fri, 13 Nov 2015, Lu, Baolu wrote: On 11/13/2015 12:20 AM, Alan Stern wrote: On Thu, 12 Nov 2015, Lu Baolu wrote: Commit 655fe4effe0f ("usbcore: add sysfs support to xHCI usb3 hardware LPM") introduced usb3_hardware_lpm sysfs node. This doesn't

Test. Please ignore

2015-11-13 Thread team
Test message. Please ignore. -- To unsubscribe from this list: send the line "unsubscribe linux-usb" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html

Re: [PATCH] usb: musb: enable usb_dma parameter

2015-11-13 Thread Greg KH
On Fri, Nov 13, 2015 at 03:45:24PM -0600, Bin Liu wrote: > Change the permission of usb_dma parameter so it can be used for runtime > debug without reboot. Why would you want to do that? This is only used at init time, so if you change it while the driver is running, I don't think you will actual

Re: [RFC] usb: dwc2: hcd: fix split schedule issue

2015-11-13 Thread Doug Anderson
John, On Thu, Nov 12, 2015 at 9:05 PM, John Youn wrote: > It seems to be an issue with single TT hubs. I've tried several > multi-TT hubs with no issues. Agreed. > With a single TT hub I do see a problem though not the exact one > described. I see corrupted and dropped packets on the FS side o

[PATCH] usb: musb: enable usb_dma parameter

2015-11-13 Thread Bin Liu
Change the permission of usb_dma parameter so it can be used for runtime debug without reboot. Signed-off-by: Bin Liu --- drivers/usb/musb/musb_core.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/usb/musb/musb_core.c b/drivers/usb/musb/musb_core.c index 0fcf01f..6a

Re: Page allocation failure

2015-11-13 Thread Steinar H. Gunderson
On Fri, Nov 13, 2015 at 04:02:48PM -0500, Alan Stern wrote: >> So what is the road from here? I guess the original questions about cache >> coherency still apply, and that this is what I'm seeing in dmesg. > What questions? It should be obvious that the user program should not > touch the buffer

Re: Page allocation failure

2015-11-13 Thread Alan Stern
On Fri, 13 Nov 2015, Steinar H. Gunderson wrote: > So what is the road from here? I guess the original questions about cache > coherency still apply, and that this is what I'm seeing in dmesg. What questions? It should be obvious that the user program should not touch the buffer contents while

Re: Page allocation failure

2015-11-13 Thread Steinar H. Gunderson
On Fri, Nov 13, 2015 at 03:20:56PM -0500, Alan Stern wrote: >> I tried just not setting as->userbuffer if usbm == NULL, and lo and behold, >> it actually seems to help. > In fact, there's no need to call copy_urb_data_to_user at all if the > buffer lies in the mmap'ed area. usbm != NULL is meant

Re: Page allocation failure

2015-11-13 Thread Alan Stern
On Fri, 13 Nov 2015, Steinar H. Gunderson wrote: > On Fri, Nov 13, 2015 at 06:50:27PM +0100, Steinar H. Gunderson wrote: > > The stack trace is simple enough, although I fear there's some inlining > > going > > on: > > OK, I guess since copy_user_enhanced_fast_string is an assembler function, >

Re: Page allocation failure

2015-11-13 Thread Alan Stern
On Fri, 13 Nov 2015, Steinar H. Gunderson wrote: > On Fri, Nov 13, 2015 at 11:24:39AM -0500, Alan Stern wrote: > >> What exactly am I looking for, beyond the stack trace the kernel already > >> gives me? > > Find out where copy_user_enhanced_fast_string is being called from, and > > using that in

Re: Page allocation failure

2015-11-13 Thread Steinar H. Gunderson
On Fri, Nov 13, 2015 at 06:50:27PM +0100, Steinar H. Gunderson wrote: > The stack trace is simple enough, although I fear there's some inlining going > on: OK, I guess since copy_user_enhanced_fast_string is an assembler function, the unwinding doesn't work properly. I added a dump_stack() in copy

Re: Page allocation failure

2015-11-13 Thread Steinar H. Gunderson
On Fri, Nov 13, 2015 at 11:24:39AM -0500, Alan Stern wrote: >> What exactly am I looking for, beyond the stack trace the kernel already >> gives me? > Find out where copy_user_enhanced_fast_string is being called from, and > using that information, figure out why it was called. That will tell >

[PATCH 3/4 V2 RESEND] usb: dwc2: Return errors from PHY

2015-11-13 Thread Stefan Wahren
When searching for PHYs, any error was treated as if the PHY did not exist or was not specified. Thus the probe function did not correctly return error conditions such as -EPROBE_DEFER. Fixed so that only a non-existing PHY is ignored and any other error is returned. Reported-by: Alexander Aring

[PATCH 0/4 V2 RESEND] usb: dwc2: fix usb host support on Raspberry Pi

2015-11-13 Thread Stefan Wahren
This patch series fixes multiple issues on Raspberry Pi which were reproducable since commit 09a75e857790 ("usb: dwc2: refactor common low-level hw code to platform.c") Changes in V2: - add fix for kernel oops - extend "usb: dwc2: Return errors from PHY" to handle kernel without PHY support - t

[PATCH 4/4 V2 RESEND] usb: dwc2: make otg clk optional

2015-11-13 Thread Stefan Wahren
Fixes commit 09a75e857790 ("usb: dwc2: refactor common low-level hw code to platform.c") The above commit consolidated the low-level phy access into a common location. This change made the otg clk a requirement and broke some platforms when it was moved into platform.c. So make clk handling optio

[PATCH 1/4 V2 RESEND] usb: dwc2: fix kernel oops during driver probe

2015-11-13 Thread Stefan Wahren
This patch make sure that all necessary members of dwc2_hsotg are initialized before the irq handler is requested. So the kernel oops triggered by dwc2_handle_common_intr has been fixed. dwc2 2098.usb: Configuration mismatch. Forcing host mode dwc2 2098.usb: no platform data or transce

[PATCH 2/4 V2 RESEND] usb: dwc2: Make PHY optional

2015-11-13 Thread Stefan Wahren
From: John Youn Fixes commit 09a75e857790 ("usb: dwc2: refactor common low-level hw code to platform.c") The above commit consolidated the low-level phy access into a common location. This change introduced a check from the gadget requiring that a PHY is specified. This requirement never existed

[PATCH 1/1] net: usb: cdc_ether: add Dell DW5580 as a mobile broadband adapter

2015-11-13 Thread Daniele Palmas
Since Dell DW5580 is a 3G modem, this patch adds the device as a mobile broadband adapter Signed-off-by: Daniele Palmas --- drivers/net/usb/cdc_ether.c | 5 + 1 file changed, 5 insertions(+) diff --git a/drivers/net/usb/cdc_ether.c b/drivers/net/usb/cdc_ether.c index 35a2bff..5e92076 100644

Re: Page allocation failure

2015-11-13 Thread Alan Stern
On Fri, 13 Nov 2015, Steinar H. Gunderson wrote: > On Fri, Nov 13, 2015 at 10:38:54AM -0500, Alan Stern wrote: > >> So, in general I think it's good news, although I don't fully understand > >> why > >> I still need the kernel-to-userspace copy for isochronous transfer. > > Maybe you can add some

Re: [PATCH v4 1/4] fs: configfs: Drop unused parameter from configfs_undepend_item()

2015-11-13 Thread Andrzej Pietrasiewicz
Hello, W dniu 26.10.2015 o 17:43, Krzysztof Opasiak pisze: subsys parameter is never used by configfs_undepend_item() so there is no point in passing it to this function. Signed-off-by: Krzysztof Opasiak --- Changes since v3: - fix build break in ocfs2 Any comments on the series adding unlo

Re: [PATCH v3 04/12] usb: xhci: dbc: add support for Intel xHCI dbc quirk

2015-11-13 Thread Dmitry Malkin
On Mon, 9 Nov 2015 15:38:33 +0800, Lu Baolu wrote: > On Intel platform, if the debug target is connected with debug > host, enabling DCE bit in command register leads to a hung bus > state. In the hung state, the host system will not see a port > connected status bit set. Hence debug target fails

Re: Page allocation failure

2015-11-13 Thread Steinar H. Gunderson
On Fri, Nov 13, 2015 at 10:38:54AM -0500, Alan Stern wrote: >> So, in general I think it's good news, although I don't fully understand why >> I still need the kernel-to-userspace copy for isochronous transfer. > Maybe you can add some debugging to copy_user_enhanced_fast_string(). > Add a flag,

Re: Page allocation failure

2015-11-13 Thread Alan Stern
On Fri, 13 Nov 2015, Steinar H. Gunderson wrote: > On Fri, Nov 13, 2015 at 12:00:53AM +0100, Steinar H. Gunderson wrote: > > Interesting. I hacked libusb to get the fd. Then I did > > USBDEVFS_ALLOC_MEMORY, > > which succeeded (well, as soon as I filled mem.size before calling), > > then mmap on

Re: [PATCH v2 1/3] usb: core: lpm: fix usb3_hardware_lpm sysfs node

2015-11-13 Thread Alan Stern
On Fri, 13 Nov 2015, Lu, Baolu wrote: > On 11/13/2015 12:20 AM, Alan Stern wrote: > > On Thu, 12 Nov 2015, Lu Baolu wrote: > > > >> Commit 655fe4effe0f ("usbcore: add sysfs support to xHCI usb3 > >> hardware LPM") introduced usb3_hardware_lpm sysfs node. This > >> doesn't show the correct status o

Re: [PATCH 2/4 V2] usb: dwc2: Make PHY optional

2015-11-13 Thread Stefan Wahren
Am 13.11.2015 um 13:25 schrieb Sergei Shtylyov: > Hello. > > On 11/13/2015 12:08 AM, Stefan Wahren wrote: > >> From: John Youn >> >> Fixes commit 09a75e857790 >> ("usb: dwc2: refactor common low-level hw code to platform.c") >> >> The above commit consolidated the low-level phy access into a commo

Re: [PATCH 1/2] cdc_acm: Ignore Infineon Flash Loader utility

2015-11-13 Thread Johan Hovold
On Fri, Nov 13, 2015 at 03:13:41PM +0100, Daniele Palmas wrote: > 2015-11-13 11:58 GMT+01:00 Johan Hovold : > > On Thu, Nov 12, 2015 at 02:55:04PM +0100, Bjørn Mork wrote: > >> I believe this supports the assumption that Infineon Flash Loader > >> devices have some ACM descriptors without actually

Re: [PATCH 1/2] cdc_acm: Ignore Infineon Flash Loader utility

2015-11-13 Thread Daniele Palmas
Hi Johan, 2015-11-13 11:58 GMT+01:00 Johan Hovold : > On Thu, Nov 12, 2015 at 02:55:04PM +0100, Bjørn Mork wrote: >> Daniele Palmas writes: > >> > But I see that Infineon flashing devices in newer chipsets have become >> > an only bulk serial link device (see device 0x8087/0x0716 in >> > usb-seri

Re: [PATCH v5 7/7] usb: gadget: f_midi: pre-allocate IN requests

2015-11-13 Thread Robert Baldyga
Hi Felipe, On 11/10/2015 06:52 PM, Felipe F. Tonello wrote: > This patch introduces pre-allocation of IN endpoint USB requests. This > improves on latency (requires no usb request allocation on transmit) and avoid > several potential probles on allocating too many usb requests (which involves > DM

Re: [PATCH 2/4 V2] usb: dwc2: Make PHY optional

2015-11-13 Thread Sergei Shtylyov
Hello. On 11/13/2015 12:08 AM, Stefan Wahren wrote: From: John Youn Fixes commit 09a75e857790 ("usb: dwc2: refactor common low-level hw code to platform.c") The above commit consolidated the low-level phy access into a common location. This change introduced a check from the gadget requiring

Re: Page allocation failure

2015-11-13 Thread Steinar H. Gunderson
On Fri, Nov 13, 2015 at 12:00:53AM +0100, Steinar H. Gunderson wrote: > Interesting. I hacked libusb to get the fd. Then I did USBDEVFS_ALLOC_MEMORY, > which succeeded (well, as soon as I filled mem.size before calling), > then mmap on it as described (which also succeeded), and everything _works_,

Re: [PATCH 1/2] cdc_acm: Ignore Infineon Flash Loader utility

2015-11-13 Thread Johan Hovold
On Thu, Nov 12, 2015 at 02:55:04PM +0100, Bjørn Mork wrote: > Daniele Palmas writes: > > But I see that Infineon flashing devices in newer chipsets have become > > an only bulk serial link device (see device 0x8087/0x0716 in > > usb-serial-simple), so maybe this has a meaning... > > Yes. I have

Re: [PATCH v3 5/5] Add ioctls to enable and disable local controls on an instrument

2015-11-13 Thread Dave Penkler
Hi Andy, On Wed, Nov 11, 2015 at 09:36:41PM +0200, Andy Shevchenko wrote: > On Wed, Nov 11, 2015 at 1:21 PM, Dave Penkler wrote: > > These ioctls provide support for the USBTMC-USB488 control requests > > for REN_CONTROL, GO_TO_LOCAL and LOCAL_LOCKOUT snip > > + goto exit;

Re: [PATCH v5 7/7] usb: gadget: f_midi: pre-allocate IN requests

2015-11-13 Thread Clemens Ladisch
Felipe F. Tonello wrote: > This patch introduces pre-allocation of IN endpoint USB requests. This > improves on latency (requires no usb request allocation on transmit) and avoid > several potential probles on allocating too many usb requests (which involves > DMA pool allocation problems). > > Thi

Re: [PATCH v5 5/7] usb: gadget: gmidi: Cleanup legacy code

2015-11-13 Thread Robert Baldyga
On 11/10/2015 06:52 PM, Felipe F. Tonello wrote: > Remove unnecessary headers and variables. > > Signed-off-by: Felipe F. Tonello Reviewed-by: Robert Baldyga > --- > drivers/usb/gadget/legacy/gmidi.c | 8 > 1 file changed, 8 deletions(-) > > diff --git a/drivers/usb/gadget/legacy/gm

Re: [PATCH v5 4/7] usb: gadget: f_midi: fix leak on failed to enqueue out requests

2015-11-13 Thread Robert Baldyga
Hi Felipe, On 11/10/2015 06:52 PM, Felipe F. Tonello wrote: > This patch fixes a memory leak that occurs when an endpoint fails to enqueue > the request. If that happens the complete function will never be called, thus > never freeing the request. > > Signed-off-by: Felipe F. Tonello > --- > dr

Re: [PATCH 0/4 V2] usb: dwc2: fix usb host support on Raspberry Pi

2015-11-13 Thread Marek Szyprowski
Hello, On 2015-11-12 22:08, Stefan Wahren wrote: This patch series fixes multiple issues on Raspberry Pi which were reproducable since commit 09a75e857790 ("usb: dwc2: refactor common low-level hw code to platform.c") Changes in V2: - add fix for kernel oops - extend "usb: dwc2: Return errors f

Re: [PATCH v5 6/7] usb: gadget: f_midi: set altsettings only for MIDIStreaming interface

2015-11-13 Thread Clemens Ladisch
Felipe F. Tonello wrote: > This avoids duplication of USB requests for OUT endpoint and > re-enabling endpoints. > ... > /* For Control Device interface we do nothing */ > - if (intf == 0) > + if (intf != midi->ms_id) > return 0; The comment now is misleading. Regar

Re: [PATCH v5 6/7] usb: gadget: f_midi: set altsettings only for MIDIStreaming interface

2015-11-13 Thread Clemens Ladisch
Felipe Ferreri Tonello wrote: > On 10/11/15 18:43, Sergei Shtylyov wrote: >> On 11/10/2015 08:52 PM, Felipe F. Tonello wrote: >>> @@ -75,6 +75,7 @@ struct f_midi { >>> struct usb_ep*in_ep, *out_ep; >>> struct snd_card*card; >>> struct snd_rawmidi*rmidi; >>> +

Re: [PATCH v5 3/7] usb: gadget: define free_ep_req as universal function

2015-11-13 Thread Robert Baldyga
On 11/10/2015 06:52 PM, Felipe F. Tonello wrote: > This function is shared between gadget functions, so this avoid unnecessary > duplicated code and potentially avoid memory leaks. > > Signed-off-by: Felipe F. Tonello Reviewed-by: Robert Baldyga > --- > drivers/usb/gadget/function/f_midi.c

Re: [PATCH v5 2/7] usb: gadget: f_midi: remove duplicated code

2015-11-13 Thread Robert Baldyga
On 11/10/2015 06:52 PM, Felipe F. Tonello wrote: > This code is duplicated from f_midi_start_ep(midi, f, midi->out_ep). > > Signed-off-by: Felipe F. Tonello Reviewed-by: Robert Baldyga > --- > drivers/usb/gadget/function/f_midi.c | 19 --- > 1 file changed, 19 deletions(-) >

Re: [PATCH v5 1/7] usb: gadget: f_midi: Transmit data only when IN ep is enabled

2015-11-13 Thread Robert Baldyga
On 11/10/2015 06:52 PM, Felipe F. Tonello wrote: > This makes sure f_midi doesn't try to enqueue data when the IN endpoint is > disabled, ie, USB cable is disconnected. > > Signed-off-by: Felipe F. Tonello Reviewed-by: Robert Baldyga > --- > drivers/usb/gadget/function/f_midi.c | 2 +- > 1 fi

[PATCH 1/1] usb: misc: usbtest: improve the description fo error message

2015-11-13 Thread Peter Chen
Now the function of complicated_callback is not only used for iso transfer, improve the error message to reflect it. Signed-off-by: Peter Chen --- drivers/usb/misc/usbtest.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/usb/misc/usbtest.c b/drivers/usb/misc/usbt

[PATCH 2/3] Documentation: usb: gadget-testing: add description for depth of queue

2015-11-13 Thread Peter Chen
Add both bulk and iso depth of queue for sourcesink. Signed-off-by: Peter Chen --- Documentation/usb/gadget-testing.txt | 2 ++ 1 file changed, 2 insertions(+) diff --git a/Documentation/usb/gadget-testing.txt b/Documentation/usb/gadget-testing.txt index b24d3ef..84b3d10 100644 --- a/Documenta

[PATCH 3/3] Doc: ABI: configfs-usb-gadget-sourcesink: add two entries for depth of queue

2015-11-13 Thread Peter Chen
Add both bulk and iso depth of queue entries. Signed-off-by: Peter Chen --- Documentation/ABI/testing/configfs-usb-gadget-sourcesink | 2 ++ 1 file changed, 2 insertions(+) diff --git a/Documentation/ABI/testing/configfs-usb-gadget-sourcesink b/Documentation/ABI/testing/configfs-usb-gadget-sou

[PATCH 1/3] usb: gadget: f_sourcesink: add queue depth

2015-11-13 Thread Peter Chen
Add queue depth for both iso and bulk transfer, with more queues, we can do performance and stress test using sourcesink, and update g_zero accordingly. Signed-off-by: Peter Chen --- drivers/usb/gadget/function/f_sourcesink.c | 144 ++--- drivers/usb/gadget/function/g_zer