On Thu, Sep 17, 2015 at 07:48:46AM +, Barry Song wrote:
> From: Rong Wang
>
> Chipidea puts ci information to drvdata, but this overwrites the drvdata
> placed by EHCI core. EHCI core thinks drvdata is ehci_hcd. We can find this
> from codes like ehci-sysfs.c:
>
> static ssize_t show_compani
support usb3.0 phy of mt65xx SoCs
Signed-off-by: Chunfeng Yun
---
drivers/phy/Kconfig | 9 +
drivers/phy/Makefile | 1 +
drivers/phy/phy-mt65xx-usb3.c | 506 ++
3 files changed, 516 insertions(+)
create mode 100644 drivers/phy/phy-m
The patch supports MediaTek's xHCI controller.
There are some differences from xHCI spec:
1. The interval is specified in 250 * 8ns increments for Interrupt Moderation
Interval(IMODI) of the Interrupter Moderation(IMOD) register, it is 8 times as
much as that defined in xHCI spec.
2. For the valu
add a DT binding documentation of xHCI host controller for the
MT8173 SoC from Mediatek.
Signed-off-by: Chunfeng Yun
---
.../devicetree/bindings/usb/mt8173-xhci.txt| 52 ++
1 file changed, 52 insertions(+)
create mode 100644 Documentation/devicetree/bindings/usb/mt81
add a DT binding documentation of usb3.0 phy for MT65xx
SoCs from Mediatek.
Acked-by: Rob Herring
Signed-off-by: Chunfeng Yun
---
.../devicetree/bindings/phy/phy-mt65xx-usb.txt | 68 ++
1 file changed, 68 insertions(+)
create mode 100644 Documentation/devicetree/binding
add xHCI and phy drivers for MT8173-EVB
Signed-off-by: Chunfeng Yun
---
arch/arm64/boot/dts/mediatek/mt8173-evb.dts | 16 +++
arch/arm64/boot/dts/mediatek/mt8173.dtsi| 43 +
2 files changed, 59 insertions(+)
diff --git a/arch/arm64/boot/dts/mediatek/mt817
There some vendor quirks for MTK xhci host controller:
1. It defines some extra SW scheduling parameters for HW
to minimize the scheduling effort for synchronous and
interrupt endpoints. The parameters are put into reseved
DWs of slot context and endpoint context.
2. Its IMODI unit for Interr
Hi Stefan,
[auto build test results on v4.3-rc3 -- if it's inappropriate base, please
ignore]
reproduce: make htmldocs
All warnings (new ones prefixed by >>):
>> include/linux/usb.h:188: warning: Excess struct/union/enum/typedef member
>> 'authorized' description in 'usb_interface'
vim +188
Signed-off-by: Stefan Koch
---
include/linux/usb.h | 2 ++
1 file changed, 2 insertions(+)
diff --git a/include/linux/usb.h b/include/linux/usb.h
index 3deccab..2cbcf8d 100644
--- a/include/linux/usb.h
+++ b/include/linux/usb.h
@@ -122,6 +122,8 @@ enum usb_interface_condition {
* has been
On Mon, Sep 28, 2015 at 09:26:47PM +0200, Stefan Koch wrote:
> This patch introduces an interface authorization for USB devices.
> The kernel supports a device authorization because of wireless USB.
>
> But the new interface authorization allows to authorize or deauthorize
> individual interfaces
On Tue, Sep 22, 2015 at 03:16:56PM +0200, Mian Yousaf Kaukab wrote:
> If dual role configuration is not selected, check and force dr_mode
> based on the selected configuration.
>
> Signed-off-by: Mian Yousaf Kaukab
> Tested-by: Robert Baldyga
this failed to apply. Please rebase on testing/next
We *know* our threads executes with our IRQs
disabled. We really don't need to use the _irqsave()
variant of spin_lock().
Signed-off-by: Felipe Balbi
---
drivers/usb/dwc3/gadget.c | 5 ++---
1 file changed, 2 insertions(+), 3 deletions(-)
diff --git a/drivers/usb/dwc3/gadget.c b/drivers/usb/dwc
Instead of limiting __dwc3_gadget_kick_transfer() to
Xfer Complete, we can try to issue Update Transfer
command from Xfer In Progress too.
Signed-off-by: Felipe Balbi
---
drivers/usb/dwc3/gadget.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/usb/dwc3/gadget.c b
If we get a Xfer Not Ready event with reason
"Transfer Active" it means endpoint is still
transferring data and we can use that to issue
update transfer for this particular endpoint
in case we have pending requests in our queue.
Signed-off-by: Felipe Balbi
---
drivers/usb/dwc3/gadget.c | 9 +
On 09/28/2015 09:26 PM, Stefan Koch wrote:
The attribute authorized shows the authorization state for an interface.
Signed-off-by: Stefan Koch
---
include/linux/usb.h | 2 ++
1 file changed, 2 insertions(+)
diff --git a/include/linux/usb.h b/include/linux/usb.h
index 447fe29..a2068d7 1006
This part adds the documentation for the interface authorization.
Signed-off-by: Stefan Koch
---
Documentation/ABI/testing/sysfs-bus-usb | 20
Documentation/usb/authorization.txt | 31 +++
2 files changed, 51 insertions(+)
diff --git a/Docume
Driver probings and interface claims get rejected
if an interface is not authorized.
Signed-off-by: Stefan Koch
---
drivers/usb/core/driver.c | 8
1 file changed, 8 insertions(+)
diff --git a/drivers/usb/core/driver.c b/drivers/usb/core/driver.c
index 818369a..9908e74 100644
--- a/driv
The attribute authorized shows the authorization state for an interface.
Signed-off-by: Stefan Koch
---
include/linux/usb.h | 2 ++
1 file changed, 2 insertions(+)
diff --git a/include/linux/usb.h b/include/linux/usb.h
index 447fe29..a2068d7 100644
--- a/include/linux/usb.h
+++ b/include/linux/
This introduces an attribute for each interface to
authorize (1) or deauthorize (0) it:
/sys/bus/usb/devices/INTERFACE/authorized
Signed-off-by: Stefan Koch
---
drivers/usb/core/sysfs.c | 36
1 file changed, 36 insertions(+)
diff --git a/drivers/usb/core/sys
Interfaces are allowed per default.
This can disabled or enabled (again) by writing 0 or 1 to
/sys/bus/usb/devices/usbX/interface_authorized_default
Signed-off-by: Stefan Koch
---
drivers/usb/core/hcd.c | 47 ++
drivers/usb/core/message.c | 1 +
i
This patch introduces an interface authorization for USB devices.
The kernel supports a device authorization because of wireless USB.
But the new interface authorization allows to authorize or deauthorize
individual interfaces instead authorization or deauthorize a whole device.
Therefore the aut
With this patch a flag instead of a variable
is used for the default device authorization.
Signed-off-by: Stefan Koch
---
drivers/usb/core/hcd.c | 31 +--
drivers/usb/core/usb.c | 2 +-
include/linux/usb/hcd.h | 16 +---
3 files changed, 31 insertions(+
The kernel supports the device authorization because of wireless USB.
These is usable for wired USB devices, too.
These new interface authorization allows to enable or disable
individual interfaces instead a whole device.
If a deauthorized interface will be authorized so the driver probing must
be
On Mon, Sep 07, 2015 at 09:56:06AM +0300, Heikki Krogerus wrote:
> Hi,
>
> On Tue, Sep 01, 2015 at 06:37:54PM +0300, Ville Syrjälä wrote:
> > On Tue, Sep 01, 2015 at 10:17:59AM -0500, Felipe Balbi wrote:
> > > Hi,
> > >
> > > On Tue, Sep 01, 2015 at 05:39:28PM +0300, Ville Syrjälä wrote:
> > > >
On 9/21/2015 3:16 AM, Marek Szyprowski wrote:
> Hello,
>
> This is an updated DWC2 related part of initial patchset posted here:
> https://lkml.org/lkml/2015/8/21/306
> Only DWC2 related patches have been modified since the initial
> submission.
>
> Changelog:
> v3:
> - rebased onto latest 'test
Before running the platform_driver_unregister() the code will either return
retval or jump to clean. Removing this line that is unreachable.
Signed-off-by: Luis de Bethencourt
---
drivers/usb/host/fotg210-hcd.c | 1 -
1 file changed, 1 deletion(-)
diff --git a/drivers/usb/host/fotg210-hcd.c b/d
gadget methods should be called without
spinlocks held.
Reported-by: Alexey Khoroshilov
Signed-off-by: Felipe Balbi
---
drivers/usb/gadget/udc/pch_udc.c | 8
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/drivers/usb/gadget/udc/pch_udc.c b/drivers/usb/gadget/udc/pch_udc.
From: James Bottomley
> Sent: 28 September 2015 16:12
> > > > The x86 cpus will also do 32bit wide rmw cycles for the 'bit'
> > > > operations.
> > >
> > > That's different: it's an atomic RMW operation. The problem with the
> > > alpha was that the operation wasn't atomic (meaning that it can't
> -Original Message-
> From: John Youn [mailto:john.y...@synopsys.com]
> Sent: September-24-15 8:16 PM
> To: Roman Bacik; John Youn; Scott Branden; Greg Kroah-Hartman; linux-
> u...@vger.kernel.org
> Cc: linux-ker...@vger.kernel.org; bcm-kernel-feedback-list
> Subject: Re: [PATCH v3 0/1] US
On Mon, 2015-09-28 at 14:50 +, David Laight wrote:
> From: James Bottomley [mailto:james.bottom...@hansenpartnership.com]
> > Sent: 28 September 2015 15:27
> > On Mon, 2015-09-28 at 08:58 +, David Laight wrote:
> > > From: Rafael J. Wysocki
> > > > Sent: 27 September 2015 15:09
> > > ...
>
On 28 Sep 2015 at 10:31, David Laight wrote:
> From: PaX Team
> > Sent: 26 September 2015 14:47
> > hi all,
> >
> > drivers/usb/host/r8a66597-hcd.c:r8a66597_hub_descriptor can truncate
> > r8a66597.max_root_hub (of type unsigned int) to an unsigned char:
> >
> > desc->bNbrPorts = r8a66597->m
if by the time we get to XFER_COMPLETE we have
pending requests to be processed, instead of waiting
for a following XFER_NOT_READY, let's start the request
right away and, maybe, save the time of a few NAKs
due to lack of started transfers.
Signed-off-by: Felipe Balbi
---
drivers/usb/dwc3/gadget
From: James Bottomley [mailto:james.bottom...@hansenpartnership.com]
> Sent: 28 September 2015 15:27
> On Mon, 2015-09-28 at 08:58 +, David Laight wrote:
> > From: Rafael J. Wysocki
> > > Sent: 27 September 2015 15:09
> > ...
> > > > > Say you have three adjacent fields in a structure, x, y, z,
On Fri, Sep 25, 2015 at 06:49:54AM -0700, Christoph Hellwig wrote:
> Signed-off-by: Christoph Hellwig
> ---
> fs/dlm/config.c | 288
> +++-
> 1 file changed, 74 insertions(+), 214 deletions(-)
Looks good to me.
Dave
--
To unsubscribe from this
On Mon, 2015-09-28 at 08:58 +, David Laight wrote:
> From: Rafael J. Wysocki
> > Sent: 27 September 2015 15:09
> ...
> > > > Say you have three adjacent fields in a structure, x, y, z, each one
> > > > byte long.
> > > > Initially, all of them are equal to 0.
> > > >
> > > > CPU A writes 1 to
Hi Nicholas,
W dniu 27.09.2015 o 05:16, Nicholas A. Bellinger pisze:
From: Nicholas Bellinger
This patch adds the missing tcm_usbg_drop_nexus() to properly
release tcm_usbg_nexus memory during typical ->fabric_drop_tpg()
callback shutdown.
Also, fix up tcm_usbg_tpg_store_enable() return value
Hi,
W dniu 28.09.2015 o 15:41, Christoph Hellwig pisze:
On Mon, Sep 28, 2015 at 01:46:57PM +0200, Andrzej Pietrasiewicz wrote:
}
-static struct f_lb_opts_attribute f_lb_opts_qlen =
- __CONFIGFS_ATTR(qlen, S_IRUGO | S_IWUSR,
- f_lb_opts_qlen_show,
-
> Haven't you just removed show_attribute() and store_attribute() from
> configfs_item_operations?
Oops, looks like the old text manage to slip back in. I'll fix it up.
--
To unsubscribe from this list: send the line "unsubscribe linux-usb" in
the body of a message to majord...@vger.kernel.org
Mo
On Mon, Sep 28, 2015 at 01:46:57PM +0200, Andrzej Pietrasiewicz wrote:
>> }
>>
>> -static struct f_lb_opts_attribute f_lb_opts_qlen =
>> -__CONFIGFS_ATTR(qlen, S_IRUGO | S_IWUSR,
>> -f_lb_opts_qlen_show,
>> -f_lb_opts_qlen_store);
>> -
> In my opinion t
On Mon, Sep 28, 2015 at 01:35:38PM +0200, Andrzej Pietrasiewicz wrote:
>> -#define UVCG_STREAMING_CONTROL_SIZE 1
>
> Moving this define seems an unrelated change to me.
I can move it back - this one wasn't intentional.
>> +#define identity_conv(x) (x)
>
> What is this needed for here?
>
> This #d
On Sun, Sep 27, 2015 at 10:50:53AM -0500, Felipe Balbi wrote:
> this (and the other helper below) could be macros just fine.
They could, but they shouldn't. Inlines are always preferable over
function-like macros.
> Are you 100% compiler
> will *always* inline these helpers.
With gcc you can't
The Subject line is part of the commit log. If you have a useful
suggestion for improving the logs please feel free to suggest it.
--
To unsubscribe from this list: send the line "unsubscribe linux-usb" in
the body of a message to majord...@vger.kernel.org
More majordomo info at http://vger.kerne
On Monday, September 28, 2015 10:24:58 AM Arnd Bergmann wrote:
> On Sunday 27 September 2015 16:10:48 Rafael J. Wysocki wrote:
> > On Saturday, September 26, 2015 09:33:56 PM Arnd Bergmann wrote:
> > > On Saturday 26 September 2015 11:40:00 Viresh Kumar wrote:
> > > > On 25 September 2015 at 15:19,
On Mon, Sep 28, 2015 at 03:24:04PM +0300, Mathias Nyman wrote:
> Driver will tell the latency value to the host controller, when a exit
> latency time is set the host will know that the link is power managed, and
> host will start to schedule additional PING TP transfers to the device to
> wake the
On 26.09.2015 23:13, Steinar H. Gunderson wrote:
On Fri, Sep 25, 2015 at 10:12:51PM +0200, Steinar H. Gunderson wrote:
I have no idea whatsoever how this breaks bandwidth management, but seemingly
it does.
To verify; I built 4.3rc-2 with CONFIG_PM=n, and it can drive both cards
without problem
Dear colleagus,
It seems code handling USB_RESET interrupt contains unavoidable deadlock.
pch_udc_isr() locks dev->lock, then calls to pch_udc_dev_isr(dev, dev_intr)
that seems to have a couple of locks dev->lock itself:
pch_udc_isr()
spin_lock(&dev->lock);
pch_udc_dev_isr(dev, dev_intr);
Hi Christoph,
W dniu 25.09.2015 o 15:49, Christoph Hellwig pisze:
This series consolidates the code to implement configfs attributes
by providing the ->show and ->store method in common code and using
container_of in the methods to access the containing structure.
This reduces source and binary
Hi Christoph,
Please see inline.
W dniu 25.09.2015 o 15:50, Christoph Hellwig pisze:
Remove the old show_attribute and store_attribute methods and update
the documentation. Also replace the two C samples with a single new
one in the proper samples directory where people expect to find it.
Sig
W dniu 25.09.2015 o 15:49, Christoph Hellwig pisze:
Signed-off-by: Christoph Hellwig
Reviewed-by: Andrzej Pietrasiewicz
---
drivers/usb/gadget/function/f_serial.c | 26 --
1 file changed, 4 insertions(+), 22 deletions(-)
diff --git a/drivers/usb/gadget/function/f
W dniu 25.09.2015 o 15:49, Christoph Hellwig pisze:
Signed-off-by: Christoph Hellwig
Reviewed-by: Andrzej Pietrasiewicz
---
drivers/usb/gadget/function/f_phonet.c | 25 -
1 file changed, 4 insertions(+), 21 deletions(-)
diff --git a/drivers/usb/gadget/function/f_
W dniu 25.09.2015 o 15:49, Christoph Hellwig pisze:
Signed-off-by: Christoph Hellwig
Reviewed-by: Andrzej Pietrasiewicz
---
drivers/usb/gadget/function/f_uac2.c | 28 +++-
1 file changed, 11 insertions(+), 17 deletions(-)
diff --git a/drivers/usb/gadget/function/
W dniu 25.09.2015 o 15:49, Christoph Hellwig pisze:
Signed-off-by: Christoph Hellwig
Reviewed-by: Andrzej Pietrasiewicz
---
drivers/usb/gadget/function/f_obex.c | 26 --
1 file changed, 4 insertions(+), 22 deletions(-)
diff --git a/drivers/usb/gadget/function/f_o
Hi Christoph,
The commit title should be " usb-gadget/f_uac1 ..."
instead of " f_ac1 ..."
Reviewed-by: Andrzej Pietrasiewicz
W dniu 25.09.2015 o 15:49, Christoph Hellwig pisze:
Signed-off-by: Christoph Hellwig
---
drivers/usb/gadget/function/f_uac1.c | 39 +++---
Hi Christoph,
The same remark as for f_loopback (__CONFIGFS_ATTR location vs
CONFIGFS_ATTR location after applying)
If addressed
Reviewed-by: Andrzej Pietrasiewicz
W dniu 25.09.2015 o 15:49, Christoph Hellwig pisze:
Signed-off-by: Christoph Hellwig
---
drivers/usb/gadget/function/f_mass_s
Hi Christoph,
The same remark as for f_loopback (__CONFIGFS_ATTR location vs
CONFIGFS_ATTR location after applying)
If addressed
Reviewed-by: Andrzej Pietrasiewicz
W dniu 25.09.2015 o 15:49, Christoph Hellwig pisze:
Signed-off-by: Christoph Hellwig
---
drivers/usb/gadget/function/f_sourc
Hi Christoph,
The same remark as for f_loopback (__CONFIGFS_ATTR location vs
CONFIGFS_ATTR location after applying)
If addressed
Reviewed-by: Andrzej Pietrasiewicz
W dniu 25.09.2015 o 15:49, Christoph Hellwig pisze:
Signed-off-by: Christoph Hellwig
---
drivers/usb/gadget/function/f_printe
Hi Morimoto-san,
Thank you for the comment.
And, I'm sorry for the delayed response.
> Sent: Friday, September 18, 2015 5:25 PM
>
> Hi Shimoda-san
>
> > This patch adds a compatible string to support for R-Car H3.
> >
> > Since the HS-USB controller of R-Car H3 is almost the same specification
Hi Christoph,
Please see comments inline.
With the issue addressed you can add
Reviewed-by: Andrzej Pietrasiewicz
W dniu 25.09.2015 o 15:49, Christoph Hellwig pisze:
Signed-off-by: Christoph Hellwig
---
drivers/usb/gadget/function/f_loopback.c | 32
1 fil
W dniu 25.09.2015 o 15:49, Christoph Hellwig pisze:
Signed-off-by: Christoph Hellwig
Reviewed-by: Andrzej Pietrasiewicz
---
drivers/usb/gadget/function/f_midi.c | 37
1 file changed, 16 insertions(+), 21 deletions(-)
diff --git a/drivers/usb/gadget/f
W dniu 25.09.2015 o 15:49, Christoph Hellwig pisze:
Signed-off-by: Christoph Hellwig
Reviewed-by: Andrzej Pietrasiewicz
---
drivers/usb/gadget/function/f_ecm.c| 8 ++---
drivers/usb/gadget/function/f_eem.c| 8 ++---
drivers/usb/gadget/function/f_ncm.c
W dniu 25.09.2015 o 15:49, Christoph Hellwig pisze:
Signed-off-by: Christoph Hellwig
Reviewed-by: Andrzej Pietrasiewicz
---
drivers/usb/gadget/function/f_acm.c | 26 --
1 file changed, 4 insertions(+), 22 deletions(-)
diff --git a/drivers/usb/gadget/function/f_ac
W dniu 25.09.2015 o 15:49, Christoph Hellwig pisze:
Signed-off-by: Christoph Hellwig
Reviewed-by: Andrzej Pietrasiewicz
---
drivers/usb/gadget/function/f_hid.c | 34 ++
1 file changed, 14 insertions(+), 20 deletions(-)
diff --git a/drivers/usb/gadget/func
Hi Christoph,
please see my comments inline.
With the issues addressed you can add
Reviewed-by: Andrzej Pietrasiewicz
W dniu 25.09.2015 o 15:49, Christoph Hellwig pisze:
UVC is a little different from other configfs consumers in that it wants
different function and field names from the expos
W dniu 25.09.2015 o 15:49, Christoph Hellwig pisze:
Signed-off-by: Christoph Hellwig
Reviewed-by: Andrzej Pietrasiewicz
---
drivers/usb/gadget/configfs.c | 295 ++--
include/linux/usb/gadget_configfs.h | 19 +--
2 files changed, 118 insertions(+),
From: PaX Team
> Sent: 26 September 2015 14:47
> hi all,
>
> drivers/usb/host/r8a66597-hcd.c:r8a66597_hub_descriptor can truncate
> r8a66597.max_root_hub (of type unsigned int) to an unsigned char:
>
> desc->bNbrPorts = r8a66597->max_root_hub;
>
> based on the surrounding code my guess is
From: Rafael J. Wysocki
> Sent: 27 September 2015 15:09
...
> > > Say you have three adjacent fields in a structure, x, y, z, each one byte
> > > long.
> > > Initially, all of them are equal to 0.
> > >
> > > CPU A writes 1 to x and CPU B writes 2 to y at the same time.
> > >
> > > What's the resu
On Sunday 27 September 2015 16:10:48 Rafael J. Wysocki wrote:
> On Saturday, September 26, 2015 09:33:56 PM Arnd Bergmann wrote:
> > On Saturday 26 September 2015 11:40:00 Viresh Kumar wrote:
> > > On 25 September 2015 at 15:19, Rafael J. Wysocki
> > > wrote:
> > > > So if you allow something lik
67 matches
Mail list logo