On Thu, Feb 05, 2015 at 10:29:42AM -0500, Alan Stern wrote:
> On Wed, 4 Feb 2015, Al Viro wrote:
>
> > > > Um... readv() is also going through ->aio_read().
> > >
> > > Why does readv() do this but not read()? Wouldn't it make more sense
> > > to have all the read* calls use the same internal
On 6 February 2015 at 02:24, Sergei Shtylyov
wrote:
>> diff --git a/Documentation/devicetree/bindings/usb/hi6220-usb.txt
>> b/Documentation/devicetree/bindings/usb/hi6220-usb.txt
>> new file mode 100644
>> index 000..e926364
>> --- /dev/null
>> +++ b/Documentation/devicetree/bindings/usb/hi622
V2:
Correct the subject of patch #5. Replace "link feed" with "line feed".
v1:
Code adjustment.
Hayes Wang (7):
r8152: adjust rx_bottom
r8152: adjust lpm timer
r8152: check linking status with netif_carrier_ok
r8152: check RTL8152_UNPLUG for rtl8152_close
r8152: adjust the line feed for
If a error occurs when submitting rx, skip the remaining submissions
and try to submit them again next time.
Signed-off-by: Hayes Wang
---
drivers/net/usb/r8152.c | 15 +--
1 file changed, 13 insertions(+), 2 deletions(-)
diff --git a/drivers/net/usb/r8152.c b/drivers/net/usb/r8152.
Set LPM timer to 500us, except for RTL_VER_04 which doesn't link at
USB 3.0.
Signed-off-by: Hayes Wang
---
drivers/net/usb/r8152.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/net/usb/r8152.c b/drivers/net/usb/r8152.c
index 41a1cbc..ff122fa 100644
--- a/drive
It is unnecessary to accress the hw register if the device is unplugged.
Signed-off-by: Hayes Wang
---
drivers/net/usb/r8152.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/net/usb/r8152.c b/drivers/net/usb/r8152.c
index 6667809..aade7b5 100644
--- a/drivers/net/usb
Keep NETIF_F_HW_VLAN_CTAG_RX and NETIF_F_HW_VLAN_CTAG_TX at the
same line.
Signed-off-by: Hayes Wang
---
drivers/net/usb/r8152.c | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/drivers/net/usb/r8152.c b/drivers/net/usb/r8152.c
index aade7b5..8bdd477 100644
--- a/drivers/net
vlan_get_protocol() has been defined and use it to replace
get_protocol().
Signed-off-by: Hayes Wang
---
drivers/net/usb/r8152.c | 16 ++--
1 file changed, 2 insertions(+), 14 deletions(-)
diff --git a/drivers/net/usb/r8152.c b/drivers/net/usb/r8152.c
index 8bdd477..24e6aef9 100644
Replace (tp->speed & LINK_STATUS) with netif_carrier_ok().
Signed-off-by: Hayes Wang
---
drivers/net/usb/r8152.c | 23 +--
1 file changed, 9 insertions(+), 14 deletions(-)
diff --git a/drivers/net/usb/r8152.c b/drivers/net/usb/r8152.c
index ff122fa..6667809 100644
--- a/driv
Use BIT macro to replace (1 << bits).
Signed-off-by: Hayes Wang
---
drivers/net/usb/r8152.c | 34 +-
1 file changed, 17 insertions(+), 17 deletions(-)
diff --git a/drivers/net/usb/r8152.c b/drivers/net/usb/r8152.c
index 24e6aef9..5980ac6 100644
--- a/drivers/net/
On Thu, Feb 05, 2015 at 09:24:02PM +0800, Zhangfei Gao wrote:
> Since phy is definitely used in usb controller, load the phy
> earlier to make boot time shorter.
>
> Signed-off-by: Zhangfei Gao
> ---
> drivers/usb/Makefile | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a
>
> In this series no, but 'chipidea: pci: register nop PHY' from the other patch
> if not
> queued yet. Thanks!
>
> >
It is already at my next tree, will send Greg it soon.
Peter
From: Takashi Iwai
Date: Thu, 5 Feb 2015 11:15:24 +0100
> Pass the static attribute groups and the driver data via
> tty_port_register_device_attr() instead of manual device_create_file()
> and device_remove_file() calls.
>
> Signed-off-by: Takashi Iwai
> ---
> v1->v2: rebased to linux-next
A
Not everybody uses a utf8 locale (unfortunately), so let's avoid
non-ascii characters in the kernel log. Replace the 3-byte utf8
sequence with a 3-byte ascii equivalent.
Signed-off-by: Rasmus Villemoes
---
drivers/usb/gadget/udc/dummy_hcd.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
on multiple machine, from a multiple pc, when reading data from USB
port CDC driver (actually using arduino uno, arduino due,
stm32f3-discovery) i often get a
hub 1-3:1.0: hub_port_status failed (err = -110) [19953.337829] hub
1-3:1.0: hub_port_status failed (err = -110) [19958.344533] hub
1-3:1.0
From: Markus Elfring
Date: Thu, 5 Feb 2015 21:40:29 +0100
The umc_device_unregister() function tests whether its argument is NULL
and then returns immediately. Thus the test around the call is not needed.
This issue was detected by using the Coccinelle software.
Signed-off-by: Markus Elfring
-
Dear Recipient,
You have been awarded the sum of 8,000,000.00 (Eight Million Pounds sterling)
with reference number 77100146 by office of the ministry of finance UK.Send us
your personal details to deliver your funds.
Gloria Peter
--
To unsubscribe from this list: send the line "unsubscribe li
* Felipe Balbi [150205 10:12]:
> On Thu, Feb 05, 2015 at 08:35:12AM -0800, Tony Lindgren wrote:
> > The value for the multipoint dts property is ignored when parsing with
> > of_property_read_bool, so we currently have multipoint always set as 1
> > even if value 0 is specified in the dts file.
>
Hello.
On 02/05/2015 05:46 PM, Zhangfei Gao wrote:
Signed-off-by: Zhangfei Gao
---
.../devicetree/bindings/usb/hi6220-usb.txt | 50 ++
1 file changed, 50 insertions(+)
create mode 100644 Documentation/devicetree/bindings/usb/hi6220-usb.txt
diff --git a/Docum
We still have a combination of legacy phys and generic phys in
use so we need to support both types of phy for musb_dsps.c.
Cc: Brian Hutchinson
Signed-off-by: Tony Lindgren
---
drivers/usb/musb/musb_dsps.c | 17 +
1 file changed, 17 insertions(+)
--- a/drivers/usb/musb/musb_ds
On Thu, Feb 05, 2015 at 08:35:12AM -0800, Tony Lindgren wrote:
> The value for the multipoint dts property is ignored when parsing with
> of_property_read_bool, so we currently have multipoint always set as 1
> even if value 0 is specified in the dts file.
>
> Let's fix this to read the value too
On Thu, Feb 05, 2015 at 05:02:46PM +0200, Laurent Pinchart wrote:
> Hi Prabhakar,
>
> Thank you for the patch.
>
> On Thursday 05 February 2015 13:02:18 Lad Prabhakar wrote:
> > From: "Lad, Prabhakar"
> >
> > this patch fixes following sparse warnings:
> >
> > uvc_video.c:283:5: warning: symbo
Hello.
On 02/05/2015 08:47 PM, Romain Perier wrote:
Don't register interrupt handler becore usb gadget is correctly initialized.
s/becore/before/?
For some embedded platforms which don't have a usb-phy it crashes the driver
because an interrupt is emitted with non-initiliazed hardware.
Don't register interrupt handler becore usb gadget is correctly initialized.
For some embedded platforms which don't have a usb-phy it crashes the driver
because an interrupt is emitted with non-initiliazed hardware.
According to devm_request_irq documentation, an interrupt can be emitted
at any ti
Le 22/01/2015 17:56, Sylvain Rochet a écrit :
> This patch add suspend/resume with wakeup support for Atmel USBA.
>
> On suspend: We stay continuously clocked if Vbus signal is not
> available. If Vbus signal is available we set the Vbus signal as a wake
> up source then we stop the USBA itself an
Le 22/01/2015 18:14, Boris Brezillon a écrit :
> On Thu, 22 Jan 2015 17:56:44 +0100
> Sylvain Rochet wrote:
>
>> Renamed struct usba_udc_errata to struct usba_udc_caps, we are adding a
>> new property which is not about errata, this way the struct is not
>> misnamed.
>>
>> New struct usba_udc_cap
The value for the multipoint dts property is ignored when parsing with
of_property_read_bool, so we currently have multipoint always set as 1
even if value 0 is specified in the dts file.
Let's fix this to read the value too instead of just the property like
the binding documentation says as other
Hi,
Here are two fixes, the first one probably should be Cc stable.
Regards,
Tony
Tony Lindgren (2):
usb: musb: Fix use for of_property_read_bool for disabled multipoint
usb: musb: Fix getting a generic phy for musb_dsps
drivers/usb/musb/musb_dsps.c | 24 ++--
drivers
The issue is still there for 3.19.0-rc7
--
To unsubscribe from this list: send the line "unsubscribe linux-usb" in
the body of a message to majord...@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
From: Markus Elfring
Date: Thu, 5 Feb 2015 16:54:12 +0100
The usb_put_hcd() function tests whether its argument is NULL and then
returns immediately. Thus the test around the call is not needed.
This issue was detected by using the Coccinelle software.
Signed-off-by: Markus Elfring
---
driver
On Thu, 2015-02-05 at 07:33 -0800, Greg KH wrote:
> On Thu, Feb 05, 2015 at 07:36:40PM +0530, temp sha wrote:
> > You mean to say only Sierra has its own proprietary commands and no one
> > else ?
> > What is so special about Sierra that requires a dedicated driver in
> > Linux while rest of
> > a
From: Markus Elfring
Date: Thu, 5 Feb 2015 16:33:09 +0100
The release_firmware() function tests whether its argument is NULL and then
returns immediately. Thus the test around the call is not needed.
This issue was detected by using the Coccinelle software.
Signed-off-by: Markus Elfring
---
d
On Thu, Feb 05, 2015 at 07:36:40PM +0530, temp sha wrote:
> You mean to say only Sierra has its own proprietary commands and no one else ?
> What is so special about Sierra that requires a dedicated driver in
> Linux while rest of
> all vendors share the same option driver ? Does Sierra do somethin
On Wed, 4 Feb 2015, Al Viro wrote:
> > > Um... readv() is also going through ->aio_read().
> >
> > Why does readv() do this but not read()? Wouldn't it make more sense
> > to have all the read* calls use the same internal interface?
>
> Because there are two partially overlapping classes wrt
From: Markus Elfring
Date: Thu, 5 Feb 2015 16:07:43 +0100
The backlight_device_unregister() function tests whether its argument is NULL
and then returns immediately. Thus the test around the call is not needed.
This issue was detected by using the Coccinelle software.
Signed-off-by: Markus Elfr
Hi Prabhakar,
Thank you for the patch.
On Thursday 05 February 2015 13:16:26 Lad Prabhakar wrote:
> From: "Lad, Prabhakar"
>
> this patch fixes following sparse warnings:
>
> uvc_v4l2.c:264:29: warning: symbol 'uvc_v4l2_ioctl_ops' was not declared.
> Should it be static? uvc_v4l2.c:355:29: war
Hi Prabhakar,
Thank you for the patch.
On Thursday 05 February 2015 13:02:18 Lad Prabhakar wrote:
> From: "Lad, Prabhakar"
>
> this patch fixes following sparse warnings:
>
> uvc_video.c:283:5: warning: symbol 'uvcg_video_pump' was not declared.
> Should it be static? uvc_video.c:342:5: warnin
Add usb phy controller for hi6220 platform
Signed-off-by: Zhangfei Gao
---
drivers/usb/phy/Kconfig | 9 ++
drivers/usb/phy/Makefile | 1 +
drivers/usb/phy/phy-hi6220.c | 290 +++
3 files changed, 300 insertions(+)
create mode 100644 drivers/u
Signed-off-by: Zhangfei Gao
---
drivers/usb/dwc2/platform.c | 29 +
1 file changed, 29 insertions(+)
diff --git a/drivers/usb/dwc2/platform.c b/drivers/usb/dwc2/platform.c
index ae095f0..ceee385 100644
--- a/drivers/usb/dwc2/platform.c
+++ b/drivers/usb/dwc2/platform.
Add necessary dwc2 binding documentation for Hisilicon soc: hi6220
Signed-off-by: Zhangfei Gao
---
Documentation/devicetree/bindings/usb/dwc2.txt | 1 +
1 file changed, 1 insertion(+)
diff --git a/Documentation/devicetree/bindings/usb/dwc2.txt
b/Documentation/devicetree/bindings/usb/dwc2.txt
i
Signed-off-by: Zhangfei Gao
---
.../devicetree/bindings/usb/hi6220-usb.txt | 50 ++
1 file changed, 50 insertions(+)
create mode 100644 Documentation/devicetree/bindings/usb/hi6220-usb.txt
diff --git a/Documentation/devicetree/bindings/usb/hi6220-usb.txt
b/Documenta
hi6220 usb controller is inherited from dwc2
add phy accordingly
support otg gadget/host
Zhangfei Gao (4):
Documentation: dt-bindings: add dt binding info for hi6220 dwc2
Documentation: dt-bindings: add dt binding info for hi6220
usb: dwc2: platform: add hi6220 support
usb: phy: add phy-hi
You mean to say only Sierra has its own proprietary commands and no one else ?
What is so special about Sierra that requires a dedicated driver in
Linux while rest of
all vendors share the same option driver ? Does Sierra do something unique and
different from rest of all vendors?
Thanks
On Fri,
Instead of manual device_create_file() and device_remove_file() calls,
assign the static attribute groups to the lun device to register.
The RO or RW permissions for some entries are decided in is_visible
callback. This simplifies the code (also the logic) and avoids the
possible races, too.
Sign
Signed-off-by: Takashi Iwai
---
drivers/usb/serial/bus.c | 11 +--
1 file changed, 9 insertions(+), 2 deletions(-)
diff --git a/drivers/usb/serial/bus.c b/drivers/usb/serial/bus.c
index b730366d524f..4b34afc51535 100644
--- a/drivers/usb/serial/bus.c
+++ b/drivers/usb/serial/bus.c
@@ -80
Hi,
here are two patches cleaning up device_create_file() & co by
replacing with the static attribute groups, plus a patch to add the
missing error handling in usb serial driver.
Takashi
===
Takashi Iwai (3):
USB: serial: use static attribute groups for sysfs entries
USB: serial: Handle th
Instead of manual device_create_file() and device_remove_file() calls,
pass the static attribute groups to tty_register_device_attr().
Signed-off-by: Takashi Iwai
---
drivers/usb/serial/bus.c | 19 +--
1 file changed, 9 insertions(+), 10 deletions(-)
diff --git a/drivers/usb/ser
Hi,
On Thu, Jan 22, 2015 at 08:37:45AM +0100, Yegor Yefremov wrote:
> I have the same experience with 3.15. The switching is working when
> CONFIG_USB_MUSB_DUAL_ROLE is set and dr_mode = "otg". But since 3.16
> it seems to be broken. Still had no time to bisect this.
I've been giving a few versio
Gadget directly set GAHBCFG_HBSTLEN_INCR4, reuse ahbcfg if assigned from
platform
Signed-off-by: Zhangfei Gao
---
drivers/usb/dwc2/core.c | 2 +-
drivers/usb/dwc2/gadget.c | 8 ++--
2 files changed, 7 insertions(+), 3 deletions(-)
diff --git a/drivers/usb/dwc2/core.c b/drivers/usb/dwc2/c
v2:
remove parentheses mentioned by Sergei
assume @ahbcfg is used for dma case
Zhangfei Gao (2):
usb: phy: load usb phy earlier
usb: dwc2: gadget reuse ahbcfg assigned from platform
drivers/usb/Makefile | 2 +-
drivers/usb/dwc2/core.c | 2 +-
drivers/usb/dwc2/gadget.c | 8 ++--
3
Since phy is definitely used in usb controller, load the phy
earlier to make boot time shorter.
Signed-off-by: Zhangfei Gao
---
drivers/usb/Makefile | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/usb/Makefile b/drivers/usb/Makefile
index 2f1e2aa..d8926c6 100644
--- a
From: "Lad, Prabhakar"
this patch fixes following sparse warnings:
uvc_v4l2.c:264:29: warning: symbol 'uvc_v4l2_ioctl_ops' was not declared.
Should it be static?
uvc_v4l2.c:355:29: warning: symbol 'uvc_v4l2_fops' was not declared. Should it
be static?
Signed-off-by: Lad, Prabhakar
---
drive
From: "Lad, Prabhakar"
this patch fixes following sparse warnings:
g_ffs.c:136:3: warning: symbol 'gfs_configurations' was not declared. Should it
be static?
g_ffs.c:281:16: warning: Using plain integer as NULL pointer
Signed-off-by: Lad, Prabhakar
---
Found this issue on linux-next (gcc ve
From: "Lad, Prabhakar"
this patch fixes following sparse warnings:
uvc_video.c:283:5: warning: symbol 'uvcg_video_pump' was not declared. Should
it be static?
uvc_video.c:342:5: warning: symbol 'uvcg_video_enable' was not declared. Should
it be static?
uvc_video.c:381:5: warning: symbol 'uvcg_
On Monday 02 February 2015 20:14:35 Felipe Balbi wrote:
> On Mon, Feb 02, 2015 at 08:07:51PM +0100, Pali Rohár wrote:
> > On Monday 02 February 2015 20:01:11 Felipe Balbi wrote:
> > > Hi,
> > >
> > > On Mon, Feb 02, 2015 at 07:58:59PM +0100, Pali Rohár wrote:
> > > > On Monday 02 February 2015 19:
On Tuesday 03 February 2015 20:57:11 Pali Rohár wrote:
> On Tuesday 03 February 2015 20:35:25 Felipe Balbi wrote:
> > On Tue, Feb 03, 2015 at 08:27:52PM +0100, Pali Rohár wrote:
> > > On Tuesday 03 February 2015 20:18:59 Felipe Balbi wrote:
> > > > On Tue, Feb 03, 2015 at 05:17:28PM +0100, Pali Roh
Le 22/01/2015 17:56, Sylvain Rochet a écrit :
> Vbus IRQ handler needs a started UDC driver to work because it uses
> udc->driver, which is set by the UDC start handler. The previous way
> chosen was to return from interrupt if udc->driver is NULL using a
> spinlock around the check.
>
> We now re
Tested on 3.10.67 and 3.18.5 kernels with ATEN UC-232A usb-serial adapter.
No patch, sorry. To actually see the stuck "break" signal on TxD line, you
need either some sort of LED or voltmeter connected to the data transmit
line. Other RS-232 serial ports that I have access to (normal PC hardware
se
On Thu, 2015-02-05 at 01:21 +, Peter Chen wrote:
> So no patch I need to queue in chipidea tree, right?
In this series no, but 'chipidea: pci: register nop PHY' from the other
patch if not queued yet. Thanks!
>
> For this patch:
>
> Acked-by: Peter Chen
>
> Peter
>
--
Andy Shevchenko
Pass the static attribute groups and the driver data via
tty_port_register_device_attr() instead of manual device_create_file()
and device_remove_file() calls.
Signed-off-by: Takashi Iwai
---
v1->v2: rebased to linux-next
drivers/net/usb/hso.c | 17 ++---
1 file changed, 10 insertio
On 02/05/2015 10:03 AM, Al Viro wrote:
> On Thu, Feb 05, 2015 at 08:47:29AM +, Al Viro wrote:
>> You are confusing datagram-per-syscall (which they are) with
>> datagram-per-iovec (which they are definitely not). IOW, they behave
>> as UDP sockets - writev() is purely scatter-gather varia
On Thu, Feb 05, 2015 at 08:47:29AM +, Al Viro wrote:
> You are confusing datagram-per-syscall (which they are) with
> datagram-per-iovec (which they are definitely not). IOW, they behave
> as UDP sockets - writev() is purely scatter-gather variant of write(),
> with datagram per syscall
W dniu 04.02.2015 o 15:33, Chris McClimans pisze:
Hi Andrzej,
Thank you for your time.
I'd like to take a stab at FunctionFS before I start looking at
backporting hid and uvc from 3.19+
I found a lot of information (mainly from you [1] [2]) on gadget
ConfigFS and hid, but I'm
having less luck
On Thu, Feb 05, 2015 at 09:24:32AM +0100, Robert Baldyga wrote:
> No, function/f_fs.c and legacy/inode.c are in class (1). They have
> datagram semantics - each vector element is submitted in separate USB
> request. Each single request is sent in separate USB data packet (for
> bulk endpoints it c
From: Takashi Iwai
Date: Wed, 4 Feb 2015 14:39:33 +0100
> Pass the static attribute groups and the driver data via
> tty_port_register_device_attr() instead of manual device_create_file()
> and device_remove_file() calls.
>
> Signed-off-by: Takashi Iwai
This does not apply cleanly to the net-
On 02/05/2015 12:07 AM, Al Viro wrote:
> On Wed, Feb 04, 2015 at 03:30:32PM -0500, Alan Stern wrote:
>>> * this one. Note that you are not guaranteed that ep_config() won't
>>> be called more than once - two threads might race in write(2), with the
>>> loser
>>> getting through mutex_lock_int
66 matches
Mail list logo