v3:
For patch #1, remove unnecessary initialization for ret and
unnecessary blank line in r8152_submit_rx().
v2:
For patch #1, set actual_length to 0 before adding the rx to the
list, when a error occurs.
For patch #2, change the flow. Stop submitting the rx if a error
occurs, and add the remaini
If there is a error for r8152_submit_rx(), add the remaining rx
buffers to the list. Then the remaining rx buffers could be
submitted later.
Signed-off-by: Hayes Wang
---
drivers/net/usb/r8152.c | 19 +++
1 file changed, 19 insertions(+)
diff --git a/drivers/net/usb/r8152.c b/dr
The behavior of handling the returned status from r8152_submit_rx()
is almost same, so let r8152_submit_rx() deal with the error
directly. This could avoid the duplicate code.
Signed-off-by: Hayes Wang
---
drivers/net/usb/r8152.c | 40
1 file changed, 20
On Wed, Nov 19, 2014 at 07:22:06PM -0600, Ahmed Tamrawi wrote:
> Bug Report Filed: https://bugzilla.kernel.org/show_bug.cgi?id=88521
> Linux Version [3.17-rc1]
> Configuration: Default configuration for x86
>
> Function Source:
> http://lxr.free-electrons.com/source/drivers/usb/class/cdc-acm.c#L14
Bug Report Filed: https://bugzilla.kernel.org/show_bug.cgi?id=88521
Linux Version [3.17-rc1]
Configuration: Default configuration for x86
Function Source:
http://lxr.free-electrons.com/source/drivers/usb/class/cdc-acm.c#L1404
In function (acm_probe) in file (drivers/usb/class/cdc-acm.c):
Pointer
On Wed, 19 Nov 2014, Alan Stern wrote:
> On Wed, 19 Nov 2014, Андрей Аладьев wrote:
>
> > I've tested with 3.18-rc5. It looks the same.
>
> I was able to duplicate the problem in 3.18-rc5. Give me some time to
> investigate it, and I'll get back to you.
The patch below fixed the problem on my
Hi,
On Wed, Nov 19, 2014 at 05:04:27PM +0200, Mathias Nyman wrote:
>
> One theory would be that when we fail to reset the device because it's
> already in the
> default state (state after reset) we end up not freeing the rings, and won't
> free the
> reserved bandwith either.
>
> If you wan't
2014-11-19 23:29 GMT+03:00 Robert Jarzmik :
> Dmitry Eremin-Solenikov writes:
>
>> I have sketched a compile-tested only PHY for the Lubbock platform. Could you
>> please take a look and test.
>> git://git.infradead.org/users/dbaryshkov/zaurus.git lubbock
>
> Okay, now my ADSL line is repaired,
Dmitry Eremin-Solenikov writes:
> I have sketched a compile-tested only PHY for the Lubbock platform. Could you
> please take a look and test.
> git://git.infradead.org/users/dbaryshkov/zaurus.git lubbock
Okay, now my ADSL line is repaired, thank you Mr farmer "I drive a tractor but I
don't ca
From: Sudip Mukherjee
Date: Tue, 18 Nov 2014 21:55:21 +0530
> remove unused variable
>
> Signed-off-by: Sudip Mukherjee
> ---
>
> change in v2: changed the commit message
Applied, thank you.
--
To unsubscribe from this list: send the line "unsubscribe linux-usb" in
the body of a message to ma
On Wed, Nov 19, 2014 at 1:47 AM, 李云志 wrote:
> hi Julius & Alan
>
> Shall we use dwc2's private status "hsotg->lx_state" here instesd of
> "hcd->state" for checking root hub is in suspend state ?
> I see the EHCI driver do something like this(ehci->rh_state ==
> EHCI_RH_SUSPENDED) before resume
* Enric Balletbo Serra [141119 03:14]:
> 2014-11-18 16:42 GMT+01:00 Tony Lindgren :
>
> Checked again, and no luck. It's very weird because from the OTG point
> of view, OTG is exactly the same between Beagleboard-XM and IGEPv2.
>
> Can you confirm that you're using kernel 3.18-rc5 without other
On Wed, 19 Nov 2014, Андрей Аладьев wrote:
> I've tested with 3.18-rc5. It looks the same.
I was able to duplicate the problem in 3.18-rc5. Give me some time to
investigate it, and I'll get back to you.
Alan Stern
--
To unsubscribe from this list: send the line "unsubscribe linux-usb" in
the
On Wed, 19 Nov 2014, Greg Kroah-Hartman wrote:
> > On Mon, 17 Nov 2014, Oliver Neukum wrote:
> >
> > > The touchscreen needs the same quirk as the other models.
> > >
> > > Signed-off-by: Oliver Neukum
> > > Reported-by: Bryan Poling
> > > CC: sta...@vger.kernel.org
> > > ---
> > > drivers/hi
On Wed, Nov 19, 2014 at 2:43 AM, Kiran Kumar Raparthy
wrote:
> From: Todd Poynor
>
> usb: phy: introduce usb_phy_set_event interface
Hi Kiran, this is new stuff that is all your own work and you deserve
the credit.
Thanks for working to get this feature in shape for mainline!
Todd
--
To unsub
On Wed, Nov 19, 2014 at 03:52:29PM +0100, Jiri Kosina wrote:
>
> [ Greg and linux-usb@ added to CC ]
>
> On Mon, 17 Nov 2014, Oliver Neukum wrote:
>
> > The touchscreen needs the same quirk as the other models.
> >
> > Signed-off-by: Oliver Neukum
> > Reported-by: Bryan Poling
> > CC: sta...@
On 18.11.2014 18:41, Felipe Balbi wrote:
> On Tue, Nov 18, 2014 at 11:07:34AM -0500, Alan Stern wrote:
>> On Tue, 18 Nov 2014, Kever Yang wrote:
>>
>>> After we implement the bus_suspend/resume, auto suspend id enabled.
>>> The root hub will be auto suspend if there is no device connected,
>>> we n
On Tue, 18 Nov 2014, Julius Werner wrote:
> >> You should be aware that it's not safe to use hcd->state for anything
> >> in a host controller driver. That field is owned by usbcore, not by
> >> the HCD, and it is not protected by any locks.
> >>
> >> Thus, for example, hcd->state does not get se
From: Ronald Wahl
Commit 7628083227b6bc4a7e33d7c381d7a4e558424b6b (usb: gadget: at91_udc:
prepare clk before calling enable) added clock preparation in interrupt
context. This is not allowed as it might sleep. Also setting the clock
rate is unsafe to call from there for the same reason. Move cloc
This makes to_phy() macro work with other variable names
besides "dev".
Signed-off-by: Heikki Krogerus
Tested-by: Vivek Gautam
Acked-by: Felipe Balbi
---
include/linux/phy/phy.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/include/linux/phy/phy.h b/include/linux/phy/phy.
This set will in practice just separate the creation of a phy and
binding of it to the consumer. Mapping phys to consumers can be now
done with lookups similarly how clocks can be mapped in clkdev.c.
Vivek needs to handle the phys of dwc3 also in xhci driver on
Exynos5420 SoC, so I'm resending the
The driver does no use it any more.
Signed-off-by: Heikki Krogerus
---
arch/arm/mach-omap2/twl-common.c | 12 +---
include/linux/i2c/twl.h | 2 --
2 files changed, 1 insertion(+), 13 deletions(-)
diff --git a/arch/arm/mach-omap2/twl-common.c b/arch/arm/mach-omap2/twl-common.c
Creates the lookup separately. Hard coding the consumer as
it can't be anything else except musb.
Signed-off-by: Heikki Krogerus
---
drivers/phy/phy-twl4030-usb.c | 9 ++---
1 file changed, 6 insertions(+), 3 deletions(-)
diff --git a/drivers/phy/phy-twl4030-usb.c b/drivers/phy/phy-twl4030-
Separates registration of the phy and the lookup. The method
is copied from clkdev.c,
Signed-off-by: Heikki Krogerus
---
Documentation/phy.txt | 60 ++-
drivers/phy/phy-core.c | 84 -
include/linux/phy/phy.h | 16
The device name is usually required when assigning resources
like clocks to platform devices. The problem is that the
device name is not know before platform_device_add is called
and that can be too late as the drivers may have already
requested the resources when the function returns. By naming
th
On some platforms a PHY may need to be handled also in the
host controller driver. Exynos5420 SoC requires some "PHY
tuning" based on the USB speed. This patch delivers dwc3's
PHYs to the xhci platform device when it's created.
Signed-off-by: Heikki Krogerus
Tested-by: Vivek Gautam
Acked-by: Fel
The users of the old method are now converted to the new one.
Signed-off-by: Heikki Krogerus
---
drivers/phy/phy-bcm-kona-usb2.c | 2 +-
drivers/phy/phy-berlin-sata.c| 2 +-
drivers/phy/phy-core.c | 49 +++-
drivers/phy/phy-exynos-dp-v
Hi
On 19.11.2014 01:03, Brian Campbell wrote:
> Hi,
>
> I'm having trouble with USB devices connected to a Thinkpad X230's dock
> disappearing after a few suspend/resume cycles. Devices connected directly to
> the laptop rather than the dock are not affected. The main symptom in the
> logs is a
HI,
On Wed, Nov 19, 2014 at 12:37:53PM -0200, Fabio Estevam wrote:
> Building with bcm2835_defconfig, which has CONFIG_PM_SLEEP=n causes the
> following build warning:
>
> drivers/usb/dwc2/platform.c:227:12: warning: 'dwc2_suspend' defined but not
> used [-Wunused-function]
> drivers/usb/dwc2/p
[ Greg and linux-usb@ added to CC ]
On Mon, 17 Nov 2014, Oliver Neukum wrote:
> The touchscreen needs the same quirk as the other models.
>
> Signed-off-by: Oliver Neukum
> Reported-by: Bryan Poling
> CC: sta...@vger.kernel.org
> ---
> drivers/hid/hid-ids.h | 1 +
> drivers/hid/usb
Building with bcm2835_defconfig, which has CONFIG_PM_SLEEP=n causes the
following build warning:
drivers/usb/dwc2/platform.c:227:12: warning: 'dwc2_suspend' defined but not
used [-Wunused-function]
drivers/usb/dwc2/platform.c:237:12: warning: 'dwc2_resume' defined but not used
[-Wunused-functio
Hello.
On 11/19/2014 8:20 AM, Hayes Wang wrote:
The behavior of handling the returned status from r8152_submit_rx()
is almost same, so let r8152_submit_rx() deal with the error
directly. This could avoid the duplicate code.
Signed-off-by: Hayes Wang
---
drivers/net/usb/r8152.c | 41 ++
Hi!
You're among Families that will receive 200,000.00Gbp Grant from UN Approved
Funds for Less Privileges, Tsunami, Earthquake and Flood victims.
Send your family Grant Number: UN/GRANT/VIC2014 to Andrej Mahecic on
+443303501130 / un@inbox.com for your Transfer.
Yours Sincerely,
Vannina
Dear Marcin Wojtas,
On Thu, 13 Nov 2014 00:49:50 +0100, Marcin Wojtas wrote:
> This commit fixes ehci-orion operation in big-endian mode by enabling byteswap
> when accessing registers using 'rdl' and 'wrl' macros.
>
> Signed-off-by: Grzegorz Jaszczyk
> Signed-off-by: Marcin Wojtas
> Reviewed-b
Hi Tony,
2014-11-18 16:42 GMT+01:00 Tony Lindgren :
> * Enric Balletbo Serra [141118 01:04]:
>> Hi Tony,
>>
>> 2014-11-17 19:04 GMT+01:00 Tony Lindgren :
>> >
>> > Just tested v3.18-rc5 with beagleboard xm, and the host mode
>> > enumerates the devices, then may fail with "insufficient bus power"
From: Todd Poynor
usb: phy: hold wakeupsource when USB is enumerated in peripheral mode
Some systems require a mechanism to prevent system to enter into suspend
state when USB is connected and enumerated in peripheral mode.
This patch provides an interface to hold a wakeupsource to prevent susp
From: Todd Poynor
usb: phy: Handle per-PHY event for connnect and disconnect events
When usb is connected and enumerated in device mode or when usb is
disconnected,call usb_phy_set_event from phy drivers to handle per-PHY event.
Cc: Felipe Balbi
Cc: Greg Kroah-Hartman
Cc: linux-ker...@vger.ke
From: Todd Poynor
usb: phy: introduce usb_phy_set_event interface
PHY drivers require a generic interface to handle per-PHY events.
usb_phy_set_event interface sets event to phy event.
PHY drivers call this interface for each phy event.
Cc: Felipe Balbi
Cc: Greg Kroah-Hartman
Cc: linux-ker..
On Sun, Nov 16, 2014 at 09:17:30PM +0100, Martin Hauke wrote:
> Added new device layout "DEVICE_HWI" and also added the USB VID/PID for the
> HP lt4112 LTE/HSPA+ Gobi 4G Modem (Huawei me906e)
>
> Signed-off-by: Martin Hauke
Applied, thanks.
Johan
--
To unsubscribe from this list: send the line
On Mon, Nov 17, 2014 at 02:33:17PM -0800, Troy Clark wrote:
> This is a patch to the ftdi_sio_ids.h and ftdi_sio.c files that adds PIDs for
> new Matrix Orbital GTT series products
>
> Signed-off-by: Troy Clark
Applied, thanks.
Johan
--
To unsubscribe from this list: send the line "unsubscribe
As the driver call usb_add_gadget_udc --> usb_add_gadget_udc_release
with NULL as release parameter, so it will use usb_udc_no_release.
So, the release in driver won't used, remove it.
And at the same time, in the usb_add_gadget_udc_release will set the
gadget name, so remove it also in driver.
S
As the driver call usb_add_gadget_udc --> usb_add_gadget_udc_release
with NULL as release parameter, so it will use usb_udc_no_release.
So, the release in driver won't used, remove it.
And at the same time, in the usb_add_gadget_udc_release will set the
gadget name, so remove it also in driver.
S
42 matches
Mail list logo